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Chapter

Introducing InfoAssist+

InfoAssist+ provides business users with the most advanced, yet simple to use, ad hoc
reporting features needed to create intricate reports and perform insightful analysis.

InfoAssist+ provides a robust, user-friendly solution that helps companies overcome
traditional ad hoc reporting challenges.

InfoAssist+ is available in the following versions:

_I
;|

InfoAssist+. Complete version of this powerful report-generation tool.

InfoMini. Applications built from an InfoAssist+ report that contain a subset of
InfoAssist+ functionality at run time.

In this chapter:

-

_I

InfoAssist+ Highlights

Additional InfoAssist+ Types

InfoAssist+ Highlights

With InfoAssist+, you can quickly and easily:

_I

L U U U U

L

Generate highly complex reports, charts, visualizations, and documents from any enterprise
information source without IT intervention.

Complete tasks, such as building a report, with minimal clicks.

Create useful and dynamic visualizations, giving you greater insight into your data.
Create maps to illustrate trends and identify patterns in your data.

Progress to more sophisticated activities, such as publishing and sharing documents.
Convert reports to charts, or charts to reports, in a single click.

Analyze multiple reports and charts simultaneously, using advanced tiling options to view
data from multiple perspectives.

Browse enterprise-information sources, including multi-dimensional sources.

.d Output data in a variety of formats, including HTML, HTML5 (charts only), active reports,

PDF, active PDF, Excel®, and PowerPoint®.

Db2 Web Query InfoAssist+ Part 1 11



Additional InfoAssist+ Types

InfoAssist+ is a Rich Internet Application (RIA) that uses AJAX (Asynchronous JavaScript and
XML) technology. It delivers its cutting-edge functionality using a familiar Microsoft Windows®
ribbon interface. This highly intuitive environment shields users from the underlying technical
complexities associated with ad hoc reporting features, while providing access to all the
functionality needed to address mission-critical information requirements.

This powerful ad hoc reporting tool enables rapid and efficient design and deployment of
reports and charts. It uses an interactive and fully-customizable WYSIWYG (What You See Is
What You Get) development environment. Users receive instant feedback throughout the
development process to ensure that reports and charts are properly built.

InfoAssist+ offers ad hoc reporting in a single, thin-client environment. There is no software to
install, no desktop clients to maintain, and no user licenses to track. It is a RIA that makes
desktop-style ad hoc applications readily available, using the Web, to business users across
your enterprise.

Note: If you manually edit a report created with InfoAssist+, do not delete or modify the
internal comments located at the top of the procedure. Modifying these comments, or any
content of the procedure, could produce unpredictable results when you open the report with
InfoAssist+.

Additional InfoAssist+ Types

InfoMini

12

This section describes additional InfoAssist+ types.

You have the option to activate InfoMini when you create a report. When you run a report with
InfoMini activated, an InfoMini application is launched. An InfoMini application contains a
subset of the functionality available to a full InfoAssist+ report. You can limit or expand the
functionality that is available to the user at run time when you build the report.

An InfoMini application opens in its own browser window if it is running from InfoAssist+.

IBM



Chapter

Navigating the InfoAssist+ Interface

InfoAssist+ provides an intelligent, flexible layout for creating reports, charts, documents,

and visualizations.

The application window provides intuitive menus and toolbars, a versatile ribbon that
provides access to specialized groups for different functional areas of report design, a
taskbar for selecting output, and a status bar for directing output.

The application window also provides a resources area for selecting and sorting data,
and a multi-faceted results area that can display report design, a preview of report
output, or actual report output.

In this chapter:

_I

L U uJ o o o U

InfoAssist+ Application Window
Application Main Menu

Quick Access Toolbar

Ribbon

Home Tab

Insert Tab

Format Tab

Data Tab

L U U U UJd Jd Jd o U

Slicers Tab

Layout Tab

View Tab

Field Tab

Series Tab

Understanding the Resources Panel
Understanding the Canvas

Using the Navigation Taskbar

Using the Status Bar

Db2 Web Query InfoAssist+ Part 1
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InfoAssist+ Application Window

InfoAssist+ Application Window

14

The components of the InfoAssist+ Application window are shown in the following image.
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The main interface components are explained as follows:

1. Application button. Provides access to the Application menu of procedure-related
commands.

2. Quick Access Toolbar. Displays frequently-used commands, such as New, Open, Save,

Undo, Redo, View code, Run, and Preview, in a toolbar that remains visible. For more
information, see Quick Access Toolbar on page 25.

3. Ribbon. Displays the commands you need to create reports, charts, visualizations, and
documents. It also displays the Help menu. For details, see Ribbon on page 26.

4. Help. Provides access to the online technical content for InfoAssist+ in a new browser
window.

5. Resources panel. Displays the Data pane, Query pane, and Filter pane.

Canvas. Displays the results of your report. In Live Preview mode, the canvas displays a

preview of the file as it is developed.

Depending on the type of file that you are developing, the canvas may display differently.

For example, when creating a document, the canvas includes rulers around the
development area. This is to assist you in placing the components on to the document.

IBM



2. Navigating the InfoAssist+ Interface I

7. Navigation taskbar. Displays groups and icons that provide different views and quick
access to all active reports and report output. For details, see Using the Navigation Taskbar
on page 70.

8. Status bar. Provides an output format button that you click to see the selected format and
an output target button that you click to view the selected option for displaying new output
windows or tabs. For more information, see Using the Status Bar on page 71.

Application Main Menu

In the upper-left corner of the InfoAssist+ interface, click the hamburger menu button = to
open the Application main menu.

You can run the following commands from the Application main menu:

d New. Opens the InfoAssist+ splash screen, where you can create a new report, chart,
document, or visualization. The exact functionality of the New command depends on your
current InfoAssist+ session.

If you open a Reporting Object through InfoAssist+, and then click New, a new report is
generated from the Reporting Object. You are prompted to choose the type of report you
want to create from the Reporting Object.

When you open a new session of InfoAssist+ and then click New, a new report is created.
You are prompted to choose a data source.

-1 Open. Opens an existing report, chart, document, or visualization.
d Save. Saves a report, chart, document, or visualization.

d Save As. Saves a report, chart, document, or visualization with a new name.

Note: When saving a read-only, non-writable procedure (.fex) in the Save As dialog box, the
first writable folder will be selected, by default.

-1 Run. Runs a report, chart, document, or visualization.

. Run Deferred. Submits a report, chart, document, or visualization for processing in the
background while you continue to work on other tasks.

.4 Close. Closes the currently active report, chart, document, or visualization.

Db2 Web Query InfoAssist+ Part 1 15



Application Main Menu

-1 Recent Items. Displays recent reports, charts, documents, or visualizations, and those
items that have been pinned to the menu. The Recent Items area of the InfoAssist+
Application main menu is shown in the following image.

— [_] & H @ &] = Run -
LY
o Recent Items

| E} Quantity Sold By Stores r
- i =] Regional Analysis #
[ = E_ﬂ Scatter - Profit vs COGs for Products (Anima... o
H Save
H Save As

| Fun

R,
_? Fun Deferred
2
| | Close

Jf Options ¢ Exit

Pinned reports, charts, documents, or visualizations are represented by a blue pin ? icon.
Pinned items appear at the top of the list in alphabetical order.

Recent reports, charts, documents, and visualizations are represented by a sideways blue

pin ~® icon. Recent items appear below the separator bar in the order in which they were
created, with the most recently created item at the top.

You can pin important reports, charts, documents, and visualizations to the top of the
Recent Reports section of the Application main menu for quick and easy access. To
promote a recent report to pinned report, click the sideways blue pin icon. The icon turns
upright and the report is moved to the pinned report area of the Recent Items window,
where it stays until it is unpinned.

To demote a pinned report, click the blue pin icon. The icon turns sideways and the report
is moved below the separator bar.
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2. Navigating the InfoAssist+ Interface I

A shortcut menu is available when right-clicking a recent item, as shown in the following

image.
—_ UE d & B | wRun-
N
| New Recent Items
. l%} Quantity Sold By Stores P
;—l Open —
La._;j 3] Regional Analysis F
H S E_} Scatter - Profit vs COGs for Products (Anima... g
i) Open
m Save As il Op
N $  Ppinto list
h}.l Run & Bemove from list
1 »” Clear unpinned list

y Run Deferred
r
| t Close

J§ Options QY Exit

The options in the menu are:
4 Open. Opens the selected report, chart, document, or visualization.

- Pin to list. Pins or unpins a recent report, chart, document, or visualization to the
pinned reports list above the separator bar.

'd Remove from list. Unpins a pinned report, chart, document, or visualization from the
pinned reports list.

.4 Clear unpinned list. Clears all unpinned reports, charts, documents, or visualization
from the Recent Items list.

.d Options. Opens the Options dialog box to customize your user preferences. For more
information, see Changing InfoAssist+ User Preferences on page 21.

4 Exit. Exits the application.

Db2 Web Query InfoAssist+ Part 1 17



Application Main Menu

Reference: Open Dialog Box

18

The Open dialog box displays when you launch InfoAssist+. It also displays when you join and
blend data. You can use this dialog box to do the following:

. Select data sources for creating reports, charts, visualizations, and documents.

d Select data sources for joining and blending data.

.4 Configure data adapters for connecting to an existing database and creating synonyms.
- Upload user data.

The Open dialog box is shown in the following image.

|2y Open - IBFS:/EDA/EDASERVE/wfretailg2 O x
(3 [ DASRRE » wiretalsz » # ~ @,
28 Connect to Data ] Upload Data =~
- H EDASERVE “  Name Type Title Last Modified
b ) foccache luud bv_namespace_off IBFSFalder bv_namespace_off 8/27/2017, 11:24:44 PM
| ibisamp | bv_namespace_on IBFSFolder bv_namespace_on 8/27/2017, 11:24:44 PM
F L wiretaild2 luu) dimensions IBFSFolder dimensions 8272017, 11:24:44 FM
b ) retail_samples Il facts IBFSFalder facts 8/27/2017, 11:24:44PM
| test IBFSFalder test 8/27/2017, 11:24:44 PM
o) uploads IBFSFolder uploads 8272017, 11:24:44 FM
o w_retail SQL Server Cluster Join of Fact Tables Sales, Shipme 8/27/2017, 11:24:44 PM
.% wf_retail_lite SQL Server Lite Cluster Jain of Fact Tables Sales and 8/27/2017, 11:24:44 PM
.."?j wf_retail_tiny SQL Server TINY Cluster Join of Fact Tables Sales an 8/27/2017, 11:24:44 PM
v
File name: - Master Files (*.mas) -
Open Cancel

The Open dialog box contains the following options:

Connect to Data

Opens the Metadata tool, where you can configure a Data Adapter to connect to an
existing database and create synonyms.

Upload Data

Opens the Upload tool, where you can upload user data from a machine to which you have
access. This data can be used with Db2 Web Query reporting.

Open

Opens the selected Master File.
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2. Navigating the InfoAssist+ Interface I

Accessing InfoAssist+ Options

On the InfoAssist+ application window, click the Application button to open the InfoAssist+
Application main menu of procedure-related commands. When you click New, a splash screen
that contains all available options opens, as shown in the following image.

InfoAssist

Db2 Web Query - Version 2.1

Getting Started Help
{ » Build a Report » InfoAssist Help
Build a Chart » Online Forum

» Build a Document

» Build a Visualization

» Open Existing Item

» Change Default Options

» Close Application

The available options are grouped into Getting Started and Help.

Getting Started

The following Getting Started options are available:

_I

_I

Build a Report. Opens the Open dialog box, where you can select a data source for your
report.

Build a Chart. Opens the Open dialog box, where you can select a data source for your
chart.

Build a Document. Opens the Open dialog box, where you can select a data source for your
document.

Build a Visualization. Opens the Open dialog box, where you can select a data source for
your visualization.

d Open Existing Item. Opens the Open dialog box, where you can select an existing item.

Change Default Options. Opens the Options window, where you can change the default
settings to reflect your preferences.

Db2 Web Query InfoAssist+ Part 1 19



Application Main Menu

-1 Close Application. Closes and exits the application.

Help

The Help options provide help for the new user. The following Help options are available when
you open InfoAssist+.

- InfoAssist+ Help. Opens the online documentation window for InfoAssist+.

.4 Online Forum. Opens the Focal Point website in a new browser window.

Selecting a Data Source

Selecting a data source is the first step when you create a new report or chart. When the Open
dialog box appears, select the desired data source and click OK, which closes the dialog box.
You can also double-click a data source to open it and close the dialog box in one step. If the
desired data source is not in the default directory, select a different directory using the Look in
drop-down list.

The Open dialog box is shown in the following image.

Open O x

Look in: L5 Reporting Server ~| o | B-

Mame Description Type: A
i BROKERS WebFOCUS

i@ car WebFOCUS

i@ caroLap WebFOCUS

i@ casHFLOW WebFOCUS

i COURSE WebFOCUS

i DMLoCS Plant Locations Fixed-format sequential

i EDUCFILE WebFOCUS

i@ EMPDATA WebFOCUS

i@ EMPLOYE2 WebFOCUS

i EMPLOYEE WebFOCUS

i FINANCE WebFOCUS

&8 GEDFMNG WehFOCLIS bt
< >
File name:

Files of type: Master Files -

o €5 cancel
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2. Navigating the InfoAssist+ Interface I

InfoAssist+ also displays the Open dialog box when you save a report, select a drill-down
procedure, or open a StyleSheet, theme, or Cascading Style Sheet (CSS) file.

Reference: Opening a New Procedure

When you open a new procedure, you are presented with the splash (start-up) screen.
Selecting Build a Report, Build a Chart, or Build a Document displays the Open dialog box for
selecting a data source. When you select a data source and click OK, the InfoAssist+
application window opens, as shown in the following image.

Ladls e [ &L [ S run ] Quick Access Toolbar

Home g Format Data Slicers Layout View ) UJ
—

L ’ A bata from Source ) I A = [ 2= Column Totals

Ty L = IR = Ry L © 2% B2 B

r = i = i 5 Use Sample Data = - StRowTotals

HTML =l Repor Query  Interactive  Document s - [ Theme  Style Banded Header & -

Records:  sgg Ehnie Ribbon
Format Design Report
BE [
= @ car - -~
1= 4 Dimensions
8 COUNTRY
0 CAR
£ MODEL
B BODYTYPE
B WARRANTY
B STANDARD Results Panel
=) 6 Measures/Properties
Query Design Panel
Sl | E =
r m@h‘mtma Navigation Taskbar
Sone Status Bar | ElReports - &l = || RasingeTab

Changing InfoAssist+ User Preferences

You can change the default user preferences to customize the way that InfoAssist+ behaves
when you create reports and generate output. The application theme, which is inherited from
the Bl Portal, customizes the InfoAssist+ interface, including all menus and dialog boxes.

You can style your reports by selecting a document theme independent from the interface. On
the InfoAssist+ Application main menu, click Options.
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Application Main Menu

The Options dialog box, as shown in the following image, opens to provide you with a user-
friendly interface for customizing the InfoAssist+ application.

Options %
Customize your Infossist enviranment

View Layout
Dizsign View Live Breview ] PageSie Letter -
Preview Methad Preview with Source Data |w|  Cneniacen Landscane -
Record Limit 200 = Format
Data Pansl Logical = Report output type HTML -

Query Panel Tres - Chart output typs HTMLS

Output Target single Tab - Document autput type HTML Anzlytic Documznt |

Environment and Styling

Documant Theme Use Default Styleshest Browse

Accordian Autafit

Fraazs Autofit -

S OK | dpResst | @) Cancel |

Note: If you make changes to the default selections in the Options dialog box, changes will
take effect the next time InfoAssist+ launches.

If any of the options are unavailable, contact your administrator for assistance.

You can also select a document styling theme through the ribbon. On the Home tab, in the
Report group, click Theme. For more information, see Home Tab on page 28.

Startup Options

Note: The Startup Options are disabled because in Web Query 2.x, you can choose the mode
of InfoAssist+ directly from the Resource Tree in the Bl Portal.

View

The View area provides settings for establishing the design view in which you will work, the
type of data you will use when you preview your output, the limit you need to set on your record
input, how your data and query panels will look, and the output target that you will use.

.d Design View. Values are Live Preview and Query. Select Live Preview to activate the Preview
Method drop-down menu. The default value is Live Preview.

4 Preview Method. Values are Preview with Source Data and Preview with Sample Data. This
menu becomes active when you select Live Preview from the Design View drop-down menu.
The default value is Preview with Source Data.

d Record Limit. Values are All records, 1, 10, 50, 500, or you can type a numeric value
directly in the menu. The default value is 500.
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-1 Data Panel. Values are Logical, List, and Structured. The default value is Logical.

d Query Panel. Values are 2x2 (2 columns by 2 rows), 1x4 (1 column by 4 rows), and Tree.
The default value is Tree.

d Output Target. Values are Single Tab, New Tab, Single Window, and New Window. The
default value is Single Tab.

Layout

The Layout area provides settings for printing reports and charts.
d Page Size. Values are A4, A3, A5, Letter, Tabloid, and Legal. The default value is Letter.

.d Orientation. Values are Portrait and Landscape. The default value is Portrait.

Format

The Format area provides settings for the output types for reports, charts, and documents.

-1 Report output type. Values are HTML, PDF, PowerPoint (pptx), Excel (xIsx), Excel (xIsx
Formula), Excel, Excel (Formula), Excel(csv), and active report. The default value is HTML.

.d Chart output type. Values are HTML, HTML5, PDF, PowerPoint (pptx), Excel (xIsx), Excel,
and active report. The default value is HTML5.

d Document output type. Values are HTML, PDF, PowerPoint (pptx), Excel (xIsx), Excel (xIsx
Formula), Excel, Excel (Formula), and active report. The default value is active report.

Environment and Styling

The Environment and Styling area provides settings for styling reports and charts through the
specification of a Document Theme. Click the Browse button to open the Templates - Browse
predefined template files dialog box, in which you can search for an existing Db2 Web Query
StyleSheet. The default StyleSheet is Warm.sty, but you can select from the other themes that
are available (Dark.sty or Flat.sty).

Note: StyleSheets are stored in the following directory of your Db2 Web Query installation:
/qibm/proddata/QWEBQRY/base80/ibi_html/ibi_themes
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In addition, you can access a repository of additional themes by accessing the Legacy

Templates, under Libraries, as shown in the following image.

|Zy Legacy Templates - Browse predefined legacy template files o x
B=-
w Libraries Name Size Type Last Modified Title
Templates & ENBlack_Dark.sty 5.81 KB Style File 10/8/2019, 9:04:19 PI ENBlack_Dark.sty
Legacy Templates 61 ENBlack_DarkComp.sty 5.66 KB Style File 10/8/2019, 9:04:19 PI ENBlack_DarkComp.sty
- aW , E_ﬂ ENBlack_Lightl.sty 5.57 KB Style File 10/8/2019, 9:04:19 PI ENBlack_Light1.sty
orispaces 6id ENBlack_Light2.sty 6.02 KB Style File 10/8/2019, 9:04:19 PI ENBlack_Light2.sty
¥l HealthcareNet 6i) Enelack_Medium1.sty 598 KB Style File 10/8/2019, 9:04:19 PI ENBlack_Medium1.5ty
¥l My Workspace &5 ENBlack_Medium2.sty S06KE StyleFle  10/8/2010, 0:04:10 Pl ENBlack_Medium2.sty
» lad Responsive Demo &8 ENblack_theme.sty 571KB StyleFile  10/8/2019, 9:04:19 Pl ENblack_theme.sty
¥ I Retail Samples & ENblackblupurple sty 1L64KB StyleFile  10/8/2019, 9:04:19 Pl ENblackbluepurple.sty
E_ﬂ ENblue-medium.sty 20.26 KB Style File 10/8/2019, 9:04:19 Pl ENblue-medium.sty
i ENBlue_Dark.sty 5.52KB Style File 10/8/2019, 9:04:19 PI ENBlue_Dark.sty
Ey ENBlue_DarkComp.sty 5.64 KB Style File 10/8/2019, 9:04:19 PI ENBlue_DarkComp.sty
i) EnBlue_Light1.sty 5.67 KB Style File 10/8/2019, 9:04:19 PI ENBlue_Light1.sty
&& EnBlue_Light2.sty 6.05KB Style File 10/6/2019, 9:04:19 Pl ENBlue_Light2.sty
@ ENBlue_Medium1.sty 6.01 KB Style File 10/8/2019, 9:04:19 PI ENBlue_Medium1.sty
E_ﬂ ENBlue_Medium2.sty 6.19 KB Style File 10/8/2019, 9:04:19 Pl ENBlue_Medium2.sty
Ey ENblue_theme.sty 8.08 KB Style File 10/8/2019, 9:04:19 PI ENblue_theme. sty
& ENcharcozl_theme sty B.30 KB Style File 10/8/2019, 9:04:19 PI ENcharcoal_theme.sty
&) Enpark.sty 16.24 KB Style File 10/8/2019, 9:04:19 PI ENDark.sty
i ENFlat.sty 15.87 KB Style File 10/8/2019, 9:04:19 Pl ENFlat.sty
@ ENgolden.sty 11.67 KB Style File 10/8/2019, 9:04:19 PI ENgolden.sty
61 ENgradient_combine.sty 23.84 KB Style File 10/8/2019, 9:04:19 P ENgradient_combine.sty <
»
File name: | \jce Default Stylesheet - WebFOCUS style files (*.sty) -
Use Default Stylesheet Open Cancel

The theme that you select determines the coloring and hues that display within InfoAssist+.
The default templates in the Templates section apply to all languages, whereas some of those
in the Legacy Templates sections are specific to just one language (for example, EN=English).

Note: If you switch themes when working in Report mode, all custom styling is removed from

the procedure.

.4 Accordion. Values for this option are: Autofit and Legacy. The enhanced Accordion report
format is built to autofit and be adaptive within windows and portal page containers. The

legacy Accordion report opens in a tree structure independent of the window or container.
The default value is Autofit.

Freeze. The Freeze option allows you to define a scroll area within the data of your report. It
locks column headings in place, as well as headings and footings, enabling you to scroll
through the data within the container. The scroll area is defined to automatically fit within
the size of the container where the report is run.

Changing Global Preferences

You can change global preferences for InfoAssist+ through the Administration Console, which
can be accessed from the Bl Portal Administration Menu.
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Quick Access Toolbar

The Quick Access Toolbar provides access to the most commonly used functions. It is located
to the right of the Application main menu button and is always visible no matter which options
are selected.

d Create a new report, chart, document, or visualization. Opens the InfoAssist+ splash
screen, where you can create a new report, chart, document, or visualization.

d Open existing item. Opens the Open dialog box, where you can select an existing item.
d Save. Saves a report, chart, document, or visualization.

4 Undo and Redo. The Undo icon undoes your last action. The Redo icon repeats your last
action.

The Undo icon is enabled (blue) when there is an action to undo. Otherwise, the icon is
unavailable (gray). The Redo icon is enabled (blue) when there is an action to redo.
Otherwise, the icon is unavailable (gray).

For example, if you add a database field to a report, the Undo icon turns blue. You can now
click the Undo icon to remove the database field from the report. The Undo icon turns gray,
and the Redo icon turns blue. To restore the field to the report, click the blue Redo icon.

You can also press Ctrl+Z to undo an action, or Ctrl+Y to redo an action.

You can undo and redo up to 25 actions per session. InfoAssist+ maintains the undo and
redo list of actions even when you switch between reports.

When a dialog box is open in the application window, you cannot use the Undo and Redo
icons. However, when you click OK and close the dialog box, the icons become available for
use. With a single click of Undo, you can undo all the actions that you performed in the
dialog box, and you can reinstate them with a single click of Redo.

d View code. View the underlying code for the report.

.d Procedure Settings. Click the Procedure Settings button to specify and control items for
inclusion in a procedure. The Procedure Settings dialog box presents various SET
commands which are useful when you need to tailor your report, chart, or document
presentation or content to meet your individual needs. For more information, see Using
Procedure Settings on page 76.
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- Run. Click the Run button to run a report, chart, document, or visualization immediately.
Click the down arrow to open the Run menu, which contains the following additional

options:

4 Preview. Runs the report, chart, document, or visualization in the selected format with
the limited number of records as set in the Design group on the Home tab.

d Run with Default Parameter Values. Runs a report or chart using the default parameter
values. If you have parameters defined, the default value is the first data field defined
for the parameter. If you do not have parameters defined, the report or chart will run,
regardless.

d SQL Trace. Returns the SQL commands for the request.

4 SQL Preview Trace. Returns the SQL commands for the Live Preview run.

The ribbon is a rectangular area of distinct groups of buttons that spans the top of the
InfoAssist+ application window.

The ribbon, with the Home tab selected, is shown in the following image.

= 0&@a 8 8 @ 9muw-
Home Format  Data  Slicers Layout View
—n [al) Chart =1 ﬁi&:} ? 7}, Data from Source 9 By == Ex F= Column Totals =
& = i | = T - : ¥ = i =
- [E)Report (= LS L [ Use Sample Data 2= .~ EtRow Totals
HTML Query Live Document oo Theme  Style Banded Header &
FFie - Preview i s0 = Focter

Format Design Filter Report

The ribbon is contextual and changes depending on the type of file that you are developing. For
example, in Chart mode, the ribbon is made up of nine tabs, whereas when working in
Visualization mode, the ribbon consists of five tabs. Each tab contains a subset of InfoAssist+
functionality organized in logically-related groups of controls and commands graphically
represented by distinctive icons.
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Working With the Ribbon

The ribbon contains two types of arrow-based buttons. The first type of button opens a menu
when you click it. The Orientation button is an example of this type of button. Clicking the
Orientation button opens a menu of options, as shown in the following image.

C |

Orientation

Portrait Ir\\s re
Wl Landscape
The second type of button is a split button. Clicking the left side of the split button performs a
default action. Clicking the down arrow, on the right side of the button, opens a menu of

options. The Header & Footer button is an example of a split button. It is shown in the
following image.

)
Header &

Footer @

U Report Header
Page Header

|
7 0

]
4]

Page Footer
Report Footer

Clicking the Header & Footer button on the left opens the Header & Footer dialog box. Clicking
the down arrow on the right opens a menu of options.

Some options open dialog boxes of additional commands and option lists.

The ribbon displays all controls and commands using different sized icons and groups,
depending on the size of the monitor and application window.

In the following example, the Features group is fully expanded and all its icons are visible.

= 0E@de 888 9u-

Home Format | Data Slicers Layout \View

Be-l0 2 32 3.8 % & @ & B % %

InfoMini Table Tableof  Freeze  PagesOn OLAE; Title Accordion  Repeat Sort Stack Accessibility | Auto Dril | Enable Auto  Auto Link
FFie - Contents Demand Analysis Popup value Measures Linking Target

Destination Navigation Features Run with Auto Linking

When you reduce the size of the application window, some groups are collapsed into single
icons as determined by the amount of available space.
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The following image shows the Features group, from the Format tab, collapsed into a single
icon.

= D@hde 88 B 9uw-

Home Format | Data slicers Layout View
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Destination Mavigation Run with Auto Linking

When a group is collapsed into a single icon, the individual icons are removed from view, but
are still available. Clicking a collapsed group icon restores the group to its normal full size and
displays all of the individual icons.

When expanding a collapsed group, the ribbon collapses a neighboring group to make enough
room to expand the selected group.

When an icon, button, or option in a menu or dialog box appears dimmed, that functionality is
not available for that report as it currently exists. Some functionality is available for reports
only, charts only, visualizations only, or documents only.

In some situations, selecting one or more options makes other options incompatible with the
previously selected ones. As a result, the incompatible options are dimmed and unavailable for
selection. InfoAssist+ automatically makes incompatible options unavailable as you create and
modify a report.

Note: If you do not have access to a particular option, contact your administrator.

The Home tab contains the most commonly used commands and options, which you can use
when developing reports, charts, documents, or visualizations. The following list highlights the
features on the Home tab for each mode.

4 For reports, the Format, Design, Filter, and Report groups offer options for changing the
output format of your report, as well as styling it.

. For charts, the Format Design, Filter, and Report groups enable you to change the theme or
your chart or add a header and footer.

.4 For documents, options are enabled in the Format and Design groups only. Available
options for documents include changing the data source for the document and changing
the output format.

.4 For visualizations, the Clipboard, Data, Visual, and Storyboard groups enable you to
perform some of the more basic functions, such as copy and paste. You also use the
Home tab to change your visual type.
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On the InfoAssist+ Home tab, the File & Printer Format option to direct report output to DB2
has been enhanced to support an append option, as shown in the following image.

Destination: | pg2 B

Destination/Library: ‘ |

Mame: ‘ |

® Cregte or replace table
' Append to existing table

By default, report output to DB2 will create a new table. Select the Append to existing table
option if you wish to add records to an existing table.

The Home tab is shown in the following image. The options and groups on the Home tab
change, depending on what mode of InfoAssist+ you are in.
= 0O&d4d S = CRIE LR

Home Format Data Slicers Layout View

L [l Chart = A, Data from Source - N g == == Column Totals  ~
& 4 = g s $ % B ¥
- [E) Report = [ Use sample Data Bas + Ef Row Totals
HTML Query Live Document R corie: Theme  Style Banded Header &
Frile - Preview cords: 50 (> Footer

Format Besign Fker Repor
Related Information for Reports, Charts, and Documents:

Id View on page 22

I Creating Customized Report Outputs

I Styling Reports, Charts, and Visualizations on page 333

I Filtering Data

Related Information for Visualizations:

I Interacting With Visualizations on page 265
Id Using Storyboards on page 303

Id Manipulating Data

I Joins
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The Insert tab contains options to add reports, charts, existing reports, text, images, and
active form controls (for active report and active PDF outputs only) to a canvas in Document
mode.

It is shown in the following image.

@ D da BB 9
Home | Insert | Format Data Slicers Layout View
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Note: The Insert tab is only available in Document mode.
Related Information for Documents:

.d Creating and Customizing Documents on page 221

. Accessing Document Mode on page 221

. Building a Document on page 224

The Format tab provides options for formatting your report, chart, document, or visualization.
Depending on the mode you are using, you can perform tasks such as selecting a chart type,
enabling Auto Linking, or adding navigational aspects to a report.

The following list highlights the features on the Format tab for each mode.

.d For reports, the Format tab provides access to the Destination, Navigation, Features, Run
with, and Auto Linking groups. These options enable you to perform many functions related
to reports, including Auto Drill or any other report navigation feature.

. For charts, the Format tab provides access to the Destination, Chart Types, Features,
Labels, Interactive, Run with, and Auto Linking groups. These options enable you to perform
a variety of charting tasks, including changing the chart type and adding interactive options.

.4 For documents, the Format tab enables you to change to Report or Chart mode. You can
also access InfoMini.

. For visualizations, the Format tab provides access to the Report, Features, Labels, and
Interactive groups. These options enable you to format your visualization. Also included are
grid commands, as well as various features and label commands.
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The Format tab is shown in the following image. The options and groups on the Format tab
change, depending on what mode of InfoAssist+ you are in.

U@ de: . 88 ouw-

Home Inset Format | Data Slicers Layout View Series

B WexwE & & ¢ 4 & B %

InfoMini Bar Pie Line Area Scatter  Choropleth  Proporticnal Features Labels Interactive Run with
b2 Symbol Options

Destination Chart Types Interactive
Related Information for Reports, Charts, and Documents:
.4 Styling Reports on page 80
Formatting a Series on page 140
Formatting Data Labels on page 158
Formatting a Legend on page 168
How to Style and Customize a Report on page 233

How to Style and Customize a Chart on page 234

L U o d oo ou

Using Auto Drill on page 311

- Using the Auto Linking Feature to Link Content on page 315
Related Information for Visualizations:

d Interacting With Visualizations on page 265

4 Customizing Visualizations on page 286

Data Tab

The Data tab contains data manipulation and data display options. For example, you can
access Join functionality and work with Defines and Computes. The Data tab is available in the
Report, Chart, and Document mode. It is not available in Visualization mode.

The following list highlights the features on the Data tab for each available mode.

.4 For reports, the Data tab provides access to the Calculation, Join, Filter, Display, and Data
Source groups. When working with reports, you can join data sources or create Defines and
Computes. You can also filter data.

.4 For charts, the Data tab provides access to the Calculation, Join, Filter, Display, and Data
Source groups. When working with charts, these options enable you to join data sources,
create a Define or Compute, and filter data.
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-l For documents, the Data tab provides access to the Calculation, Join, Filter, Display, and
Data Source groups. When working with a document, you can create a define or join data
sources. You can also add or switch data sources.

The Data tab is shown in the following image.

Ly L& H Q8 B 9rn-
1 Home Format = Data | Slicers  Layout  View Series
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Related Information for Reports, Charts, and Documents:
- Using Define and Compute Fields
d Joins

.d Filtering Data

Slicers Tab

The Slicers tab provides the ability to create and edit slicers. Slicers are dynamic filters that
you can use with reports, charts, and documents.

Note: The Slicers tab is unavailable in Visualization mode.

The features on the Slicers tab are the same for reports, charts, and documents. You can
perform the following functions with the slicer functionality:

- Add slicers to your report, chart, or document to create dynamic filters
d Set a record limit for the display of your data

.4 Create groups of slicers to filter your data

4 Add fields to existing slicers

.4 Clear slicers to clear all selected values from existing slicers
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The Slicers tab is shown in the following image.
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Related Information for Reports, Charts, and Documents:
.4 Using Slicers
. Filtering With Slicers

. Edit Slicers Dialog Box

Layout Tab

The Layout tab provides access to page display and layout options. These include page
orientation and AutoFit, which is a feature that limits the width of columns in a report to be no
wider than the largest value in each column.

The Layout tab is available in Report, Chart, and Document mode.
Note: The Layout tab is unavailable in Visualization mode.

The following list highlights the features on the Layout tab for each available mode.

.4 For reports, the Layout tab provides access to the Page Setup and Report groups. These
options allow you to change the size or orientation of your report. You can also add page
numbers.

- For charts, the Layout tab provides access to the Page Setup and Size & Arrange groups.
These options allow you to change the orientation or size of your chart. You can also set a
height and width for your chart, and enable the AutoFit functionality.
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The Layout tab is shown in the following image. The options and groups on the Layout tab
change, depending on what mode of InfoAssist+ you are in.
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Related Information for Reports, Charts, and Documents:
.4 Customizing Reports on page 333

4 Customizing Page Setup on page 345

The View tab provides access to reporting options, including design and display options. Some
of the options on the View tab control how information is displayed, whether it be in structured
view or list view. The View tab is available in all modes of InfoAssist+.

The following list highlights the features on the View tab for each mode.

. For reports, the View tab provides access to the Design, Show/Hide, Data Panel, Query
panel, Output Window and Report groups. When creating your report, you can change the
way your data displays or switch to another mode, such as document.

4 For charts, the View tab provides access to the Design, Show/Hide, Data Panel, Query
panel, Output Window and Report groups. When creating your chart, you can change the
output location for the chart or switch to another report or chart.

.d For documents, the View tab provides access to the Design, Show/Hide, Data Panel, Query
panel, Output Window and Report groups. When working with your document, you may want
to change the display of data in the Data pane or Query pane.

.4 For visualizations, the View tab provides access to the Show/Hide, Data Panel, and Report
groups. When creating your visualization, you can use these options to show or hide the
resources panel. You can also change the display of your data to either logical, list or
structured.
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The View tab is shown in the following image. The options and groups on the View tab change,
depending on what mode of InfoAssist+ you are in.
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Related Information for Reports, Charts, and Documents:

.4 Using the Query Pane and Filter Pane on the Canvas on page 68

Field Tab

The Field tab is enabled in the ribbon when you select a data source field. The options
available in the Field tab are specific to the data type that is selected. The options available for
numeric fields are different from the options available for non-numeric and date fields. The
Field tab provides access to the Filter, Sort, Break, Style, Format, Display, and Links groups.

The following list highlights the features on the Field tab for each mode.

. For reports, the Field tab provides options for filtering and styling your report. It also
provides you with access to the Traffic Lights and Within functionality, making your reports
more robust and customized.

.4 For charts, the Field tab enables you to hide a particular field or group values in your chart.
You can also use the filter options to limit the display of information in your chart.

-1 For documents, the Field tab provides options for filtering, as well as Traffic Light
functionality. You can also hide fields and add aggregations.

. For visualizations, the Field tab provides options for filtering and sorting, as well as access
to the Multi Drill feature. You can also hide fields and add aggregations.

The Field tab is shown in the following image.
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Related Information for Reports, Charts, and Documents:

.d How to Apply Traffic Light Conditional Styling to a Report (By Constant) on page 86
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-1 How to Apply Traffic Light Conditional Styling to a Report (By Field) on page 87
.d Changing a Field Format on page 90

.4 How to Access the Within Functionality on page 99

Related Information for Visualizations:

4 Working With Filters at Run Time on page 306

The Series tab provides access to chart options through the Select, Style, Properties, Line, and
Pie groups. The Series tab is available in Document, Chart, and Visualization mode. It is not
available in Report mode.

The following list highlights the features on the Series tab for each available mode.

4 For charts, the Series tab enables you to add such features as a trendline or data labels to
your chart. If multiple series are specified, you can select a series and specify options
specific to that series.

.4 For documents, the Series tab displays once you have specified fields within your document
or embedded chart. You can use the options on the Series tab to add markers,
smoothlines, or trendlines to your data.

. For visualizations, the Series tab enables you to switch between series, style the selected
series, or add any other property or line features, as required.

The Series tab is shown in the following image.
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Related Information for Reports, Charts, and Documents:
.4 Formatting a Series on page 140

- Formatting Data Labels on page 158

Related Information for Visualizations:

. Formatting Axis Labels on page 286
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- Using Handles to Organize Your Visualization on page 301

Understanding the Resources Panel

The Resources panel is comprised of the Data pane, the Filter pane, and the Query pane. It is
located on the left side of the InfoAssist+ interface and is visible by default. You can
customize how the Resources panel displays by using the options on the Home tab and View
tab. For example, on the View tab, in the Design group, click Query to display only the Query
and Filter panes.
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The following image shows the default view of the Resources panel, which displays the Data
pane next to the Query and Filter panes when you create a chart.
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4 Dimensions
Sales_Related
4 Product

Product,Category
2 Product, Subcategory

% Model
Values ‘¥ Filter
5hi t_Related .

LSl \} Store,Business,5ub Region Equal to Asia or Canad
St »

ore \} Sale,Year Greater than or equal to 2015
Customer

The Data pane, which contains all the fields from the selected data sources, is always
displayed.

You can manually adjust the size of the Resources panel. To do so, move the mouse pointer
over the border. When the pointer changes to a two-way arrow, drag the border.
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Reference: Field Image List

In the Resources panel, each field has an image associated with it. The following table
displays each image and describes what it represents.

Note: This list of icons changes based on the type of database that is in use.

Icon Type

n Blob

& Calculated Date Field
élg’ Calculated Numeric Field
& Calculated Other Field
5\ Calculated Text Field

&‘.

Cube Property

Date or Date and Time Field

Dimension Field (Standalone or Drillable)

Dimension Field (Drillable, Second-level)

Dimension Field (Drillable, Third-level)

Note: There are 17 dimension field levels. Level O is
specific to certain databases.

Geographic Role Dimension Field (Standalone or
Drillable)

Geographic Role Dimension Field (Drillable, Second-level)

Geographic Role Dimension Field (Drillable, Third-level)

Note: There are 17 geographic role dimension field
levels. Level O is specific to certain databases.
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Icon Type

\l( Funnel (filter)

i.i':'i Geolocation

B Index Field

Ga Key Field

E Measure

ri Numeric Field

r] Text or Alpha Field

Reference: Filter Pane

The Filter pane displays all filters that have been created for the selected report.
For more information on filtering, see Field Tab on page 35 and Data Tab on page 31.

Note: The Filter pane displays all created filters, both active (included) and inactive (excluded).

Using the Data Pane

40

The Data pane contains the data fields that are used to construct reports, charts, or
visualizations. The default structure of data in the Data pane displays your data by field type,
for example, measure field or dimension field. You can explore this structure using the sample
retail database that is included with InfoAssist+. The structure of this sample database, which
is a cube database, includes measure groups, measure fields, dimension hierarchies,
dimension fields, and attributes.

The data fields that display in the Data pane may vary. Depending on the underlying structure
of your metadata, these fields may be organized and presented differently. For example, you

may have just measures and dimensions, or you may have fields that represent multiple drill
levels. You can also have any combination of these field types.
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The structure of your metadata dictates the order of the fields, as well as the hierarchy that
they employ. InfoAssist+ displays this hierarchy based on the structure defined for the master
file that you choose. For more information on the specific field types, see Field Image List on
page 39.

If you are using a Business View (BV) data source, which is built based on a pre-determined
targeted hierarchy or structure, the view of your Data pane will be set to Structured, by default.
When using a BV data source, Logical view is disabled. These options are available on the
View tab, in the Data Panel group.

Note: When you open a BV data source, you will have access to common components, such as
measures, dimensions, and filters, but values will not be displayed.

When navigating folders and content in the Data pane, you can double-click a folder to expand
or collapse its contents. This applies to folders based on the hierarchy of your data source. It
does not apply to fields that have additional fields within them.

Note: You can also use the arrow adjacent to the folder name to expand and collapse folders.

The Expand Data Source Tree check box in the Administration Console controls the initial view
of the fields in the Data pane. For example, if you are working with a data source that has
numerous fields and you wish to collapse the list to limit their view, contact your administrator
to clear this check box. All items in the Data pane will collapse into their highest categorical
level.

The fields in the database structure are displayed in Logical view, by default. You can use the
commands in the View tab to change how your data fields are organized in the Data pane.
These commands display the data fields in a Logical, List, or Structured view. All three views
provide options for displaying each data source field as a Title, Description, Field, or Alias. The
List view also includes options to show the Alias, Format, and Reference of each field.

Field list search functionality is also available in the Data pane, which you can use to search
for specific fields within a tree or list. When conducting a search in the Tree view, the search
functionality searches only the attribute that is displayed.

When searching in List view, all attributes are searched at once.

Note: There are additional options on which you can search, including Name, Title, Alias,
Format, Segment, Filename, Description, and Reference.

As you enter search criteria, InfoAssist+ begins the search process. When you enter just a few
letters, the list of records that is returned is typically long. As your search criteria gets more
specific, the list of returned fields narrows.
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If you are conducting a search that you wish to cancel, click the X icon in the field list search
tool to abort the search.

Note: The X icon displays only when you have search criteria specified in the Search fields box.

The following is an example of the default Logical view, displaying the Title of each field.

a Data - wi_retail_lite

sald] X

g& Sale Unit(s)

= SaleYear
Sale,Quarter

i sale,Month

- Sale,Day

Y sale,Date

&y sale,Day Name

ﬁﬁ Sale,Day of Week

ﬁii Sale,Holiday

& sale,Month Name

2y sale,weekend

&y sale,vear Month

ﬁii Sale,Year Quarter

£y sale,vear Week

E SaleYear
Sale,Year/Quarter

33 Sale,Year/Month

- Sale,Day

Using the Data Pane to Add Fields to a Report

There are several ways that you can add data source fields to a report. You can drag, double-
click, or right-click data source fields in the Data pane to add them to a Query field container or
the Filter pane. You can also replace an existing field in the Query pane by dragging the new
field from the Data pane so that it is over the data field in the Query pane. You can also drag
fields from other field containers in the Query pane over a field in a different field container. A
dotted line displays, indicating that this new field will replace the existing field. Release your
mouse to confirm placement of the new data field.

Note: When you drag a field from the Data pane to the Query pane, Filter pane, or canvas, a
tooltip displays to indicate the name of the field.
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When rearranging fields in the Query pane, a solid line is used to indicate placement. A solid
line is also used when you are dragging a data field from the Data pane into the Query pane in
between existing fields or into an empty field container. You can also use the solid line to drop
a field onto a field container directly, which places that data field into that specific field
container.

After you add data source fields to a Query field container, you can change the order of the
fields by dragging and dropping one field above or below another field.

Drag. This method provides the most control. You can drag data source fields from the Data
pane to the appropriate Query field container or Filter pane.

For a larger work area in which to drop data source fields in the appropriate Query field
container, make sure that Query Design view is selected, and then, on the View tab, in the
Query Panel group, click Areas 2x2 or Areas 1x4.

You can select Query Design view on the Home tab, in the Design group, by clicking Query or
on the View tab, in the Design group by clicking Query. That selection expands the Query and
Filter panes.

Multi-Select. You can multi-select data source fields that you want to add to a report in Live
Preview, Query Design view, and Document mode. To select multiple data source fields to add
to a report, click the appropriate fields while holding the Ctrl key on the keyboard. You can drag
fields onto the canvas, or add them to the Query field container.

Double-Click. To automatically add a field to the appropriate Query field container in the Query
pane, you can double-click a data source field in the Data pane.

.4 When you double-click a measure field in the Data pane, it is automatically added to the
Sum Query field container.

4 When you double-click a dimension field in the Data pane, it is added to the By (Row Label)
Query field container for a report, or to the X-axis Query field container for a chart.

You cannot automatically add a field to the Across (Column Label) Query field container for a
report, or to the Legend (Series) and Multi-graph Query field containers for a chart.

Right-Click. You can right-click a field in the Data pane to add it to the Filter area or a Query
field container in the Query pane. For reports, the available shortcut menu options are as
follows:

4 Across. For dimension fields.

4 Add to Query. Opens a menu of available Query field containers, to which you can add your
data.
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-l Create Group. Allows you to create a group of elements based on the field data type that
you select.

Include as Category Axis. For dimension fields.

Include as Coordinated. Only available in Document mode.

Include as Legends Series. For dimension fields.

Filter. For all types of fields.

Slicers. For all types of fields.

Sort. Adds the field to the Sort field container. This is for all types of fields.

Sum. For measure fields.

L U U oo L LU uUou

Create Bins. Allows you to create a bin for the selected measure. Bins are used with the
Binning functionality. For more information, see Binning on page 130.

A measure is a numeric value, such as Gross Profit or Cost of Goods Sold, that you may want
to aggregate. All numeric values that can be summed are measures. Numeric fields that
cannot be summed, such as product number and miles per gallon, are not treated as
measures. Instead, they may be used in the same way as dimension fields to analyze
measures. It is up to you to understand your data and determine whether each numeric field
can be summed. Related measures can be organized into measure groups. For example,
Gross Profit and Cost of Goods Sold can be part of a Sales measure group.

A dimension is a way to categorize data. You can use a dimension to analyze and compare
measures. Generally, any field that is not a measure, usually an alphanumeric field such as
product, is a dimension. Dimensions can be organized into hierarchies to define the
relationships between the fields in the hierarchies. For example, a Geography hierarchy can
contain the Continent, Country, State, and City dimensions. You can also define dimension
fields that are not part of a dimension hierarchy.

Enforcing Paths to Disable Unavailable Fields

The Enforce Paths feature controls access to fields in the metadata tree based on their
relationship to other fields within your data source. With each field that you add to the field
containers in the Query pane, Enforce Paths will update the available fields and only allow for
the selection of fields in related fact tables. Fields in unrelated fact tables will become
inaccessible.

As of Release 8.2 Version 04, Enforce Paths is available to all InfoAssist users. It is disabled,
by default. This default can be changed for your site in the InfoAssist Properties section of the
Administration Console.
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Enforcing Paths can be enabled for any individual procedure by clicking the Enforce Paths
button (the silo container) to the left of the Data title in the Resources panel. This container is
shown in the following image.

3 Data - wf_retail_lite

Enforce Paths

You can disable this feature for any procedure by toggling this Enforce Paths button.

A synonym can describe a single path or multiple paths. When Enforce Paths is enabled, if a
field cannot be accessed as part of the retrieval path of fields that have already been selected,
it will be greyed out and unavailable for selection. The following example shows a data source
without and with Enforce Paths enabled, respectively.

In WFRetail, the shipping information is not directly related to the sales information so they
cannot be used together in a single request.

With Enforce Paths disabled, as shown in the following image, InfoAssist will allow you to add
a Shipping Date field and the Sales Revenue field to the field containers but the request will
not produce valid results because the fact tables have no direct link.
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With Enforce Paths Disabled

3 Data - wf_retail_lite =) Query
Search fields jo 4 EI Report (wf_retail_lite)
I Filters and Variables Z sum
4 Measure Groups 4 = By

4 53les Fl Shipping EDD,Year
g& Revenue Per,5q. Ft. Agross
5§, Revenue Local Per 5Q. M.
21 Cost of Goods,Local Curre
i Cost of Goods
.2 Discount,Local Currency

HIH

[ Discount
2] Gross Profit,Local Currenc
2 Gross Profit
2] MSRP,Local Currency
L MSRP
2 Quantity,Sold
i Revenue,Local Currency
2 Ravenue
g&, Sale Unit(s)
Shipments
4 Dimensions
Sales_Related
Product

With Enforce Paths enabled, as shown in the following image, once the Shipping Date field is
added to the field container, the sales related measures become unavailable so that the
invalid request cannot be built.
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With Enforce Paths Enabled

3 Data - wi_retail_ite ) query
Search fields jo 4 |=| report (wf_retail_lite)
I+ Flters and Variables % sum
4 Measure Groups 4 =By
4 Sgles Bl Shipping EDD, Year
B, Revenue Per,5q. Ft. == Across

B, Revenue Local Per 5Q. M,
i Cost of Goods,Local Curre
{52 Cost of Goods
[z Discount,Local Currency
iz Discount
{z2d Gross Profit,Local Currenc
i Gross Profit
izl MSRP,Local Currency
zj MSRP
&) Quantity, Sold
2 Revenue,Local Currency
i Revenue
B, sale Unit{s)
Shipments

4 Dimensions
Sales Related
Product

Using the Query Pane and Filter Pane

The Query and Filter panes appear to the right of the Data pane, except when you select Query
Design view, which expands the size of the Query and Filter panes. There are different Query
field containers for reports and charts.

Note: If you have more than one item in either Sum, By, or Across Query field containers (for
reports) or Measure (Sum) or X-axis Query field containers (for charts), you can drag them up or
down in the Query pane to rearrange the order in which they display in your report or chart.
When you drag fields to rearrange them, an indicator line displays, providing guidance as to
where the field will be placed. The color of this line is determined by the theme. Once you have
performed the rearrangement, the Live Preview refreshes based on the newly indicated order.
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Reports. For all reports, the Query field containers in the Query pane include Sum, By, and
Across.

-

Use the Sum & field container to aggregate or display numeric measure fields. Its context
menu provides options to Sum (default), Print, Count, or List the fields in the report.

Use the By Query field container to vertically sort dimension fields to produce row labels in
the report output. Dimension fields are normally non-numeric or date fields.

Use the Across Query field container to horizontally sort dimension fields to produce
column labels in the report output.

Charts. For most charts, the Query field containers in the Query pane include Measure (Sum),
X Axis, Legend (Series), Multi-graph and Coordinated. More complex charts that require
additional dimension fields have alternative Query field containers.

-

Measure (Sum). Use this Query field container to aggregate or display numeric measure
field values.

Location. Use this Query field container to display a location field. This Query field
container displays for maps only.

X Axis. Use this Query field container to sort dimension fields in the chart output.

Legend (Series). Use this Query field container to display dimension fields as color-coded
values (lines, bars, areas, scatter plots) that match the color-coded dimension values
displayed in the legend below the chart. Legend (Series) provides functionality that is
similar to an Across field in a report.

Multi-graph. Use this Query field container to create outermost sort fields and to serve as a
page break for working with multiple charts. The sort field added to this Multi-graph Query
field container is not plotted on the chart, but each unique sort field value is listed for every
chart.

Coordinated. Use this Query field container to collectively sort and collate by a common
sort group (for documents only).

For pie charts, the Query field containers in the Query pane include Measure (Sum), Slices,
Category, Multi-graph, and Coordinated.

-1 Measure (Sum). Use this Query field container to aggregate or display numeric measure

field values in the pie.
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- Pie slices. Use this Query field container to display dimension fields as color-coded pie
slices that match the color-coded dimension values displayed in the legend below the
chart. The Pie slices Query field container is equivalent to the Legend (Series) Query field
container used for other chart types.

d Multi-graph. Use this Query field container to create outermost sort fields and to serve as a
page break for working with multiple charts. The sort field added to this Multi-graph Query
field container is not plotted on the chart, but each unique sort field value is listed for every
chart.

d Category. Use this Query field container to sort dimension fields in the chart output.
Category is equivalent to the X-axis Query field container used for other chart types.

.d Coordinated. Use this Query field container to collectively sort and collate by a common
sort group (for documents only).

Using Field Containers

Field containers are used to hold fields that you select based on the function that you want it
to perform. For example, in Chart and Visualization mode, you can add a field to the Color field
container, which will color your data based on the selected field.

For reports, the available field containers are different than those presented for charts and
visualizations. This section reviews all of the field containers, providing you with a reference
point when working with field containers.

Field Containers for Reports

The following field containers display when creating reports.

Across

Enables you to display column headings across the top of the report for the measure or
dimension that is placed in this field container.

By
Enables you to specify sort fields for your report.

Note: You can rearrange the display order of your By sorts by dragging them into the
desired order in the Query pane.

Sum

Displays numeric totals for numeric (measure) fields that are added to this field container.

Db2 Web Query InfoAssist+ Part 1 49



Understanding the Resources Panel

50

Field Containers for Charts and Visualizations
The following field containers display when creating charts and visualizations.

Animate

Enables you to animate time progression using a slider control. As you move the control
along the slider bar, an animation effect results. The slider control has a Play button that
allows you to play and pause the animation. When you click Play, the Pause option is
activated, enabling you to pause the progression and analyze your data. Slider controls are
limited to one sort field and should be time or sequence related, such as month or year.
This field container displays for many different chart types.

By

Use this field container to differentiate data types in a field that contains multiple
categorical values. For example, when creating a gauge chart, the field that you specify in
this field container becomes a By field, by which all values are displayed as a separate
chart.

Category

Enables you to display data categorically in a chart. This field container displays for Tag
Cloud charts, which are available in the Other charts category.

Category Axis

Use this field container to specify a field that contains categorical data. These categories
display on the categorical portion of a 3D bar chart. The other axis, Series Axis, is plotted
against the categorical data.

Close

Enables you to specify a numeric field to indicate the closing value of a stock. Other
required values include: Open, High, and Low. This field container displays for Stock
charts, which are available in the Other charts category.

Color

Enables the application of different colors based on the underlying data set for the field in
this field container. When you place a numeric field in the Color field container, the legend
displays as a heat scale. When you place an alphanumeric or a date field (non-measure) in
the Color field container, the legend displays as colored markers. To change how the
legend displays, right-click the Color field container and click Color BY.
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Columns

Enables you to specify a field to display column data in a matrix chart in a visual. The use
of measure fields is supported. Column data is displayed at the top of the visual, along the
X axis. This field container is available for charts and visualizations.

Detail

Use this field container to add detail to your visual by adding a data field to it. For
example, if you add Sale,Quarter to the Detail field container in your Scatter plot, the
points on the plot are quadrupled, one for each quarter. In addition, the field that you
specify in the Detail field container also displays on the hover menu for each point in the
plot.

Geolocation

Enables you to specify a Geolocation field for use in a map.

'Irh
Note: Geolocation fields are listed in the Data pane with a Geolocation icon %&.
Grouping

Enables you to specify a field by which to present your data in categories or groups. For
example, this data field controls how a treemap is grouped.

High

Enables you to specify a numeric field to indicate the high value of a stock. Other required
values include: Open, Low, and Close. This field container displays for Stock charts, which
are available in the Other charts category.

Horizontal Axis

Displays the data for the selected along the X axis. This field container is available for
charts and visualizations.

Note: You can specify up to three fields on the horizontal axis.
Latitude

Enables you to specify a geolocation field that contains latitudinal data. This field container
displays for Leaflet bubble maps.

Longitude

Enables you to specify a geolocation field that contains longitudinal data. This field
container displays for Leaflet bubble maps.
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Legend (Series)

Enables you to add a field to specify for the legend of the chart. This field container
displays for a number of charts that are available in the Other chart category.

Low

Enables you to specify a numeric field to indicate the low value of a stock. Other required
values include: Open, High, and Close. This field container displays for Stock charts, which
are available in the Other charts category.

Lower Limit

Enables you to specify a numeric (measure) field by which to establish a lower limit. This
field container displays for Vertical Box Plot charts, which are available in the Other chart
category.

Lower quartile

Enables you to specify a numeric (measure) field by which to establish a lower quatrtile.
This field container displays for Vertical Box Plot charts, which are available in the Other
chart category.

Measure

Use this field container to specify a measure that will serve as the basis for a pie chart.
The Measure metric is used with the Color field container for pie charts to create sections
based on your field selections. It is also used with Gauge charts.

Measure (Sum)

Enables you to specify a numeric (measure field) by which to sum data. This field container
displays for a number of charts that are available in the Other chart category.

Median
Enables you to specify a numeric (measure) field by which to establish an median. This
field container displays for Vertical Box Plot charts, which are available in the Other chart
category.

Multi-graph
Enables the creation of multiple graphs based on the field that you place in this field

container. This field container displays for many different chart types, including Spectral
Heatmaps, which are available from the Other dialog box.

Open

Enables you to specify a numeric field to indicate the opening value of a stock. Other
required values include: High, Low, and Close. This field container displays for Stock
charts, which are available in the Other charts category.
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Rows

Enables you to specify a field to display row data in a matrix chart in a visual. The use of
measure fields is supported. Row data is displayed on the left side of the visual, along the
Y axis. This field container is available for charts and visualizations.

Series Axis

Use this field container to specify a series to plot against the data presented on the
Categorical Axis. This field container displays for 3D bar charts.

Size
Controls the size of markers or other data points.
Size (Sum)

Enables you to specify a numeric (measure) field, which will control the size of the data
presented in a chart. This field container displays for Tag Cloud charts, which are available
in the Other charts category.

Slices

Enables you to specify a field whose data values will dictate the size of the slices in a
chart. This field container is available for Funnel charts, which are available in the Other
chart category.

Tooltip

When you place a field in this field container, InfoAssist+ enables you to view additional
information in the tooltip for a chart or visual.

Upper limit

Enables you to specify a numeric (measure) field by which to establish an upper limit. This
field container displays for Vertical Box Plot charts, which are available in the Other chart
category.

Upper quartile

Enables you to specify a numeric (measure) field by which to establish an upper quartile.
This field container displays for Vertical Box Plot charts, which are available in the Other
chart category.

Vertical Axis

Displays the data for the selected field along the Y axis. This field container is available for
charts and visualizations.
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X Axis

Enables the specification of a field on the X Axis of certain chart types. For example, XY
Polar. This field container displays for a number of charts that are available in the Other
chart category.

Y1 Measure (Sum)

Enables you to specify a measure (numeric) field for the Y Axis in a Pareto and certain line
charts, which can be accessed from the Other chart category.

Y2 Measure

Use this field container to indicate a measure to serve as the basis for second Y axis. This
field is used in various line charts, which can be accessed from the Other chart category.

Adding Parameters for Data Selection at Run Time
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You can add new parameters to your report or chart to create parameter options for selection
at run time. This enables you to dynamically select and review different scenarios with your
data, offering you on-demand, dynamic report or chart creation at run time.

When you add a parameter, it becomes a field container into which you can add one or more
measures and dimensions. You create a new parameter by right-clicking on a field container in
the Query pane and clicking New Parameter. This creates a numbered parameter (for example,
Parameter 1). In cases where you have multiple parameters defined, the numbering is applied
sequentially.

Once you add a parameter, you can define the parameter prompt by right-clicking the
Parameter-n field container and clicking Parameter Prompt, where n is the number of the
parameter that was added. The new parameter prompt will display in the Query pane and at
run time. This allows you to easily identify the parameters while categorizing the data fields
that you want each to contain. For example, if you add a number of Sales-related fields to a
parameter, you can rename the parameter with a title of Sales to encapsulate the data fields
that you selected. Parameters should be renamed before you run the report or chart so that
they are easy to identify.

In order to populate parameters in your report or chart, data fields must be placed in the
parameter field container. You can do this by selecting fields from the Data pane and dragging
them into the relevant parameter field containers that you create.

Note: Double-clicking the data fields in the Data pane places the data field in the default field
containers in the Query pane, not the parameter field container. For example, in a report, if you
double-click Discount, the data field is placed in the Sum container (outside of the parameter
field container that you created). You can always drag a data field into a parameter container
from another field container in the Query pane if you wish to consider it a parameter.
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You can also reorder the data fields that you have placed in a given parameter field container
by dragging them into the order that you wish to display them at run time.

Parameters can be specified in any field container, with the exception of Multi-graph. Once you
have defined your parameters and selected the relevant data fields, run the report or chart.
Using the drop-down lists for each parameter, you can select different options from the
parameter lists to view the data in your report or chart dynamically. To load different scenarios,
select the values and then click Run.

The following image shows the Query pane with a number of parameters and data fields
specified.

[ul] Query
4 [,il] Chart (wf_retail_lite)
a 577 Matrix
EE Rows
jjj Columns
a [l Axis
4[| vertical Axis
4 [ Sales
B Cost of Goods
B Discount
B Gross Profit
a I!A! Harizantal Axis
4 |14 Product
B Brand
B Product,Category
B Product,Subcategory
a Ed Marker
% Color
B] size
#2| Tooltip
E Multi-graph
=} Animate

Procedure: How to Add a Parameter

1. Create a new report or chart or open an existing one.
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2. Add a new parameter by right-clicking a field container and clicking New Parameter, as

shown in the following image.

4 [al) Chart (wf_retail_lit=)
a 57 Matrix
[ =]
4= Rows

jjj Columns

a [l axis
Ll vertical pvic
I!.!! Horizont New Parameter %
Multi- split

=
4 un| Marker

% Calor

A new parameter field container is added.

Add the data fields that you would like to display in a parameter list at run time to the new
parameter field container.

Optionally, rename the parameter by right-clicking the parameter and clicking Parameter
Prompt.

This is not required, but it does help in differentiating the various numbered parameters
that display, depending on how many you define.

Note: When the defining parameter prompt, you can include a space in any position in the
prompt string. The first character cannot be a single quotation mark (') and the following
characters cannot be used within the parameter prompt: & . ; ()

Optionally, add one or more additional parameters, and relevant data fields, into the field
containers for which you would like to select data values at run time.

On the Quick Access toolbar, click Run.

You can use the Parameter drop-down lists that display at run-time to create different
views of your data, as shown in the following image.

Sales

Discount

Product

Product Category
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Note: You can optionally run your report or chart using the default parameters without
making a selection. Click the down arrow on the Run button in the Quick Access toolbar
and select Run with Default Parameter Values.

The following navigational icons display at run time:

Icon Description

Close Filter Panel. Click this option to collapse the filter panel,
displaying more of the report or chart in the right pane.

Reset filter values. Click this option to reset the filter values to
their default values, as indicated when the parameter was
initially set up.

Run with filter values. Click this option to run the report or chart
based on your selections.

Show filter panel. Click this option to show the filter panel when
viewing a report or chart. When viewing the filter panel, you can
close it by clicking Close Filter panel.

Using Shortcut Menu Options in the Query Pane

In the Query pane, you can right-click any field and select from a list of available options that
are displayed in the menu that appears. The options that you can select vary, depending on
the type of Query field container in which the field is located and the type of report that you are
creating.
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You can also rename the content type in the Query pane. You can right-click the component
and click Rename to change the title, as shown in the following image

|,1|] Query
a [il] Chart (wf_retsil litad
4 £ Matrix Rename
s
EE Roy cum
"]*]'_] 2. Primt
“ M‘ Al Count

a |LII Vertcar Bs

This allows you to customize the title in the Query pane. In addition, when working in Excel
format, the name that you provide is used as the worksheet name in the workbook that is
generated at run-time.

Note:

. If you are working with a report or chart in HTML format, you can also access Sum, Print,
List, and Count aggregations from the shortcut menu on the report or chart component.

Related Information:
. Using Field Containers on page 49

- Right-Click Field Options in the Query and Filter Panes on page 58

Right-Click Field Options in the Query and Filter Panes

The following table lists and describes all the right-click field options available in the Query and
Filter panes for a selected field.

Option Description

# of Columns Opens the Number of Columns dialog box, where you can indicate
the number of columns in which you wish to display multiple
graphs. This is only available for the Multi-graph field container.
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Option

Description

Aggregation Functions

Provides a menu for selecting options to assign an aggregation
type value to a selected numeric or dimension (non-numeric) field
in a report or chart.

Break Provides a menu of options to enable page breaks and subtotals,
and resetting page numbers. This option is available for any
measure or dimension field used in a report.

Color BY Changes the Color field container to Color BY. The field container

also changes to Color BY when you place a field into the Color
field container. You can disable Color BY, which changes a
dimension field into a measure field. This option is only available
for charts and visualizations.

Create Group

Allows you to create a group of elements based on the field data
type that you select. Once you define a new group, a higher-level
field is created that contains the selected elements. This option
is available for dimension fields of non-numeric format or
attribute.

For more information, see How to Create a Dynamic Group on
page 63.

Change Title Opens the Edit Title dialog box, where you can change the title of
the selected field by typing the new title in the Enter Title field.
This option is available for all fields.
Note: When changing the title of a column heading, you can place
a comma between words in the Enter Title field to create a multi-
line header.

Data Bars Provides a menu for enabling the data bar representation

functionality. Selecting On adds a data visualization column to the
right of a selected numeric field. The column displays values in
each row using horizontal bars that extend from left to right in
varying lengths, depending on the corresponding data values. This
option is available for fields within the Sum field container in a
report.
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Option

Description

Delete

Deletes the selected field. This option is available for all fields in
every field container.

Note: In the Query and Filter panes, you can select and delete
multiple data fields at one time. Using the CTRL key, select two or
more data fields, right-mouse click, and then click Delete.

Drill Down

Opens the Drill Down dialog box, where you can create multiple
drilldown links on a data field to external procedures or websites.
This option is available for any measure or dimension field in a
report or chart.

Edit Format

Opens the Field Format Options dialog box, where you can edit
the field type and display options. This option is available for
fields within the Sum field container in a report, as well as
measure fields in a chart or visualization.

Note: Any changes to the format of a field will be reflected in the
tooltip for charts at run time, as well as for visualizations at
design and run time.

Filter Values

Opens the Filter dialog box for creating WHERE statements, which
enable you to select only the data that you want and to exclude
all unwanted data. This option is available for all fields, except for
a field in the Multi-graph field container.

Geographic Role

Opens the Location Type dialog box, from which you can make a
location selection.

Note: This option is only available when working with Leaflet
maps.

Multi-Y split

Allows you to display individual charts for each measure field
where multiple measures are specified. Located on the Vertical
Axis, this option is available for charts and visualizations.
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Option

Description

New Parameter

Allows you to add new parameters to your report or chart, which
creates parameter options for selection at run time. You can
create a new parameter in a report or chart in any field container.

Note: When working with charts, a new parameter can only be
added for charts that use the new attribute syntax.

Missing

Allows you to show or hide fields with no value. This option is
available for fields in the Sum and By field containers in reports.
For charts, the option appears but is disabled.

Sort

Provides access to the Sort, Rank, and Limit menus. The Sort
menu allows you to sort your data either in ascending or
descending order. The Limit menu allows you to specify the
number of unique values displayed for a sort group that has been
added. The Rank menu allows you to insert a rank column
immediately to the left if a Sort By field is selected and adds a
rank column to the left of the Sort By field if a Measure field is
selected. Ranking a Measure field results in two copies of the
field, the original Measure field and the Sort By field that is
created during ranking. This option is available for any measure or
dimension field used in a report or chart.

Sub Footer

Opens the Sub Header & Sub Footer dialog box, where you can
edit and style your footers. This option is available for fields
within the By field container in a report.

Sub Header

Opens the Sub Header & Sub Footer dialog box, where you can
edit and style your headers. This option is available for fields
within the By field container in a report.

Suppress Empty Group

Suppresses any part of your chart that is empty. You can deselect
this option, which is enabled, by default. This option is available
on the Horizontal axis in both Chart and Visualization mode.
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Option Description

Sort by Total Value Enables you to sort the output in a chart or visualization using the
values from the y-axis (Horizontal axis) of a stacked bar chart.
While this feature was implemented specifically for Stacked Bar
charts, it also applies to regular bar charts, as well as line and
area charts. This enables you to view your data as ranked, or
sorted, from highest value to lowest value. Accordingly, this
option sorts the output by the bar (or other) with the highest total.
This option is set to Off by default, but you can select Ascending
or Descending to sort your data. This option is available on the
Horizontal axis in both Chart and Visualization mode.

Note: If you rotate your chart horizontally, the Sort By Total Value
menu option displays on the Vertical Axis.

For more information, see How to Sort a Chart by Total Value on
page 215.

Traffic Light Conditions | Opens the Traffic Light Condition dialog box, where you can add
new conditional styling or modify existing conditional styling by
applying traffic light (and other) colors to a selected field in the
report output when the field meets specified criteria. This option
is available for both measure and dimension fields in reports and
measure fields in charts.

Visibility Provides a menu for controlling the visibility of the selected field.
Clicking Hide removes the selected field from the report output.
Clicking Show (default) displays the selected field in the report
output. This option is available for all fields, except for the Multi-
graph field container or parameters.

All of the shortcut menu options that are available in the Query and Filter panes are also
available in the Field tab. For more information, see Field Tab on page 35.
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Dynamic Grouping

Dynamic grouping allows you to create groups of elements based on the field data type that
you select. For example, in the wf_retail_lite database, there are a number of brands of
televisions. Using the dynamic grouping functionality, you can create groups based on the
popularity of a particular brand. The first group might include top sellers such as LG and Sony.
The second group might contain the remaining brands (Panasonic, GPX, Supersonic, Tivax, and
Audiovox). This would allow you to group top sellers into one group, and the remaining brands
into another group.

Note: The Create Group option is only available for dimension fields of non-numeric format or
attribute.

You can also specify multiple, unique groupings in the same session. For example, you might
want to group the data to indicate groups or products, or specific regions.

Note: If you want to exclude a specific data element from your analysis, you can use the filter
functionality.

The grouping that you specify is applied and this new group then replaces the original field that
you selected in the Query pane. The name that you specify when creating the group is reflected
in the Query pane.

The process of dynamic grouping creates a Define field, which can then be used in other
reports or charts in the same session. Dynamic grouping also supports Auto Drill, enabling you
to drill through the hierarchy of your data just like any other data field. For more information,
see Using Auto Drill on page 311.

Note:

- You can edit the group once it has been created by right-clicking on the higher-level field
and clicking Edit Group.

4 When working with Reporting Objects, Dynamic Grouping is not supported.

Procedure: How to Create a Dynamic Group
1. From the Data pane, add one or more data fields to your report or chart.

Note: You can use the dynamic grouping functionality on non-numeric dimension fields
only.

2. In the Query pane, right-click the data field for which you want to apply dynamic grouping.
Note: The Create Group option is also available in the Data pane shortcut menu.

3. Click Create Group.
The Create a Group dialog box displays.
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4. In the Field text box, optionally type a hame for the new group.

Note: The fully qualified field name is displayed in the Field Origin text field. This field is
enabled and has a read-only attribute. The display of the fully qualified field name is
particularly useful when renaming or editing a group, as it identifies the data source
followed by the hierarchical location of the field within a data set. For example,
WF_RETAIL_LITE.WF_RETAIL_PRODUCT.BRAND.

5. Select the data values that you want to group. Use CTRL + click to select more than one
value, as shown in the following image.

'EE Create a Group O x
Field: | PRODUCT_SUBCATEG_1 Field Origin: |WF_RETAIL_LITE.WF_RETAIL_PRODUCT.PRODUCT_S!
Groups
e Group
| Search: jel X

Charger

DVD Players

DVD Players - Portable
Flat Panel TV
Handheld

Headphones

Home Theater Systems
Portable TV
Professional

Receivers

Smartphone

Speaker Kits

standard

Streaming

Tablet

Universal Remaote Controls -

@) Cancel 2 Apply

6. Click Group.

Note: To ungroup values, click a group and then click Ungroup.
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7. Optionally, create additional groups, as shown in the following image.

EE Create a Group

O x
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Charger

Speaker Kits
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Tablet

W 0K ® Cancel A2 apply

8. Click OK.

Your grouped data will display in the Data pane when your report, chart, or visualization
refreshes, as shown in the following image.

3 Data - wi_retail_lite

Query Variables
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Product
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=8 ProductGroups
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Understanding the Canvas
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The canvas displays a preview of the report being created or modified on the canvas when you
are in the default Live Preview. To select Live Preview, go to Home tab, and in the Design
group, click Live Preview, or on the View tab, in the Design group, click Live Preview. The
canvas is always fully maximized and cannot be minimized, cascaded, or tiled. However, a
blank canvas opens when there is no report.

The canvas displays either live data or sample data.

4 To display live data, on the Home tab, in the Design group, click Data from Source (default).

When you select Data from Source, a live preview of the report being built, with records
from your data source, is refreshed on the canvas as you add, remove, and style fields in
the report.

When you use live data, you can set the number of records that display in your content by
selecting a value from the Records menu. Displaying more records gives a more complete
view of your data at design time, but may result in slower performance.

Note: Prior to Release 8207, when creating content using an Oracle Database 12c data
source, design time record limits were applied prior to aggregation. In Release 8207 and
higher, the record limit when using Oracle Database 12c is applied after aggregation.

4 To display sample data, on the Home tab, in the Design group, click Use Sample Data.

When you select Use Sample Data, the canvas displays sample data based on the field
type, with the same formatting and styling used to display live data.

When you execute a report, the canvas displays the Output window. If the Output is minimized,
or if there is no report to preview, the canvas is blank. To change the canvas view, you can
select Query Design view or Live Preview from the Design group of the View tab or Home tab.
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The following image shows the canvas, which displays a chart preview when you first launch
InfoAssist+ to create a chart. The Resources panel appears to the left of the canvas.

3 Data - wi_retai_lite [ul} Query T Live Preview (500 Records)
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Sales_Related il Horizontal Axis 40
Product 4 T3 Marker
Shipment_Related 2 Color
Store Bl size
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When working with a report in Live Preview, you can rearrange the columns of the report by
dragging them to the left or right, depending on your display preference. If the column is

numeric, you are presented with the option to Drop as Sum or Drop as Sort, as shown in the
following image.

=

~

i Live Preview (500 Records)

Product

Category Drop as Sort Gross Profit
Accessories 13 T em 854,440.53
Camcorder 161,574 103, D 598 845 24
Computers 10812537320 53350881812

Note: If you select Drop as Sort, the values are listed individually and they are sorted. If you

select Drop as Sum, the values are summed for that particular row. The default is Drop as
Sum.

When placing the column in a new location, an indicator bar displays, indicating the location of
placement for the moved column. This allows you to see where the column will be placed
before you actually perform the operation.
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Note: Column sort order can also be rearranged by dragging the fields in the Query field
containers of the Query pane to reorder them. For more information, see Using the Query Pane
and Filter Pane on page 47.

If you create a filter, then the filter appears in the Filter pane.

Using the Query Pane and Filter Pane on the Canvas

If you click Query on the Home tab, in the Design group, the Query and Filter panes expand in
to the canvas.

This provides a larger area for displaying the Query and Filter panes. This feature is useful
when you are designing a report with multiple filters or numerous fields.

Depending on whether you are creating a report or a chart, the Query pane displays selected
data source fields using different types of Query field containers.

Related Information:
4 Using Filters to Customize the Display of Data

. Using Field Containers on page 49

Understanding Output Options

68

When you run a report, the output appears, either in a tab on the canvas, or in a new browser
window. You can create and display output in several different ways, depending on the
following options. You can select these options on the View tab, in the Output Window group:

- Cascade

Tile Horizontally
Tile Vertically
Single Tab

New Tab

Single Window

New Window

L U o U U U

Switch Output

Output window and tab options are also available in the status bar, and output window display
options are also available in the Navigation taskbar.
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Reference:

Reference:

Note: When you run a report, tab focus is not on the output window and pressing the Tab key
does not move the selection. To move the Tab focus out of the output window, press F6.

Output Target Options

The following are output target options that you can select.

. Single Tab. When you click Single Tab and run a report, a new output window is created on

the canvas, a report instance is created, and an output tab is placed on the Navigation
taskbar. As you modify a report, the same output window is refreshed each time the report
is run. This option, which is the default, is ideal when you are working with just one report.

New Tab. When you click New Tab, each time you run a report, a new output window is
created on the canvas. A new report instance is also created and preserved by the addition
of a new output tab on the Navigation taskbar. Each output tab maintains the output of the
report that generated the corresponding output window. Selecting an output tab on the
Navigation taskbar loads the associated output instance into the output window.

Single Window. When you click Single Window and run a report, a hew browser window is
opened and populated with the report output. As you modify the report, the same browser
window is refreshed each time the report is run. If the browser window is closed and the
report is run, a new browser window is opened again and is refreshed for each subsequent
run. The output is not displayed on the canvas, and an output tab is not added to the
Navigation taskbar.

New Window. When you click New Window, each time you run a report, a new browser
window is opened and populated with the report output. The output is not displayed on the
canvas, and an output tab is not added to the Navigation Taskbar.

Output View Options

The following are output view options (Arrange) that you can select.

.4 Cascade. When you click Cascade, if multiple output windows exist, they are cascaded

diagonally across the canvas. This option does not affect open browser windows when you
select New Window or Single Window.

Tile Horizontally. When you click Tile Horizontally, if multiple output windows exist, they are
tiled horizontally, one above another, across the canvas. This option does not affect open
browser windows when you select New Window or Single Window.

Tile Vertically. When you click Tile Vertically, if multiple output windows exist, they are tiled
vertically, side by side, across the canvas. This option does not affect open browser
windows when you select New Window or Single Window.
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Reference:

- Switch Output. When you click Switch Output, a drop-down menu opens, where you can
select any active report to view the output. The selected report is loaded into the output
window or browser window, depending on the selected output window or tab option.

Output Format Options

The Output window can display report output in the following formats: HTML, HTML5, active
report, PDF, and active PDF.

Note: Excel and PowerPoint formats open in their native programs in a window external to
InfoAssist+.

Using the Navigation Taskbar

70

The Navigation taskbar provides quick access to all active output windows and to the report
design that generated the output. You can return to the last report that you edited in the Query
pane by clicking Display Design View on the taskbar. The Navigation taskbar is always visible. It
is located near the bottom of the application window, just above the status bar.

Each of the active output windows displays a tab on the Navigation taskbar. Selecting the tab
displays that output window on the canvas. If you save a report with a unique name each time
you modify it, when the report is executed and a new output window is generated, the unique
name appears as a tab on the taskbar. If you continue to modify and execute a report without
saving it with a unique name, a number in parentheses is appended to the original, saved
report name to differentiate it among the multiple output windows.

The ability to select report output from the Navigation taskbar depends on the output window
option selected from the status bar or from the Output Window group of the View tab. For more
information, see Using the Status Bar on page 71, or Understanding Output Options on page
68.

Each report tab on the Navigation taskbar has a shortcut menu with the following options:
.4 Restore

Minimize

d

4 Maximize
d Close

1

Auto Resize
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Restore, Minimize, Maximize, and Close are standard options available in any browser window
or software application. Minimize, Maximize (if the window is not maximized), or Restore (if the
window is maximized), and Close can also be found in the top-right corner of the output
window.

The Auto Resize option enables automatic resizing of an output window as needed when you
add or remove fields.

The Window Options menu at the far left of the Navigation taskbar provides options for
displaying all active output windows on the canvas. The display options that you can select are
Cascade, Tile Horizontally, Tile Vertically, Restore All, Minimize All, Maximize All, or Close All.
The name of each active output window appears at the bottom of the menu.

The Window Options menu options are directly linked to the options available in the Output
Window group of the View tab.
Using the Status Bar

The status bar displays the status of the last selected action, a reports button that shows the
number of open reports, an output format button that shows the selected format, as well as a
list of the available formats, and an output target button that shows the selected option for
displaying new output windows or tabs.

The status bar is shown in the following image.

Done =) 9 Reports - & ] HTML - | figSingle Tab -

When you click the reports button, a menu opens, with options for selecting any of the open
reports. Each report is listed by name and an icon which represents the report type (report,
chart, visualization, document). The report you select becomes active.

When you click the output format button, a menu opens, with options for selecting a different
output format. For a complete list of options, see Understanding Output Options on page 68.

When you click the output target button, a menu opens, with options for Single Tab (default),
New Tab, Single Window, and New Window. For more information, see Understanding Output
Options on page 68.
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Chapter

Creating and Customizing Reports

You can apply styling to specific areas of a report to customize its appearance and
functionality. You can also use the many optional reporting features to add custom
functionality and output formats to reports.

In this chapter:

.4 Creating Reports

. Styling Reports

4 Changing a Field Format

4 Using Custom Reporting Features

- Creating Customized Report Outputs
Creating Reports

You can use the following procedures to create a basic report in the Bl Portal and InfoAssist+.

Procedure: How to Create a Report

After you have signed in to Db2 Web Query, you can work with an existing folder, or create a
new folder in the Bl Portal to store your reports.

1. Open InfoAssist+ in Report mode.

2. Drag fields onto the canvas or into the Query pane to begin building your report.
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A basic report is shown in the following image.

Product Quantity

Category Sold Revenue
Accessories 511,667 5129 608,333.53
Camcorder 455 244 5154 46570224
Computers 3/1,777 $103 315 48212
Media Player 771,934 5246 073,059 35
Stereo Systems 1,114,332 52591,294 933.52
Televisions 105,188 £78,381,132.81
Video Production 199,749 5§58 053,276.62

Procedure: How to Create a Report From the Application Main Menu

Procedure:

74

1.

In the upper-left corner of the InfoAssist+ interface, click the /A button to open the
Application Main Menu.

From the Application Main Menu, click New.
The InfoAssist+ splash screen opens.
On the InfoAssist+ splash screen, select Build a Report.

The Open dialog box opens.

From the Open dialog box, select the data source that you want to use, and click Open.

The data source that you selected appears in the Data pane of the Resources panel.

Drag fields onto the canvas or into the Query pane to begin building your report.

How to Create a Report From the Quick Access Toolbar

1.

On the Quick Access Toolbar, click the New icon.
The InfoAssist+ splash screen opens.
On the InfoAssist+ splash screen, select Build a Report.

The Open dialog box opens.

From the Open dialog box, select the data source that you want to use, and click Open.

The data source that you selected appears in the Data pane of the Resources panel.

Drag fields onto the canvas or into the Query pane to begin building your report.
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Procedure: How to Create a Report From an Existing Chart

1.
2.

Open the chart that contains the data that you want to present in a report.
On the Home tab, in the Format group, click Report.
The data is presented as a report.

Note: When creating a report, the SUM or PRINT field containers can support the addition
of up to 99 fields. If you add a one-hundredth field, it will automatically replace the last
field on the list.

Choosing a Report Output

The following output types are available for reports:

L U o o U u

HTML

active report
PDF

active PDF
Excel

PowerPoint

Note: When you create a report in Document mode, you have access to Excel only.

When you create a report in Live Preview or Query Design view, you have access to the
following Excel output types:

_I

_I

_I

Excel (xIsx). Outputs the report in Excel 2007 (and higher) format.
Excel. Outputs the report in Excel format.

Excel Formula (xIsx). Outputs the report, using Excel formulas that calculate and display
the results of any type of summed information, such as column totals, row totals, and
subtotals. This format is for Excel 2007 (and higher).

Excel Formula. Outputs the report, using native Excel formulas for totals and computed
values.

Note: Additional output types can be enabled in the Db2 Web Query Administration Console,
including Excel Pivot.
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Using Procedure Settings

Procedure Settings, also known as SET commands, enable you to specify and control items for
inclusion in a procedure. If you want to include a Procedure Setting in a procedure (.fex), select
the relevant check box to include that setting in the procedure (.fex). Procedure Settings are
available in Report, Chart, and Document mode.

You can access Procedure Settings from the Quick Access toolbar. When you click Procedure
Settings, the Procedure Settings dialog box displays, allowing you to select the options to apply
to your procedure, as shown in the following image.

Options include:

-
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Collation Sequence (COLLATION). Establishes a binary or case-insensitive collation
sequence. Options include Code Page (default), Binary, Case-Sensitive, and Case-
Insensitive. This value will not be written into the procedure (.fex), by default. Therefore,
you must select the check box to prompt this action.

Summary Lines (SUMMARY LINES). Allows you to combine fields with and without prefix
operators on summary lines in one request. Options include New (default value), Old, and
Explicit. This value will not be written into the procedure (.fex), by default. Therefore, you
must select the check box to prompt this action.

Missing Value (NODATA). Specifies the missing data characters to be printed in a report.
This is a text box with a default value of period ( . ). Common entries include N/A or NONE.
In addition, this field has a limit of six characters. This value will not be written into the
procedure (.fex), by default. Therefore, you must select the check box to prompt this action.

Note: You can use amper (&) variables in the Missing Data field to allow the entry of values
at run-time. In general, valid values include any string or amper (&) variable, which will print
automatically. You can use &xx to activate autoprompt. For example, you can use &NONE
to specify a value at run-time. In Live Preview, this value is set to _FOC_NULL or as many
characters that will fit in the width as defined by the existing values in a column. Global
variables (&&x) should not be entered as they do not activate autoprompt. Mixing strings
with amper (&) variable can result in Focus error messages. For example, &&&&N& or
&nn&n&).

Print Plus (PRINTPLUS). Introduces printing enhancements. Radio buttons include On
(default value) and Off. This value will not be written into the procedure (.fex) by default.
Therefore, you must select the check box to prompt this action.

In-Document Analytics. Allows you to select between the Designer Style and Legacy
formats when working with In-Document Analytics.
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-1 Decimal Notation (CDN). Ensures the correct display of currency for the target language.
Radio buttons include On and Off (default value).

4 HTML Encode (HTMLENCODE). Controls whether HTML tags are encoded when these tags
are stored within the actual data or when they are created using a DEFINE or COMPUTE
command. Radio buttons include On (default value) and Off. This option is selected for
inclusion in the procedure (.fex), by default (the check box is selected), as it is not a default
setting of the Reporting Server.

4 Empty Report (EMPTY REPORT). Controls the output generated when a TABLE request
retrieves zero records. Radio buttons include On (default value) and Off. When set to On, an
empty report (column headings with no content) is generated. When set to Off, no report is
generated. This option is selected for inclusion in the procedure (.fex), by default (the check
box is selected), as it is not a default setting of the Reporting Server.

Note: In Report mode, all settings apply. In Chart mode, only Collation Sequence (COLLATION),
Decimal Notation (CDN), and Empty Report (EMPTYREPORT) settings are applicable. In
Document mode, Procedure Settings apply to the whole document. These settings are
currently unavailable in Visualization mode.

Procedure: How to Create a Procedure Using the Missing Value Option

1. Create a report with a dimension, a measure, and an across sort field that shows missing
values, as shown in the following image.

Month 3 4
Product Product Revenue Per Revenue Per
Category Subcategory Shipment Unit(s)  Sale Unit(s) Sq.Ft.  Shipment Units)  Sale Unit(s) Sq. Ft.
Accessories Charger 1,973 6,204 $63.63 1,747 5,650 §57.78
Headphones 4245 13,463 $1,190.61 3,843 12,178 $1,111.56
Universal Remote Controls 3,340 10,639 $790.19 2985 9,581 $717.55
Camcorder Handheld 4575 14,636 5648 54 4,256 13,490 60710
Professional 242 756 568219 216 748 £688.30
Standard 3,610 11,263 $1,049.08 3,291 10,408 £988.71
Computers Smartphone 3,622 11,413 573486 3178 10,281 §658.53
Tablet 3,102 8134 $619.59 3,368 3,858 §619.43
Media Player Elu Ray 12,623 40,707 $3762.71 11,421 36,130 $3,315.39
DVD Players I-_ . . . .
Streaming 1,364 4167 $111.40 1314 3,696 $95.89
Stereo Systems Home Theater Systems 7,485 23315 $1,300.07 6,599 21,120 $1,200.77
Receivers 2,767 8,730 $857.80 2477 8,085 $325.00
Speaker Kits 4542 14,332 $1,691.64 4,020 13,117 $1,554.90
iPod Docking Station 5,863 18,348 3659.46 5,147 16,636 §597.27
Televisions Flat Panel TV 1,709 5427 $1,166.90 1,561 4982 $1,04834
Video Production Video Editing 3744 11,881 $920.18 3317 10,774 §337.75

Note: The highlighted area indicates the default ( . ) for missing values.

2. On the Quick Access toolbar, click Procedure Settings.
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Procedure: How to Create a Procedure Using the Empty Report Option
1.
2.

78

Click the Missing Value check box.

In the Missing Value text box, enter the characters to be used to represent missing values

in your report. For example, NONE.

Note: By default, this is set to (. ). However, common examples include N/A or NONE.

Click OK.

Fields with missing values are indicated by the word NONE, in this case, as that is what
was specified. This value is shown in the following image.

Product
Category
Accessories

Camcorder

Computers

Media Player

Stereo Systems

Televisions
Video Production

Month

Product

Subcategory

Charger

Headphones

Universal Remote Controls
Handheld

Professional

Standard

Smartphone

Tablet

Blu Ray

DVD Players
Streaming

Home Theater Systems
Receivers

Speaker Kits

iPod Docking Station
Flat Panel TV

Video Edifing

6. Save the procedure.

Shipment Unit(s)

3 4
Revenue Per Revenue Per
Sale Unit(s) 5q. FL. Shipment Unit(s) Sale Unit(s) §q. Ft.
1,673 6,204 $63.63 1,747 5,650 $57.78
4,245 13,463 $1,190.61 3,843 12,178 $1,111.56
3,340 10,639 £790.19 2,085 9,581 §717.55
4,575 14,636 $648.54 4,256 13,490 860710
242 756 68219 216 48 §638.30
3,610 11,263 §1,049.08 3,201 10,409 89381
3622 11,413 573486 3,178 10,281 8658.53
3102 8,134 $619.59 3,368 8,858 8619.43
12 623 40,707 53 ?E\_Z,T‘\ 11,421 36,130 $3,31539
NONE NONE NONE NONE NONE NONE I
1,364 4167 $111.40 1,314 3,696 $95 89
7,485 23,315 $1,300.07 6,599 21,120 $1,200.77
2,767 8,730 $857.80 2477 8,085 §825.00
4,542 14,332 $1,601.64 4,020 13,117 $1,554.90
5,863 18,348 $650.46 5,147 16,636 $507.27
1,708 5427 $1,166.90 1,561 4,982 $1,048.34
3,744 11,881 $920.18 3,317 10,774 883775

Create a report with one or more measures and two dimensions.

Add a filter to create an empty report by filtering on a value that does not exist in the
dimension that you select.

Note: The addition of a filter condition causes your report to have no records, and the
default behavior (EMPTYREPORT=0N) displays the heading and column titles.
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The following image shows an empty report.

[E) Query
d E] Report (wf_retail_lite)
4 F sum
B Discount
B Gross Profit

4 Elby

B Product, Category
B Product, Subcategory

oo
== AcCross

¥ rilter

J Product,Category Equal to VCR

Y Live Preview (500 Records)

Product
Subcategory

Product

Category Discount Gross Profit

3. On the Quick Access toolbar, click Procedure Settings.

4. Clear the Empty Report check box.

Note: This option is selected, by default. Notice that Empty Report can be set to On or Off.
When enabled and set to On, the shell of the report (headings and titles) will be displayed.
If the setting is turned off, the environment default will be used.

5. Click OK.

When the Empty Report check box is cleared, no report is generated, as shown in the

following image.

=) Query
- E] Report (wf_retail_lite)
4 ¥ sum
Bl Discount
B Gross Profit
By
B Product, Category
B Product, Subcategory

=
==/ Across

1Y
i

¥ Filter

J Product,Category Equal to VCR
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6.

Save the procedure.

Styling Reports

You can apply custom styling to specific areas of a report. When creating a report, you can
perform the following styling customization.

-

.

Global styling for the entire report. For more information, see How to Apply Styling to an
Entire Report on page 80.

Style data and column titles. For more information, see How to Perform Field-Level Styling in
a Report on page 81.

Style headings and footings. For more information, see How to Style Headings and Footings
in a Report on page 84.

Style the rows of data with alternating colors. For more information, see How to Style Rows
of Data With Alternating Colors in a Report on page 85.

Apply traffic light conditional styling to data. For more information, see How to Apply Traffic
Light Conditional Styling to a Report (By Constant) on page 86 and How to Apply Traffic
Light Conditional Styling to a Report (By Field) on page 87.

Increase or decrease the amount of space inserted between rows and columns. For more
information, see How to Use Cell Padding in a Report on page 89.

Procedure: How to Apply Styling to an Entire Report

80

1.
2.

Create a report, or open an existing report.
On the Home tab, in the Report group, click Style.
The Report Style dialog box opens.

Select any of the following styling options that are available in the Style group.
Font. Opens a drop-down list, which you can use to change the font.

Font size. Opens a drop-down list, which you can use to change the font size value.

Italic. Applies italic font formatting to the selected text.

d
1
.4 Bold. Applies bold font formatting to the selected text.
1
d Underline. Underlines the selected text.

d

Justify Left. Aligns the text to the left of the canvas.
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Justify Center. Aligns the text to the center of the canvas.
Justify Right. Aligns the text to the right of the canvas.

Font Color. Opens the Color dialog box, where you can select the font color.

L U o LU

Background Color. Opens the Color dialog box, where you can select the background
color for the report.

Note: If you have chosen to specify a color, you must click OK to return to the Report
Style dialog box.

.4 Currency Symbol. Opens a drop-down menu, from which you can choose a currency
symbol. Options are US dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel.

d Reset to Quick Styles from Template. Resets all settings to the default settings from
the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must use
the Undo command on the Quick Access Toolbar.

Preview. Displays the text as you have formatted it.

4. Click OK. The report is styled accordingly.

Procedure: How to Perform Field-Level Styling in a Report

You can style data, column titles, or both, in the report output for the selected data source
field.

1. Create a report.
2. Inthe Query pane, select a data source field.
The Field tab appears on the ribbon.
3. In the Style group, click one of the following:
-1 Data Style. Styles only the data for the selected data source field.

d Title Style. Styles only the column title for the selected data source field.

- Data + Title. Styles both the data and the column title for the selected data source
field.

4. Select any of the following styling options that are available in the Style group.

.4 Font. Opens a drop-down list, which you can use to change the font.
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Font size. Opens a drop-down list, which you can use to change the font size value.
Font Color. Opens the Color dialog box, where you can select the font color.

Reset styling to default style. Resets any styling changes to the default style.
Bold. Applies bold font formatting to the selected text.

Italic. Applies italic font formatting to the selected text

Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

L U U U U U U U U oL

Background Color. Click the button to open the Color dialog box, where you can select
the background color for the report.

Note: When working with font or background colors, you must click OK on the Color
dialog box to return to the Report Style dialog box.

5. Click OK. The report is styled accordingly.

Procedure: How to Add Headings and Footings to a Report

You can make a report more meaningful by adding headings and footings. Headings and
footings supply context and key information about a report, such as its purpose and audience.
Headings and footings also provide structure, helping you navigate to the detail sought. They
enhance visual appeal.

In this procedure, you will add and style a report heading and page heading. The procedure
uses sample values, but you can supply values that apply to your own reports.

Headings and Footings are available in Query Design view, Live Preview, and Document mode.
1. Create a report.
2. On the Home tab, in the Report group, click the Header & Footer button.
The Header & Footer dialog box opens.
3. Click the tab for the heading or footing element that you want to add.

For a report, you can add a report heading, page heading, page footing, or report footing.
By default, the Report Header tab is selected. In this procedure, accept the default.
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4. Click inside the design area of the dialog box, and type the text for the heading.
For example, the text for a sample report heading might be Quantity Sold by Product.
5. Using the styling ribbon, apply styling to the report heading text.

For example, click HELVETICA from the Font drop-down list. From the Font size drop-down
list, click 12.

The sample report heading with the selected styling values is shown in the following
image.

% Header & Footer [m]
|_T§_'=l] Report Header I%] Page Header l% Page Footer %Repor‘c Footer

HELVETICA |+ (14~ B r © B & 2 B-

Quantity Sold by Product

" OK 49 Reset (S Cancel 2 Apply

Click Apply to save the changes you have made so far, without closing the dialog box.
To add a page heading, click the Page Header tab.

In this procedure, you are going to add one of the supplied quick text options.

8. Click the last icon @ T (Insert preformatted text content for headers/footers) on the right
of the styling ribbon, and click Confidential in the list.

9. Change the font and font size. For example, change the font to HELVETICA and the size to
10.

You can add your own text before or after the supplied text, for example, For Regional
Managers Only.

%] Header & Footer ox
% Report Header % Page Header % Page Footer % Report Footer
HELVETICA = |10 ~ B 7 T Bl 2 BE-

Confidential
For Regional Managers Only

" OK @ Reset || 9 Cancel | 2, Apply
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Procedure:

84

10. Click OK to save the report heading and page heading and close the Header & Footer

dialog box.

The report heading and page heading that you added and styled are shown in Live Preview
in the following image.

Quantity Sold by Product

Confidential

For Regional Managers Only

Product Quantity
Category Sold
Accessories 511,667
Camcorder 455,244
Computers 381,777
Media Player 771,934
Stereo Systems 1,114,332
Televisions 105,188

Video Production 199,749

11. To make changes to either the report or page heading, right-click the heading and click

Edit. You can also double-click on the header to open the Header & Footer dialog box.

How to Style Headings and Footings in a Report

You can style headings and footings in the report output for the selected heading or footing
field.

1.
2.

Create a report.

With the report opened in Live Preview, select the heading or footing text that you want to
style.

On the Home tab, in the Report group, click Header & Footer.
The Header & Footer dialog box opens.

Select any of the following styling options that are available in the Style dialog box.
.4 Font. Opens a drop-down list, which you can use to change the font.

. Font size. Opens a drop-down list, which you can use to change the font size value.
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Bold. Applies bold font formatting to the selected text.

Italic. Applies italic font formatting to the selected text.

Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

Font Color. Opens the Color dialog box, where you can select the font color.

Background Color. Opens the Color dialog box, where you can select the background
color for the report.

Reset to Quick Styles from Template. Resets all settings to the default settings from
the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must
use the Undo command on the Quick Access Toolbar.

5. Click OK. The report is styled accordingly.

Procedure: How to Style Rows of Data With Alternating Colors in a Report

You can style rows of data in a report with alternating colors.

1.
2.
3.

Create a report.

Open the report in Live Preview.

On the Home tab, in the Report group, click Banded.

The Color dialog box opens.

Select a color.

Click OK.
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The selected color provides an alternating color scheme for the report. The report output
displays alternating rows of data, using a white background for one row and a background
of the selected color for the next row. This pattern continues throughout the report, as
shown in the following image of Banded report output.

Product Quantity
Category Sold
Accessories 511,667

Computers 351,777

Stereo Systems 1,114,332

Video Production 199,749

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Constant)

You can apply traffic light conditional styling to data for a selected measure field. By default
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1. Open a report in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:

IJ Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

Id Shortcut Menu: Right-click a field on the report, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens.

3. From the Relational Operators drop-down menu below the field name, click a relational
operator. For example, Equal to.

4. In the field to the right of the Relational Operators drop-down menu, click the down arrow
for the Type drop-down menu.

The Type menu opens.
5. In the Type drop-down list, click Constant.

Enter a value in the Value field.
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10.
11.

12.
13.

14.

15.
16.

or

a. From the Get Values drop-down menu, select one of the following values: All, First,
Last, Minimum, Maximum, or From File. The value that you select appears in the Get
Values field.

b. Select the value in the Get Values field. The value that you selected appears in the
Value field.

Click OK.

The value that you selected appears in the field to the right of the Relational Operators
drop-down menu.

Click the Style button.

The Style menu opens.

From the Style menu, click the Font Color or Background Color button.
The Color dialog box opens.

Select a color.

Click OK.

The color appears in the Preview box.

Click Apply to apply the colors to the report.

Click the Drill Down button.

The Drill Down dialog box opens.

In the Drill Down dialog box, use the radio buttons to specify the action you wish to
perform. For example, drill down to a report or webpage, create an auto link target, or
refresh a BI portal.

Click OK to close the dialog box.

In the Traffic Light Condition dialog box, click the New button to set traffic light conditions
for additional fields.

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Field)

You can apply traffic light conditional styling to data for a selected measure field. By default,
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1.

Open a report in Live Preview.
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10.

11.
12.

13.

Open the Traffic Light Condition dialog box in one of the following ways:

.d Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

.4 Shortcut Menu: Right-click a field on the report, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens.

From the drop-down menu below the field name, select a relational operator. For example,
Equal to.

In the field to the right of the Relational Operators drop-down menu, click the arrow for the
Type drop-down menu.

The Type dialog box opens.

In the Type drop-down list, select Field.

The Type dialog box displays a list of the data fields that you can choose from.
Select a data field from the list.

Click OK.

The field that you selected appears in the field to the right of the Relational Operators
drop-down menu.

Click the Style button.

The Style menu opens.

From the Style menu, click the Color button.
The Color dialog box opens.

Select a color.

The color appears in the Preview box.

Click OK.

Click the Drill Down button.

The Drill Down dialog opens.

In the Drill Down dialog, specify each of the following:
. Drill down to a report or a webpage

.4 URL of the webpage

4 An alternate comment
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- Target (New Window, Same Window)

.d Parameters that you want to use (Name, Value)

14. Click OK.
15. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Use Cell Padding in a Report

You can customize the amount of space inserted between rows and columns in a report.

1. Open a report in Live Preview.

2. On the Layout tab, in the Report group, click Cell Padding, and then click Custom.
The Cell Padding dialog box opens.
Type the cell padding values that you want in the Top, Bottom, Left, and Right fields.
Click OK.
The report reflects the cell padding that you set.
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The following image shows a report with custom cell padding.

Quantity Sold by Product

Confidential

For Regional Managers Only

Product
Category

Accessories
Camcorder
Computers
Media Player
Stereo Systems
Televisions

Video Production

Changing a Field Format

You can change the format of any field except a Sort field. You can change the format of
measure fields, as well as any calculated fields. For more information, see Binning on page

130.

You can access the Field Format Options dialog box from the following locations:

.4 Define and Compute dialog boxes.

CQuantity
Sold

511,667
455,244
3INTTT
771,934
1,114,332
105,185
199,749

.4 Edit Format option when you right-click a measure in the Query pane (all modes), right-click

a column in a chart, or a measure column in a report.

.4 Format group on the Field tab.

90
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The following image shows the Field Format Options dialog box.

5 Field Format Options for (Cost of Goods) X
Field type: Display options
’“'leha“ umeric Currency Symbal Percent (%)
Floating point =
Integef > Floating Currency = Scientific Notation (E)
Decimal
Packed
Date Use Comma (C) Suppress Comma (c)
Date-Time
sample: Leading Zeros (L) Suppress Zeros (5)
£12345678901234568
Brackets Negative (B) Credit negative (R)
Field Length {1-20) Decimals (0-18)

- -

20

-

45 Reset (S Cancel

The Field Format Options dialog box enables you to choose from a variety of Field types.
Display options are enabled based on the Field type you select. For example, the default Field
type selection is Decimal. The first Display option, Currency Symbol, provides the following list
of currency symbol options:

None

Floating Currency
Non-floating Currency

Fixed Euro symbol

Floating Euro symbol

Euro symbol on the right
Fixed pound sterling sign
Floating pound sterling sign
Fixed Japanese yen symbol

Floating Japanese yen symbol

L U o U v v oJ d uJd doC

Fixed dollar sign

Db2 Web Query InfoAssist+ Part 1 91



Changing a Field Format

- Floating dollar sign
- Dollar sign on the right

- Dollar sign on the left

The default value for Currency Symbol is set to None, unless the Field Format dialog box was
invoked when changing the format of a field that already contains a currency symbol from the
Master File. Accordingly, the currency symbol will default to that which is defined in the Master
File.

Charts work with floating currency symbols to allow the placement of the currency symbol to
work within the different elements of the chart. In a chart, any fixed currency designations will
automatically be presented with a floating currency symbol. Floating and fixed currency formats
are supported for Reports only.

When working with charts, the axis label formats are defined separately from the field format.
To set the format of the axis label, use the option in the Labels group on the Format tab. Click
Axes, point to Vertical Axis, and click More Vertical Axis Options. In the Format Vertical Axis
dialog box, click Labels, open the Format Labels drop-down menu, and select a currency
format.

The following procedures show how to change a field format from the Field Format Options
dialog box. For more information on how to use the Format group options, see Field Tab on
page 35.

Procedure: How to Assign an Alphanumeric Format

1. With a report open in Live Preview, right-click a virtual field or column measure field, and
select Edit Format.

The Field Format Options dialog box opens.
From the Field type list, select Alphanumeric.

3. To assign a different length, specify a number between 1 and 4095 in the Total length
field. The default value is 20.

4. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Numeric Format

92

1. With a report open in Live Preview, right-click a virtual or column measure field, and click
Edit Format.

The Field Format Options dialog box opens.
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2. From the Field type list, click one of the following options:
. Floating Point (default length 7.2)
. Integer (default length 5)
.4 Decimal (default length 12.2)

d Packed (default length 12.2)

If the selected field matches the selected format type, its current length appears in the
Field Length field. Otherwise, the default length appears in the Field Length field. The
Decimals field shows the numbers of decimal places for Floating Point, Decimal, and
Packed.

4 To assign a different length, specify it in the Field Length field for format types as
follows: 1-9 for Floating Point, 1-11 for Integer, 1-20 for Decimal, and 1-33 for Packed.

4 To assign a different number of decimal places for Floating Point, Decimal, or Packed,
specify the number in the Decimals field.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Date Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.

2. To assign a different date display format, select a date format from the Display options
list.

The default date display format is MDY.
Optionally, select a separator for the date format.
Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Date-Time Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.
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Procedure:

2. To assign a different date-time format, select the date format you want to use from the
Date Format list. Expand Year First, Month First, or Day First to see the available options.

3. Select a time format (if applicable) from the Time Format list.

If you select the Time Only check box then you can only set a time format. Expand Hour
First, Minute First, or Seconds First to see the available options.

Note: These expansion options are only visible when you select Time Only.
4. Optionally select a separator for the date format.

The default is /, but you can select . (period), - (hyphen), (space) or None.
5. Click the Use AM/PM check box if you are indicating a time format.

The format of the time selection displays in the text box at the bottom of the dialog box. A
preview displays in the Sample text box in the left pane, showing you the exact format of
your time-based selection.

6. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

How to Add a Percent Sign to a Numeric Field

You can add a percent sign to the end of a numeric value (Decimal, Integer, Packed, and
Floating Point formats). This numeric display option includes a percent sign along with the
numeric data, but does not calculate the percent.

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.

2. From the Field type list, click a numeric value format (Floating point, Integer, Decimal, or
Packed), and then select the Percent (%) check box.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Using Custom Reporting Features

94

You can use the following custom features when creating reports.

-1 Rank. Inserts a ranking column for dimension and measure fields in a report. For more
information, see How to Rank Fields in a Report on page 96.

4 Limit. Limits the number of unique variables in a column. For more information, see How to
Limit the Values of a Column in a Report on page 97.
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-1 Page Breaks. Starts a new page in the output when the primary sort field changes. For
more information, see How to Add Page and Line Breaks to a Report on page 97.

. Line Breaks. Inserts a line in the report output when the primary sort field changes. For
more information, see How to Add Page and Line Breaks to a Report on page 97.

. Subtotal. Inserts subtotals in the output for all numeric fields when the primary sort field
changes. For more information, see How to Add Subtotals to a Report on page 97.

. Column Totals. Inserts a grand total row at the bottom of the report to sum numeric data in
each column. For more information, see How to Add Column Totals to a Report on page
98.

4 Row Totals. Inserts a grand total column to the right side of the report to sum numeric
data in each row. For more information, see How to Add Row Totals to a Report on page
98.

.4 Sub Header. Adds a subheading just below the column titles in the report output when the
primary sort field changes. For more information, see How to Add Subheadings and
Subfootings to a Report on page 98.

.d Sub Footer. Adds a subfooting at the end of the data on each page of the report output
when the primary sort field changes. For more information, see How to Add Subheadings
and Subfootings to a Report on page 98.

4 Pop-up Titles. Adds pop-up titles to report output when the mouse pointer hovers over a
column title. For more information, see How to Add Pop-Up Titles to a Report on page 98.

1 Data Bars. Adds data visualization bars to numeric data. For more information, see How to
Add Data Visualization Bars to a Report on page 99.

- Aggregation. Displays numeric measure data or non-numeric dimension data using
aggregation options other than the default of Sum for measures or Count for non-numeric
measures. For more information, see How to Display Numeric Measure Data Using
Aggregation Options in a Report on page 99 or How to Display Aggregations on Dimension
(Non-Numeric) Data on page 154.

-l Repeat Sort Values. Displays all repeated sort values instead of blanks after the first
instance of a new sort value appears in the report. The default behavior is to display blanks
after the first instance of a new sort value. For more information, see How to Display
Repeated Sort Values in a Report on page 100.
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- Recompute. Recalculates the result of a Compute command. Recompute is similar to
Subtotal in that it recalculates only at the specified sort break. For more information, see
How to Recalculate the Result of a Compute Command on page 101.

Procedure: How to Rank Fields in a Report

96

You can add rank columns to the dimension and measure fields in a report by clicking the
Rank button. You access the Rank button, on the Field tab, in the Sort group.

.4 Adding a rank column to a dimension field inserts a rank column immediately to the left of
the field.

.4 Adding a rank column to a measure field creates a copy of the column as a dimension field
and adds a rank column to the left of the new dimension field.

Note: The rank option can also be accessed by right-clicking a dimension or measure field and
accessing the Rank option through the shortcut menu by clicking Sort and then Rank.

1. With a report open, in the Query pane, select a dimension or a measure field.
The Field tab appears on the ribbon.
2. In the Sort group, click Rank.

A rank column appears, as shown in the following image.

Product Quantity

RANK Category Gross Profit Sold
1 Accessofies $30.354 44053 511,667.00%
Camcerder 49 5935 54524 435244 00%
Computers $33,5208,815.12 351, 777.00%

Media Player 355,832 57836 T71,934.00%

Stereo Systems  $86,181,070.52  1,114,332.00%
Televisions 516,830,023.81  105,158.00%
Video Production $17,947,619.62  199,749.00%

=l & Wh o e P

Note: The rank column can now be edited and formatted like any other column, with the
following exceptions:

.4 The only formatting that can be applied is Traffic Light Conditions.

- It cannot be hidden.
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- You cannot insert breaks or a filter on the RANK column.

. No column can be moved in between the rank column and the column it is ranking.

Procedure: How to Limit the Values of a Column in a Report

You can limit the number of unique values that appear in a column through the Limit menu.
First, you must select a column, then the Limit menu becomes available on the Field tab, in
the Sort group.

Note: You can also access the Limit option by right-clicking a column, pointing to Sort, and
then selecting Limit.

1. With a report open, in the Query pane, select a dimension or measure field.
The Field tab appears on the ribbon.

2. In the Sort group, enter a value in the Limit field, or select a value from the list. The
number of unique values that appear in the column is now limited to the value that you
set.

Procedure: How to Add Page and Line Breaks to a Report
You can add page breaks and line breaks to report output for the primary sort field.
1. With a report open, in the Query pane, select a dimension (sort) field.
The Field tab appears on the ribbon.

2. From the Break group, click Page Break or Line Break.

Procedure: How to Add Subtotals to a Report
1. With a report open, in the Query pane, select a dimension (sort) field.
The Field tab appears on the ribbon.
2. From the Break group, click Subtotal.

If you select Page Break, a new page is created every time the value of the primary sort
field changes. Each page includes a new set of column titles.

If you select Line Break, a new divider line is inserted in the report output every time the
value of the primary sort field changes.
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Procedure:

Procedure:

Procedure:

Procedure:

98

Clicking Subtotal turns Subtotal on for all fields as a RECOMPUTE and inserts a line of
descriptive text (*Subtotal FIELD Value). Clicking the down arrow launches a menu of
options. From this menu, you can choose between Simple and Recomputed. Selecting
More Options opens a dialog box from which you can choose which fields to subtotal, as
well as what type of aggregation to do for those fields. You can also change the Subtotal
text.

How to Add Column Totals to a Report
On the Home tab, in the Report group, click Column Totals.

Clicking Column Totals adds a grand total row at the bottom of the report that sums numeric
data in each column. Clicking the down arrow launches a menu of options. From this menu,
you can choose between Simple and Recomputed. Selecting More Options opens a dialog box
from which you can choose which fields to total, as well as what type of aggregation to do for
those fields. You can also change the Current Total text.
How to Add Row Totals to a Report
On the Home tab, in the Report group, click Row Totals.
Clicking Row Totals adds a grand TOTAL column to the right side of the report that sums
numeric data in each row.
How to Add Subheadings and Subfootings to a Report
You can add subheadings and subfootings to report output for the sort field.
1. With a report open, in the Query pane, select a dimension (sort) field.

The Field tab appears on the ribbon.
2. From the Break group, click Sub Header or Sub Footer.

The Sub Header & Sub Footer dialog box opens.
3. Inthe Sub Header & Sub Footer dialog box, type and style the text, and click OK.

Subheadings appear just below the column titles in the report output every time the value
of the primary sort field changes. Subfootings appear at the end of the data on each page
of the report output every time the value of the primary sort field changes.

How to Add Pop-Up Titles to a Report

On the Format tab, in the Features group, click Title Popup.
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Procedure:

Procedure:

Procedure:

Clicking Title Popup displays a pop-up title when the mouse pointer hovers over any column
title in the report, at run-time.
How to Add Data Visualization Bars to a Report

You can add data visualization bars to the report output for a selected numeric data source
field.

1. With a report open, in the Query pane, select a measure field.
The Field tab appears on the ribbon.
2. Inthe Display group, click Data Bars.

A data visualization column appears to the right of the selected numeric data source field
to display values in each row. The column uses horizontal bars that extend from left to
right and vary in length, depending on the corresponding data values.

How to Display Numeric Measure Data Using Aggregation Options in a Report

You can display numeric measure data using a variety of aggregation type values other than
the default of Sum.

1. With a report open, in the Query pane, select a measure field.
The Field tab appears on the ribbon.

2. Access the Aggregation Functions menu by doing one of the following:
. From the Display group, click Aggregation.

or

4 Right-click the selected measure field, point to More, then Aggregation Functions, and
choose one of the options. For example, First Value.

If you change the Measure Query field container from Sum to Print, Count, or List, it
overrides all assigned aggregation type values.

How to Access the Within Functionality

You can use the Within functionality to apply specific aggregation tasks at different report
levels.

1. With a report open, in the Query pane, select a numeric measure field.

The Field tab appears on the ribbon.
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2. On the Field tab, in the Display group, click Within.

%] Hide Field
[) Hide Missing

‘;; Traffic Lights
F | Data Bars

Display

4 »

Note: Depending on how your data is set up, you can apply the Within phrase on a By or

Across field.

Optionally, you can access the Within functionality from the shortcut menus on the column
level. You can also access these menus when you right-click a measure field in the Query

pane.

a ¥ Filter values...

2% Sort
) visibility

[®] Change Title...

i Edit Format

!E] Drill Down
~

More

Delete

Accessories
Camcorder
Computers
Media Flayer
Stereo Systems
Televisions

Viden Productinn
¥ [E] Data Bars

@] Aggregation Functions

';1 Traffic Light Conditions...
E Aggregate Within

E] Missing

©89,753,393.00
$104,866,857.00
569,507 ,664.00
$190,240,451.00
$205,113,863.00
$61,551,109.00

£40,105,657.00
b

]

3 By » {Mone)

Product,Category [}l

135,623,183..
161,574,103.1
108,125,373..
257,592,160
304,825,764,

82,016,323..

60,749,161.!

3. On the Within menu, click the down arrow to select the Within phrase for the By or Across

field.

4. Select a By field from the list of available fields.

The report automatically generates based on your selection.

Procedure: How to Display Repeated Sort Values in a Report

100

Run this procedure when the output format, Excel, for example, does not sort properly.

On the Format tab, in the Features group, click Repeat Sort Value.
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When you click Repeat Sort Value, all repeated sort values appear in the report output. This
option overrides the default behavior, which displays blanks after the first instance of each
new sort value that appears in the report.
Procedure: How to Recalculate the Result of a Compute Command
For more information on the compute command, see Using Define and Compute Fields.
1. With a report open, in the Query pane, select a By (sort) field.
The Field tab appears on the ribbon.

2. You can recalculate the result of a Compute command in one of the following ways:

.4 Ribbon: On the Field tab, in the Break group, open the Subtotal menu. On the menu,
click Recomputed.

.4 Shortcut Menu: Right-click a sort field, point to Break, then Subtotal, and then click
Recomputed.

Creating Customized Report Outputs

You can create customized report outputs in InfoAssist+. The standard output formats, which
are found in the Format group on the Home tab, include: HTML, active report, PDF, active PDF,
Excel, and PowerPoint. For charts, HTML5 is the default output format. For reports, you can
also create the following custom report output formats from the Navigation group on the
Format tab, including: Table, Table of Contents, Freeze, Pages on Demand, and OLAP.

. Table. Generates standard browser output. This is the default.

.d Table of Contents. Generates output by displaying a table of contents icon in the upper-left
corner where report output typically appears. Clicking Table of Contents opens a menu that
enables you to select (view) individual values of the first Sort By (By) field, one value at a
time.

You can also select options to view the entire report or remove the table of contents. For
more information, see Create Table of Contents Reports.

Note:

.4 The Table of Contents option is activated only when HTML, active report, Excel, or
PowerPoint output format is selected.

4 You cannot use the Table of Contents option with the Accordion feature. For more
information, see Create Accordion Reports.
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-1 Pages On Demand. Provides access to two distinct features depending upon the output
type that you have selected.

_I

_I

HTML. If you select this output type, and click Pages On Demand, then the report opens
in the Web Query Viewer.

The Web Query Viewer saves the bulk of your report to your web server and delivers one
page of report output at a time, decreasing the amount of time that you wait for the
report to process.

The bulk of your report remains on the web server until you request it or close the Web
Query Viewer.

The Web Query Viewer menu bar, at the bottom of the Viewer, contains options for
navigating through the pages. For more information on these options, see Create Pages
on Demand Reports.

active reports. If you select this output type, and click Pages On Demand, then active
cache is enabled. For more information on active cache, see Active Cache Option.

d OLAP. To view output with OLAP functionality. For more information, see Create OLAP
Reports.

Note: This functionality is disabled by default. It can be enabled in the Db2 Web Query
Administration Console. Contact your administrator for assistance.

Procedure: How to Create Table of Contents Reports
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Note: You cannot use the Table of Contents with the Accordion feature.

1. Create a report.

2. On the Format tab, in the Navigation group, click Table of Contents.

When you run the report, a table of contents button appears in the top-left corner of the
report output, as shown in the following image.

¥
E! ko{! uct Product Quantity
Category Subcategory Sold
Accessories  Charger 105,257
Headphones 228,349

Universal Remote Controls 178,061

Double-click the button to display the Table of Contents menu. The Table of Contents

menu enables you to select and view individual values of the first sort (By) field, one value
at a time.
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Drag the Table of Contents menu in any direction to view the report output, which appears
behind the menu by default.

Product Product Quantity
Category Subcategory Sold
Accessories  Charger 105,257

Headphones 228,349

Universal Remote Conirols 178,061

L Table of Contents
*@ Accessories
*@ Camcorder
*1& Computers
*Q Media Player
IR Stereo Systems
@ Televisions
*1& Video Production
O View Entire Report (On/O:

O Remove Table of Content
£ >

Select a sort field to view values for that field.
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In the following example, clicking Stereo Systems displays the corresponding report output.

Product Product Quantity
Category Subcategory Sold
Stereo Systems Boom Box 9,370

Home Theater Systems 399,092

Receivers 150,568
Speaker Kits 244 199
iPod Docking Station 311,103

L’ Table of Contents
*@ Accessories
*I& camcorder
& Computers
1@ Media Player
& Stereo Systems
@ Televisions
*& video Production
3 View Entire Report (On/Or

O Remove Table of Content
< >

You can also select options to view the entire report or remove the table of contents.

Procedure: How to Freeze Column Titles in Reports
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On the Format tab, in the Navigation group, click Freeze.
Column titles freeze (remain in view) when you scroll through pages of the report output.

Note: You must run the report in order to see the frozen column titles.
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The following image shows the scroll bar that appears when you freeze column titles.

Store
Business
Region

Subtotal: EMEA
Morth America

Product
Category

Accessories
Camcorder
Computers
Media Player
Stereo Systems
Televisions

Video Production

Subtotal: North America

Oceania

Accessories
Camcorder
Computers
Media Player
Stereo Systems
Televisions

Video Production

Subtotal: Oceania

Quantity
Sold

1,404,540
293 461
259,953
214,049
435684
636,612

56,161

114,260
2,010,180
592

554
526
934

1,265

94

227
4,242

Procedure: How to Create Pages On Demand Reports

This procedure describes using the Pages On Demand feature to create an HTML report.

1.

Create a report.

The default output is HTML.

On the Format tab, in the Navigation group, click Pages On Demand.

Run the report.

The report opens in the Web Query Viewer.

Navigate through the report using the navigation options available on the Web Query

Revenue
$422,745,677.92
574,326,669 37

568,243,855.49
564,415,033.70
$139,282,702.54
$166,530,524.29
54383797712

$33,280,088.15
$609,916,853.66
$153,375.30

515522260
5165,451.59
$304,677.892
333705474

$31,026.50

$60,468.74
$1,260,307.29

Viewer menu bar. For example, Go to the first page.
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Procedure: How to Create OLAP Reports

106

1. On the Format tab, in the Navigation group, click the OLAP Analysis button, which enables
the OLAP Analysis functionality.

2. On the OLAP Analysis button, click the down arrow.

The OLAP Analysis menu displays. It contains the following options:

-1 OLAP panel accessible. Select this option to access the OLAP panel in the output of
the report at run-time. You can access the OLAP panel by clicking on one of the
categories that displays at the top of the report.

-1 OLAP panel not accessible. Select this option to only display sorting options in the
column titles. The OCP (OLAP ribbon) cannot be accessed from the title options.

- Dimension filtering enabled. Select this option to display dimension filters at the top of
the report. You customize the filter placement within the Navigation dialog box. You
access the dialog box by clicking More options.

- Dimensions grouped in tabs. Select this option to group dimension filters in tabs
based on hierarchy within statements in the metadata.

- More options. Select this option to open the OLAP Analysis dialog box.

In addition to the options discussed previously, the OLAP Analysis dialog box allows
the following additional configuration and customization options for OLAP output:

- No OLAP. Select this option to disable OLAP Analysis.

- OLAP panel is accessible. Select this option to make the OLAP panel accessible.
This option is selected by default.

1 OLAP panel is not accessible. Select this option to make the OLAP panel
inaccessible.

- Hide access to the OLAP Panel. Select this option to hide access to the OLAP
panel.

- Dimension filtering enabled. This option provides a secondary positioning option
allowing placement of the filters on the Top (default) or Bottom of the report.

Note: If the Dimension filtering enabled option is cleared at any time, the position
option resets to Top.

- Auto drill options. The auto drill options are:
1 Dimensions. Select this option to automatically drill down on dimensions in both

reports and graphs.
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-1 Dimensions and Measures. (Default). Select this option to automatically drill
down on dimensions in both reports and graphs and on measure fields in
reports.

J None. Select this option to disable automatic drill downs.
3. Select an option.

Selecting an option from the OLAP options group, such as OLAP panel accessible,
generates output that invokes OLAP processing. The OLAP button displays below the
report. When clicked, the OLAP Control Panel is launched.

Product Quantity
m Category Digcount Sold
Computers $4,803.910.10 351,777
Stereo Systems $13,530,873.57 1,114,332
Televisions $3,635,693.36 103,183
Video Production $2,695,890.76 199,749
oLAP

Procedure: How to Create Accordion Reports
Note: You cannot use the Table of Contents in conjunction with the Accordion feature.

1. Create a report.
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Product
Category
Media Player

Stereo Systems

Televisions

E Media Player

[ Stereo Systems

E Televisions

Store
Business
Region

EMEA

Morth America
Oceania
South America
EMEA

Morth America
Oceania
South America
IRIEA

Morth America
Mceania

South America

Quantity
Sold

771,934
1,114,332
105,188

Procedure: How to Implement Stack Measures
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The following image shows a report before the accordion option is applied.

Quantity
Sold

314,737
435 684
984
20,529
447,733
636,612
1,265
28,722
45714
56,161
94
3,219

2. On the Format tab, in the Features group, click Accordion and then click Run.

Plus signs indicate that there are expandable views of data for each vertical sort field.

You can manually expand your view to expose the data.

1. Create a report with at least two measure fields.
2. On the Format tab, in the Features group, click Stack Measures.

All measure fields in the report are stacked.
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Chapter

Creating and Customizing Charts

InfoAssist+ enables you to easily create different types of simple and complex charts.
You can select from a variety of chart types and output formats, and add custom
features to a chart.

You can also create a chart from any existing report.

In this chapter:

i

U U o o o o

Visualizing Your Data With Charts
Selecting a Chart Type

Creating Charts

Binning

Accessing Chart Formatting Tools
Formatting a Series

Formatting Data Labels

LU o d dd

L

Formatting a Legend

Formatting Gridlines

Formatting Axis Labels

Formatting a Frame and a Background
Formatting a Gauge Chart

Formatting Page Headings and Page
Footings

Using Additional Formatting Features
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Visualizing Your Data With Charts

A chart often conveys meaning more clearly and effectively than data displayed in tabular form.
A chart enables you to visually communicate quantitative information. On a chart, you can give
data a shape and form, and reveal patterns and relationships among many data values. A
chart can highlight anomalies that require further investigation. These are some things to
consider when deciding between a report and a chart for your data.

Use aTable to: Use a Chart to:

Look up individual values. Show the overall shape of values.

Compare individual values. Show relationship among multiple

Use values precisely. values using patterns and trends.
Product Quantity 120

Gender  Category Sold Revenue
F Accessories 254,028 564,304,431.91

Camcorder 225,926 576,636,444 31
Computers 174,733 551,264,985 17 e
Media Player 382,256  $121,329,616.38
Stereo Systems 553,054 $144,581,936.30
Televisions 51929 538,989,029 66 =
Video Production 98,334 528,755,341.55 ‘g . Product Category

M Accessories 257,639 $65,303,006.62 ] W Accessories
Camecorder 229,318 577,829,257 93 § Cameordar
Computers 177,044 552,051,496.95 L ;Zi:":;;
Media Player 380673 5124,243,44293 I Stereo Systems
Stereo Systems 561278  $146,712,997.22 0.3M Televisions
Televisions 53,259 $39,392,103.15 Video Production
Video Production 100,915 $29,297,935.07

0 \ o
A
& & & & v@o%q_ & &
¥
Product Category

Selecting a Chart Type

InfoAssist+ provides a complete chart library of both basic and advanced charts. You can
choose from a wide variety of charts to best represent the data that you want to display.

It is important that you choose a chart that is appropriate for your data. When working with
chart types in the Other category, which is available in the Chart Types group on the Format tab
in Chart mode, you can quickly access a description for each chart, simply by hovering over the
chart type with your mouse in the Select a chart dialog box. This facilitates quick identification
of the relevant chart type, making it easy to create the right type of chart based on your data.

Note:

. To change the chart type of a migrated chart procedure that contains bar, line, or area
charts, click the Type button on the Series tab, instead of the Format tab.
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Bar Charts

-l The new chart attribute syntax has been applied to the following chart types: Dual Bar and
Line, Tag Cloud, Streamgraph, Mekko, Funnel, and Pyramid. In InfoAssist+, specific field
containers display for each chart type. For information on the field containers for charts,
see Field Containers for Charts and Visualizations on page 50.

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or
variable measure fields that appear along the axis). The length of a bar corresponds to a value
or amount. You can clearly compare data series (fields) by the relative heights of the bars. Use
a bar chart to display the distribution of numerical data. You can create horizontal and vertical
bar charts.

Note:

. If you are working with a large dataset, you can enable the display of a scroll bar under your
chart, allowing you to easily scroll through your data from left to right. If you want to enable,
disable or re-enable scroll bars, click the Format tab and then click Interactive Options. In
the Interactive Options dialog box, select the Auto Enable X-Axis Scrolling check box.

.4 When working with stacked bar charts in either Chart or Visualization mode, borders can be
enabled to show each series or measure in the chart. When enabled, the borders outline
each measure in a stacked bar chart. This allows you to differentiate between the
measures when they are displayed using the same color on a riser.

You can specify a border for all series in the Style dialog box, which is accessible from the
Series tab.

When to use: Use a bar chart when individual values are important. For example, a basic
vertical bar chart can compare the individual products sold to the total amount in sales for
each product. A retailer would find it important to know which pieces of inventory are selling
and how much revenue each item is generating for the company.
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The following image is an example of a bar chart showing gross profit and quantity sold by

product category.

100M

s0m

60Mm

Gross Profit

40m

20M

Product Category

Accessories Camcorder Computers Media Player Siereo Systems Televisions Video Production

A horizontal bar chart becomes useful when you want to emphasize a ranking relationship in
descending order, or the X-axis labels are too long to fit legibly side-by-side. For example, a
basic horizontal bar chart can rank in descending order which products are generating the most

revenue for the retailer.

Bar Chart Types

The following table lists the available bar chart types.

Available Bar Chart Types

Vertical Clustered Bar

Horizontal Clustered Bar

Vertical Stacked Bar

Horizontal Stacked Bar

Vertical Dual-Axis Clustered Bar

Horizontal Dual-Axis Clustered Bar

Vertical Dual-Axis Stacked Bar

Horizontal Dual-Axis Stacked Bar

Vertical Bi-Polar Clustered Bar (Not in HTML5)

Horizontal Bi-Polar Clustered Bar (Not in
HTML5)
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Pie Charts

Available Bar Chart Types

Vertical Bi-Polar Stacked Bar (Not in HTML5)

Horizontal Bi-Polar Stacked Bar (Not in
HTML5)

Vertical Percent Bar

Horizontal Percent Bar

Vertical Histogram

Horizontal Histogram

Vertical Waterfall

Horizontal Waterfall

Vertical Multi-3Y Bar (Not in HTML5)

Vertical Multi-5Y Bar (Not in HTML5)

Vertical Multi-4Y Bar (Not in HTMLS)

Error Bar

A pie chart is a circular chart that represents parts of a whole. A pie chart emphasizes where
your data fits, in relation to a larger whole. Pie charts work best when the data consists of
several large segments. As a best practice, limit your pie chart to five measure fields. Too
many measure fields can divide a pie into many thin components that could become difficult to
see. Use color on individual segments to create visual contrast.

In addition, you can add one or more measures to the Measure field container. Each measure
will be used to create a separate, unique pie chart, to which you can add a measure or
dimension to the Color field container to add color to your chart.

Note:

-1 When working with pie charts, you can add one measure field to the Color field container.
This adds the measure as a By field, and determines how the pie chart is colored.
Depending on your measure data, this may result in a large number of pie segments.

4 You cannot plot negative data on a pie chart.

When to use: Use a pie chart when you have several large segments of data that you want to

display as a whole.
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For example, the following image is a pie chart showing the product revenue by sale quarter.

Sale Quarter

Product Category

. Accessories
Camoorder
. Computers
Media Player
‘ . Sterec Systems
Televisions
Video Production

Revenue Revenue Revenue Revenue

Pie Chart Types

The following table lists the available pie chart types.

Available Pie Chart Types

Multi Pie Multi Ring Pie

Multi Proportional Pie (Not in HTML5) Multi Proportional Ring Pie (Not in HTML5)
Single Pie Single Ring Pie

Pie-Bar (Not in HTMLD5) Ring Pie-Bar (Not in HTMLD5)
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Line Charts

Line charts are useful for emphasizing the movement or trend of numerical data over time.
They allow you to trace the evolution of a data point by working backwards or interpolating.
Highs and lows, rapid or slow movement, or a tendency towards stability are all types of trends
well suited to a line chart.

You can also plot line charts with two or more scales to present a comparison of the same
value, or set of values, in different time periods.

Note: If you are working with a large dataset, you can enable the display of a scroll bar under
your chart, allowing you to easily scroll through your data from left to right. If you want to
enable, disable or re-enable scroll bars, click the Format tab and then click Interactive Options.
In the Interactive Options dialog box, select the Auto Enable X-Axis Scrolling check box.

When to use: Use a line chart when you want to trend data over time. For example, monthly
changes in employment figures, or yearly sales of an item in your inventory.

For example, the following image is a line chart that traces product revenue over a four-year
period.

150M

120M

90M

Revenue

Sale Year

60M O 2012
2014

O 2015

2016

30M

Accessories
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Area Charts
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Radar charts are essentially analogous to line charts, except that the scale wraps around.
Radar charts compare two or more data sets. They work well with data that is cyclical, such as
the months of a year. A radar line chart is available in the line chart category, and a radar area
chart is available in the area chart category. You can use axes or polygons to represent values
in a star or spider configuration.

Line Chart Types

The following table lists the available line chart types.

Available Line Chart Types

Vertical Absolute Line Horizontal Absolute Line
Vertical Stacked Line Horizontal Stacked Line
Vertical Dual-Axis Absolute Line Horizontal Dual-Axis Absolute Line
Vertical Dual-Axis Stacked Line Horizontal Dual-Axis Stacked Line

Vertical Bi-Polar Absolute Line (Not in HTML5) | Horizontal Bi-Polar Absolute Line (Not in
HTML5)

Vertical Bi-Polar Stacked Line (Not in HTML5) Horizontal Bi-Polar Stacked Line (Not in
HTML5)

Vertical Percent Line Horizontal Percent Line

Radar Line

Area charts are similar to line charts except that the area between the data line and zero line
(or axis) is usually filled with color. Area charts allow you to stack data on top of each other.
Stacking allows you to highlight the relationship between data series, showing how some data
series approach a second series.

Note: If you are working with a large dataset, you can enable the display of a scroll bar under
your chart, allowing you to easily scroll through your data from left to right. If you want to
enable, disable or re-enable scroll bars, click the Format tab and then click Interactive Options.
In the Interactive Options dialog box, select the Auto Enable X-Axis Scrolling check box.
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When to Use: Use an area chart when you want to distinguish the data more dramatically by
highlighting volume with color. For example, the following image is a stacked area chart
depicting the gross profit, revenue, and quantities sold for products over a three-year time

period.
350M
300M
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M Gross Frofit : 2014
2001 Quantity Sold : 2014
150M
100M
50M
0
Accessories Camcorder Computers Media Player ~ Stereo Systems  Televisions  Video Production
Product Category
Area Chart Types

The following table lists the available area chart types.

Available Area Chart Types

Vertical Absolute Area

Horizontal Absolute Area

Vertical Stacked Area

Horizontal Stacked Area

Vertical Bi-Polar Absolute Area (Not in HTMLD)

Horizontal Bi-Polar Absolute Area (Not in
HTML5)

Vertical Bi-Polar Stacked Area (Not in HTML5)

Horizontal Bi-Polar Stacked Area (Not in
HTMLD5)

Vertical Percent Area

Horizontal Percent Area
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Available Area Chart Types

Radar Area

Scatter Charts

Scatter charts enable you to plot data using variable scales on both axes. When you use a

scatter chart, the data is plotted with a hollow marker, so that you can visualize the density of
individual data values around particular points, or discern patterns in the data. A numeric X
axis, or sort field, always yields a scatter chart, by default, however you can optionally specify
a non-measure (dimension) field on either the vertical or horizontal axis. You can also specify a

non-measure field on both axes, which results in a vertical display of your dimension data.

If your chart reveals clouds of points, there is a strong relationship between X and Y values. If

data points are scattered, there is a weak relationship, or no relationship.
When to use: Use a scatter chart when you want to determine patterns in your data.

The following image is a scatter chart that shows gross profit and MSRP data for product

categories.
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Multi-Axis Charts

Bar, line, and area chart types have multi-axis options, such as dual-axis charts and multi-Y
charts, where you can compare one X-axis value to several Y-axis measure fields.

InfoAssist+ allows you to assign each individual series to the Y1 through Y5 axis. For more
information, see How to Create a Dual-Axis Chart on page 129.

When to use: Use a multi-axis chart when you want to plot values on an additional axis, or
multiple axes, to compare multiple sets of data that are on different scales.

For example, the following image is a dual-axis bar chart that shows the revenue and MSRP by

store type over a four-year time period.
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XY Plot Charts

An XY plot chart depicts the relationships among the numeric values in several data series.

It

plots two groups of numbers, where for every X value, there is a corresponding Y value. This

results in a single point of XY coordinate.
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When to use: Use XY plot charts when you have two sets of numbers to compare and want to
perform trend analysis.

.d Scatter. Scatter charts show a relationship between X and Y values. They compare two

sets of numbers at once, possibly revealing patterns and trends.

You can plot data using variable scales on both axes. When you use a scatter chart, the

data is plotted with a basic line pattern so that you can visualize the density of individual
data values around particular points, or discern patterns in the data. A numeric X axis, or
sort field, always yields a scatter chart by default.

If your chart reveals clouds of points, there is a strong relationship between X and Y values.
If data points are scattered, there is a weak or no relationship.

Scatter charts share many of the characteristics of basic line charts. Scatter charts and
line charts are distinguishable from one another only by virtue of their X-axis format. Line
charts can appear without connecting lines, making them look like scatter charts, and
scatter charts can appear with connecting lines, making them look like line charts.

Polar. A polar chart is a circular chart. Data is displayed on a polar chart in terms of values
and angles. Polar charts share characteristics with scatter charts. Only one column field is
allowed, in the following order: X (degree) for the column field, and Y (distance from the
center) for the Across or By field.

Bubble. A bubble chart is a chart in which the data points are represented by bubbles.
Bubble charts can have two column fields representing X and Y data values, or have three
column fields representing X, Y, and Z data values, in that order. The third variable (Z)
represents size. The size of each bubble is used to show the relative importance of the
data.

Note: You can specify a non-measure (dimension) data field on the horizontal or vertical
axis, or both.

XY Plot Chart Types

The following table lists the available XY plot chart types.

Available XY Plot Chart Types

XY Scatter XY Polar

Bubble
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3D Charts
A 3D chart uses three axes, X, Y, and Z to display data from two or more data sets so that
trends are most apparent.
When to use: Use a 3D bar chart when you want to look at the general shape of the data, but
add visual depth to a chart presentation. A 3D chart would not be a good choice for presenting
exact values, since it is difficult to determine values in a 3D chart.
Note: When working with charts in HTML5 format, the 3D Effect option is not supported.
The following image is a 3D chart that shows the revenue for products categories over a four-
year time period.
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3D Chart Types

The following table lists the available 3D chart types.

Available 3D Chart Types

3D Bar 3D Pyramid (Not in HTMLD5)

3D Octagon (Not in HTML5) 3D Cylinder (Not in HTML5)

3D Floating Cubes (Not in HTML5) 3D Floating Pyramids (Not in HTML5)
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Available 3D Chart Types

3D Connected Series Area 3D Connected Series Ribbon

3D Connected Group Area 3D Connected Group Ribbon

3D Cone (Not in HTML5) 3D Sphere (Not in HTML5)

3D Surface 3D Surface with Sides (Not in HTML5)

3D Smooth Surface (Not in HTML5) 3D Smooth Surface with Sides (Not in
HTML5)

3D Honeycomb Surface (Not in HTML5)

Stock Charts

Stock charts track the trend of a particular stock. They show the trading volume of the stock,
its opening and closing values, and its high and low values over a specific time period. The
data is represented by sets of bars or lines.

45

m ——
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Stock Chart Types

The following table lists the available stock chart types.

Available Stock Chart Types

Stock Hi-Lo (Not in HTMLD5) Stock Hi-Lo with Volume (Not in HTML5)

Stock Hi-Lo Open-Close (Not in HTML5) Stock Hi-Lo Open-Close with Volume (Not
in HTML5)

Open-Hi-Lo-Close Candle Stock Open-Hi-Lo-Close Candle Stock with
Volume (Not in HTML5)

Special Charts

Special charts include a variety of additional chart types.

_I

_I

Gauge. A gauge chart indicates the current position of a single data value within a given
spectrum. This chart has a circular shape.

Gauge Thermometer. A gauge thermometer chart indicates the current position of a single
data value within a given scale. This chart has the shape of a thermometer. It is not
available in HTML5.

Pareto. A Pareto chart uses the X axis to show group members, and the Y axis to show the
percent of the total of all groups that each group represents. This chart highlights the
differences between groups of data.

Vertical Box Plot. A vertical box plot is oriented vertically, and shows the distribution of
data through five-number summaries: Upper limit, Upper Quartile, Median, Lower Quartile,
and Lower Limit. This chart can be represented with or without outliers, also known as
whiskers.

Horizontal Box Plot. A horizontal box plot is oriented horizontally, and shows the
distribution of data through five-number summaries: Upper limit, Upper Quartile, Median,
Lower Quartile, and Lower Limit. This chart can be represented with or without outliers, also
known as whiskers.

Funnel. A funnel chart is essentially a pie chart, displaying only one group of data at a time,
from the first series to the last series at the bottom of the funnel.

Pyramid. A pyramid chart is essentially a pie chart, displaying only one group of data at a
time, from the first series to the last series at the top of the pyramid.
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-1 Spectral Map. A spectral map contains a row or column matrix of markers that are
displayed in different colors, according to the data values.

HTML5 Charts

The following HTML5 charts are available:

- Parabox. Parabox charts are used to visualize and analyze multivariate data. In a typical
scenario, hundreds of possible outcomes can be compared by filtering along any
dimension.

1 Mekko Chart. Mekko charts compare two related variables by percent of total and
magnitude. They are popular in business and marketing.

- Streamgraph. Streamgraph charts are typically used to illustrate how data has changed
over time. They resemble a stacked area chart. However, the x-axis is not fixed.
Streamgraphs are commonly used to illustrate trends in the Social Media arena.

1 Tag Cloud. Tag Cloud charts display the most prominent terms in a visual representation
for text data. They are noted for their quick display of relevant information, allowing you to
make quick decisions and narrow your search for terminology. Tag Cloud charts are typically
used to depict keywords on websites or to visualize free form text.

- Treemap. Treemap charts are used to display large amounts of hierarchically structured
data. In a sectioned format, each rectangle represents an aspect of the selected measure.
When a second measure is indicated, color coding is applied, emphasizing the unique
sections of the treemap.

d Grid. Grids present data in tabular form. For example, in Chart mode, you can use the Grid
chart type to create a table that summarizes your data. This option is also available in
Visualization mode.

Combination Charts

124

A combination chart displays multiple series using two or more different types of data graphics
from a bar, line, or an area chart. Combining these charts improves clarity in the presentation
of your data, and highlights the relationship between various data sets on one graph. This
combination chart is referred to as a mixed, composite, or overlay graph.
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Maps

When to use: For example, a retailer might want to combine a vertical bar chart that shows
revenue and discount with an area chart that shows cost of goods.
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InfoAssist+ maps use Geographic Information System (GIS) capabilities to convert data values
into maps that can be used for visualizing patterns or trends. This allows you to display your
underlying data regionally. More specifically, data that is bound to a geo-location, such as
State, Country, and ZIP Code, can be viewed as symbol layers integrated into a powerful map
viewer.

InfoAssist+ maps also utilize the robust mapping capabilities of Esri, a mapping engine that
enables the display of layered maps with extensive detail and topography.

The mapping functionality supports a variety of popular formats, such as bubble markers and
heat-filled polygons (also known as choropleths). These map formats are described below.

I Choropleth. A geographically-based heat map. It is useful for visualizing location-based
data, trends, and distributions across a geographic area.

I Proportional Symbol (Bubble). A technique that uses symbols of different sizes to
represent data associated with different areas or locations within the map.

Db2 Web Query InfoAssist+ Part 1 125



Creating Charts

When to use: The mapping functionality enables business users to make informed decisions.
They can also visualize patterns, trends, and relationships related to the location information
in their data.

For information on maps, see Creating Maps to lllustrate Trends on page 347.

Creating Charts

On the Format tab, the Chart Types group provides buttons for each of the five most commonly-
used chart types. These include Bar (default), Pie, Line, Area, and Scatter. You also have
access to Esri Choropleth and Proportional Symbol maps. A button labeled Other gives you
access to the complete chart library of advanced charts, including Lightweight (Leaflet) maps.
For more information, see Creating and Customizing Maps in InfoAssist+ on page 354.

The Chart Types group is shown in the following image.

Format =Data Slicers Layout View Field  Series
By ',-: ] o P
Ads 7amas
Bar Pie Line Area Scatter Choropleth Proportional Other
Symbol
Chart Types

Note: For more information on how to invoke the version of InfoAssist+ that you are using,
please see Introducing InfoAssist+ on page 11.

When switching between chart formats that use a different syntax, you are prompted with a
message that allows you to proceed with the change, or cancel your request. This message is
shown in the following image.

Chart Attributes Modified

Your report has been modified to use different chart attributes which may
! result in different display output. Click "Yes' to accept the changes, or 'No' to
* zave the changes to a different file.

Mo Cancel

On the Chart Attributes Modified dialog box, you can click Yes to accept the changes or click
No to save the changes to a different file and preserve the originating procedure (.fex).
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Procedure:

Procedure:

How to Create a Basic Chart

You can run this procedure in Query Design view or Live Preview.

1.

On the Format tab, in the Chart Types group, click the button of the chart that you want to
create. Bar chart is the default.

The chart appears on the canvas.
Populate the chart with your data in one of the following ways:

.d Drag the dimension fields and measure fields onto the chart.

.4 Drag the dimension fields and measure fields into the appropriate Query field
containers in the Query pane.

How to Create an Advanced Chart

You can run this procedure in Query Design view or Live Preview.

On the Format tab, in the Chart Types group, click Other.

The Select a chart dialog box opens. The chart types, depicted by icons, display on the left
side of the dialog box.

To display the name of a chart type, hover over the chart type with the mouse.

From top to bottom, the chart type categories are Bar, Line, Area, Pie, XY Plots, 3D, Stock,
Special, HTML5, Map, and HTML5 Extension.

Note:

.4 For streamgraphs, which are in the HTML5 category, the tooltip has been enhanced to
display specific information, by data point, depending on the underlying data source.

4 HTML5 Extensions are chart types developed outside of Web Query and made available
to InfoAssist+.

In the left pane, click a chart type.

All supported variations of the chart type appear as thumbnail images in the dialog box.

Click an image to display a detailed description of that chart type.

If you are not familiar with a chart type, be sure to read the description carefully before

finalizing your selection. Some chart types require a certain number of data values, or a
certain type of data values. If your data does not satisfy the requirements, the chart will
not accurately represent the data.

Db2 Web Query InfoAssist+ Part 1 127



Creating Charts

In the following image, the Pie chart type is selected. To the right, the dialog box displays
thumbnail images of the chart variations that are supported. Once a selection is made, a
description for that chart appears underneath.
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W 0K ) Cancel 2 apply
You can also hover over an image with your mouse to display the chart type name.

5. In the Select a chart dialog box, click OK to finalize your selection and close the dialog
box.

6. Populate the chart with your data in one of the following ways:
Id Drag the dimension fields and measure fields onto the chart.

Id Drag the dimension fields and measure fields into the appropriate Query field
containers in the Query pane.
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Procedure:

Procedure:

Procedure:

How to Create a Combination Chart
You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want to
create. Bar chart is the default.

The chart appears on the canvas.
2. Populate the chart with your data in one of the following ways:

- Drag the dimension fields and measure fields onto the chart.

. Drag the dimension fields and measure fields into the appropriate Query field
containers in the Query pane.

3. Change a series type in one of the following ways:

.4 Ribbon: On the Series tab, in the Select group, select the series that you want to
display in a different chart type. Then, in the Properties group, from the Type drop-down
menu, select the chart type.

.4 Shortcut Menu: On the canvas, right-click the series that you want to display in a
different chart type, point to Series Type, and click the chart type.

The series appears in the new chart type.

How to Create a Dual-Axis Chart

When you create a dual-axis chart, you assign one data series to the Y1 axis and another data
series to the Y2 axis.

Note: This applies to charts in HTML format. If you are creating a dual-axis chart in HTML5
format, the field containers are labeled Vertical Axis 1 and Vertical Axis 2. If your chart is
horizontal, the field containers are labeled Horizontal 1 and Horizontal 2.

1. Create a chart.
2. On the Format tab, in the Chart Types group, click Other.
The Select a chart dialog box opens.
Select a dual-axis chart, such as dual-axis bar, and then click OK.

Drag one field onto the Y1 field, and then drag another field onto the Y2 field.

How to Create a Multi-Axis Chart

When you create a multi-axis chart, you assign one data series to the Y1 axis and another data
series to the Y2, Y3, Y4, and Y5 axes (as needed).
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Note: This procedure is specific to HTML format.

1. Create a chart.

2. On the Format tab, in the Chart Types group, click Other.
The Select a chart dialog box opens.

Select a multi-axis chart, and then click OK.

Drag fields into the Y1, Y2, Y3, Y4, and Y5 fields, as needed.

Chart Outputs

Binning

130

You can create charts using one of the following output formats:

-4 HTML

Jd HTML5 (default)
- active report

d PDF

-l active PDF

- Excel

- PowerPoint

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript
engine. Charts with this output format utilize the very latest capabilities of the HTML5 Web
standard, including animation, high-quality vector output, and attractive alpha-channel and
gradient effects.

Note: Not every chart type can be output in every format listed here. To make sure that the
chart that you are creating can be output in the format that you want, please see the topic for
that particular chart type.

Binning is a powerful tool for analyzing your data using ranges that you define.

Binning enables you to determine the frequency of values across the entire range of values. It

is used for analyzing a frequency distribution. With binning, you can create discrete buckets of
continuous data that control how groups of your data display. In addition, binning gives you the
ability to review trends and spot outliers.
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For example, you can review the range of expenses incurred by households. In the following
example, these ranges are represented by bins that are grouped by $1000. In this case, you
can see that the largest number of households had the smallest expense (16) while the trend
declines as the bin size gets larger. With binning, you can see the frequency of how often
values in a range appear across the different groupings, as shown in the following image.

HOUSEHOLDS. BIN_1 $2,000
CNT Households: 11

50 51,000 53.000 54,000

52,000
HOUSEHOLDS_BIN_1

In InfoAssist+, bins are automatically created for Histograms. You can change the size of your
bins to meet the requirements of your data. For example, if your data has very large values (for
example, in billions) you might want to create larger bins. You can also create bins manually in
Vertical bar charts and reports.

Note: When creating a bin, the format of the bin and the value set for the Width of Bins must
be compatible. If the Width of Bins is a large decimal value, define the field format to match
the format of the field being converted so that the bins can be successfully generated with the
appropriate numeric precision.

Binning is available for the different output types, including reports, charts, and visualizations,
depending on how you choose to display and analyze your data.

Procedure: How to Use Binning in a Vertical Bar Chart

1. Open InfoAssist+ in Chart mode.

2. In the Query pane, right-click the chart component and change Sum to Count, as shown in
the following image.

[ul] Query
L @ Chart (wf_retail_inc-—-*
7 E---. Matrix [3 Rename
=
i=Rows Sum
daa
111 Columns Print
4 MA)“S Count

L vertical Axis
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7.

Add a measure, such as Households, to the Vertical Axis field container.
From the Data Pane, right-click the same measure and click Create Bins.
In the Create Bins dialog box, accept the default bin value and click OK.

From the Data pane, drag the bin into the Horizontal Axis field container.
The chart displays showing the bins along the x-axis, as shown in the following image.
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HOUSEHOLDS_BIN

@

Save the chart.
You can edit the bin size to meet your requirements for grouping and display.

Procedure: How to Edit an Existing Bin

132

1.
2.

Open a report, chart, or visualization that contains a bin.

From the Dimensions group, in the Data pane, right-click the existing bin and click Edit
Bins.
The Edit Bins dialog box opens, as shown in the following image.

%a Edit Bins - WF_RETAIL_ INCOME.WF_RETAIL_INCOMEHOUSEHOLDS X

Fieldé JOUSEHOLDS BIN x Format  |/I11

Width of Bins 10

|:| (S Cancel

Note: If you are working with a report, chart, or visualization where the bin is specified and
therefore displays in the Query pane, the position of the Edit Bins field in the shortcut
menu appears in a different location.

Optionally, change the name of the field for the bin, and click Format to edit the formatting
that you want to change (for example, currency).

In the Width of Bins field, specify a value that meets your display requirements.
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5. Click OK.

Procedure: How to Create Bins for Reporting

You can create bins in reports, which lets you view the detail behind a chart or histogram. You
can optionally switch between report and chart as you perform your analysis. This allows you to
review the actual values that fall into each bin.

1. Create a report.

2. In the Query pane, on the Report component, change Sum to Print, as shown in the
following image.

=] Query
“ @ Repart (v @ F.lename -
& Print
G By sSum
= Acros Print
Count
List

Right-click the measure on which to bin, and click Create Bins.

4. In the Create Bins dialog box, set the width of the bins and change any formatting options
(for example, currency).

Click OK.
6. In the Data pane, double-click the bin to add it to your report.
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The report displays showing the bin assignments per value, as shown in the following

image.
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7. Optionally, you can change the Print and By field assighments to view the Households

values by bin, as shown in the following image.
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Binning Values in a Histogram

Histograms graphically represent the distribution of numeric data. They facilitate the
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identification and discovery of the underlying frequency distribution within a set of continuous

data. You can use histograms to identify trends and illustrate categorizations, or groupings,

also known as bins. For more information, see Binning on page 130.

Histograms use bins to group data. Bins allow you to establish a range of values for your data.

For example, you can review how the bins are designated when you consider the age of

everyone in your company. In the first table, you can review the bins (using the default value of
10) and counts for each bin.

AGE COUNT
09 0]
10-19 5
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AGE COUNT
20-29 26
30-39 351
40-49 460
50-59 310
60-69 285
70-79 22
80-89 3

Total 1462

In the second table, you can review the same data for the bins (with a bin width of 15) and
counts for each bin. Notice that as the bin size gets larger, more employees fall into these

different ranges.

AGE COUNT
0-14 0
15-29 31
30-44 611
45-59 510
60-74 296
75-89 14
Total 1462

When you create a histogram in either Chart or Visualization mode, a bin is created

automatically for the measure you select. When working with bins, you can change the width of

the bin by editing it. In the Query or Data pane, right-click a bin field and click Edit Bins to
change the value that dictates the width or format of the contents of the bin.
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The bin value is desighated as a dimension field, since it is a limited field with a discrete set
of possible values that was created from a field with an unlimited, continuous range of values.
The measure displays as a count (.CNT) field and the related bin is created in the Query pane.
It is also placed in the Data Pane for future use.

Procedure: How to Create a Histogram with Automatic Binning in Chart Mode
1. Open InfoAssist+ in Chart mode.
On the Format tab in the Chart Types group, click Other.

In the Bar group of charts, click Vertical Histogram.
Click OK.

ok w N

From the Data pane, drag a measure into the Measure field container in the Query pane.
A histogram is automatically created using the measure you selected along with a
generated bin, as shown in the following image.
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Note: This process produces the same results as if you had created the histogram
manually, however it automatically converts the measure to a count (.CNT) field. It also
creates the bin for you, placing it on the x-axis, accordingly.

Procedure: How to Create a Histogram with Automatic Binning in Visualization Mode
1. Open InfoAssist+ in Visualization mode.
2. On the Home tab, in the Visual group, click Change.
3. Inthe Select a Visual dialog box, click Histogram.
4

From the Data pane, drag a measure into the Measure field container in the Query pane.
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A histogram is automatically created using the measure you selected along with a
generated bin, as shown in the following image.
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You can optionally edit the bin to change its width or format. For information on building a
histogram manually, in Chart mode, see Binning on page 130.

Accessing Chart Formatting Tools

Your presentation of data on a chart is successful when it communicates to your audience the
message that you intend. InfoAssist+ helps you meet the needs of your audience and convey
your message by providing numerous chart features. For example, you can adjust the

appearance of a chart, add layers of information, or customize the labels that identify the data
on the chart.

Using Live Preview

In Live Preview, the canvas on the right of the window provides a preview of the report or chart
content that you can interact with. Live Preview enables you to see your changes as you make
them. You can access more detail by running your report or chart.
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In the following image, the legend displays on the right side of the canvas.
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In Live Preview, when you select a graph element (for example, legend, axis label, title), the
bounding area is highlighted with a solid line.

Once you select a chart element, you can access all available design options on the ribbon, or
you can right-click an element to open a shortcut menu of frequently-used design options. Once
you have selected your design option from the ribbon or the menu, InfoAssist+ instantly
applies it to the chart element, so that you see the result immediately.

Shortcut menus are enabled for charts that are generated with either sample data, or live data
from your data source.

The following sections describe the chart elements and the ribbon options that you can work
with to design your charts in Live Preview.

Related Information:
Id Using Shortcut Menu Options in the Query Pane on page 57

Id Using Field Containers on page 49
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Formatting a Series

A series is a measure field that is included in a chart. You can format a series in a variety of
ways. For example, you can change the color of a series, add a trendline to a series, or change
the appearance of markers on a series.

You can access the full set of formatting options on the Series tab and Field tab. For more
information, see Series Tab on page 36 and Field Tab on page 35.

You can also access a subset of frequently-used options by right-clicking a series element on a
chart to open a menu of those options.

Tip: The options that you see on the menu depend on the type of chart that you are creating.
For example, the Series Type option would not appear on the menu for a pie chart, but it would
appear for a bar, line, and area chart.

Associated Dialog Boxes

140

Whether you access series options from the ribbon or the shortcut menu, you are presented
with a dialog box of options. The following dialog boxes are commonly used for formatting a
series:

4 Format Series
. Edit Title

. Traffic Light Condition

For Instructions on how to open these dialog boxes, see the procedures in Using Series
Properties on page 148.

Format Series Dialog Box

The Format Series dialog box contains options to format the fill and border of each series on a
chart. To access this dialog box, on the Series tab, in the Style group, click Style.

The Format Series dialog box contains the following tabs:
< Fill
.4 Border

. Effect (for HTML5 charts only)

Use the Fill tab to modify the color of a chart series.
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The Fill tab is shown in the following image.

@ Format All Series x
Fill Fill
Border Mo fill
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The Fill tab contains the following options:
.4 No fill. Select this option to remove the color from the series.
-1 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
series.

d Transparency. Move the slider to make the bands opaque (0%) or transparent (100%).
The default is 0%.

- Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

.4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.

Use the Border tab to specify a border for a chart series.
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The Border tab is shown in the following image.
@ Format All Series

Fill Barder

Border

Show Border Caolor
Effect

Border Color -l

o OK (S Cancel 2 Apply
The Border tab contains the following options:
4 Show Border Color. Select this option to show a border color around each series.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border.

Use the Effect tab to specify styling and shadowing options for HTML5 charts.
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The Effect tab is shown in the following image.
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Note: This tab only displays when working with HTML5 charts.
The Effect tab contains the following options:

d Riser Style. Use this drop-down menu to select a riser style. Options include: None, Bevel,
Cylinder, Darken, Inverted Darken, Lighten, and Inverted Lighten.

4 Show Shadow. Select this option to set a shadow.

Edit Title Dialog Box

To edit the title of a series, right-click a series on the canvas, and click Change Title. The Edit
Title dialog box contains a text field in which you can type the title for a series on a chart. Click
OK and the title appears on the chart.

If you have specified an amper (&) variable in your title while working in Live Preview,
_FOC_NULL displays to indicate that an amper variable that has not been evaluated. It
indicates that the value will be evaluated at run time.

Traffic Light Condition Dialog Box

The Traffic Light Condition dialog box contains fields for adding new conditional styling or
modifying existing conditional styling by applying a traffic light color to the selected field.
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The Traffic Light Condition dialog box is shown in the following image.
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The Traffic Light Condition dialog box contains the following fields.

- Relational Operators. Select from this drop-down menu to set the relational operator. For
example, Equal to.

. Type/Value. Click this unlabeled field to open a dialog box that contains the following
fields:

.4 Type. Opens a drop-down menu of the following values Constant and Field. Select
Constant to enter a constant value. Select Field to open a visual display of the fields in
your data source.

. Value: Enables you to specify a value based on the Type that you select.

Note: If you are creating a Traffic Light condition on a full date field, the Value field will
have a calendar icon adjacent to it. You can use this icon to select a date using a
calendar control.

d Get Values. Select a value option from this drop-down list. For example, All or First.

The Traffic Light Condition dialog box contains the following buttons:
4 Selected Condition. Click this icon to select a condition to work on.

4 New. Creates a new rule.
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- Delete. Deletes a rule.
.4 Color. Opens the Color dialog box.

.4 Drill Down. Opens the Drill Down dialog box, where you can drill down to a webpage or a
URL using Multi Drill functionality. Specify the following:

.4 URL of the webpage or location of the report
- An alternate comment
4 Target (New Window, Same Window, a value that you enter)

.4 Parameters that you want to use (Name, Value)

Note: In InfoAssist+, when the output destination is set to Single Tab or New Tab, the
drilldown target cannot be displayed in the Same Window so a new window will be
generated. When the report is run outside of InfoAssist+ the Same Window setting will be
respected.

Series Elements Shortcut Menu

When you right-click a series, a menu of options opens. The menu contains options that are
available on the Field and Series tabs.

The menu options are described in the following table. The table provides links to the sections
of this document in which those options are also discussed.

Option Description

Filter Values Enables you to create or modify a WHERE statement, using the
Filter dialog box. With a WHERE statement, you select only the
data that you want to display, and exclude unwanted data.

For information on filtering your data, see Data Tab on page 31
and Field Tab on page 35.

Sort Enables you to sort the series in either ascending or
descending order.
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Option Description

Visibility Controls the display of the selected series (field) on a chart.
The value Hide suppresses the display of the series, and the
default value Show displays the series.

For instructions, see How to Hide a Field in a Series on page

153.

Change Title Enables you to edit the title of the selected series. In the Edit
Title dialog box, type the new title in the Enter Title field, and
click OK.

For instructions, see How to Change the Title of a Series on
page 157.
Edit Format Enables you to change the format of a field. This includes field

type, display options, field length, and the specification of
applicable decimal points. For more information, see Changing
a Field Format on page 90.

Note: Any changes to the format of a field will be reflected in
the tooltip for charts at run time, as well as for visualizations at
design and run time.

Series Type Changes the chart type of the selected series to bar, line, or
area. The option None (default) returns the series to the chart
type that was in effect before you changed it. This option
applies to bar, line, and area chart types only.

For instructions, see How to Change the Type of a Series on
page 149.

Series Color Enables you to specify the color of the selected series, using
the Color dialog box. For more information, see Using the Color
Dialog Box on page 337.

More Style Options Opens the Format Series dialog box. For more information, see
Format Series Dialog Box on page 140.
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Option

Description

Data Labels

Controls the display of data labels (values) on the selected
series. The default value Hide suppresses the display of labels,
and the value Show displays labels.

This option does not apply to the gauge chart type.

For instructions, see How to Show and Hide Data Labels on
page 167.

Color Mode

Controls how color is applied to a series (measure field) on a
chart. The possible settings are By Series (default) and By
Group. For example, assume that there is only one series on a
sample bar chart. The By Series setting applies the same color
to all the bars in the series. The By Group setting applies a
different color to each bar.

For instructions, see How to Control the Color Mode on page
158.

Add Trendline

Draws a line on a chart to indicate a statistical trend.

This option does not apply to the pie, funnel, 3D, gauge, or
stock chart type.

For an example of a chart with a trendline, see How to Add a
Trendline on page 149.

Drill Down

Opens the Drill Down dialog box, where you can configure a
hyperlink or a drill-down procedure for the selected field.
Clicking that field in the report output, at run-time, redirects you
to the URL you specified or executes the indicated procedure.
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Option Description

More Contains the Aggregation Functions, Traffic Light Conditions,
and Missing options.

Aggregation Functions assign an aggregation value to a numeric
measure field in a report. For instructions, see How to Display
Aggregations on Measure Data on page 154.

Traffic Light Conditions enables you to specify the color of
numeric measure fields in the output, depending on conditions
that you set. You can use the Traffic Light Condition dialog box
to specify the conditions and colors.

For instructions, see How to Apply Traffic Light Conditions With
Drill-Down to a Numeric Measure Field (By Constant) on page
155 and How to Apply Traffic Light Conditions With Drill-Down to
a Numeric Measure Field (By Field) on page 156.

The Missing option allows you to show or hide fields with no
value.

Delete Removes the selected series from the report and updates the
Live Preview accordingly.

Using Series Properties

The following sections contain procedures for customizing a series.

Procedure: How to Select a Series
1. Create a chart.

2. On the Series tab, in the Select group drop-down menu, select the Series that you want to
customize.

The Series appears in the drop-down menu field.

Procedure: How to Format the Fill and Border of a Series
1. Create a chart.

2. Open the Format Series dialog box in one of the following ways:

4 Ribbon: On the Series tab, in the Style group, click Style.
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Procedure:

Procedure:

-1 Shortcut Menu: Right-click a series on the chart, and click More Style Options.
The Format Series dialog box opens.
3. Use the fill and border options to format the series.
For more information, see Format Series Dialog Box on page 140.
4. Click OK to close the dialog box.
The Format Series dialog box closes. The series fill and border are formatted accordingly.

5. Click Run to generate the report.

Enhancing Series Using the Series Tab

The Properties group contains commands for enhancing charts, such as changing the type or
adding a trendline, for the selected series.

How to Change the Type of a Series

1. Create a bar, line, or area chart.

2. Access the list of series types in one of the following ways:

.4 Ribbon: On the Series tab, in the Properties group, open the Type drop-down menu.

.4 Shortcut Menu: Right-click a series on the chart, and point to Series Type.
3. Select the type that you want the series to become.

The chart contains the new series type.

How to Add a Trendline

A trendline is a line that is drawn over the plot area of a chart or visual to show the pattern of
data points. The pattern reveals a statistical trend. In particular, the slope of the trendline,
which is calculated by subtracting and dividing two different x, y coordinate values, is a value
that indicates the rate at which the y value of a line rise or falls as the x value increases. Once
the slope of your chart or visual is determined, you can further extrapolate your results and
gain further insight into your data.

Note: The mathematical equation for the selected trendline option is only available in Chart
mode. It is not available in Visualization mode.

1. Create a chart or visual.

2. Access the menu of trendline types in one of the following ways:

- Ribbon: On the Series tab, in the Properties group, open the Trendline drop-down menu.
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Id Shortcut Menu: Right-click a series on the chart or visual, and point to Add Trendline.
3. Select the type of trendline that you want to display.

The trendline appears on the canvas.

4. Optionally, to display the mathematical equation for the selected trendline option, on the
Series tab, in the Properties group, click Equation.

The following image shows a trendline that appears with the Linear option.
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Formatting Charts Using the Series Tab

The Series tab contains options for formatting charts.

Procedure: How to Apply Smooth Line Effect to a Line Chart
1. Create a line chart.
2. Select a series on the line chart.

3. On the Series tab, in the Line group, click Smooth Line.

The Smooth Line effect is applied to the series.

Procedure: How to Hide a Series Line Between Markers

Lines appear between markers by default.
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To hide a series line between a marker:
1. Create a line chart.
2. Select a series on the line chart.

3. On the Series tab, in the Series group drop-down menu, select the series that you want to
hide.

4. In the Line Group, click Connect Lines.

The series line between the markers disappears.

To make the series line reappear, click Connect Lines again.

Procedure: How to Change the Appearance of a Marker

Markers are used to display points of data on a line chart. They are also used in the legend to
identify the data that is on the chart. The different marker shapes distinguish one series from
another.

1. Create a line chart.

2. Select a series on the line chart.

3. On the Series tab, in the Line group, click Marker to open a drop-down menu of options.
4

From the Marker drop-down menu, select the marker shape. For example, Diamond or
Hourglass.

The markers are formatted.

Db2 Web Query InfoAssist+ Part 1 151



Formatting a Series

The following image shows a triangle marker for gross profit data and a star marker for
revenue data.
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Procedure: How to Expand Pie Slices

1. Create a pie chart.

2. On the Series tab, in the Select group, from the drop-down menu, select one of the
following:

. All Series expands all slices out from the center of the pie.

.4 A specific series expands that particular slice out from the center of the pie.

3. In the Pie group, click Expand.

The pie expands accordingly.

Procedure: How to Hide a Pie Slice
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1. Create a pie chart.

2. On the Series tab, in the Select group, from the drop-down menu, select the series that you
want to hide. Then, in the Pie group, click Hide.

The slice is hidden.
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Procedure: How to Filter Values in a Series

1. Create a chart.

2. Select a series on the chart.

3. Open the Filter dialog box in one of the following ways:
4 Ribbon: On the Field tab, in the Filter group, click Filter.
.d Shortcut Menu: Right-click a series, and click Filter Values.
The Filter dialog box opens.

4. Select values for values and prompts.
Click OK to close the dialog box.

The series values are filtered.

Procedure: How to Sort the Fields in a Series
1. Create a chart.
2. Select a series.

3. Sort the series in one of the following ways:

.4 Ribbon: On the Field tab, in the Sort group, click Up to sort the series values from
smallest to largest, or click Down to sort the series values from largest to smallest.

-1 Shortcut Menu: Right-click a series on the chart, and point to Sort, and then Sort
again. Click Ascending to sort the series values from smallest to largest, or click
Descending to sort the series values from largest to smallest. Select Limit to open a
list of values to display for a sort group.

The chart appears with the series sorted accordingly.

Procedure: How to Hide a Field in a Series
1. Create a chart.

2. Hide a field in a series in one of the following ways:
. Select the field in the Query pane.
.4 Right-click the field in the chart.

.4 Ribbon: Select the field in the Query pane or by right-clicking it in the chart. On the
Field tab, in the Display group, click Hide Field. Click Hide Field again to make the
series reappear.
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- Shortcut Menu: Right-click a series in the Query pane, or in the chart, point to Visibility,
and then click Hide. Right-click the same series, point to Visibility, and then click Show
to make the series reappear.

The field is hidden.

Procedure: How to Display Aggregations on Measure Data

Procedure:

154

You can display numeric measure data using a variety of aggregation values.

For more information, see Missing Data in a Chart.

1.
2.

Create a chart.

Open the list of Aggregation options in one of the following ways:
- Ribbon: On the Field tab, in the Display group, click Aggregation.

- Shortcut Menu: Right-click a series, point to More, and then Aggregation Functions.
Select an aggregation function.
The aggregation function is applied to the series.

Note: If you change the Measure (Sum) Query field container in the Query pane from Sum
to Print, Count, or List, the change overrides all assigned aggregation values.

How to Display Aggregations on Dimension (Non-Numeric) Data

You can use various aggregations when working with dimension (non-numeric) fields in a chart,
including Count, Count Distinct, and Percent of Count. The Count aggregation counts the
number of occurrences of a field. Count Distinct counts the number of distinct values within a
field. Percent of Count computes a field percentage, based on the number of instances found.
When a dimension (non-numeric) field is placed in the Vertical Axis field container, it is
converted to a Count field. You can subsequently change the aggregation to Count Distinct or
Percent of Count.

1.
2.

Create a chart.

Convert a dimension (non-numeric) field into a Count field by placing it in the Vertical Axis
field container.

Select the series on which to perform an aggregation.

Open the list of Aggregation options in one of the following ways:
- Ribbon: On the Field tab, in the Display group, click Aggregation.

d Shortcut Menu: Right-click a series, point to More, and then click Aggregation
Functions.
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5.

Select an aggregation function.

The aggregation is applied to the series.

Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By

Constant)
1. Create a chart.
2. Open the Traffic Light Condition dialog box in one of the following ways:
.4 Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.
.4 Shortcut Menu: Right-click a series on the chart, point to More, and then click Traffic
Light Conditions.
The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 143.
3. From the Relational Operators drop-down menu below the field name, select a relational
operator. For example, Equal to.
4. In the field to the right of the Relational Operators drop-down menu, click the down arrow
for the Type drop-down menu.
The Type dialog box opens.
In the Type dialog box, select Constant.
6. Enter a value in the Value field, or
a. From the Get Values drop-down menu, select one of the following values All, First,
Last, Minimum, Maximum, From File. The value that you select appears in the Get
Values field.
b. Select the value in the Get Values field. The value that you selected appears in the
Value field.
7. Click OK.
The value that you selected appears in the field to the right of the operator drop-down
menu.
8. Click the Color button.
The Color dialog box opens.
9. Select a color.
10. Click OK.

The color appears in the Preview box.
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Procedure:
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11. Click the Drill Down button.

The Drill Down dialog box opens.

12. In the Drill Down dialog box, specify each of the following:

- Drill down to a report or a webpage
- URL of the webpage

- An alternate comment

- Target (New Window, Same Window)

- Parameters that you want to use (Name, Value)

13. Click OK to close the dialog box.

14. Click the New button to set traffic light conditions for additional fields.

How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By
Field)

1.
2.

Create a chart.

Open the Traffic Light Condition dialog box in one of the following ways:

- Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.

- Shortcut Menu: Right-click a series on your chart, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 143.

From the Relational Operators drop-down menu below the field name, select a relational
operator. For example, Greater than.

In the field to the right of the operator drop-down menu, click the arrow for the Type drop-
down menu.

The Type dialog box opens.
In the Type dialog box, select Field.

The Type dialog box displays the Dimensions, Measures, and Properties of your data. You
can display the data in the following ways:

d View fields in business order. Select from the following options: Title, Description,
Name, or Alias.
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- View fields in a sortable grid. Select from the following options: Name, Title, Alias,
Format, Segment, Filename, Description, or Reference.

.4 View the hierarchical structure of the data. Select from the following options: Title,
Description, Name, or Alias.

6. Select a field.
Click OK.

The field that you selected appears in the field to the right of the operator drop-down
menu.

8. Click the Color button.
The Color dialog box opens.
9. Select a color.
The color appears in the Preview box.
10. Click OK.
11. Click the Drill Down button.
The Drill Down dialog box opens.
12. In the Drill Down dialog box, specify a value for each of the following:
.l Drill down to a report or a webpage
.4 URL of the webpage
. An alternate comment
d Target (New Window, Same Window)
. Parameters that you want to use (Name, Value)

13. Click OK to close the dialog box.
14. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Change the Title of a Series
1. Create a chart.

2. Open the Edit Title dialog box in one of the following ways:
.4 Shortcut Menu: Right-click a series on the chart, and click Change Title.
4 Query Pane: Right-click a series, and click Change Title.

The Edit Title dialog box opens.
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Procedure:

Procedure:

3. Inthe Enter Title field, type the new name for the series.
4. Click OK to close the dialog box.

The series has a new title.

How to Control the Color Mode

When you create a single-series chart, all series groups appear in the same color. To use a
different color for each group, set the color mode to By Group.

1. Create a chart.
2. Rightclick a series on the chart, point to Color Mode, and then click By Group.

A different color is applied to each group in the series. To return to the default display of
the series in one color, right-click the series, point to Color Mode, and then click By Series.

3. Click Run to generate the report.

How to Delete a Series
1. Create a chart.
2. Rightclick a series on the chart, and click Delete.

The series is deleted.

Formatting Data Labels

Data labels highlight important data points on a chart. They identify exact numbers. You can
customize data labels in a variety of ways to make them stand out more clearly on the chart.
For example, you can change the position, angle, color, or size of data labels.

Associated Dialog Boxes
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Whether you access data label options from the ribbon or the shortcut menu, you are
presented with a dialog box of options. The following dialog boxes are commonly used for
formatting data labels:

d Format Labels
d Style
d Line Style

For instructions on how to open these dialog boxes, see the procedures in Using Data Labels
Properties on page 166.
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Format Labels Dialog Box

The Format Labels dialog box contains options for editing data labels. The Format Labels
dialog box offers different options depending on the chart type that you are using. Bar, line,
and area charts share the same tabs.

The Format Labels dialog box contains the following tabs:
General Options

Advanced

Pie Title (for pie charts only)

Pie Labels (for pie charts only)

L U o oo u

Funnel Labels (for funnel and pyramid charts)
General Options Tab

Use the General Options tab to add data labels to a chart and set their position, angle, and
radius.

The General Options tab is shown in the following image.

@ Format Labels x

General Options General Options

Advanced
. Show Data Labels

Positian Above =4
Format Labels General -
Style Labels @

W OK & Cancel

The General Options tab contains the following options:

.d Show Data Labels. Select this option to show data labels on a chart. Clear this option to
suppress data labels.
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- Position. Select an option from this drop-down menu to determine where the data label will
be positioned. The options are:

4 Above

. Below top edge
- Center

4 Base

4 Center back

.d Format Labels. Select from this drop-down menu of preset formats that can be applied to
the labels. Some of the options include Use Pattern, Currency General, and Date Full.

J Custom Format. Enter a standard number format pattern for the data label. This option is
only available when you select the Use Pattern option from the Format Labels drop-down
menu.

The following table describes the characters that you can use in a custom format.

Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for decimal separator.

, (comma) Is a placeholder for grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in
the prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or
suffix.

d Style Labels. Click this icon to open the Style dialog box, where you can style text. For
more information, see Style Dialog Box on page 165.
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- Show Cumulative Sums. Select this option to have the data text labels show cumulative
sums. Clear this option to have data text labels show individual sums. This option is
available for stacked charts.

d Show Stacked Total. Select this option to display stacked totals. Data position should be
set to Center to display a stacked total. This option is available for stacked charts.

Advanced Tab
Use the Advanced tab to modify additional data labels properties.
The Advanced tab is shown in the following image.

@ Format Labels x

General Options Advanced

Advanced
Show Zero Labels

Megative Data labels

Apphy color to negative data labels

o || @ancel | | 2 son |
The Advanced tab contains the following options:

d Show Zero Labels. Select this option to display zero values in a chart. Clear this option to
display all data values except zero.

-1 Apply color to negative data labels. Select this option to style negative data labels
separately from positive data labels.

. Color. Click this icon to open the Color dialog box, where you can select a color for the
negative number.

Pie Labels Tab

Use the Pie Labels tab to customize your pie data labels.
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The Pie Labels tab is shown in the following image.

@ Format Labels X
Pie Labels Pie Labels

Pie Title Label Position Hide -

Feeler Line

" OK S Cancel
The Pie Labels tab contains the following options:

.4 Label Position. Select from this drop-down menu an option to control the display of feeler
lines and labels on a pie chart.

.4 Label Display. Select from this drop-down menu an option to control the format of labels
displayed next to feelers on a pie chart.

-1 Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.

4 Custom Format. Select this option to use a custom format from a list of preset formats.
See the following table for a list and description of the characters that you can use in a
custom format.

.4 Style Labels. Click this button to open the Style dialog box, where you can style text.

Ring Label. These options appear on the tab for a ring pie chart.

4 Show Ring Label. Select this option to control the display of the total label on a pie ring
chart.

d Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.
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- Custom Format. Enter a standard number format pattern for the data label. This option is
only available when you select the Use Pattern option from the Format Labels drop-down
menu.

.4 Style Labels. Click this button to open the Style dialog box, where you can style text.

Feeler Line. Provides options to style the feeler lines for pie chart labels.

4 Line Style. Click this button to open the Line Style dialog box, where you can edit the color,
weight, and style of the feeler line.

Pie Title Tab
Use the Pie Title tab to create and style a pie title.
The Pie Title tab is shown in the following image.

[ Format Labels x

Pie Labels Pie Title

Pie Title
| Show Pie Title

Style Title B

7 OK ) Cancel 2 Apply
The Pie Title tab contains the following options:

d Show Pie Title. Clear this option to suppress a pie title. Select this option to display a pie
title. This is the default option.

.d Style Title. Click this icon to open the Style dialog box, where you can style pie title text.
Funnel Labels Tab

Use the Funnel Labels tab to customize the labels on a funnel or a pyramid chart.
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The Funnel Labels tab is shown in the following image.

@ Format Labels x

Funnel Labels Funnel Labels

Label Position Labels and Values to the Right -
Format Labels General -
Style Labels E
Style Value @

Feeler Line

#| Show Feeler Lines

Ling Style e

" OK () Cancel

The Funnel Labels tab contains the following options:

.4 Label Position. Select an option from this drop-down menu to control the display of feeler
lines and labels on a funnel chart.

4 Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.

.d Custom Format. Select this option to use a custom format. See the table in the previous
section for a list and description of the characters that you can use in a custom format.

.4 Style Labels. Click this button to open the Style dialog box, where you can style text.

. Style Value. Opens the Style dialog box, where you can style the value.

Feeler Line

d Show Feeler Lines. (Default) Clear this option to suppress feeler lines. Select this option to
display feeler lines.

. Line Style. Click this button to open the Line Style dialog box, where you can edit the color,
weight, and style of the feeler line.
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Note: While some style options, such as Show Pie Title and Show Feeler Lines, are enabled
by default, a stylesheet applied to the chart may contain different settings that will override
these default settings.

Style Dialog Box
The Style dialog box contains options to style the data labels.

The Style dialog box is shown in the following image.

@ Report Style x
ARIAL - g -
Bsru === Bd § £
Preview
ARIAL 9

o 0K () Cancel

The Style dialog box contains the following options:

- Font. Use the drop-down menu to change the font.

Font size. Use the drop-down menu to change the numeric value for the font size.

Font style. Click the appropriate button (bold, italic, underline) to style the selected text.

Text alignment. Click the appropriate button (left, center, right) to align the selected text.

L U o U

Font color. Click the button to open the Color dialog box, where you can select the font
color.

d Reset to Quick Styles from Template. Click the button to reset all settings to the default
settings from the template.

Note: Reset only works while the Style dialog box is open. Once you click OK, all changes
are committed. To undo global styling after it has been committed, you must use the Undo
command on the Quick Access Toolbar.

Db2 Web Query InfoAssist+ Part 1 165



Formatting Data Labels

Line Style Dialog Box
The Line Style dialog box contains options to style lines on a chart.
The Line Style dialog box is shown in the following image.

(W]

ExE Line Style O x

@ Color

Weight - —_— Style -

" OK 45 Reset | | (§) Cancel

The Line Style dialog box contains the following options:

.4 Color. Click this button to open the Color dialog box, where you can select the color for the
line.

.4 Weight. Click this button to open a drop-down menu of line weight options.
.4 Style. Click this button to open a drop-down menu of line style options.

. Reset. Click this button to reset the line to the default options.

Data Labels Elements Shortcut Menu

When you right-click a data label on a bar, line, or area chart, a menu of the following options
opens:

4 Data Labels. Point to this option to toggle between Show and Hide.

.4 More Label Options. Click this option to open the Format Labels dialog box.

The shortcut menu contains options that are available on the Series tab.

Using Data Labels Properties

The following sections contain procedures for customizing data labels.
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Procedure: How to Show and Hide Data Labels

1. Create a chart.

2. You can access the option to show data labels in one of the following ways:

- Ribbon: On the Series tab, in the Properties group, click Data Labels, and from the drop-
down menu, click More Data Label Options. The Format Labels dialog box opens. On
the General Options tab, select the Show Data Labels check box, and click OK to close
the dialog box. You can use this dialog box to format and style the data labels. For
more information, see Format Labels Dialog Box on page 159. To hide data labels,

clear this option.

.4 Shortcut Menu: Right-click a series on the chart, point to Data Labels, and then click
Show. To hide data labels, right-click a series on the chart, point to Data Labels, and

then click Hide.

The data labels appear, and are formatted and styled accordingly.

The following image shows a chart with data labels.
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Procedure: How to Change the Position of Data Labels

Stereo Systems

Televisions | [&

1. On the Series tab, in the Properties group, click Data Labels.

2. On the menu, select the position for the data labels.
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The data labels are positioned accordingly.

Formatting a Legend

A legend contains information that is necessary to accurately interpret the data on a chart. By
default, a chart displays either a vertical axis title if there is a single measure field, or a legend
if there are multiple measure fields.

Format Legend Dialog Box

168

Whether you access legend options from the ribbon or the shortcut menu, you are presented
with the Format Legend dialog box of options. For instructions on how to open this dialog box,
see Using Legend Properties on page 171.

The Format Legend dialog box contains options for formatting a legend on a chart or
visualization. It contains the following tabs:

4 Legend Options
d Markers & Labels
1 Fill

d Border Styles

For instructions on how to open this dialog box, see the procedures in Using Legend Properties
on page 171.

Use the Legend Options tab to customize the appearance of a legend on a chart or
visualization.

The Legend Options tab is shown in the following image.
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\:fg_- Format Legend b 4

Legend Options Legend Options

Markers & Labels #| Show Legend
Fill Legend Position Right =
Border Styles

Reverse Legend Order

Docking State Expanded -

«| Enable Scrolling

Show Title

" 0K (S Cancel

The Legend Options tab contains the following options.

d Show Legend. When selected, a legend displays on a chart or visualization. Clear this
option to suppress a legend on a chart or visualization.

.4 Legend Position. Opens a drop-down menu of options to position the legend. For example,
top or left.

.d Reverse Legend Order. Specifies that the legend be drawn in reverse order. Clear this
option to specify that the legend be drawn in normal order.

d Docking State. This option dictates how the legend is docked. It is set to Expanded by
default, but you can set it to Collapsed, which will show that the legend is available (using
the grey arrow). This option saves real estate in your chart by collapsing the categorical text
labels in the legend while preserving the legend label colors. This is particularly useful
when items in your legend have long labels and you wish to truncate them for the purposes
of display. If you set this option to None, the ability to expand or collapse the legend is
removed and the grey arrow no longer displays.
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-1 Enable Scrolling. Select this check box to enable scrolling in your legend. This is
particularly useful when you have numerous entries in your legend. This check box is
selected by default. To disable scrolling in your legend, clear the Enable Scrolling check
box. All legend options display in columns, and a scroll bar does not display.

.d Show Title. Select this check box to display the legend title.

Use the Markers & Labels tab to customize the appearance of markers and labels on legends.
The Markers & Labels tab contains the following options:

. Style Labels. Opens the Style dialog box, where you can style text.

4 Marker Position. Opens a drop-down menu of options to set the position of text relative to
the legend marker. For example, Left of Text or Above Text.

Use the Fill tab to modify the color of the legend area. For more information, see Format Series
Dialog Box on page 140.

Use the Border Styles tab to place a border around a legend. For more information, see Format
Series Dialog Box on page 140.

The Border Styles tab contains the following options:
d Show Border. Select this option to place a border around a legend.

4 Color. With the Show Border option selected, you can click this button to open the Color
dialog box, where you can select a color for the border.

Legend Elements Shortcut Menu

When you right-click a legend on a chart, a menu of options opens. The menu contains options
that are available on the Format tab.

The shortcut menu options are described in the following table. The table provides links to the
sections of this document in which those options are also discussed.
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Option

Description

Show legend

Controls the display of the legend. InfoAssist+ displays the legend
by default. When you clear this option, InfoAssist+ suppresses
the legend. For instructions, see Using Legend Properties on page
171.

The background shortcut menu has an option to restore the
legend after it has been suppressed.

Legend Position

Controls the placement of the legend on the chart. For
instructions see, Using Legend Properties on page 171.

Legend Area Color

Enables you to specify the color of the legend background area
using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on page
171.

Legend Border Color

Enables you to specify the color of the border around the legend
background area using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on page
171.

More Legend Options

Opens the Format Legend dialog box.

Using Legend Properties

The following sections contain procedures for customizing legends. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Procedure: How to Hide a Legend

1. Create a chart with multiple measure fields.

2. Clear the Show legend option in one of the following ways:

.4 Ribbon: On the Format tab, in the Labels group, click Legend, then click Show legend to

clear the option.

.4 Shortcut Menu: Right-click the legend, and clear the Show legend option.
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The legend is hidden.

Procedure: How to Position a Legend

1.
2.

3.

Create a chart with multiple measure fields.

Open the menu of label position options in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, click Legend, then point to Legend
Position.

- Shortcut Menu: Right-click the legend, and point to Legend Position.

Select a position for the legend. For example, Auto or Right.

Procedure: How to Specify the Color of a Legend Border

1.
2.

172

Create a chart with multiple measure fields.

Open the Format Legends dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, click Legend, then click More Legend
Options.
- Shortcut Menu: Right-click the legend, and click More Legend Options.

The Format Legend dialog box opens. For more information, see Format Legend Dialog Box
on page 168.

On the Border Styles tab, select the option to Show Border.

Click the Color icon to open the Color dialog box, where you can specify the color of the
legend border.

Click OK to close the Color dialog box.
Click OK to close the Format Legend dialog box.

The legend border is formatted accordingly.
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The following image is an example of a chart with a styled legend.
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Formatting Gridlines

Gridlines are used on a chart as a reference to help you understand the quantities and values
of your data and decode information on the axis. There are four types of gridlines that you can
display and edit on your chart. They are:

.4 Horizontal major gridlines
.d Horizontal minor gridlines
.4 Vertical major gridlines

. Vertical minor gridlines

Major gridlines enhance the display of values, while minor gridlines supplement major
gridlines. If a plot point falls in between major gridlines, you can use minor gridlines for more
precise interpretation of the data.

.4 Vertical gridlines in a vertical chart run on the X axis.
.4 Horizontal gridlines in a vertical chart run on the Y axis.

.4 Horizontal major gridlines enhance the display of values, compared to the Y-axis scale
alone. They are enabled by default on many charts. They do not apply to the pie, 3D,
gauge, spectral map, or funnel chart type.
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- Horizontal minor gridlines are disabled by default. They do not apply to the pie, 3D, gauge,
spectral map, or funnel chart type.

. Vertical major gridlines enhance the display of values, compared to the X-axis scale alone.
They are enabled by default. They do not apply to the pie, 3D, gauge, spectral map, or
funnel chart type.

4 Vertical minor gridlines are disabled by default. They apply only to scatter and bubble chart
types, where the X axis is numeric. They do not apply to the pie, 3D, gauge, spectral map,
or funnel chart type.

Note: The orientation of a chart determines the available gridline options.

Format Grid Lines Dialog Box

174

You can format horizontal and vertical gridlines, color bands, and frames on a chart using the
options in the Format Grid Lines dialog box. For instructions on how to open this dialog box,
see the procedures in Using Gridline Properties on page 177.

Color bands come in a pair, with each band uniquely colored. They appear in a continually
repeating pattern behind a series on a chart. The contrast of colors is designed to make the
chart easier to read.

Alternate formatting can be used to apply different colors to sections, called regions, of an
axis.

The Format Grid Lines dialog box contains the following tabs:
4 Major Grid Lines

4 Minor Grid Lines

.d Color Bands

d Frames
Use the Major Grid Lines tab to format the major gridlines on the chart.

The Major Grid Lines tab contains the following options:

.4 Show Grid Lines. Select this option to display major gridlines on a chart if minor gridlines
are the default for the chart.

.4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

.d Show Ticks. Select this check box to enable or disable the tick mark functionality.
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-1 Tick Style. Select from this drop-down menu of tick styles (Inside, Outside, Spanning).

.4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Use the Minor Grid Lines tab to format the minor gridlines on your chart.
The Minor Grid Lines tab contains the following options:

d Show Grid Lines. Select this option to display minor gridlines on a chart. By default, this
option is enabled.

. Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Grid count. Set the number of minor gridlines that will appear between major gridlines.
Show Ticks. Select this check box to enable or disable the tick mark functionality.

Tick Style. Select from this drop-down menu of tick styles (Inside, Outside, Spanning).
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Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Use the Color Bands tab to format the color bands on your chart.

The Color Bands tab contains the following options:
.4 Band 1. Select this option to add Band 1 to a chart.

. Color. Click this icon to open the Color dialog box, where you can edit the color of Band
1.

4 Transparency. Move the slider to make Band 1 opaque (0%) or transparent (100%). The
default is 0%.

.4 %. Enter or select the percentage of the transparency of Band 1.
4 Band 2. Select this option to add Band 2 to a chart.

.4 Color. Click this icon to open the Color dialog box, where you can edit the color of Band
2.

4 Transparency. Move the slider to make the Band 2 opaque (0%) or transparent (100%).
The default is 0%.

- %. Enter or select the percentage of the transparency of Band 2.
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Use the Frames tab to enable or disable frame regions, and to set the location and style of the
frame text.

The Frames tab contains the following options:

-

-

-

Show Frame Regions. Select this option to show a frame region. Clear this option to
suppress a frame region.

d Region. Select from this drop-down list, the region that you want to format.
- Add. Click this button to add a region.

-l Remove. Click this button to remove a region.

Location. Enter the location of the region.

Color. Click this icon to open the Color dialog box, where you can edit the color of the
frame.

Border Color. Click this icon to open the Color dialog box, where you can edit the color of
the frame border.

Text. Enter the text that you want to appear on the frame.

Style Text. Click this icon to style the frame text.

For instructions on how to open this dialog box, see the procedures in Using Gridline Properties
on page 177.

Gridline Elements Shortcut Menu

176

When you right-click a gridline on a chart, a menu of options opens. The options for the gridline
elements are described in the following table.
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Element

Option

Description

Horizontal Major Gridlines
Horizontal Minor Gridlines
Vertical Major Gridlines

Vertical Minor Gridlines

Delete

Removes the gridline from the
chart and updates the Live
Preview accordingly.

Set Line Color

Enables you to specify the color of
the gridline, using the Color dialog
box. For more information, see
Using the Color Dialog Box on

page 337.

More Grid Lines
Options

Opens the Format Gridlines dialog
box. For more information, see
Format Grid Lines Dialog Box on
page 174.

Using Gridline Properties

The following sections contain procedures for customizing gridlines.

Procedure: How to Display Horizontal Major Gridlines

If your chart does not display gridlines by default, use this procedure to generate gridlines.

1. Create a chart.

2. On the Format tab, in the Features group, open the Grid drop-down menu, point to

Horizontal Gridlines, and then click Major Gridlines.

Horizontal major gridlines are added to the chart.

Procedure: How to Display Horizontal Minor Gridlines

1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Horizontal Gridlines, and then click Minor Gridlines.

.d Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Horizontal Grid Lines dialog box opens. On the Minor Grid Lines tab, select

Show Grid Lines.

Db2 Web Query InfoAssist+ Part 1

177



Formatting Gridlines

Horizontal minor gridlines are added to the chart.

Procedure: How to Display Vertical Major Gridlines
1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Vertical Gridlines, and then click Major Gridlines.

- Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Vertical Grid Lines dialog box opens. On the Major Grid Lines tab, select
Show Grid Lines.

Vertical major gridlines are added to the chart.

Procedure: How to Display Vertical Minor Gridlines
1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Vertical Gridlines, and then click Minor Gridlines.

- Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Vertical Grid Lines dialog box opens. On the Minor Grid Lines tab, select
Show Grid Lines.

Vertical minor gridlines are added to the chart.

Procedure: How to Set the Color, Weight, and Style of a Gridline

1. Open the Format Grid Lines dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point
to the gridline type that you want to format, and click More Grid Lines Options.

- Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.
The Format Grid Lines dialog box opens.
2. Click the Line Style icon.

The Line Style dialog box opens.
3. Set the color, weight, and style of the gridline.
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4. Click OK to close the Line Style dialog box.
Click OK again to close the Format Grid Lines dialog box.
The gridline is formatted accordingly.

The following image shows a line chart with styling applied to the gridlines.
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Procedure: How to Set Ticks

Ticks are short lines which are perpendicular to a gridline. They are used to tick off specific
increments along the gridline.

1. Create a chart with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point
to the gridline type that you want to format, and click More Grid Lines Options.

. Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.

The Format Grid Lines dialog box opens.

3. From the Tick Style drop-down menu, select a tick style option. The options are:

. Inside
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- Outside

.4 Spanning

weight, and style of the gridline.

Click OK to close the Line Style dialog box.

Click OK again to close the Format Grid Lines dialog box.

The tick marks are formatted accordingly.

Click the Line Style icon to open the Line Style dialog box, where you can edit the color,

The following image shows a chart with tick marks spanning both the vertical axis and
horizontal axis.
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Procedure: How to Set Color Bands
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1. Create a chart with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point
to gridlines that you want to format, and click More Grid Lines Options.

. Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.

The Format Grid Lines dialog box opens.
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3. On the Color Bands tab, click the Color icon to open the Color dialog box, where you can
set the color of the color bands.

4. Use the transparency slider, or the percentage box, to type or select the percentage of the
transparency that you want to apply to the color.

Click OK to close the Color dialog box.
6. Click OK again to close the Format Grid Lines dialog box.

The following image shows a chart with color bands along the horizontal gridline.
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Procedure: How to Delete a Gridline
1. Create a chart with gridlines.
2. Select a gridline.

3. Delete the gridline in one of the following ways:

Id Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. From
the menu, point to the gridline that you want to format, and click More Grid Lines to
open the Format Grid Lines dialog box. On the tab for the gridline that you want to
delete, clear the Show Grid Lines option, and click OK.

[d Shortcut Menu: Right-click the gridline, and from the menu, select Delete.
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The gridline is deleted from the chart.

Procedure: How to Add Frames to Regions on a Chart

1.
2.
3.

182

Create a chart.
On the Format tab, in the Features group, click Grid.

On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and then
click More Grid Lines Options.

The Format Grid Lines dialog box opens.
On the Frames tab, select the Show Frame Regions check box.
Click Apply.

Colored frames are added to the chart, using the default styling options. Optionally, you
may use the color and border color options to change these.

The following image shows a bar chart with colored frames around each region.
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Formatting Axis Labels

Vertical and horizontal axes are based on the orientation of the graph. For example, in a
vertical graph, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis.
In a horizontal graph, the horizontal axis refers to the Y axis and the vertical axis refers to the
X axis. This is important to consider, since options could change depending on the orientation
of the graph.

A chart can contain the following types of axis labels:

.d Horizontal axis labels represent the X axis. They do not apply to pie, funnel, or gauge
charts.

.4 Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric
scale, usually located on the left side of a vertical chart.

.d Secondary horizontal and vertical labels can only be used when dual axes charts are
selected.

Format Axis Dialog Box

Reference:

Whether you access axis options from the ribbon, or the shortcut menu, you are presented
with the Format Axis dialog box of options for formatting for both vertical and horizontal axes.
The Format Axis dialog box contains the following tabs:

-l General (for horizontal axes)
.4 Scale (for vertical axes)

d Title

- Labels

4 Advanced

Format Vertical Axis Dialog Box

You use the Format Vertical Axis dialog box to specify formatting options for the vertical axis in
your chart.

Use the Scale tab to modify scale properties.
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The Scale tab is shown in the following image.

@ .I;.crmat Vertical Axis x

Seale Scale

Title «| Automatic Minimum
Labels Value

Advanced #| Automatic Maximum
Value

#| Automatic Grid Step

value

Logarithmic Scale

#| Include zere on scale

W OK ©cancel | | 8

The Scale tab contains the following options:

- Automatic Minimum. Supplies the minimum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the minimum value by entering a
number into the Value text box.

.4 Value. Type the minimum value in this text box if you have not selected Automatic
Minimum.

-1 Automatic Maximum. Supplies the maximum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the maximum value by entering a
number into the Value text box.

4 Value. Type the maximum value in this text box if you have not selected Automatic
Maximum.

d Automatic Grid Step. Calculates the number of major grid steps automatically. To use
manual scaling, clear this option. You can then set the value by typing the number into the
Value text box.

.4 Value. Type the value in this text box if you have not selected Automatic Grid Step.

d Logarithmic Scale. Controls whether or not the Y-axis scale progresses logarithmically
instead of linearly. This option is disabled by default. When selected, the logarithmic base
is set to 10.0.
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- Include zero on scale. Controls whether or not a zero (0O) value appears on the scale. This
option is enabled by default.

Use the Title tab to show or hide the axis title, and create and style the title for the axis.

The Title tab contains the following options:

d Show title. Select this check box to show the axis title (default) or clear the check box to
hide the axis title.

d Text. Type a title for the axis in the Text field.

d Style text. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

d Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

. Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

. Style labels. Opens the Style dialog box, where you can style text.
d Format Labels. Contains a list of preset formats that can be applied to the labels.

.d Custom Format. Allows you to use a custom format. This option is activated when Use
Pattern /100 and Use Pattern are selected as the format labels.

The Format Labels drop-down menu provides a list of preset formats that you can apply to
labels. When you select a custom format, it must be defined using a custom format pattern.
See the following table for a list and description of the characters that you can use in a
custom format.

Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for a decimal separator.
, (comma) Is a placeholder for a grouping separator.
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Character Description

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in the
prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or suffix.

Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

Jd Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
.4 Exclude Maximum Label. Excludes the label with the highest axis value from the chart.
4 Descending Axis. Draws the axis in descending order.

d Show axis line. Controls the display of the axis baseline.

4 Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

.1 Show zero line. Controls the display of the zero line.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the zero line.

. Custom Baseline. Controls the display of the custom baseline.
- Value. Type a value for the custom baseline.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the custom baseline.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on
page 190.

Reference: Format Horizontal Axis Dialog Box

You use the Format Horizontal Axis dialog box to specify formatting options for the horizontal
axis in your chart.
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The General tab contains the Show axis line check box, which controls the display of the axis
line. When this check box is selected, you can style the axis line.

The General tab is shown in the following image.

@ Format Horizontal Axis x
Sarer] General
Title Show axis line
Labels Line Style 4

Advanced

" OK (S Cancel 2 Apply

The General tab contains the following options:
. Show axis line. Enables the display of the axis line.

- Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:
4 Text. Type a title for the axis in the Text field.

- Style. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

d Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

- Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

. Style labels. Opens the Style dialog box, where you can style text.

d Stagger Labels. Sets the labels to appear staggered.
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-1 Concatenate Labels. Concatenates the labels in your chart. This is enabled by default.
Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

4 Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
.4 Exclude Maximum Label. Excludes the label with the highest axis value from the chart.
-l Reverse Groups. Reverses the order of the display of the groups on the horizontal axis.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on
page 190.

Secondary Axes Options

Formatting options are available for secondary axes in dual-axis charts. For example, in a
vertical dual-axis chart, the secondary vertical axis refers to the Y2 axis.

The Format Secondary Axis dialog box contains the following tabs for both vertical and
horizontal axes:

.4 General. For more information, see the Scale tab options in Format Axis Dialog Box on page
183.

. Title. For more information, see the equivalent tab in Format Axis Dialog Box on page 183.

.4 Labels. For more information, see the equivalent tab in Format Axis Dialog Box on page
183.

.4 Advanced. For more information, see the equivalent tab in Format Axis Dialog Box on page
183.

Axis Elements Shortcut Menu

188

When you right-click an axis label or title in a chart in Live Preview, a menu of options opens.
The options for the right-click axis label elements are described in the following table.
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Element Option Description
Axis Title Delete Deletes the axis title from the chart and updates the Live
Preview accordingly.

Change Title Enables you to change the axis title.

Style Title Enables you to apply styling to the axis title, using the Style
dialog box. For more information, see Style Dialog Box on
page 165.

Horizontal Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Stagger Controls the positioning of the labels. The On value
positions the labels in a zigzag pattern. The Off default
value positions the labels in a straight row.

Rotate Rotates the labels a specified number of degrees.

Style Labels Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 165.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 183.

Vertical Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Rotate Rotates the labels a specified number of degrees.

Format Formats the labels according to the value that you specify.

Labels

Style Labels Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 165.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 183.
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Using Axis Properties

The following sections contain procedures for customizing an axis. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

Procedure: How to Delete Axis Labels
1. Create a chart.

2. You can delete axis labels in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and clear the Show Labels option.

- Shortcut Menu: Right-click an axis label on the chart, and click Delete.

The axis labels are deleted from the chart.

Procedure: How to Stagger Axis Labels
Note: You can only apply a staggered effect to horizontal axis labels.

1. Create a chart with at least one axis label on display.

2. Access the Stagger option in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to Horizontal Axis, and click Stagger Labels.

- Shortcut Menu: Right-click an axis label on the chart, point to Stagger and select On.

The axis labels are staggered.

Procedure: How to Rotate Axis Labels
1. Create a chart with axis labels.

2. Access the Rotate option in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, point to Rotate Labels, and then click the degree
to which you want to rotate the axis labels.

- Shortcut Menu: Right-click an axis label on the chart, point to Rotate, and then click
the degree to which you want to rotate the axis labels.

The axis labels are rotated.

190 IBM



4. Creating and Customizing Charts I

Procedure: How to Format Axis Labels

1.
2.

Create a chart with an axis label.

Access the list of axis label options in one of the following ways:
- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options to open the Format

Axis dialog box. Open the Labels tab, and from the Labels option drop-down menu,
select the formatting option that you want.

.4 Shortcut Menu: Right-click an axis label, point to Format Labels, and click the
formatting option that you want.

The axis labels are formatted accordingly.

Procedure: How to Manually Set the Scale of an Axis

1.
2.

Create a chart.

Open the Format Axis dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.

.d Shortcut Menu: Right-click an axis value on the chart, and click More Axis Options.
The Format Axis dialog box opens.

On the Scale tab, clear the Automatic Minimum option and enter your own minimum value
in the Value text box.

Clear the Automatic Maximum option, and enter your own maximum value in the Value text
box.

Clear the Automatic Grid Step option, and enter your own grid step value in the Value text
box.

Optionally, you can select the Logarithmic Scale option. You can also clear the Include zero
on scale option if you do not want zero to appear on the axis.

Click OK to close the dialog box.

The axis scale is set accordingly.

Procedure: How to Add an Axis Title

1.

Create a chart with an axis label.
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2.

Open the Format Axis dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.

- Shortcut Menu: Right-click an axis label, and click More Axis Options.

The Format Axis dialog box opens.

On the Title tab, type the axis title in the Text field.

Click the Style text icon to open the Style dialog box, where you can style the text.
The axis title is styled accordingly.

Note: Right-click the axis title to delete, change, or style the axis title.

Procedure: How to Set Advanced Axis Properties
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1.
2.

Create a chart with an axis label.

Open the Format Axis dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.

- Shortcut Menu: Right-click an axis label, and click More Axis Options.

The Format Axis dialog box opens.

On the Advanced tab, set the following options:
- Exclude Minimum Label

- Exclude Maximum Label

Descending Axis

Show axis line

Show zero line

L U U L

Custom Baseline (Value)

You can edit the color, weight, and style of all the lines that you set in the Line Style
dialog box.

Click OK.

The axis advanced options are set accordingly.
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Formatting a Frame and a Background

The frame of a chart is the area that contains the plot points. It is also the area in which
horizontal and vertical gridlines are drawn.

The background of a chart is the area around the frame.

You can adjust the appearance of the frame and background to achieve different visual effects
for your charts. For example, you can change the appearance of the chart frame line, or you
can change the color of the background of your chart, as shown in the following image.
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Frame & Background Dialog Box

Whether you access frame and background options from the ribbon, or the shortcut menu, you
are presented with the Frame & Background dialog box of options for formatting the frame and
background of a chart. The Frame & Background dialog contains the following tabs:

I Frame
Id Frame Edge

[d Background
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The Frame & Background dialog box and pertinent tabs are discussed in this section for the
following types of charts:

- 2D Charts and 2D Charts with 3D Effects (Frame and Frame Edge tabs)
- Pie Charts (Frame and Frame Edge tabs)

- 3D Charts (Left Wall, Right Wall, Floor, and Advanced tabs)

Note: The options in the Frame tab vary based on the chart type selected.

Use the Frame tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and
depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

- Depth Angle. Enter the angle from the front of the chart to the back where the chart risers
and frames are drawn. You can set the depth angle from zero to 180 degrees, but it must
be used along with Depth Radius.

The depth angle in 3D charts can only be changed when using the HTML, PDF, PowerPoint,
and Excel output formats.

- Depth Radius. Enter how far out the extruded frame will be extended. Small values, such
as zero, produce very narrow charts. Large values, the maximum being 100, produce
thicker charts.

Fill
- No fill. (Default). Select this option to keep the legend colorless.
- Solid fill. Select this option to display the Color and Transparency options.

- Color. Click this icon to open the Color dialog box, where you can select a color for a
frame.

- Transparency. Move the slider to make the frame opaque (0%) or transparent (100%).
The default is 0%.

- Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

- Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.
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Gradient style

.1 Color Pattern. Select the color pattern for the data series. The color pattern option on the
left is an AB wash that uses two colors in the pattern colorl - color2, for example, red-
green. The color pattern option on the right is an ABA wash that uses two colors in the
pattern colorl - color2 - colorl, for example, red-green-red.

-1 First Color. Click this icon to open the Color dialog box, where you can select a color for the
first color.

.4 Second Color. Click this icon to open the Color dialog box, where you can select a color for
the second color.

Shadow

.d Show Shadow. Select this option to set a shadow.

Use the Frame Edge tab for 2D charts and 2D charts with 3D effects to set a frame depth
angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types
of charts.

The Frame Edge tab for 2D charts and 2D charts with 3D effects contains the following
options:

d Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

Side Frame
.d Show Color. Select this option to show the color of the side frame.

. Color. Click this icon to open the Color dialog box, where you can select a color for the side
frame.

.4 Show Border Color. Select this option to show the color of the border of the side frame.

The border color only displays when using the HTML, PDF, PowerPoint, and Excel output
formats.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the side frame.

Bottom Frame
.d Show Color. Select this option to show the color of the bottom frame.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

Db2 Web Query InfoAssist+ Part 1 195



Formatting a Frame and a Background

196

- Show Border Color. Select this option to show the color of the bottom frame.

The border color only displays when using the HTML, PDF, PowerPoint, and Excel output
formats.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the bottom frame.

Use the Frame tab for pie charts to set pie depth and tilt, select a fill and color for a pie frame,
and set a shadow for the frame.

Note: This is only available for pie charts in HTML format.

The Frame tab is shown in the following image.

@ Frame & Background x
Frame Frame
Frame Edge
Pie Depth 0 Pie Tilt 0
Background
Fill
®) N fill
() solid fill
() Gradient fill
Shadow
[] show shadow

0K © Cancel gnp :

The Frame tab for pie charts contains the following options:

. Pie Depth. Set the depth of the edge of a pie chart. You can select a value from zero to
100 to set the thickness of an edge.

4 Pie Tilt. Set the tilt of the pie chart. The smaller the value you add, the flatter the pie chart
appears. The larger the value you add, more of the pie edge appears.

Fill

. No fill. (Default). Results in no color added to the edge of the pie.
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-1 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
frame.

.4 Transparency. Move the slider to make the fill opaque (0%) or transparent (100%). The
default is 0%.

- Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

.4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.

d Gradient Style

1 Color Pattern. Select the color pattern for the data series. The color pattern option
on the left is an AB wash that uses two colors in the pattern colorl - color2, for
example, red-green. The color pattern option on the right is an ABA wash that uses
two colors in the pattern colorl - color2 - colorl, for example, red-green-red.

.4 First Color. Click this icon to open the Color dialog box, where you can select a color
for the first color.

. Second Color. Click this icon to open the Color dialog box, where you can select a
color for the second color.

Shadow

d Show Shadow. Select this option to set a shadow around the frame.
Use the Frame Edge tab for pie charts to set the edge of a pie frame.

The Frame Edge tab for pie charts contains the following options:

J Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

.d Show Color. Select this option to show the color of the side frame.

- Color. Click this icon to open the Color dialog box, where you can select a color for side
frame.

4 Show Border Color. Select this option to show the color of the border of the side frame.
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-1 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the side frame.

Bottom Frame
J Show Color. Select this option to show the color of the bottom frame.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

.d Show Border Color. Select this option to show the color of the bottom frame.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the bottom frame.

Use Wall and Floor tabs to set the walls and floor of a 3D chart.

The Left Wall tab is shown in the following image.

@ Frame & Background b4
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Wall Thickness 20.0
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Background

Color d Border Calor I.J

" OK (S Cancel 2 Apply

These Wall and Floor tabs contain the following options:

.4 Show Wall or Show Floor. Select this option to show the wall or floor (depending on the
tab) of the 3D chart.

d Wall Thickness. Specify the thickness of the wall or floor.
.4 Cube Size. Specify the cube size of the wall or floor.

. Color. Click this icon to open the Color dialog box, where you can select a color for the wall
or floor.
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-1 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the wall or floor.

d Show Wall (Left Wall). Select this option to show the left wall.

4 Show Wall (Right Wall). Select this option to show the right wall.

.4 Show Floor. Select this option to show the floor.

Use the Advanced tab for 3D charts to modify additional properties for 3D frames.
The Advanced tab contains the following options:

4 Viewing Angles. Select from a drop-down menu of viewing angles for three-dimensional
charts. For example, Standard or Group View.

.4 Isometric Projection. Select this option to ignore perspective distortion in a project graph
cube from an isometric view.

4 Proportional Cube. Select this option to define the axis size proportional to the number of
series or groups.

. Automatic shading of walls. Select this option to shade chart walls.

- Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge.

.4 3D Zoom Factor. Enter a value in the text box to set the global scaling factor for
zooming in and out in a 3D chart. Smaller values zoom out and produce a smaller
display of the chart within a frame. Larger values zoom in and produce a larger display
of the chart within a frame.

4 Pan Horizontally. Enter a value in the text box to pan a 3D chart in the horizontal
direction. Smaller values move the frame of the chart to the left. Larger values move the
frame of the chart to the right.

1 Pan Vertically. Enter a value in the text box to pan a 3D chart in the vertical direction.
Smaller values move the frame of the chart upward. Larger values move the frame of
the chart downward.

Use the Background tab to set and customize a border for a chart.
The Background tab contains the following options:
4 Show Border Color. Select this option to show the color of the border.

'd Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border.
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-1 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
frame.

d Transparency. Move the slider to make the background opaque (0%) or transparent
(100%). The default is 0%.

- Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

.4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Radial.

Gradient Style

. Color Pattern. Select the color pattern for the data series. The color pattern option on the
left is an AB wash that uses two colors in the pattern colorl - color2, for example, red-
green. The color pattern option on the right is an ABA wash that uses two colors in the
pattern colorl - color2 - colordl, for example, red-green-red.

. First Color. Click this icon to open the Color dialog box, where you can select a color for the
first color.

.d Second Color. Click this icon to open the Color dialog box, where you can select a color for
the second color.

For instructions on how to open this dialog box, see the procedures in Using Frame and
Background Properties on page 201.

Frame and Background Shortcut Menu
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When you right-click a chart background, a menu of options opens. The options for the
background and frame elements are described in the following table.
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Element Option Description
Background Background Color Enables you to specify the color of the
background, using the Color dialog box. For
instructions, How to Change the Color of
the Background on page 202.
Show legend Controls the display of the legend on the

background. When selected, it displays the
legend. When cleared, it suppresses the
display of the legend.

More Frame and
Background Options

Opens the Frame & Background dialog box.
For more information, see Frame &
Background Dialog Box on page 193.

Frame Frame Color

Enables you to specify the color of the
frame, using the Color dialog box. For more
information, see Using the Color Dialog Box
on page 337.

Show 3D

Controls the depth of the frame. The value
On renders the frame in 3D depth. The
value Off renders the frame in one
dimension.

For instructions, see How to Set 3D Depth
on a Bar Chart on page 214.

More Frame &
Background Options

Opens the Frame & Background dialog box.
For more information, see Frame &
Background Dialog Box on page 193.

Using Frame and Background Properties

The following sections contain procedures for customizing frame and background properties.
The options for the following procedures are found in the Features group of the Format tab.
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Procedure: How to Change the Color of the Frame

Procedure:

202

The default color of the frame in a chart is determined by the Document Theme selected in the
Options dialog box. For more information, see Changing InfoAssist+ User Preferences on page

21.

This procedure describes how to change the color of the frame.

1.
2.

Create a chart.

Access the Frame & Background dialog box in one of the following ways:
.4 Ribbon: On the Format tab, in the Features group, click Frame & Background.

.4 Shortcut Menu: Right-click the chart, and click More Frame & Background Options.
The Frame & Background dialog box opens.
On the Frame tab, in the Fill section, click Solid fill, and then click the Color icon.

The Color dialog box opens. Select a new color for the frame. For more information on the
Color dialog box, see Using the Color Dialog Box on page 337. You can also set the depth
angle and depth radius for the frame, as well as set a shadow for the frame.

Click OK.

The chart displays the new frame color.

How to Change the Color of the Background

The default color of the background of a chart is determined by the Document Theme selected
in the Options dialog box. For more information, see Changing InfoAssist+ User Preferences on

page 21.
1. Create a chart.
2. Open the Frame & Background dialog box in one of the following ways:
.d Ribbon: On the Format tab, in the Features group, click Frame & Background.
. Shortcut Menu: Right-click the background of the chart, and click More Frame &
Background Options.
The Frame & Background dialog box opens.
3. On the Background tab, in the Background Fill section, click the Color icon.
The Color dialog box opens. Select a new color for the background. For more information
on the Color dialog box, see Using the Color Dialog Box on page 337.
4. Click OK.
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The chart displays the new background color.

Formatting a Gauge Chart

A gauge chart is a circular chart that indicates the current position of a single data value within
a given spectrum.

A gauge chart is shown in the following image.

1114332

Stereo Systems

You can change the appearance of a gauge chart by using the gauge chart options found on
the Format Gauge dialog box. To access the Format Gauge dialog box, on the Format tab, in
the Features group, click Gauges.

Format Gauge Dialog Box

Whether you access gauge options from the ribbon, or the shortcut menu, you are presented
with the Format Gauge dialog box of options for formatting a gauge chart. Such options include
setting and styling a title for the gauge chart, setting tick marks, enabling and styling color
bands, as well as setting advanced options, such as the gauge start and stop angle.

The Format Gauge dialog box contains the following tabs:

[J General Options
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-l Axis Scale & Labels
- Tick Marks

- Bands

- Advanced

Use the General Options tab to set general gauge options.

The General Options tab contains the following options:

-l Gauges per row. Enter or select how many gauges appear on each row. The default setting
displays two gauge charts. A maximum of 32 gauge charts can appear on each row.

Note: The number of charts displayed per row can differ, based on the output format
selected. For example, HTML format will display two charts per row, and HTML5 will display
four.

Gauge Title

-1 Show title. (Default) Displays a gauge title appear for each gauge. Clear this option to
suppress the title.

- Position. Select a position for the gauge title. Above is the default value.
- Style. Click this icon to open the Style dialog box, where you can style text.
Gauge value

- Show value. (Default) Clear this option to suppress the gauge value.

- Style. Click this icon to open the Style dialog box, where you can style text.
-1 Format Value. Contains a list of preset formats that can be applied.

- Custom Format. Allows you to use a custom format. This option is activated when Use
Pattern /100 and Use Pattern are selected as the format labels.

Use the Axis Scale & Labels tab to set the axis scale and label properties for the gauge
needle.

The Axis Scale & Labels tab contains the following options:

Scale

- Automatic Minimum. (Default) Sets the engine to automatically supply the minimum value
on the scale. Clear this option to manually set the minimum value by entering a number
into the Value text box.
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- Value. Enter the minimum value in this text box if you have not selected Automatic
Minimum.

. Automatic Maximum. (Default) Sets the engine to automatically supply the maximum value
on the scale. Clear this option to manually set the maximum value by entering a number
into the Value text box.

.4 Value. Enter the maximum value in this text box if you have not selected Automatic
Maximum.

Labels

d Show Labels. (Default) Displays labels next to the axis. Clear this option to suppress
labels.

4 Style Labels. Click this icon to opens the Style dialog box, where you can style text.

4 Format Labels. Select from a drop-down menu of present formats that can be applied to
the labels. When a custom format is selected, the format must be defined using a custom
format pattern. For a list and description of the characters that you can use in a custom
format, see the table in Formatting Data Labels on page 158.

d Custom Format. Text field to enter the custom format that you want to use.
The Tick Marks tab contains options to format tick marks on a gauge chart.
The Tick Marks tab contains the following options for both major and minor ticks:

. Automatic Grid Step. (Default) Automatically calculates the number of major grid steps in a
gauge chart. Clear this option to manually set the value by entering a number in the Value
text box.

4 Value. Enter the value in this text box if you have not selected Automatic Grid Step.

- Tick Color. Click this icon to open the Color dialog box, where you can select a color for the
tick marks.

4 Tick Mark Length. Enter a value for the relative length of major tick marks in a gauge chart.
The valid range is from 0.0 to 0.5. If you set the smallest value, major tick marks do not
appear.

The Bands tab contains options to format the color of the scale background on a gauge chart.
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The Bands tab contains the following options:

-

Band 1. Opens a drop-down menu of available bands.

- Add. Adds the band selected from the drop-down menu of bands to the gauge chart.
You can create up to five bands for a gauge chart.

-1 Remove. Removes the band selected from the drop-down menu of bands to the gauge
chart.

Minimum Value. Enter a minimum value to a quality band in the gauge chart.
Maximum Value. Enter a maximum value to a quality band in the gauge chart.

Border Color. Opens the Color dialog box, where you can edit the color of the gauge band
border.

No fill. Removes fill from the quality band.
Solid fill. (Default) Applies a solid color to the quality band.

Color. Click this option to open the Color dialog box, where you can select the color for the
quality band.

Transparency. Move the slider to make the band opaque (0%) or transparent (100%). The
default is 0%.

The Advanced tab contains options to set additional properties for the gauge needle.

The Advanced tab contains the following options:

-

Descending Axis. Select this option to draw the gauge scale in descending order. When
this option is cleared (default), the gauge scale is drawn in ascending order.

Show Zero Label. Displays the zero label on the axis scale. Clear this option to start the
gauge at another value. This is the default.

Gauge Center by Quality. Select this option to have the center of the gauge needle appear
in the same the color as the band to which it is pointing. This option is available for HTML
charts only.

Gauge Start Angle. Enter a value to rotate the gauge start angle to a specified number of
degrees. Values can range from O to 359 degrees. The default is 220 degrees.
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Gauge Stop Angle. Enter a value to rotate the gauge stop angle to a specified number of
degrees. Values can range from O to 359 degrees. The default is 320 degrees. Setting a
start angle to O, and a stop angle to 180, creates a semi-circle.

Relative Inner Radius. Enter a value to define the inner radius of the gauge bands and
labels relative to the outer background of the gauge. Smaller values, such as 0.0, place the
inner radius closer to the center of the gauge. A maximum value of 1.0, places the inner
radius close to the gauge outline.

Relative Thickness. Enter a value to define the relative thickness of the gauge bands.
Values can range from 0.0 to 1.0.

Same Size Gauges. This option applies to multi-category gauge charts. If you are working
with three or more gauges per row, you can select this option to have the gauges display in
the same size.

Gauge Elements Shortcut Menu

When you right-click a gauge chart, a menu containing the More Gauge Options becomes
available. Select this option to open the Format Gauge dialog box. This is only available when
using the HTML output format.

Using Gauge Properties

Procedure:

The following sections contain procedures for gauge properties. The Gauges option can be
found on the Format tab, in the Features group.

Note: This option is only available when you are working with a gauge chart.

How to Set the Number of Gauges Per Row

If you have multiple gauges on a chart, you might want to specify how many gauges appear on
each row.

1. Create a gauge chart that has multiple values.

2. Open the Format Gauge dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Gauges.
.4 Shortcut Menu: Right-click the gauge chart and select More Gauge Options.

The Format Gauge dialog box opens.

On the General options tab, in the Gauges per row field, enter or select the number of
gauges that you want to appear on one row.
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4. Click OK.
The gauges now appear on one row.

After changing the setting from the default of 2 gauges per row to 3 gauges per row, all
the charts now appear on one row.

Procedure: How to Set the Minimum and Maximum Axis Scale Values

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:
- Ribbon: On the Format tab, in the Features group, click Gauges.
- Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.

The Format Gauge dialog box opens.

3. On the Axis Scale & Labels tab, in the Scale area, either accept the minimum and
maximum values for the scale automatically supplied by the chart engine, or enter your
own in the Value fields.

4. Click Apply.

The gauge scale reflects the selections that you have made.

Procedure: How to Style Axis Labels
1. Create a gauge chart.

2. Open the Style dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In
the Labels area, click the Style Labels icon.

- Shortcut Menu: Right-click an axis label, and click Style.
The Style dialog box opens.

Select your styling options.

Click OK.

The scale labels reflect the style selections that you have made.

Procedure: How to Format Axis Labels

1. Create a gauge chart.
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Procedure:

Procedure:

2.

Access the menu of available format options for axis labels in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In
the Labels area, open the Format Labels drop-down menu.

-1 Shortcut Menu: Right-click an axis label, and point to Format.
The menu of available format options opens.
Select your format option.

Note: If you select a custom format (for example, Use Pattern, or Use Pattern /100), from
the Format Labels menu on the Format Gauge dialog box, the Custom Format menu
becomes available. When you select a custom format, it must be defined using a custom
format pattern. For a list and description of the characters that you can use in a custom
format, see the table in Formatting Data Labels on page 158.

Click OK.

The scale labels reflect the format selection that you have made.

How to Rotate Axis Labels

Create a gauge chart.
Right-click an axis label.

On the shortcut menu, point to Rotate, then select the degree to which you want the labels
rotated.

How to Set Gauge Tick Marks

This procedure describes how to set the grid step, tick color, and tick length for the major and
minor tick marks.

1.
2.

Create a gauge chart.

Open the Format Gauge dialog box in one of the following ways:
4 Ribbon: On the Format tab, in the Features group, click Gauges.
- Shortcut Menu: Right-click the gauge chart and select More Gauge Options.

The Format Gauge dialog box opens.

On the Tick Marks tab, for the Automatic Grid Step, either accept the value automatically
supplied by the chart engine, or enter your own, in the Value fields.

Click the Tick Color icon, to open the Color dialog box, where you can select a color for the
tick mark.
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Procedure:

Procedure:

210

5. For the Tick Mark Length, either accept the value automatically supplied by the chart
engine, or enter your own, in the Value fields.

How to Set Gauge Color Bands
1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Gauges.

d Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.
The Format Gauge dialog box opens.

3. On the Bands tab, set the minimum and maximum value for each band that you want to
appear on the gauge chart.

4. Set the color of the fill and border for each color band.
Note: The gradient fill option is not available for color bands.
5. Click OK to close the Format Gauge dialog box.

The bands are formatted accordingly.

How to Match Needle Center Color to Band Color (Gauge Center by Quality)

This option matches the needle center color to the color of the band that the needle is pointing
to.

1. Create a gauge chart.
2. On the Format tab, in the Features group, click Gauges.
The Format Gauge dialog box opens.

3. On the Bands tab, set the minimum and maximum value for each band that you want to
appear on the gauge chart

4. Set the color of the fill and border for each color band.

Note: The gradient fill and transparency options are not available for gauge needles.
5. On the Advanced tab, select Gauge Center by Quality.

Note: This option displays in HTML, but not in HTML5.
6. Click OK to close the Format Gauge dialog box.

The color of the center of the gauge needle now matches the color of the band.
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Procedure: How to Style a Gauge Needle

This procedure explains how to change the gauge needle from the Normal style to the Pencil
style.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Gauges.

.4 Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.

The Format Gauge dialog box opens.

4. In the General Options tab, in the Gauge Needle section, from the Style drop-down menu,
select Pencil.

5. Click OK.

The gauge needle changes to a pencil.

Procedure: How to Set Gauge Needle Colors in a Multi Series Gauge Chart

You cannot change the fill color and border color of the needles in a multi-series gauge chart
through the General Options tab of the Format Gauge dialog box. You can do so through the
Format Series dialog box. However, you can still use the General Options tab to change the
style of the needle.

1. Create a gauge chart with more than one measure field.

2. On the Series tab, from the Series drop-down menu, select the series that you want to
style.

3. In the Style group, click Style.
The Format Series dialog box opens.

4. On the Fill tab, select the fill and color options for the gauge needle for the selected
series.

5. On the Border tab, select the Show Border Color option, if you want the gauge needle to
have a border. You can select the color for the border, as well.

6. Click Apply.
Repeat steps 2 through 5 for each series gauge needle that you want to style.
8. When you are finished, click OK to close the Format Series dialog box.

The color of the gauge needles and their borders changes accordingly.
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Formatting Page Headings and Page Footings

Procedure:

212

Page headings and page footings supply context and key information about a chart, such as its
purpose, audience, and author. Page headings and page footings also enhance visual appeal.

How to Add a Page Heading and Page Footing to a Chart
The procedure uses sample values, but you can supply values that apply to your own charts.
This feature is available in Query Design view, Live Preview, and Document mode.
1. Create a chart.
2. On the Home tab, in the Report group, click Header & Footer.
The Header & Footer dialog box opens.

Tip: Another way to access the Heading & Footing dialog box is to click the arrow next to
the Header & Footer button. Doing so opens a drop-down menu from which you can select
the heading or footing that you want to work with. After you make your selection, the
Header & Footer dialog box opens, and the heading or footing that you selected is active.

3. Click the tab for the page heading or page footing, depending on which you want to add.

By default, the Page Heading tab is selected. In this procedure, accept the default to add
a page heading first.

4. Click inside the design area of the dialog box, and type the text for the page heading.
For example, the text for a sample page heading might be Customers By Occupation.

5. Using the styling options, apply styling to the page heading text.
For example, 14 pt. bold Helvetica with center alignment.

6. Click Apply to save the changes that you have made, without closing the dialog box.
To add a page footing, click the Page Footer tab.

For this procedure, you are going to add one of the supplied quick text options, followed by
some text of your own.

8. Click the down arrow next to the preformatted text button, and click Created by from the
drop-down list.

9. Complete the text by typing the applicable value within the supplied text, for example,
Sales Manager.

10. Change the styling as you want.

11. Click OK to save the page heading and page footing and close the Header & Footer dialog
box.

The chart contains the page heading and page footing that you added and styled.
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The following image shows a chart with a styled header and footer.
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12. To make changes to either the page heading or page footing, return to Design view. Right-
click the header or footer, and click Edit from the drop-down menu.

Procedure: How to Control the Rendering of a Page Heading and Page Footing

You can control the way in which a page heading and page footing are rendered on a chart at
run time.

1. Create a chart.

2. Open the Header & Footer dialog box, as described in How to Add a Page Heading and
Page Footing to a Chart on page 212.

3. Click the Text options for chart button lm .

A drop-down menu, with two options for rendering the page heading and page footing,
opens.

Tip: Your selection for a page heading also applies to a page footing, and vice versa.

Id Create Header and Footer as text renders the heading and footing as text elements
that are separate from the chart image.

Id Embed Header and Footer in the chart renders the heading and footing text as part of
the chart image. This is the default value.
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4. Click OK to save your selection and close the Heading & Footing dialog box.

Using Additional Formatting Features

Procedure:

214

This section describes additional formatting features that are available for charts.

How to Set 3D Depth on a Bar Chart
You can apply a 3D-effect to a 2D-chart.

Note: If you find that the depth of the 3D effect makes it difficult to distinguish the values on
the Y-axis scale, then you can turn this option off. This procedure explains how to set the 3D

effect for a default vertical bar chart.

The following image shows a bar chart before the 3D effect is applied.
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1. Create a 2D chart.

2. In Live Preview, apply the 3D effect in one of the following ways:

Id Ribbon: On the Format tab, in the Features group, click 3D Effect.

Id Shortcut Menu: Right-click the frame of the chart, point to Show 3D, and click On.
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The 3D effect is applied to the chart, as shown in the following image.
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Procedure: How to Rotate a Chart
You can rotate bar, line, and area charts to change the orientation of the data.
1. Create a chart.
2. On the Format tab, in the Features group, click Rotate.

The chart is rotated 90 degrees clockwise.

Procedure: How to Sort a Chart by Total Value

Once you create a bar, line, or area chart, you can sort the results in ascending or descending
order. While this feature was implemented specifically for Stacked Bar charts, it also applies to
other chart types, as previously mentioned. This feature enables you to view your data in
numerical order, allowing you to identify trends and determine what data points are priorities.

Note: This feature is available in Chart and Visualization mode.

1. Create a bar, line, or area chart with at least one measure and one dimension.

2. In the Query pane, right-click on the Horizontal Axis and select Sort by Total Value.
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3. From the cascading menu, select Ascending to sort the chart from the lowest value to the
highest value, as shown in the following image.
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4. Select Descending to sort the chart from the largest value to the lowest value.

Procedure: How to Display a Static Reference Line

Reference lines draw attention to specific data locations on a chart. You can add up to three
horizontal (X axis) and three vertical (Y axis) reference lines to a chart.

Reference lines can be created using either a constant or a computed field.

Field values allow a property to be dynamic, so that the reference line can change position
dynamically on the chart depending on the value of the field that is assigned to it.

Note: A reference line value should be a single value, such as 10K, for example. In the
Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for
example), then InfoAssist+ plots the last value on the chart.

1. Create a chart.
2. On the Format tab, in the Features group, click Reference.

3. In the drop-down menu that opens, select one of the following:

4 Add Reference Line to Y-Axis
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[ Add Reference Line to X-Axis

The Reference Line dialog box opens, as shown in the following image.

4. Create the reference line with a static value that you set.
a. Select the Value option.

b. In the Value text field, type the value that you want to distinguish with the reference
line.

In the Text field, type the text for the reference line.

In the Position drop-down menu, select the position for the reference line on the chart. For
example, Above Center.

Click the Style button to set the style for the reference line. For example, Solid.

8. Click the Color button to open the Color dialog box, where you can select a color for the
reference line and the text.

9. Click the Weight button to select the weight of the reference line. For example, 1px - Light.

10. Click OK to save the options that you have selected, and close the Reference Line dialog
box.

The reference line is added to the chart.

The following image shows a bar chart for accessories and camcorders, revenue for which
exceeds 15 million dollars.
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Procedure: How to Display a Dynamic Reference Line
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Reference lines can be created using either a constant or a computed field.

Field values allows a property to be dynamic, so that the reference line can change position
dynamically on the chart depending on the value of the field that is assigned to it.

Note: A reference line value should be a single value, such as 10K, for example. In the
Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for
example), then InfoAssist+ plots the last value on the chart.

The following procedure provides an example of how to create a dynamic reference line, where
the value changes based on the date. In this example, you can track the number of estimated
delivery days per shipping company, where the number of days estimated for delivery are
based on whether or not the sale date is a holiday.

1. Create a COMPUTE field to calculate the Reference Line.

a.

e.

On the Data tab, in the Calculation group, click Summary (Compute).
The Summary Field (COMPUTE) dialog box opens.

In the Field text box, enter Reference.

Set the format to D12.2.

Enter IF WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_HOL EQ 'Y' THEN 5 ELSE 2
into the expression.

Click OK to close the dialog box.

Hide the Reference field from the chart.

3. Add a dynamic reference line.

a.

-~ o a o

5>

On the Format tab, in the Features group, click Reference.

From the drop-down menu, select Add Reference Line to Y-Axis.

The Reference Line dialog box opens.

Select the Field option.

From the Field drop-down menu, select Reference.

In the Text field, enter Acceptable.

From the Weight drop-down menu, select 2px - Medium.

From the Position drop-down menu, select Above Left.

Optionally, you can change the color and style of the Reference line.

Click OK to close the Reference Line dialog box.
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4. Run the chart.

The reference line displays.

Procedure: How to Display Annotations

Annotations are explanatory notes or comments. You can add up to eight annotations on a
chart.

1. Create a chart.

2. Onthe Format tab, in the Features group, click Annotate.

3. In the drop-down menu that opens, click Add an annotation.
The Annotation dialog box opens.

4. In the text input field, type the text for the annotation.

In the Position drop-down menu, select the position for the annotation on the chart. For
example, Top Left.

6. Click OK to save the options that you selected, and close the Annotation dialog box.
The annotation is added to the chart.
7. Click Run to generate the report.

The following image shows a chart with an annotation in the middle right position.
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Chapter

Creating and Customizing Documents

Designing documents in Document mode allows you to add text, images, active form
controls, reports, and charts to create documents that can be used to generate
presentation-ready reports based on your data.

Document mode combines the features of report building with the ability to style and
present customized documents.

In this chapter:
.d  Accessing Document Mode

4 Building a Document

Accessing Document Mode

In Document mode, you can:
. Build a new document.
.4 Open an existing document.

-1 Generate a new document from an existing single report.
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A blank InfoAssist+ canvas in Document mode is shown in the following image.
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How to Access Document Mode to Build a New Document

You can build new documents by accessing Document mode from the InfoAssist+ splash

screen.
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1. Click Build a Document.

The Open dialog box opens.

2. Select a data source to begin building your document.

Note: Documents can be built using more than one data source. The source you select
here is the one you will begin with, but you can add more at any time. For more
information on adding additional data sources, see Data Tab on page 31.

3. Click Open.

InfoAssist+ opens a new canvas in Document mode.
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Procedure: How to Access Document Mode by Opening an Iltem From the Splash Screen

You can access existing documents in Document mode from the InfoAssist+ splash screen.

1. Click Build a Document.
The Open dialog box opens.

2. On the Quick Access toolbar, click Create new report, chart, document or visualization.
The splash screen displays.

3. Click Open Existing Item.

The Open dialog box opens.

4. Select one of the documents. Documents are represented by the Document 2 icon.
Click Open.

InfoAssist+ opens the document in Document mode.

Note: If you select a single report in step 3, InfoAssist+ opens the report in either Query
Design view or Live Preview. To view a copy of the report in Document mode, see How to
Access Document Mode From the Document Button on the Home and View Tabs on page
224,

Procedure: How to Access Document Mode by Opening a Report From the Quick Access Toolbar

You can access documents in Document mode from the InfoAssist+ Quick Access Toolbar.

1. With InfoAssist+ open, click Open existing item & from the Quick Access Toolbar.

An Open dialog box appears.

Select one of the documents, which are represented by the Document 2 icon.
3. Click Open.

InfoAssist+ opens the document in Document mode.

Note: If you select a single report in step 2, InfoAssist+ opens the report, in either Query
Design view, or Live Preview. To view a copy of the report in Document mode, see How to
Access Document Mode From the Document Button on the Home and View Tabs on page
224.
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Procedure: How to Access Document Mode From the Document Button on the Home and View

Tabs

With InfoAssist+ open in Live Preview or Query Design view, you can access Document mode
by clicking the Document button in the Design group. The Design group appears on both the
Home and View tabs.

Accessing Document mode by clicking the Document button creates a copy of the current
single report as a document. You can use this method to promote the content of a report to a
document.

You can also access Document mode in Reporting Objects by following this procedure.

Note: When a Reporting Object is promoted to Document mode, any reports and charts that
the Reporting Object has are added to the canvas.

1. With an InfoAssist+ report open, click either the Home tab, or the View tab.
2. Inthe Design group, click Document.
InfoAssist+ enters Document mode.

Note: The single report you started with still exists in the original mode. Selecting
Document mode while a single report is open does not convert the report to a document.
It makes a copy of the report, with the copy becoming a document and the original
remaining unchanged.

You can switch between the new document and the original report using the Switch Report
button. The Switch button is found on the View tab, in the Report group. You can also
switch between the document and the report using the Reports button on the status bar.
For more information on switching between reports, see View Tab on page 34.

Building a Document

224

Document mode allows you to build multiple reports and charts on the same canvas. The
styling, design, and report building functionality of Live Preview and Query Design view is
available in Document mode.

In addition, there are many other features that simplify building documents. You can build and
insert multiple reports in the form of reports and charts into documents. You can also insert
images and text for presentation and organizational purposes.

IBM



5. Creating and Customizing Documents I

Inserting Reports From Multiple Data Sources

With InfoAssist+ opened in Document mode, you can insert multiple charts and reports onto
the canvas. These reports can be from different data sources. With documents, you have the
option to add additional data sources to the document.

In order to insert reports from different data sources, the document must have multiple data
sources loaded. For more information on adding and switching between data sources, see
Data Tab on page 31.

Note: You cannot use multiple data sources when working with a Reporting Object.

Procedure: How to Insert Two Reports From Two Different Data Sources
A document can display multiple reports from multiple data sources in the same document.

1. With InfoAssist+ open in Document mode, click the Insert tab and select Chart or Report.

2. If your document has only one data source, insert additional data sources.

For more detailed instructions on inserting multiple data sources, see Data Tab on page
31.

3. Switch to a data source different than the one used in step 1.

For more detailed instructions on switching to a different data source, see Data Tab on
page 31.

4. Insert a chart or report using this new data source, following the instructions given in
Inserting a New Report on page 225.

Your document is now populated with reports that have data from different data sources.
You can add as many data sources as you need.

Inserting a New Report

With InfoAssist+ opened in Document mode, you can insert multiple charts and reports onto
the canvas. The procedures in the following sections detail how to insert reports into
documents.

In Document mode, you can insert a report in the following ways.
. Use the Insert tab.

.4 Double-click a data source field.

4 Drag a data source field onto the canvas.

Note: When you use the Insert tab or double-click a data source field, a report placeholder is
added to the canvas.
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Dragging a data source field onto the canvas inserts the place holder at the location you
dropped it.

The following procedures describe how to insert new reports. For more information on how to
edit existing reports, see How to Style and Customize a Report on page 233.

Procedure: How to Insert a Report

Do one of the following, while in Document mode:

. On the Insert tab, in the Reports group, click Report. Add fields to the placeholder
report.

.4 On the Home tab, in the Format group, click Report. Double-click a data source to
automatically create a report with that data.

. On the Home tab, in the Format group, click Report. Drag a field to the canvas to create
a report.

Inserting a New Chart

With InfoAssist+ opened in Document mode, you can bring multiple charts and reports onto
the canvas. The procedures in the following sections describe how to insert charts into
documents.

In Document mode, you can insert a chart in the following ways:
d Use the Insert tab.

-l Double-click a data source field.

.d Drag a data source field onto the canvas.

Note: When you use the Insert tab or double-click a data source field, a chart placeholder is
added to the canvas.

Dragging a data source field onto the canvas inserts the place holder at the location you
dropped it.

The following procedures describe how to insert new charts. For more information on how to
edit existing charts, see How to Style and Customize a Chart on page 234.

Procedure: How to Insert a Chart
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1. Do one of the following, while in Document mode:

.4 On the Insert tab, in the Reports group, click Chart. Add fields to the placeholder chart.
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-1 On the Home tab, in the Format group, click Chart. Double-click a data source to
automatically create a chart with that data.

4 On the Home tab, in the Format group, click Chart. Drag a field to the canvas to create
a chart.

2. Optionally, change the chart format using the options on the Format tab, in the Chart Types
group.

Inserting an Existing Report

With InfoAssist+ opened in Document mode, you can insert existing charts and reports onto
the canvas from the Insert tab. When inserted, these components are referenced but remain
independent, supporting modular development with reusable content. Modifications must be
made in the individual components separately. These updates will then be reflected in the
document during generation.

Note:
.4 When working in Document mode, you cannot insert an existing report that has a HOLD.

4 When you insert an existing report, which has already been created and is referenced via-
INCLUDE syntax, and then select it on the Document canvas, the data fields do not display
in the Query pane.

.d When you insert an existing report that contains a field specified for multi-graph, the field
will be placed in the Coordinated field container, by default. If you override this field with
another and save the document, this change is not written back to the existing included
report. The settings in the original report will be restored when the document is restored.

The following procedure describes how you can insert reports into new documents and
documents that are already populated with reports, text, and images.
Procedure: How to Insert an Existing Report With the Insert Tab

You can create a document in the Custom Reports section of the domain and use Standard
Reports items as Existing Report components. You cannot use other Custom Report items as
components.

1. With InfoAssist+ open in Document mode, click the Insert tab.

2. Inthe Reports group, click Existing Report.
An Open dialog box appears.
3. Browse to the report that you want to insert and click Open.

The report placeholder is added to the canvas.
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Note: You cannot edit an existing report that is inserted into a document.

Creating a Document From a Single Report

You can take a single report created in Live Preview or Query Design view and convert it into a
document, displaying it in Document mode.

When you convert a single report into a document, the original report is preserved and a copy
of that report is opened as a document in Document mode. You can then add additional
reports, charts, images, and text.

Inserting Text and Images

With InfoAssist+ opened in Document mode, you can bring text and images onto the canvas.
The following procedures describe how you can insert text and images into new documents
and documents that are already populated with reports, text, and images.

Note: You can only do this in Document mode.

The following procedures detail how to insert text and images. For more information on how to
edit existing text and images, see Editing Components in a Document on page 229.

Procedure: How to Insert Text

1. With InfoAssist+ open in Document mode, click the Insert tab.
2. In the Objects group, click Text Box.

A text component is added to the canvas, containing default text.
3. Double-click, or right-click, the text component to edit the text.

For more information on editing and styling the text, see How to Edit Text on page 234.

Procedure: How to Insert an Image
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1. With InfoAssist+ open in Document mode, click the Insert tab.
2. In the Objects group, click Image.

An Open dialog box appears.

Note: By default, the Open dialog box displays image files in the current Db2 Web Query
Content folder.

3. Browse to the desired image and click Open.

The selected image is added to the canvas.
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Editing Components in a Document

The reports, controls, and text in a document can be edited, moved, resized, and deleted.
Each of these components has a context menu which can be accessed by right-clicking the
component.

Images can be moved, resized, and deleted, but they have no context menu and cannot be
edited. Right-clicking an image brings up the option to delete it.

Procedure: How to Resize a Component
You can resize a component in the following ways:
. Using the component sizing handles.
.4 Changing the height and width on the Layout tab, in the Size & Arrange group.
4 Accessing the options on the Size tab in the Size and Position dialog box.

The resize feature is available for all components that can be added to a document.

1. Open or create a document with at least one report, text component, control, or image.

2. Resize the component in one of the following ways:

4 Sizing Handles: Select the component and drag the sizing handles that appear around
it. As you manually increase the height and width of the component, the new values
appear in the corresponding text boxes in the Size & Arrange group of the Layout tab.

.4 Ribbon: You can use the ribbon in one of the following ways:

. Select the component in the document. On the Layout tab, in the Size & Arrange
group, enter values in the Height and Width fields.

. On the Layout tab, in the Size & Arrange group, click the dialog box launcher to
open the Size and Position dialog box, as shown in the following image.

Height Q)" Aspact Ratio %g] Relative Position
Width
[2, Align -
Size & Arrange (P %

.4 Shortcut Menu: Right-click the component and select Size and Position. The Size and
Position dialog box opens.

Note: You must right-click the corner of the component. For charts, if you click on any
other point in the chart, the Size and Position option will not display.
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From the Size and Position dialog box, open the Size tab, as shown in the following

image.
5;': Size and Position -
e Size
Position Size
Height |2.25 Width |3.32
Scale
Height 003 % Width 100 12 5

#| Auto Overflow

Lock Aspect Ratio

o || @l | | 2 moot |
Use the Height and Width options to change the position of the selected component.
You can adjust the pixel size of the object with the Size options or the scale
percentage of the object with the Scale options.

You can lock the aspect ratio using the Aspect Ratio button, which is available when
working with charts, images, and text boxes while working in Document mode. With the
aspect ratio locked, changing the width automatically changes the height to keep the
component to scale, and changing the height automatically changes the width.

Note: The Auto Overflow option is only available while working with reports in Document
mode through the Size & Arrange group. With Auto Overflow set, you cannot manually set
the height and width of a report. The area of the report expands automatically to show all
data.

When two objects are selected, the Relative Position button sets the bottom-left corner of
the component that is higher on the page to the upper-left corner of the one that is lower.
Once a relationship is created, arrows appear to show that relationship while both items
are still selected.
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Procedure: How to Move a Component

You can move a component by clicking it, or by accessing the Position section of the Size and
Position dialog box. This feature is available for all components that can be added to a
document.

You can also align components with each other so that their horizontal or vertical position
matches. For more information, see How to Align Components on page 231.

1. Open or create a document with at least one report, text component, control, or image.
2. Select the component and move it by using one of the following methods:
4 Drag the component anywhere on the canvas.

or
. Right-click the component and click Size and Position.
.4 On the Size and Position dialog box, click the Position tab.

.4 Use the Horizontal and Vertical options to change the position of the selected
component.

Procedure: How to Align Components

You can alignh components with each other so that their horizontal or vertical positions match.
You must have multiple components selected to use the align options.

The alignment is anchored by the component that is in the farthest position of the selected
alignment. For example, if you select two components and click Align Left, the components
align horizontally with the component farthest to the left.

1. Open or create a document with at least two components.
2. Select a component.
3. Select a second component by holding the Ctrl key and clicking a component.

Note: You can select multiple components simultaneously by holding the Ctrl key and with
the left mouse dragging a selection box around the components. When you release the
mouse, sizing handles appear around each component that you selected. If the
components display with light-grey coloring, this indicates that the components are
selected.
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Sizing handles appear around the components, as shown in the following image.
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4. Align the components using one of the following methods:

.4 Right-click one of the selected components and select an alignment option from the
Align drop-down menu, as shown in the following image.

[ Rename I "
Grt ... Goods for Produc

a3+ Size and Position...

<. Align % ¥ |2, Align Left
A Delete S| Align Right
T 19  Align Top
600K o Align Bottom

or

- Access the alignment options from the Align drop-down menu. The menu is available on
the Layout tab, in the Size & Arrange group.
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The selected components align, as shown in the following image.
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5. Click anywhere in the canvas to deselect the components.

Procedure: How to Style and Customize a Report

When you select a component, you can perform various functions on the component, such as
moving and resizing it, as explained in How to Move a Component on page 231. After clicking a
component, you can use the ribbon to affect all settings of the selected component, except for
fields. You can right-click a component to select individual fields to edit through the context
menu.

In addition to reports, you can style and customize charts and text. For more information on
charts, see How to Style and Customize a Chart on page 234. For more information on text,
see How to Edit Text on page 234.

Note: Images cannot be edited.
1. Open or create a document with at least one report.
2. Click the report.

The Query pane becomes active and you can now select fields within the report. Select a
field by clicking it in the canvas or in the Query pane.

For more information on styling and customizing reports, see Creating and Customizing
Reports on page 73.
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Procedure:

Procedure:
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How to Style and Customize a Chart

When you select a component, you can perform various functions on the component, such as
moving and resizing it, as explained in How to Move a Component on page 231. After clicking a
component, you can use the ribbon to affect all settings of the selected component, except for
fields. You can double-click or right-click a component to select individual fields to edit through
the context menu or Field tab.

In addition to charts, you can style and customize reports and text. For more information on
reports, see How to Style and Customize a Report on page 233. For more information on text,
see How to Edit Text on page 234.

Note: Images cannot be edited.
1. Open or create a document with at least one chart.
2. Click the chart.

The Query pane becomes active and you can now select fields within the chart. Select a
field by clicking it in the canvas or in the Query pane.

You can now edit the selected chart using commands available through the context menu
or the ribbon.

For more information on styling and customizing charts, see Creating and Customizing
Charts on page 109.

How to Edit Text

When you select a component, you can perform various functions on the component, such as
moving and resizing it, as explained in How to Move a Component on page 231. After clicking a
component, you can use the ribbon to affect all settings of the selected component, except for
fields. You can right-click a component to select individual fields to edit through the context
menu.

In addition to editing text, you can style and customize reports and charts. For more
information on reports, see How to Style and Customize a Report on page 233. For more
information on charts, see How to Style and Customize a Chart on page 234.

Note: Images cannot be edited.
1. Open or create a document with at least one text component.
2. Click the text box.
Sizing handles appear around the border and the text box toolbar becomes active.

3. Click anywhere in the text box and begin entering text.
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4. Highlight the text you would like to edit, and right-click it. A menu of options appears, as
shown in the following image.

[ | |
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5. Using the menu options, you can style the text and insert quick text.

The text component menu options are as follows:

Font. Opens a list of available fonts for the selected text.
Size. Opens a list of available text sizes for the selected text.
Bold. Formats the selected text in bold.

Italic. Formats the selected text in italics.

Underline. Underlines the selected text.

L U U o o U

Text color. Opens the Color dialog box where you can select a color for the selected
text.

Cut. Cuts the selected text.
Copy. Copies the selected text to the clipboard.

Paste. Pastes the selected text from the clipboard.

L U U U

Date. Opens a list of date quick text in various formats.
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-1 Time. Opens a list of time quick text in various formats.

. page #. Opens a list of page number quick text in various formats.

Procedure: How to Delete a Component
The following procedure applies to all components in Document mode.
1. Open or create a document with at least one component.
2. Right-click the component and click Delete.
The component is deleted from the canvas.

Note: You can also delete a component by clicking it and pressing the Delete key.
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Chapter

Creating and Customizing Visualizations

Visualizations centralize information by providing different views of data that are pertinent
to a particular objective. For example, reviewing trends or fluctuations in data over a
period of time or within a region. A visualization provides you with a quick glance of
information on a single screen.

Visualizations support the use of different types of charts, maps, and grids. For example,
you may want to use a bar, pie, and line chart to show different views of the same data.
Alternatively, you may want to offset a particular visual by showing other types of related
data that employ a different type of visual. You can also add a text cell to your
visualization to provide explanatory text or information that other users can reference.

Visualizations allow you to monitor changes in data. They also serve to provide
information in realtime, based on changes in underlying data or other components. A
visualization can be updated, changed, or revised at any time to account for shifts in
data needs.

In this chapter:

.4 Creating a Visual

Selecting a Visual

Interacting With Visualizations
Customizing Visualizations
Using Storyboards

Animating Visualizations

L U U o o U

Using Visualizations at Run-Time

Creating a Visual

You can create charts, maps, and grids to visually represent your data. You can add multiple
visuals to the canvas to create a complete visualization.

The default visual is a bar stacked chart. You can use the Change option in the Visual group
on the Home tab to change the visual type.
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Procedure:

Procedure:
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The following visual is a matrix marker chart that shows sales data for a range of electronic
products.

Preduct Category

Sale Year Accessaries Camcorder Computers Media Player Stereo Systems Televisions Video Production

IHSE‘.’
- @ @ e o o

63M

e . .
365.1M

Note: Visualization takes advantage of the Active Cache feature to provide the best user
experience. To display date values within the visualization, use the legacy DATE formats which
are supported with Active Cache rather than DATE-TIME formats.

How to Create a Visualization from Within Db2 Web Query

You use this procedure to create a visualization within Db2 Web Query.

1. Open InfoAssist+ in Visualization mode.

2. Inthe Open dialog box, select a data source and click Open.

3. Select fields for your visualization.

How to Create a Visualization From InfoAssist+
You can have multiple file types opened at once. To create a visualization:
1. On the Quick Access toolbar, click New.

or

Click the Application Main Menu button, and click New.
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The InfoAssist+ splash screen displays.
Click Build a Visualization.
In the Open dialog box, select a data source and click Open.

InfoAssist+ switches to Visualization mode.

Changing the Visual Type

You can create a visual using the default chart type, which is a stacked bar chart. You can add
your data to this chart and then change the chart type, or you can change the chart type prior
to making your data selections.

Once you have started exploring your data, you can switch between the different types to
obtain the graphical image that you wish to display.

You change the visual type from the Home tab.

Procedure: How to Change the Visual Type

1.

On the Home tab, in the Visual group, click Change, as shown in the following image.

ap |EEH ald

- -

Insert Change Swan Clear

2 el 5 2

Visual
Note: The Change icon updates depending on the chart, map, or grid that you select from
the Select a Visual menu. By default, the Change icon displays a stacked bar chart.
The Select a Visual menu displays.
On the Select a Visual menu, click the type of visual that you want to use.
Your canvas refreshes and displays the visual that you selected.

Note: Depending on the type of visual that you select, you may need to select additional or
different data fields.

Selecting a Visual

It is important that you select a chart, grid, or map that appropriately displays a meaningful
view of your data. InfoAssist+ provides a library of visuals.

You can select a visual type from the Select a Visual menu, on the Home tab, in the Visual
group. The following table describes the types of charts available.
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Icon Visual Type Description
Grid Grids provide a tabular view of data. They allow
you to review data in a row and column format,
similar to a printed report.
= Bar chart Bar charts plot numerical data by displaying
ads rectangular blocks against a scale (numbers or

variable measure fields that appear along the
axis).

Stacked bar chart

A stacked bar chart is the default visual.

Histogram

Histograms graphically represent the
distribution of numeric data. They facilitate the
identification and discovery of the underlying
frequency distribution within a set of
continuous data. You can use histograms to
identify trends and illustrate categorizations, or
groupings, also known as bins. For more
information, see Binning on page 130.

Absolute line chart

Line charts allow you to trace the evolution of a
data point by working backwards or
interpolating. Highs and lows, rapid or slow
movement, or a tendency towards stability are
all types of trends well suited for a line chart.

Area chart

Area charts analyze trends over time and look
for differences in values.

Stacked area chart

Stacked area charts allow you to stack data on
top of each other.

Pie chart

Pie charts are circular charts that represent
parts of a whole. A pie chart emphasizes where
your data fits, in relation to the other
components in the pie.
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Icon

Visual Type

Description

Ring pie chart

Ring pie charts are useful when you want to
review the value of each segment, which
represents the measure value for the selected
dimension, as it relates to the total for the
selected measure.

¥
.}
i

Scatter Plot

Scatter charts enable you to plot data using
variable scales on both axes. When you use a
scatter chart, the data is plotted with a hollow
marker, so that you can visualize the density of
individual data values around particular points,
or discern patterns in the data.

Bubble chart

Bubble charts can have two column fields
representing X and Y data values, or have
three column fields representing X, Y, and Z
data values. The third variable (Z) represents
size. The size of each bubble is used to show
the relative importance of the data.

Matrix Marker chart

Matrix marker charts are useful for analyzing
one or two measures against a crosstab of two
categorical dimensions. The result is a color-
scaled matrix chart that shows categorized
trends.

Treemap

Treemaps are used to display large amounts of
hierarchically structured data. Using a set of
nested rectangles to illustrate data
relationships, sections of a treemap represent
branches of a tree.
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Icon Visual Type Description

Gauge Gauges are used to display the value of a
measure. In particular, circular gauges are
used to represent a single data value within a
given spectrum. You can create a single
circular gauge for a measure or a matrix
circular gauge, which shows the value of the
selected measure across different dimensions,
such as product category or yearly sales.

£ Choropleth map A geographically-based heat map. It is useful
for visualizing location-based data, trends, and
distributions across a geographic area.
= Proportional symbol A technique that uses symbols of different
map sizes to represent data associated with

different areas or locations within the map.

data where the individual values that comprise
a matrix are represented as colors. Using
radiant hues, you can track the intensity of a
data relationship using the colors defined in
the legend.

m Heatmap A heatmap is a graphical representation of

¥ Leaflet map Part of the Lightweight Mapping functionality,
& Leaflet maps enable you to visualize trends in
your data. Choropleth and Proportional symbol
maps are available.

Note: Esri functionality is not integrated into
Leaflet maps.

Note:

4 When new data is added to a bar, line, area, pie, scatter, bubble, gauge, or treemap chart,
the chart will morph and rebuild, revealing the new values in a smooth transition.

. In addition to the standard visual types, your administrator can enable any number of chart
extensions for you. These are downloaded and installed into your Db2 Web Query
installation. For more information, contact your administrator.
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Grids

-1 Microsoft Analysis Services are supported. However, in Visualization mode, parent-child

hierarchies do not display in the Data pane.

Use the topics in this section to select and create your visuals.

Grids provide a tabular view of data. They allow you to review data in a row and column format,

similar to a printed report.

In the following example, we review the product category and subcategory data for the following

measure fields:

-4 Revenue

- Gross Profit

Sale Year Product Category

2014

2015

2016

Accessories
Computers
Media Player
Televisions
Wideo Production
Accessories
Computers
Media Player
Televisions
Wideo Production
Accessories
Computers
Media Player
Televisions

Video Production

Revenue
$16,060,415.69
$7,857,928 55
$30,105,200.05
$9,295,726.31
$7,313,170.38
$35,619,872.81
524 176 475 33
$65,002 426 97
$20,042, 85567
$15,959,696.26
$53,208,007.57
$63,190,001.88
$99,448,235 40
$30,964,700.29
$23,810,094 17

Gross Profit
$4,945 779.69
$3,376,380.55
$6,730,870.05
$1,964 927 31
$2,286,521.38

$10,953,840.81
$8,277 897 33
$14 480,370 97
$4,262 15567
$4,938,902 26
$16,362,313.57
$18,677,664.88
$22 237 62540
$6,560,087 29
$7.330,486 17

When working with grids, you can lasso or select a range of values at one time, enabling you to
filter the grid or exclude values from it.

Db2 Web Query InfoAssist+ Part 1

243



Selecting a Visual

Procedure:

Bar Charts
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Note: If you have a large number of fields specified in a grid in Visualization mode, the server
may be slow to respond.

How to Create a Grid
1. Change the visual to a grid, or insert a new grid.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

- Rows or Columns - one or more data fields

.d Measure - one or more data fields

As you add, edit, or rearrange the fields in your Query field containers, your canvas
refreshes.

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or
variable measure fields that appear along the axis). The length of a bar corresponds to a value
or amount. You can clearly compare data series (fields) by the relative heights of the bars. Use
a bar chart to display the distribution of numerical data. You can create horizontal and vertical
bar charts.

Note: If you are working with a large dataset, a scroll bar displays under your chart, enabling
you to easily scroll through your data from left to right. In Visualization mode, scroll bars are
automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab
and then click Interactive Options. In the Interactive Options dialog box, select the Auto Enable
X-Axis Scrolling check box. If you are working in any other mode, you must enable this
functionality.
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Use a bar chart when individual values are important. For example, the following image is a
basic vertical bar chart that compares the individual products sold to the total amount in sales
for each product. A retailer would find it important to know which pieces of inventory are selling
and how much revenue each item is generating for the company.
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A horizontal bar chart becomes useful when you want to emphasize a ranking relationship in
descending order, or the X-axis labels are too long to fit legibly side-by-side. For example, the
following image is a basic horizontal bar chart that ranks which products are generating the
most revenue for the retailer.
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Note: You can swap the orientation of your data in a bar chart. To do so, on the Home tab, in
the Visual group, click Swap.

Procedure: How to Insert a New Bar Chart
1. Change the visual to a bar chart or insert a new bar chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

I Vertical Axis - one or more data fields
Id Horizontal Axis - one data field
Note: You can also double-click a data field to add it to your Query field containers.

The bar chart displays on the canvas. You can add additional data fields for comparative
purposes. You can also view underlying data by hovering over any particular point on the
bar chart.
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Procedure: How to Create a Stacked Bar Chart

The bar stacked visual is the default visual.

1.
2.

Change the visual to a stacked bar chart or insert a new stacked bar chart.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

.d Vertical Axis - one or more data fields

.d Horizontal Axis - one or more data fields

.4 Color - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The stacked bar chart displays on the canvas. You can add additional data fields for
comparative purposes. You can also view underlying data by hovering over any particular
point on the stacked bar chart.

Procedure: How to Create a Matrix Bar Chart

Line Charts

1. Change the visual to a bar chart or insert a new bar chart.

2.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

. Vertical Axis - one or more data fields

.4 Horizontal Axis - one data field

.4 Matrix Rows - one data field

.4 Matrix Columns - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The matrix bar chart displays on the canvas. You can add additional fields for comparative
purposes. You can also view underlying data by hovering over any particular point on the
matrix bar chart.

Line charts allow you to trace the evolution of a data point by working backwards or
interpolating. Highs and lows, rapid or slow movement, or a tendency towards stability are all
types of trends well suited for a line chart.

You can also plot line charts with two or more scales to present a comparison of the same
value, or set of values, in different time periods.
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Note: If you are working with a large dataset, a scroll bar displays under your chart, enabling
you to easily scroll through your data from left to right. In Visualization mode, scroll bars are
automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab
and then click Interactive Options. In the Interactive Options dialog box, select the Auto Enable
X-Axis Scrolling check box. If you are working in any other mode, you must enable this
functionality.

Use a line chart when you want to trend data over time, for example, monthly changes in
employment figures, or yearly sales of an item in your inventory. The following image is a line

visual that shows the gross profit in monthly sales for products.
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Procedure: How to Create a Line Chart
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1. Change the visual type to a line chart or insert a new line chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

.4 Vertical Axis - one or more data fields

.4 Horizontal Axis - one data field

4 Color - one data field (optional)

Note: You can also double-click a data field to add it to your Query field containers.
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To add insight, you can drag a data field to the color Query field container. This displays
the values for this field using color.

The line chart displays on the canvas. You can add additional data fields for comparative
purposes. You can also view underlying data by hovering over any particular point on the
line chart.

Procedure: How to Create a Matrix Line Chart

Area Charts

Change the visual type to a line chart or insert a new line chart.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

. Vertical Axis - one or more data fields

.d Horizontal Axis - one data field

- Matrix Rows - one data field

.4 Matrix Columns - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The matrix line chart displays on the canvas. You can add additional fields for comparative
purposes. You can also view underlying data by hovering over any particular point on the
matrix line chart.

Area charts analyze trends over time and look for differences in values by using the see-thru
nature of the area fills. Stacked area charts allow you to stack data on top of each other.
Stacking allows you to highlight the relationship between data series, showing how some data
series approach a second series.

Note: If you are working with a large dataset, a scroll bar displays under your chart, enabling
you to easily scroll through your data from left to right. In Visualization mode, scroll bars are
automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab
and then click Interactive Options. In the Interactive Options dialog box, select the Auto Enable
X-Axis Scrolling check box. If you are working in any other mode, you must enable this
functionality.
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Use an area chart when you want to distinguish the data more dramatically by highlighting

volume with color. For example, the following image is a basic area chart that depicts the
yearly gross profit for various electronic products.
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Procedure: How to Create an Area Chart
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1. Change the visual type to an area chart or insert a new area chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

Id Vertical Axis - one or more data fields

I1 Horizontal Axis - one data field

Id Color - one data field (optional)

Note: You can also double-click a data field to add it to your Query field containers.

The area chart displays on the canvas. You can add additional data fields for comparative

purposes. You can also view underlying data by hovering over any particular point on the
area chart.
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Procedure: How to Create a Stacked Area Chart

1.
2.

Change the visual type to a stacked area chart or insert a new stacked area chart.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

. Vertical Axis - one or more data fields

.4 Horizontal Axis - one data field

.4 Color - one data field (optional)

Note: You can also double-click a data field to add it to your Query field containers.

The stacked area chart displays on the canvas. You can add additional data fields for
comparative purposes. You can also view underlying data by hovering over any particular
point on the stacked area chart.

Procedure: How to Create a Matrix Area Chart

Pie Charts

1.
2.

Change the visual type to an area chart or insert a new area chart.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

. Vertical Axis - one or more data fields

.4 Horizontal Axis - one data field

.4 Matrix Rows - one data field

.4 Matrix Columns - one data field

Note: You can also double-click a data field to add it to your Query field containers.

A matrix area chart displays on the canvas. You can add additional data fields for
comparative purposes. You can also view underlying data by hovering over any particular
point on the matrix area chart.

Pie charts are circular charts that represent parts of a whole. A pie chart emphasizes where
your data fits, in relation to the other components in the pie. Pie charts work best when there
are a limited number of slices (for example, less than 10) and the slices are all of a sufficient
value as to reveal their fill color inside their wedge.
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Use a pie chart when you have segments of data that you want to display as a whole. For
example, the following image is a pie chart that shows the proportions of various electronic
products based on the quarterly revenue.

Sale Quarter
1 2 3 4

Product Category

B Acoessories
Camcerder

. Computers
Media Player

B Stereo Systems
Televisions
Video Production

Revenue Revenue Revenue Revenue

You can add one or more measures to the Measure field container. Each measure will be used
to create a separate, unique pie chart, to which you can add a measure or dimension to the
Color field container to add color to your chart.

Note: When working with pie charts, you can add one measure field to the Color field

container. This adds the measure as a By field, and determines how the pie chart is colored.

Depending on your measure data, this may result in a large number of pie segments.
Procedure: How to Create a Pie Chart

1. Change the visual type to a pie chart or insert a new pie chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

Id Measure - one data field. Data in this category is used to indicate the size of the pie
slice for the relevant category.

Id Color - one data field. Data in this category indicates the colors in your pie chart.

252 IBM



6. Creating and Customizing Visualizations I

Note: You can also double-click a data field to add it to your Query field containers.

The pie chart displays on the canvas. You can add additional data fields for comparative
purposes, or to create another pie chart on the same canvas. You can also view underlying
data by hovering over any particular point on the pie chart.

Procedure: How to Create a Matrix Pie Chart

Ring Pie Charts

Change the visual type to a pie chart or insert a new pie chart.

Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

.4 Measure - one data field
Note: Each unique measure field is represented by a separate pie chart.
.4 Color - one data field
- Matrix Rows - one data field
.4 Matrix Columns - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The matrix pie chart displays on the canvas. You can add additional data fields for
comparative purposes, or to create another pie chart unique to the additional measure
fields you select. You can also view underlying data by hovering over any particular point
on the matrix pie chart.

Ring pie charts are circular charts that display the total for the selected measure, as well as
the individual segments that comprise the ring pie chart. You can hover over each segment to
review the underlying data values. This is useful when comparing the measure value for an
individual segment against the total for the measure, which displays in the center of the ring

pie.

You can add one or more measures to the Measure field container. Each measure will be used
to create a separate, unique ring pie chart, to which you can add a measure or dimension to
the Color field container to add color to your chart.

Note: The font size of the value label in the middle of the ring is automatically set by the chart
engine.

Db2 Web Query InfoAssist+ Part 1 253



Selecting a Visual

Use a ring pie chart when you want to review the value of each segment, which represents the
measure value for the selected dimension, as it relates to the total for the selected measure.
The following image is an example of a ring pie chart.

Sale Year
2014 2015 2016

Product Category

M Accessories
Computers

W Media Flayer
Televisions

M video Production

Gross Profit Gross Profit Gross Profit

Procedure: How to Create a Ring Pie Chart
1. Change the visual type to a ring pie chart or insert a new ring pie chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

I Measure - one data field. Data in this category is used to indicate the size of the ring
pie segment for the relevant category.

[d Color - one data field. Data in this category indicates the colors in your ring pie chart.
Note: You can also double-click a data field to add it to your Query field containers.

The ring pie chart displays on the canvas. The total for the selected measure displays in
the center of the ring pie chart. You can view underlying data by hovering over any of the
ring pie chart segments.
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Procedure: How to Create a Matrix Ring Pie Chart
1. Change the visual type to a ring pie chart or insert a new ring pie chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

.4 Measure - one data field

Note: Each unique measure field is represented by a separate ring pie chart.
.4 Color - one data field
.4 Matrix Rows - one data field

. Matrix Columns - one data field
Note: You can also double-click a data field to add it to your Query field containers.

The matrix ring pie chart displays on the canvas. You can add additional fields for
comparative purposes, or to create another pie chart unique to the additional measure
fields you select. You can also view underlying data by hovering over any particular point
on the matrix ring pie chart.

Scatter Charts

Scatter charts enable you to plot data using variable scales on both axes. When you use a
scatter chart, the data is plotted with a hollow marker, so that you can visualize the density of
individual data values around particular points, or discern patterns in the data. A numeric X
axis, or sort field, always yields a scatter chart, by default.

Note: You can specify a non-measure (dimension) data field on the horizontal or vertical axis,
or both.

If your chart reveals clouds of points, there is a strong relationship between X and Y values. If
data points are scattered, there is a weak relationship, or no relationship.
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Adding data fields to the Detail Query field container creates additional BY fields on the scatter
chart. For example, the following image shows the results when adding the
Product,SubCategory and Model dimension fields to Detail Query field container in a scatter
chart which showed gross profit and MSRP data.
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Procedure: How to Create a Scatter Chart

1. Change the visual type to a scatter chart or insert a new scatter chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

- Vertical Axis - one data field

-l Horizontal Axis - one data field

. Detail - one or more data fields

.4 Color - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The scatter chart displays on the canvas. You can also view underlying data by hovering
over any particular point on the scatter chart.
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Bubble Charts

A bubble chart is a chart in which the data points are represented by bubbles. Bubble charts
can have two column fields representing X and Y data values, or have three column fields
representing X, Y, and Z data values, in that order. The Z variable represents size. The size of
each bubble is used to show the relative importance of the data.

When you add a data field to the Size field container, this value is represented as the Z Axis
Title in the legend. It displays as an empty Z Axis Title when a size data field is not specified. If
you choose to indicate a Z, or size, data value, the data label displays in the legend. A Size
Legend also displays, showing the estimated data value for a range of circle sizes. This allows
you to estimate the value of the data based on the size of the circle.

Note:
.4 You can hover over the circles in the visual to obtain exact data values for any given point.

4 You can specify a non-measure (dimension) data field on the horizontal or vertical axis, or
both.

.4 In Visualization mode and for HTML5 charts, if you select the No fill option for your Series
style when creating a Bubble chart, the series displays in shades of black. For active
charts, you must enable the Show Border Color option in order to view the bubbles in your
chart at run time, otherwise the bubbles are invisible.
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In the following image, a bubble chart is used to show the Manufacturer's Suggested Retail
Price (MSRP) plotted against Revenue for a variety of electronics products. It also shows the
values for Gross Profit, which was specified in the Size field container in the Query pane.
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Procedure: How to Create a Bubble Chart

1. Change the visual to a bubble chart or insert a new bubble chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

. Vertical Axis - one data field
.4 Horizontal Axis - one data field

. Detail - one or more data fields

d Size - one data field

.4 Color - one data field (optional). Labels for the values in this data field will comprise
the legend.

Note: You can also double-click a data field to add it to your Query field containers.

The bubble chart displays on the canvas. You can also view underlying data by hovering
over any particular point on the bar chart.
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Matrix Marker

Matrix marker charts are useful for analyzing one or two measures against a crosstab of two
categorical dimensions. You can use the Size Query field container for one measure and the
Color Query field container for a second measure. The result is a color-scaled matrix chart that
shows categorized trends, as shown in the following image.
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Procedure: How to Create a Matrix Marker Chart
1. Change the visual to a matrix marker chart or insert a new matrix marker chart.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

I1 Matrix Rows - one data field

I1 Matrix Columns - one data field

I Size - one data field. The data for this field determines the size of the marker.
I Color - one data field. The data in this field determines the color of the marker.

The matrix marker chart displays.
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Treemaps

Treemaps are used to display large amounts of hierarchically structured data. Using a set of
nested rectangles to illustrate data relationships, sections of a treemap represent branches of
a tree. Each branch is given a rectangle, to which any number of smaller sub-branches can be

assigned. The size of each branch is proportional to the summed values of the elements

inside the branch.

The following treemap shows the categories of the selected dimension fields, using two data

fields to determine the size and color of the treemap segments.
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Procedure: How to Create a Treemap
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1. Change the visual to a treemap or insert a new treemap.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.

The following Query field containers must be populated for this visual:

Id Grouping - one or more data fields, which establishes the hierarchy of the Treemap

grouping.

I Size - one data field. This data controls the size of the branches that display.

Id Color - one data field. This data controls the colors that display based on the

accompanying gradient.
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Gauges

Procedure:

The treemap displays.

Gauges are used to display the value of a measure. In particular, circular gauges are used to
represent a single data value within a given spectrum. These gauges have a circular shape.
You can create a single circular gauge for a measure or a matrix circular gauge, which shows
the value of the selected measure across different dimensions, such as product category or
yearly sales. The value of the measure that displays in a circular gauge is determined by the
underlying data stored for that measure in the database.

The circular gauge functionality uses only one measure in its presentation. The legend reflects
the color of the measure within the circular gauge.

In the following example, we review revenue data for each product category by quarterly sales
in a matrix circular gauge chart.
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How to Create a Circular Gauge

1. Change the visual type to a gauge or insert a new gauge.
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2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following query field containers must be populated for this visual:

-l Measure - one data field. Data in this category is used to indicate the value of the
selected measure, which displays within the gauge.

. Tooltip - one or more data fields. The fields that you add provide you with the ability to
review additional related, underlying data for different measures. Tooltips are optional.

Note: You can also double-click a data field to add it to your Query field containers.

The circular gauge displays on the canvas. You can select additional measure fields for
which to include in the tooltip.

Procedure: How to Create a Matrix Circular Gauge
1. Change the visual type to a gauge or insert a new gauge.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following query field containers must be populated for this visual:

-l Measure - one data field. Data in this category is used to indicate the value of the
selected measure, which displays within the gauge.

Note: Since the gauge relies on a constant (measure field), each intersection of the
matrix chart is calculated using that measure along with the various matrix rows and
columns in the matrix chart.

- Matrix Rows - one data field.
. Matrix Columns - one data field.

. Tooltip - one or more data fields. The fields that you add provide you with the ability to
review additional related, underlying data for different measures. Tooltips are optional.

Note: You can also double-click a data field to add it to your Query field containers.

The matrix circular gauge displays on the canvas. You can select additional measure fields
for which to include in the tooltip.

Heatmaps

A heatmap is a graphical representation of data where the individual values that comprise a
matrix are represented as colors. Using radiant hues, you can track the intensity of a data
relationship using the colors defined in the legend.
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Procedure:

Heatmaps are useful when you are looking for hot spots in your data, or areas of focus or

interest, as shown in the following image.
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How to Create a Heatmap

1. Change the visual to a heatmap or insert a new heatmap.

Cost of Goods

2. Drag data fields to the canvas or to the Query field containers to add them to your visual.

The following Query field containers must be populated for this visual:

I Color - one data field. This data controls the colors that display based on the
accompanying gradient.

[ Horizontal field container - one data field.

I Vertical field container - one data field

Note: You can optionally populate the Matrix Rows and Columns fields to increase the

segmentation of your heatmap.

The heatmap displays.

Matrix Charts

Matrix charts are powerful, comparative tools. They provide enough detail to show a trend and

they organize information in a categorical fashion.
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Matrix charts display data in a grid, showing the comparative values on either axis. They
provide you with a quick glance at trends over time, giving you a succinct synopsis of a
situation (for example, sales or investment trends).

You can use various formats in your matrix chart (for example, pie or line chart).

In the following example, we review quarterly revenue data, by product category, for a range of
years (2014 - 2016, specifically). Using a bar chart for the matrix, we are able to review how
gross profit for each product category shifts over time.
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You can plot one value on the X axis and one value on the Y axis. For example, sales against
region. You can also plot just one value for the rows or columns in the matrix chart.

Procedure: How to Create a Matrix Chart
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1. Change the visual type to bar chart or insert a new bar chart.
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2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
The following Query field containers must be populated for this visual:

[ Vertical Axis - one data field
I Horizontal Axis - one data field

[ Matrix Row - one data field

The matrix chart displays on the canvas. You can view underlying data by hovering over any
particular point on the chart.

Note: You can change the bar matrix chart to a line, area, or pie matrix chart by changing
the type of visual in the Visual group on the Home tab.

Interacting With Visualizations

A visualization is comprised of one or more visuals, such as charts, maps, or grids and text.
You can create different views of your data in a single visualization, and share that
visualization with others in your enterprise.

The following image shows a sample visualization. This visualization includes a map, a matrix
grid, and a stacked area chart.

Choropleth Map1 +O X Gridi w3
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M| Media Player 5484877838 $21,404,087.33
: Stereo Systems 5776494083  $26.195.419.83
L Televisions $1,456,845.71 $6,858,693.71
Video Production 51,588,405 82 55.140,260.62
80.7M
2015 Accessories 5494577969 $16.080.415.69
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This section summarizes the tasks that are available to you when working with visuals. It
provides centralized instructional information on performing each task and offers links to the
most common topics when working with visuals.

Task

How To

Change visual

On the Home tab, in the Visual group, click Change.

Note: The Change icon updates depending on the
chart, map, or grid that you select from the Select
a Visual menu. By default, the Change icon
displays a stacked bar chart.

Select a chart, map, or grid from the Select a
Visual menu.

Insert new visual

On the Home tab, in the Visual group, click Insert.
Use the default stacked bar chart or click Change
to select a different chart, map, or grid from the
Select a Visual menu.

Note: You can also add additional charts, maps, or
grids to a visualization by dragging a data field onto
the canvas and placing it using the handles that
are available.

Rearrange visuals

Drag a visual on top of another visual to activate a
shaded area that contains handles, which can be
used to indicate placement.

Copying a visual

On the canvas, select a visual. On the Home tab, in
the Clipboard group, click Copy.

Note: You can also press CTRL+C to copy a
selected visual.

Pasting a visual

Copy a visual. On the Home tab, in the Clipboard
group, click Paste.

Note: You can also press CTRL+V to paste a
copied visual on the canvas.
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Task How To

Duplicating a visual On the canvas, select a visual. On the Home tab in
the Clipboard group, click Duplicate. A duplicate
visual is created and a sequential number is
assigned based on the type of visual.

Delete visual Select a visual. On the Home tab, in the Clipboard
group, click Cut. You can click the Close button in
the upper-right corner of the current visual. From
the Query pane, right-click a visual and click Delete.
You can also press the Delete key when a visual is
selected.

Apply Filter Drag a dimension field or measure field into the
Filter pane to access the filter options that are
available. To add filter options for a field that is
already in the Query pane, select the field and on
the Field tab, in the Filter group, click Filter.

Add visuals to the storyboard Create a visual. On the Home tab, in the Storyboard
group, click Add.

Procedure: How to Insert a New Visual
1. On the Home tab, in the Visual group, click the down arrow next to Insert.

2. On the menu, click one of the following options:
4 Chart. Inserts a stacked bar chart visual.
. Grid. Inserts a grid visual.

4 Text. Inserts a blank text cell.
3. Populate your visual with data or add text to the text cell.

Note:

.4 By default, when you click Insert, a stacked bar chart visual is inserted.
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- You can also drag a data field from the Data pane to the canvas to insert a new visual.
This inserts the default visual, a stacked bar chart. You can use the placement
handles to position your new visual on the canvas, for example, above an existing
visual or to the side of an existing visual.

Procedure: How to Add Text to Your Visualization
1. On the Home Tab, in the Visual group, click the down arrow on next to Insert.

2. On the menu, click Text.
A text cell opens on the canvas.
3. Add text to your visualization.

Note: You can resize the text cell and use the text formatting options to customize the
display of any text that you add, as shown in the following image.
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[This visualization shows sales by product category. It was generated on August 30,2017,

Bubblel +[IX Bar Stacked1 w0
Product Analysis Quantity Sold by Product
60K
DMP-602
DS3205/37
9 DS 1155037 150
50K ’w 'S _ BOODTMOHDO =
¢ H BCG4HRE4KN I I
= JVC XV-BP11 .
- Samsung HT-Z120 7.5M
LG MDD72
3 3.8M

Sennheiser SET8308

Sonv STRDHS10 -nm
0 10K 20K 30K 40K 50K 60K

20K ° * Ring Piel ~OX%

Sales by Product Category

. \““\ 12%
8 ® ‘

20K

@ —15%
L
- 1.1B
"
10%
L]
O 0 aM M 12m 16M L:B%
Revenue Revenue

You can also position the text cell in your visualization by dragging the text cell on top of a
visual. Use the placement handles to indicate placement of the text cell.

Procedure: How to Create a Visualization

1. Begin with the default canvas, which consists of a stacked bar chart template.
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2. Insert a new visual in one of the following ways:

a. Drag a data field from the Data pane onto the canvas. Handles display, which allow
you to select the location for the new visual, for example, top (above) or left of the
current visual, as shown in the following image.

[Bar Stackedt . |
Drop Measures or Sorts into the Query Pazie

0+ @ AT i

i EllLuscnurﬂ

b. On the Home tab, in the Visual group, click Insert.

Note: You can optionally click the down arrow on the Insert button to specify the
addition of a chart, grid, or text.

3. Add another visual.
Now, three visual cells display side-by-side.
4. Click a visual to select it.

Note: You can click a visual to activate it, or double-click on the visual number or name in
the Query pane.

Reorganize your visuals using the handles.

6. Once you have organized the placement of your visuals, select one and specify the visual
type.

a. On the Home tab, in the Visual group, click Change.
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Note: The Change icon updates depending on the chart, map, or grid that you select

from the Select a Visual menu. By default, the Change icon displays a stacked bar

chart.

b. In the Select a Visual menu, click the type of visual you want to use. For example,

Line, Area, or Map.

c. Repeat these steps for all three visuals on your canvas.

Populate each visual with your data.

You can change the type of visual that you previously selected at any time. You can also
resize or reorganize the position of each visual as you add data.

For example, move the lower-left visual to the top of the visualization.
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The bubble chart now runs across the top of the visualization.
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8. Click Save to save your visualization.

Minimizing or Maximizing a Visual

When working on a visualization with more than one chart, map, or grid, you can maximize and
minimize individual visuals. This allows you to focus on one visual at a time, and then minimize
it to view it alongside the other visuals.

The maximize and minimize icons are located in the top-right corner of each visual, next to the
Close button. When you click the Maximize icon, the current visual moves to the foreground
and is the only visual that displays on the canvas. You can work on this visual, and then
minimize it to view the other visuals.

Note: You can view other visuals in the maximized mode by selecting a different visual in the
Query pane.

Procedure: How to Minimize or Maximize a Visual

1. Create a visualization with two or more visuals.
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Procedure:

2. Perform the following actions to minimize or maximize your visual:
- Click the maximize icon or double-click on the Title bar to maximize your visual.

- Click the minimize icon or double-click on the Title bar to minimize your visual.

You can maximize one visual at a time, and you can switch between visuals in this mode
by double-clicking a different visual in the Query pane.

How to Delete a Visual
1. Inyour visualization, select the chart, map, or grid that you want to delete.

2. Perform one of the following tasks to delete the visual:
- Press the Delete key.
1 On the Home tab, in the Clipboard group, click Cut.
- Click the Close button in the upper-right corner of the current visual.

- From the Query pane, right-click on a visual, and click Delete.

Note: You can use the Undo and Redo options on the Quick Access Toolbar to reverse or
redo any prior actions.

Renaming a Visual

Procedure:

272

You can rename a visual on the canvas or within your visualization. You may want to do this for
presentation and organizational purposes, as each visual has a default label (for example, Bar
1, Bar 2, and Bar 3). You can change these labels by renaming the visual in the Query pane.

Once new labels are in place, it is easier to recognize which visual you want to select at any
given time.

Using the shortcut menu for a visual in the Query pane, you can also rename your visual.

How to Rename a Visual

1. Create a visualization with one or more chart, map, or grid.

In the Query pane, right-click the visual number for which you want to modify the title.
Click Rename.

In the Edit Title dialog box, enter a new name for the visual.

Click OK.

o 0N
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The visual is renamed in the Query pane and the new title is reflected at the top of the
selected visual.

Using Paper-Clipping to Group Values in a Visual

Paper-clipping gives you the advantage of lassoing values in a visual to create logical groups
within your selected dimension. Paper-clipping uses the core functionality of dynamic grouping,
giving you access to grouping capabilities that meet your business needs. You can also add
additional groupings or fields to an existing group, and rename the groups and values, giving
you control over how the information displays.

When you paper-clip values together, a new group is created using the naming convention of
dimensiongroup_1. You can add values to this group by lassoing this grouped component,
along with any additional components you want to add. These new values become part of that
existing group.

Note: If you group two values and then add another value to that grouping, you must manually
rename the group in order to update its display.

If you lasso other values in your visualization, and you do not capture or include a previously
defined grouping, a new grouping is created for the selected fields in the current dimension. It
is labeled using the original dimension label (dimensiongroup_1), but a new, unique grouping
is created for these values. You can see the groupings by right-clicking the group in the Query
pane and selecting Edit Group. If you want to add new values to an existing group, you must
lasso the existing group, in addition to the fields that you want to add to it, in order to combine
the additional fields into the existing grouping.
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To enable paper-clipping, lasso the values that you want to group, release the mouse, and
from the menu that displays, select Group n Selection, where n is the dimension associated
with the values you select. This menu is shown in the following image.

240M

160M

120M

Cost of Goods

Ppoins

Filter Chart

40M Exclude from Chart

Group Product,Category Selection |

Accessories Camcorder Computers Media Player Stereo Systems Televisions Video Production

Product Category

Note: Paper-clipping allows you to group on the first BY field only. In this example, the first BY
field is Product Category. If you are working with a matrix chart and you apply this rule, you are
only able to group on the first BY field. In addition, you cannot group on a numeric field (for

example, Sales_Year). In this case, if the numeric field was the first BY field, grouping is not
available.
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Once you group the values, they display in a unique group on the relevant axis. The group label
is based on the original values stored for those components. For example, in the previous
image, we grouped Camcorder and Computers in the PRODUCT_CATEGORY_1 group, as shown
in the following image.
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Media Player Slereo Systems
PRODUCT_CATEGORY_1

Once you create a group, you can easily perform the following functions:

Id Edit group. Opens the Edit Group dialog box, where you can edit the values in the current
group. For example, you can add additional values into the current group or delete them.
For more information on editing an existing group, see Dynamic Grouping on page 63.

[J Rename group. Enables you to rename the group using the Rename Group dialog box. The
revised name displays along the relevant axis and replaces the existing field name in the

Query pane.

IJ Rename x. Enables you to rename the group name (x) that is assigned based on your
grouping. This is particularly useful in cases where space is an issue in your visualization.
This revised value also replaces the original group name in the Edit Group dialog box.

[ Ungroup x. Ungroups the values of the group (x) that were previously grouped.

I Ungroup All. Ungroups all existing groups, returning the visualization to its original state.

Note: Upon ungrouping all groups, the original dimension displays as a group in the Query
pane, by default. However, no grouping is applied.
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These options are shown in the following image.
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Note: You can also edit an existing group by right-clicking the group in the Query pane and
selecting Edit Group.
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If you want to add another value to an existing group, lasso the existing group and the new
value. From the menu, click Merge with x, where x is the value of the existing group, as shown
in the following image.
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The new value is added to the existing group. You can then rename the group so that its label
contains all values in the group. You can optionally label it with a new, unique name. This
option is shown in the following image.

350M

250M

1 point

Filter Chart
Exclude from Chart

Cost of Goods

Edit group PRODUCT_CATEGORY _1
Rename group PRODUCT_CATEGORY_1

Rename Camcorder and Computers.
Ungroup Camcorder and Computers...
Ungroup All

Accessories Camcorder and Computers

Systems Televisions Video Production
DUCT_CATEGCRY 1

Note: You can also use the Edit Group dialog box to rename groups or groupings. For more
information, see Dynamic Grouping on page 63.

You can use the following procedures to create and manage your paper-clipped values.

Procedure: How to Paper-Clip Two or More Values Together

1. In visualization mode, create a bar chart with one measure and one dimension. The bar
chart displays.

2. Lasso two or more columns in the visualization.

From the menu that displays, click Group n Selection, where n is the name of the
dimension in your bar chart.

The two values are paper-clipped together, or grouped, as indicated on the x-axis.

Note: If you have swapped the orientation of your visualization, the paper-clipped values
display on the y-axis.

Procedure: How to Merge an Additional Value into an Existing Group
1. Invisualization mode, create a bar chart with one measure and one dimension. The bar

chart displays.
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Lasso two or more columns in the visualization.

From the menu that displays, click Group n Selection, where n is the name of the
dimension in your bar chart.

The two values are paper-clipped together, or grouped, as indicated on the x-axis.

Note: If you have swapped the orientation of your visualization, the paper-clipped values
will display on the y-axis.

Lasso this existing group, as well another column, to merge this additional value into the
group.

From the menu that displays, click Merge with x, where x is the hame of the group you
originally created.

This value is merged into the existing group.

Note: The name of the group is not dynamically updated. In order to reflect the contents of
the revised group, you must edit the group using the right-click menu option or the Edit
Group option that is available in the Query pane.

Procedure: How to Rename an Existing Group

1.

In visualization mode, create a bar chart with one measure and one dimension. The bar
chart displays.

Lasso two or more columns in the visualization.

From the menu that displays, click Group n Selection, where n is the name of the
dimension in your bar chart.

The two values are paper-clipped together, or grouped, as indicated on the relevant axis.

Lasso the grouped column and from the menu that displays, click Rename x, where x is
the existing label of the group.

In the Rename Value dialog box, enter the new name for the group.
Click OK.
The group is renamed, as shown on the relevant axis.

Note: Optionally, you can rename a group using the Edit Group dialog box. This is available
when you right-click on a grouped value in the Query pane and click Edit Group. For more
information, see Dynamic Grouping on page 63.
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Viewing Data Behind Visuals

280

You use InfoAssist+ to analyze your data by creating or building interactive visualizations. As
you develop these visualizations, you can create different views of the data, and find patterns
or trends.

As you gain insight and spot patterns, you may want to share only the underlying data that
comprises a specific visual with others in your enterprise. You can do this using the data
options, as shown in the following image.

.':_ b3
Show Data
Show Data with Related Columns

Export Data

The Show data option provides options for you to view and share this data. The Export data
option enables you to export the data specific to your visualization in a summary or detailed
format. You can also review related data by using the Show Data with Related Columns option.

The Show Data with Related Columns functionality allows you to review more specific
underlying data based on the fields that you have selected. Specifically, it displays data related
to other fields that are part of the dimension hierarchy that you select. For example, if you
selected the Product,Category dimension field, the related column data would include data
from the Product,Subcategory and Model dimension fields, because these data fields are part
of that dimension hierarchy.

Similar to the Show data option, the Show Data with Related Columns option provides more
detailed data based on the data fields that you select. You can sort and review the data
columns, which display in a separate browser window. Depending on the size and breadth of
your dimension hierarchy, a multiple page report may be produced.

Note: You can export data in .xIs or .csv format.

When you select the option to show data or show data with related columns, a report is
generated in a separate browser window. This report is an active report, which you can review,
sort, and modify using the drop-down menus that are available. .

When you point to the Export Data option, you can:

4 Export data in summary format, which includes totals for categories based on the data
fields that you selected for your visual.

-1 Export more granular data based on the data values that you selected in your visual.
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Procedure:

Procedure:

Procedure:

Note:

. When exporting data using the Summary or Data Detail options, you can save the resulting

data file, which is in Microsoft® Excel® format, to your local machine for further analysis
and sharing.

.4 The maximum number of records that can be exported is 100,000.

How to Show the Data Behind Your Visual

1.
2.
3.

Create a visual, such as a chart, map, or grid.
In the upper-right corner of the visual cell, click the down arrow.
In the menu that appears, click Show Data.

A new browser window opens. This window displays the data for your visual as a Db2 Web
Query active report. You can use this active report to create and share lightweight,
browser-based data discovery analytics that are portable, and only require access to a
browser.

How to Show Data With Related Columns

Create a visual, such as a chart, map, or grid.
In the upper-right corner of the visual cell, click the down arrow.
In the menu that appears, click Show Data with Related Columns.

A new browser window opens. This window displays the data for your visual as a Db2 Web
Query active report. You can use this report to sort and work with the underlying
hierarchical data in your visual.

How to Export the Data Behind Your Visual

1.
2.

Create a visual, such as a chart, map, or grid.

In the upper-right corner of the visual cell, click the down arrow.
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3. In the menu that appears, point to Export Data, and then click one of the following:

4 Summary. A prompt appears, asking you to open or save a Microsoft Excel file. This
file is a summary of your data from a high level for a general analysis, as shown in the
following image.

A A B C D
Product
1 Category Product Name Revenue Gross Profit
2 | Accessories Headphones $9,341,397 .65 $2 354,397 65
3 Cycle Energy Quick with Refresh Charger $1,508,212 41 $666,612 41
4 Denon AH-D5000 Over-Ear Headphones $9.272 133.77 $2 47730377
5 Grado RS11 Reference Series Headphones $9 452,243 25 $2,208,713.25
6 Universal Remote $14,419,020.31 $4 401,161 .31
7 Control $9,301,960.89 $1,518,520.89
8 Anywhere! Kit with Tabletop Sensor $11,401,805.70 $2.616,237.70
9 Anywhere! Kit for Home Theater $14,276,128.75 $4,825372.75
10 Headphones $8028218 25 $4,049 178 25
11 Samsung OEM 2.0 Amp Travel Charger $2 514,622 50 $1,303,511.50

. Data Detail. Generates a detailed report that provides specific data regarding your data
analysis.
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Using Multi Drill in Visualization Mode

Similar to the functionality that is available in Chart mode, you can create multiple drill down
links on a measure field in a visualization. This enables you to define custom links to other
reports or websites, making it easy to link content from internal and external sources. Once
defined, these links display on the shortcut menu that displays when you hover over a riser, as
shown in the following image.
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You create multiple drilldowns using the Drill Down dialog box, which you can access from the
Links group on the Field tab. In the Query pane, click a measure to enable the Field tab. In the
Links group, click Drill Down. The Drill Down dialog box displays, as shown in the following
image.

%3 Drill Down - Quantity, Sold x

B X

* Report Refresh BI Portal Web Page
Report*®
Browise
Description
Drill Down 1

Target

MNew Window -

Parameters

Name Value

* Required Field

W OK
Note: When creating a drill down in Visualization mode, the Auto Link Target option is not
available.

For more information and instructional guidance, see Using Multi Drill on page 323.

Creating Multi-Y Axis Comparative Visuals

When creating a chart with more than one measure (numeric) field, you can split the Y axis to
create multiple charts, based on each unique measure field.

Note: Measure fields are selected from the Data pane and display under the Vertical Axis (Y) in
the Query pane.
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This functionality is useful when analyzing trends for multiple measure fields, as you can view
data for each measure field separately within the same chart, as shown in the following image.
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This functionality is available for Bar, Bar Stacked, Line, Area, and Area Stacked charts.

Procedure: How to Create a Multi-Y Axis Comparative Visual
1. Launch InfoAssist+ in Visualization mode.
2. On the Home tab, in the Visual group, click Change.
3. Select one of the following visual types: Bar, Bar Stacked, Line, Area, or Area Stacked.
Note: Bar Stacked is the default visual type.
Add multiple measure fields to the visual. For example, Gross Profit and Revenue.
Add at least one dimension field to the visual. For example, Product Category.

In the Query pane, right-click Vertical Axis.

N ook

Click Multi-Y split.
The chart changes to display individual charts for each measure field.

Note: You can revert your chart to an integrated display by right-clicking Vertical Axis and
then clicking Multi-Y split.
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Customizing Visualizations

Once you have created a visualization, you can customize and style individual visuals within the
visualization. For example, you can add axis titles to a bar chart visual or a title or header for a
visual within a visualization. For visuals, the customization options vary depending on the type
of visual (for example, the formatting options for bar visuals differ from those that are available
for pie visuals).

This section addresses the formatting options that are available for all visual types, including:
. Format Axis Dialog Box on page 286
- Using Axis Properties on page 291
.d Formatting Data Labels on page 296
.4 Formatting the Legend on page 297
4 Formatting a Series on page 297

al

Formatting and Display Tools for Data in a Visual on page 298

Formatting Axis Labels

286

Vertical and horizontal axes are based on the orientation of the visual. For example, in a
vertical visual, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis.
In a horizontal visual, the horizontal axis refers to the Y axis and the vertical axis refers to the
X axis. This is important to consider, since options could change depending on the orientation
of the visual.

A chart can contain the following types of axis labels:
. Horizontal axis labels represent the X axis.

. Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric
scale, usually located on the left side of a vertical chart.

.d Secondary horizontal and vertical labels can only be used when dual axes charts are

selected.

Format Axis Dialog Box

The Format Axis dialog box includes options for formatting both vertical and horizontal axes.
The Format Axis dialog box contains the following tabs:

.4 General (for horizontal axes)
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- Scale (for vertical axes)
A Title
d Labels

4 Advanced

Reference: Format Vertical Axis Dialog Box

You can use the Format Vertical Axis dialog box to specify formatting options for the vertical
axis in your chart.

Use the Scale tab to modify scale properties.

The Scale tab contains the following options:

4 Automatic Minimum. Supplies the minimum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the minimum value by entering a
number into the Value text box.

.4 Value. Type the minimum value in this text box if you have not selected Automatic
Minimum.

-1 Automatic Maximum. Supplies the maximum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the maximum value by entering a
number into the Value text box.

4 Value. Type the maximum value in this text box if you have not selected Automatic
Maximum.

-1 Automatic Grid Step. Calculates the number of major grid steps automatically. To use
manual scaling, clear this option. You can then set the value by typing the number into the
Value text box.

.4 Value. Type the value in this text box if you have not selected Automatic Grid Step.

d Logarithmic Scale. Controls whether or not the Y-axis scale progresses logarithmically
instead of linearly. This option is disabled by default. When selected, the logarithmic base
is set to 10.0, but can be changed by entering another value.

. Include zero on scale. Controls whether or not a zero (0) value appears on the scale. This
option is enabled by default.
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288

When working with vertical axis options in InfoAssist+, the Include zero on scale check box is
cleared by default when setScaleMustincludeZero() is not present in the StyleSheet. When this
setting is not present, the value is false. The Reporting Server, however, sets the value to true.
This produces inaccurate results at run time.

To resolve this issue, add the setScaleMustincludeZero() setting to the StyleSheet. For
example, setScaleMustincludeZero(getY1Axis(),true);

You can also select the Include zero on scale check box in the Format Vertical Axis dialog box,
which can be accessed from the Axes option in the Labels group on the Format tab, and then
clear it. This writes the setting into the FOCEXEC and sets the value to false. Select the check
box for this option again to set the value to true.

Use the Title tab to show or hide the axis title, and create and style the title for the axis.

The Title tab contains the following options:

-1 Show title. Select this check box to show the axis title (default) or clear the check box to
hide the axis title.

- Text. Enter a title for the axis.

- Style text. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

- Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

- Style labels. Opens the Style dialog box, where you can style text.
- Format Labels. Contains a list of preset formats that can be applied to the labels.

- Custom Format. Allows you to use a custom format. This option is activated when Use
Pattern /100 and Use Pattern are selected as the format labels.

The Format Labels drop-down menu provides a list of preset formats that you can apply to
labels. When you select a custom format, it must be defined using a custom format pattern.
See the following table for a list and description of the characters that you can use in a
custom format.
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Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for a decimal separator.

, (comma) Is a placeholder for a grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in the
prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or suffix.

Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

_I

-
d
d

Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
Exclude Maximum Label. Excludes the label with the highest axis value from the chart.
Descending Axis. Draws the axis in descending order.

Show axis line. Controls the display of the axis baseline.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

Show zero line. Controls the display of the zero line.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the zero line.

Custom Baseline. Controls the display of the custom baseline.
. Value. Type a value for the custom baseline.

4 Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the custom baseline.
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Reference:

290

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on
page 291.

Format Horizontal Axis Dialog Box

You use the Format Horizontal Axis dialog box to specify formatting options for the horizontal
axis in your chart.

The General tab contains the Show axis line check box, which controls the display of the axis
line. When this check box is selected, you can style the axis line.

The General tab contains the following options:
- Show axis line. Enables the display of the axis line.

- Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:
1 Show title. Enables the display of the title.
- Text. Type a title for the axis.

- Style. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

d Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

d Style labels. Opens the Style dialog box, where you can style text.
- Stagger Labels. Sets the labels to appear staggered.

1 Concatenate Labels. Concatenates the labels in your visualization. This is enabled by
default.

Use the Advanced tab to modify additional axis properties.
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Procedure:

Procedure:

The Advanced tab contains the following options:
.d Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
. Exclude Maximum Label. Excludes the label with the highest axis value from the chart.

d Reverse Groups. Reverses the order of the display of the groups on the horizontal axis.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties.

Using Axis Properties

The following sections contain procedures for customizing an axis. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

How to Hide Axis Labels
1. Create a chart.

2. Onthe Format tab, in the Labels group, click Axes, point to the axis that you are working
with, and clear the Show Labels option.

The axis labels are hidden from the chart.

How to Stagger Axis Labels
Note: You can only apply a staggered effect to horizontal axis labels.
1. Create a chart with at least one horizontal axis label on display.

2. Onthe Format tab, in the Labels group, click Axes, point to Horizontal Axis, and click
Stagger Horizontal Labels.

The axis labels are staggered.
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The following image shows a chart with the horizontal axis labels staggered.
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Procedure: How to Rotate Axis Labels

292

Create a chart with axis labels.

On the Format tab, in the Labels group, click Axes, point to the axis that you are working

with, point to Rotate Labels, and then select the degree to which you want to rotate the

axis labels.

The axis labels are rotated.
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The following image shows a chart with the vertical axis labels rotated 45 degrees.
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Procedure: How to Format Axis Labels
1. Create a chart with an axis label.

2. On the Format tab, in the Labels group, click Axes, point to the axis that you are working
with, and click More Vertical Axis Options, or More Horizontal Axis Options.

The Format Axis dialog box opens.
Click the Labels tab.
From the Format Labels list, select the formatting option that you want.

The axis labels are formatted accordingly.
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The following image shows a chart with the vertical axis label styled in blue Arial font.
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Procedure: How to Manually Set the Scale of an Axis

294

Note: You can only set axis scale to vertical axis labels.

1.
2.

Create a chart.

On the Format tab, in the Labels group, click Axes, point to Vertical Axis, and click More
Vertical Axis Options.

The Format Axis dialog box opens.

On the Scale tab, clear the Automatic Minimum option and enter your own minimum value
in the Value text box.

Clear the Automatic Maximum option, and enter your own maximum value in the Value text
box.

Clear the Automatic Grid Step option, and enter your own grid step value in the Value text
box.

Optionally, you can select the Logarithmic Scale option and enter the log scale base in the
text field of that name. You can also clear the Include zero on scale option if you do not
want zero to appear on the axis.

Click OK to close the dialog box.
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The axis scale is set accordingly.

Procedure: How to Add an Axis Title
1. Create a chart with an axis label.

2. On the Format tab, in the Labels group, click Axis, point to the axis that you are working
with, and click More Vertical Axis Options, or More Horizontal Axis Options.

The Format Axis dialog box opens.
On the Title tab, type the axis title in the Text field.
Click the Style text icon to open the Style dialog box, where you can style the text.

The axis title is styled accordingly.

The following image shows a chart with titles added to the vertical and horizontal axis

labels.
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Procedure: How to Set Advanced Axis Properties
1. Create a chart with an axis label.

2. Onthe Format tab, in the Labels group, click Axes, point to the axis that you are working
with, and click More Vertical Axis Options, or More Horizontal Axis Options.
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The Format Axis dialog box opens.

3. On the Advanced tab, set the following options, as described in the following table:

Options Available for Vertical Available for Horizontal
Axis Labels Axis Labels
Exclude Minimum Label v v
Exclude Maximum Label 4 4
Descending Axis v/ x
Show axis line v x
Show zero line v X
Custom Baseline (Value) v ®
Reverse Groups X v

You can edit the color, weight, and style of all the lines that you set in the Line Style
dialog box.

4. Click OK.

The axis advanced options are set accordingly.

Formatting Data Labels

Data labels highlight important data points on a chart. They identify exact numbers. You can
customize data labels in a variety of ways to make them stand out more clearly on the chart.
For example, using the Format Labels dialog box, you can change the position, angle, color, or
size of data labels.

Note: The Format Labels dialog box offers different options depending on the chart type that
you are using.

Procedure: How to Access the Format Legend Dialog Box
The Format Legend dialog box contains options for formatting a legend on a chart.

1. Create a chart.
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Procedure:

2. On the Format tab, in the Labels group, click Legend, and then click More Legend Options.
The Format Legend dialog box displays.
3. Use the following options to modify your legend:

.d Legend Options. This allows you to set options for showing or hiding the legend,
setting the legend position, and showing the legend in reverse order.

d Markers & Labels. This allows you to set Marker Style and Position. It also lets you
stylize labels using a Style editor.

-l Fill. Determines how items in the legend will be filled. Options include No Fill, Solid Fill,
or Gradient Fill. The default is No Fill.

4 Border Styles. Enables you to activate the display of a border for your legend. You can
also specify a color.

Formatting the Legend

A legend contains information that is necessary to accurately interpret the data on a chart. By
default, a chart displays either a vertical axis title if there is a single measure field, or a legend
if there are multiple measure fields.

You can use the Format Legend dialog box to format the legend and customize its appearance
on a chart.

How to Access the Format Labels Dialog Box

1. Create a chart.

2. On the Series tab, in the Properties Group, click Data Labels, and then click More Data
Label Options.

The Format Labels dialog box opens.

Formatting a Series

A series is a measure field that is included in a chart. You can format a series in a variety of
ways. For example, you can change the color of a series or change the appearance of markers
on a series.
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Procedure: How to Change the Appearance of a Marker

Markers are used to display points of data on a line chart. They are also used in the legend to
identify the data that is on the chart. The different marker shapes distinguish one series from
another.

1. Create a line chart.
2. Select a series on the line chart.

3. On the Series tab, in the Line group, click Marker, then select the marker shape.
The markers are formatted.

The following image shows a diamond marker for Product Category.
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Formatting and Display Tools for Data in a Visual

When working with visualizations, you can use various filtering and editing tools to format the
display of measure and dimension data in any given visual. For example, for measures, you
can use the Edit Format option to set the display of decimals in the values of your selected
measure. For measures and dimensions, you can add filters to limit the display of information.
These options, which can be found on the right-click menu of a field, are defined and described
in the following table.
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Option

Description

Filter Values

Creates a filter for the selected measure or
dimension. You can select all values or only
the one the data values that you want to
display. In this way, you can exclude
unwanted data. For visualizations, prompts
are created, by default. However, you can
clear this option when setting your filter
options. This option displays for both
measures and dimensions.

Sort

Enables you to set sorting options for the
measure or dimension that you select. For
example, you can sort your data values in
ascending or descending order, or you can
set limits for the display of information, the
value for which is set to No Limit, by default.
This option displays for both measures and
dimensions.

Visibility

Controls the display of the selected
measure or dimension in a visual. The
default value is Show, but if you set the
option to Hide, the values are hidden from
the visual. This option displays for both
measures and dimensions.

Change Title

Enables you to edit the title of the measure
or dimension. In the Edit Title dialog box,
type the new title in the Enter Title field, and
click OK. Depending on the axis that you
select, the new label will be applied
accordingly. This option displays for both
measures and dimensions.
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Option

Description

Edit Format

Enables you to change the format of a field.
This includes field type, display options,
field length, and the specification of
applicable decimal points. For more
information, see Changing a Field Format on
page 90. This option displays for measure
fields only.

Note: Any changes to the format of a field
will be reflected in the tooltip for
visualizations at design and run time.

Drill Down

Opens the Drill Down dialog box, where you
can create multiple drill down links on a
data field to external procedures or
websites. This option is available for any
measure field in a visualization.

More

Provides access to Aggregation functions,
which enables you to apply Aggregation
functions (for example, Sum, Average, and
Count) to the numeric field that you select.
This option is only available for measure
fields. This option displays for both
measures and dimensions.

Delete

Deletes the selected field. This option is
available in every field container.

Note: In the Query and Filter panes, you can
select and delete multiple data fields at one
time. Press the Ctrl key, select two or more
data fields, right-click, and then click Delete.
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Option Description

Create Group Allows you to create a group of elements
based on the field data type that you select.
Once you define a new group, a higher-level
field is created that contains the selected
elements. This option is available for
dimension fields of non-numeric format or
attribute. For more information, see
Dynamic Grouping on page 63.

Using Handles to Organize Your Visualization

A typical visualization contains multiple charts, maps, and grids. You begin with the default
canvas and insert any number of visuals. You can control the placement of these visuals using
the handles that display when you drag a data field onto the canvas or insert a new visual.

You can add a visual in one of two ways:

d Drag a data field from the Data pane onto the canvas. Handles display, allowing you to
select the location for the new visual, for example, top (above) or left of the current visual.

-1 On the Home tab, in the Visual group, click Insert to add a new visual or text object to the
canvas. To set positioning of the new visual, drag the visual on top of another visual and
drop the visual on top of the handle that displays the relative position for the new visual.

When you drag a visual on top of another visual, this activates a shaded area. This shaded
area provides a preview of where the visual cell will dock if you release the mouse. It also
indicates the size of the resulting visual.
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The handles display within the shaded area. They allow you to indicate where you would like to
place the current visual relative to the others on your canvas. The handles are located in the
upper-right corner of the selected visual, as shown in the following image.
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Procedure: How to Place a Visual in a Visualization
You can indicate the placement of a chart, map, grid, or text object in a visualization.
1. Launch InfoAssist+.
2. Add and place one or more visuals using one of the following methods:
a. Drag a data field from the Data pane onto the canvas.

Use the handles that display in the upper-right corner of the selected visual to select
the location for the new visual, for example, below or to the right.

b. On the Home tab, in the Visual group, click Insert to add a new visual or text object to
the canvas.

To set positioning of the new visual or text object, drag it on top of another visual. Use
the handles that display in the shaded area to select a position relative to the
underlying visual.
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Procedure: How to Move a Visual in a Visualization
1. Launch InfoAssist+.
2. Add and place multiple visuals in your visualization.

3. Select and drag the visual that you want to reposition on top of an adjacent visual and
drop it on top of the handle that indicates the relative position you want to use.

Use the handles that display in the shaded area to select a position relative to the
underlying visualization.

Using Storyboards

The Storyboard feature allows you to capture and preserve snapshots of your visualizations as
you create them.

Each time you add something to the storyboard, it is placed onto a unique PowerPoint slide.
When you click Show, you can open and review your slides in PowerPoint.

Since storyboards give you the ability to turn your visualizations into a PowerPoint presentation,
you can modify your storyboard to create a customized demo. For example, you can rearrange
or delete slides, or add titles and text.

You can also make your visualization portable by saving the PowerPoint files that you create
and sharing the slides through email or other electronic distribution.
Procedure: How to Create a Storyboard
1. Create a visual, for example, a bar chart or a grid.
2. On the Home tab, in the Storyboard group, click Add.
Note: When you receive the Added to Storyboard message, click OK.
3. Insert another visual. On the Home tab, in the Visual group, click Insert.
Note: You can also click the down-arrow on the Insert button to insert a chart, grid, or text.
4. On the Home tab, in the Storyboard group, click Add.
Repeat steps 2 through 4 until you complete your data analysis.
5. On the Home tab, in the Storyboard group, click Show.

A new browser window opens, and you are prompted to open or save the PowerPoint file
that contains your storyboard.

. If you click Open, the storyboard opens in PowerPoint. You can save the file as a
PowerPoint presentation on your machine.
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I If you click Save, the storyboard will be saved to a PowerPoint (.pptx) file and placed in
the Downloads folder on your machine. Click the down arrow on the right side of the
Save button to perform a Save as. This allows you to specify the drive and directory to
which the file will be saved.

In PowerPoint, each storyboard frame displays as a PowerPoint slide, as shown in the
following image.

Animating Visualizations

Procedure:

304

You can animate visuals in a visualization. Each individual visual can have different animation
settings. The animations for each visual execute when you run the visualization.

How to Add Animation to a Visual

1.

2
3.
4

Create a visualization with one or more visuals.

Select the visual that you want to animate.

On the Format tab, in the Interactive group, click Interactive Options.

On the Interactive Options dialog box, select the Show Animation check box.
This animates the visual.

Set the duration for the animation, which determines the speed at which the animation
occurs. The default value is 1400ms. Increase the value to make the animation slower,
and decrease the value to make it faster.
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6. Optionally, clear the Enable Hover Over Effect check box.

This option lightens or adds a border to the segment of the visual that you move your
mouse over.

Click OK.
8. Click Run.

Your visual animates automatically based on the options that you specified.

Using Visualizations at Run-Time

In InfoAssist+, you can run visualizations that are either saved or run dynamically at run time.
In this case, the visualization opens in a separate browser window, as shown in the following
image.
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In the BI Portal, all users can run stored visualizations that are available to them. In this case,
the visualization opens in a new page.
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Working With Filters at Run Time

If you have added a filter to your visualization, you can use the Prompts panel to control the
display of information. When you run your visualization, the Prompts panel appears. This
enables you to select additional components by which to filter the visualization.

Note: The filters that you apply at run time can be removed using the Remove Filter option in
the Run-Time toolbar. This does not apply to filters that were added prior to running the

visualization.

The following image shows an example of a visualization with an open Prompts panel.
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Note: If you select (or lasso) components of your visualization, the Prompts panel does not

automatically update to reflect your selections.

Procedure: How to Filter Data With Tooltips at Run Time

306

1. Run a visualization from one of the following locations:
Id From the BI Portal.

I From the Application Main Menu or Quick Access Toolbar in InfoAssist+.

2. Click, point to, or lasso data in your visualization.
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A tooltip opens, as shown in the following image.

Revenue vs COGS by Month Sales by Product Category
120M

100M \/\/\/\//
80M

B0M

Product Category: Video Production
Quantity Sokd: 199,749 {5.69%)

Filter Chart
Exclude from Chart

Dill down to Product Subcategory

O Rewence
Cost of Goods

40M
200

Product Category
[ Accessories
Camcordar
M Computers
Mesia Flayer
I Stereo Systems.
Telesisicns
Video Producion

Sale Month

Revsenl'}ue and Gross Profit by Product

Product Subcategory
o o 5urey
El

Boom Box
CRTTV
Charger

4o0m DVD Fisyers
DVD Flsyers - Forisble
Flst Panel TV

30M Handheld
Hesdphones

Gross Profit

Home Thester Systems
Portable TV
20m -

Ressners
‘Smartphone
10M Speskeriats

Gross Profit
51aM

o 40M 30M  120M  160M  200M 240M  230M @
&

Revenue Quantity Sold

The tooltip includes the following options:
I Filter Chart. Filters the visualization by the data values that you have selected.
IJ Exclude from Chart. Excludes the selected data values from the visualization.

IJ Remove Filter. Removes the filter and returns the visualization to its original state.

Note:

Id The same run-time options are available when you run your visualization on a mobile

device.

I If you are working with a single bar, line, or other visualization object that displays a
single point or value, the Filter Chart and Exclude from Chart options are not available.

This applies when working in Live Preview and at run time.
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Procedure:
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Viewing Data at Run Time

When viewing data at run time, you can access the data behind each visual in your
visualization. Using the Show Data option, which is available from the Run-Time toolbar, you
can view your data in summary format. This grid display includes totals for the categories in
your visual, based on the data fields that you selected. All InfoAssist+ users can use this
option with the visualizations that are available to them.

How to View Data at Run Time

1. Run a visual or visualization from one of the following locations:
d From the Application Main Menu or Quick Access Toolbar in InfoAssist+.
.4 From the BI Portal.

2. In the bottom-right corner of the visual cell, click the arrow.

The Run-Time toolbar opens.

3. Click the Show Data button .
The visual changes to the grid view, displaying the underlying data for the selected visual.
Click the Show Data button again to return to your visual.

Note: The same run-time options are available when you run your visualization on a mobile
device.

Using the Run-Time Toolbar Options

You can access the Run-Time toolbar by clicking the arrow button, which is located in the
bottom-right corner of each visual cell at run time. The Run-Time toolbar is shown in the
following image.

The Run-Time toolbar options are described in the following table:

Icon Name Description

Show Data Alternates between the visual and the grid view,
which shows the underlying data. To return to the
visual view, click the Show Data button again.
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Icon Name Description

s Reset to Default Resets all changes and returns the visualization to its
original state.

Remove Filter Removes the filter and returns the visualization to its
original state. This option is only available if a filter is
applied at run time.

|:| Show/Hide Shows or hides the options on the Run-Time toolbar.

Note: The same run-time options are available when you run your visualization on a mobile
device.
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Chapter
Navigating Reports and Charts

Using features like Auto Drill, Auto Linking, and Multi Drill, you can easily navigate your
reports and charts. For information on additional report navigation options, see Creating
Customized Report Outputs.

In this chapter:
.4 Using Auto Drill
d Using the Auto Linking Feature to Link Content

4 Using Multi Drill

Using Auto Drill

Auto Drill enables you to navigate through different levels within the dimension hierarchy of
your data source. This allows you to review underlying data for a particular area, and move
through the structure of your data source based on your informational needs.

In order to use Auto Drill, you must enable it by clicking the Auto Drill button on the Format tab,
in the Run with group.

Once you have enabled Auto Drill, you can develop your report or chart and run it to activate
the hyperlinks that Auto Drill creates. This enables you to navigate up or down through the
related hierarchy of your data source by clicking the links that display.

When you click a hyperlink, the option to drill up or drill down displays, depending on where you
are in the hierarchy of your data. You can then select one of these options to begin navigating
your data. For example, if you have Product Category in your hierarchy, you would be able to
drill down to Product SubCategory. When you drill down, you can subsequently drill back up to
the originating dimension sort field. If you have selected a data source that has multiple levels
and your report or chart uses a component in the middle of the hierarchy, both the Drill up and
Drill down options will display. Once you have started navigating your data using the Drill up
and Drill down options, the Restore Original option displays, enabling you to start your data
analysis over by re-executing the original Auto Drill request.
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The drill up and drill down options are shown in the following image.

& |Report2[0]

Home — Accessories

Store Product

Continent  Subcategory Revenue Discount

Europe Charger $1,504,158.90 569,892 32
Headphones $28,460,260.95 $1,331,054.33
Universal Remote Controls P LT T

Restore Original
Drill up to Product Category
Dirill down to Model

At run-time, the Auto Drill functionality displays a breadcrumb header. This defines your current
location in the hierarchy of your data source and enables you to navigate back and forth
between different levels in your data.

Important:

.4 The Auto Drill functionality is only available for data sources that have a dimension
hierarchy.

-l If you have Auto Drill enabled and you attempt to run your report or chart in deferred mode,
the hyperlinks will not display. This is also true for Auto Drill enabled reports that are
distributed through ReportCaster.

4 With the exception of Visualization mode, Auto Drill is available at run-time, but not in Live
Preview.

- Auto Drill is supported for HTML and active report output format reports.

.4 Auto Drill is automatically enabled in Visualization mode for data sources that have a
dimension hierarchy.

.4 Auto Drill is not supported for all HTML output format charts, or for HTML5 output format
charts that do not support the new chart attributes syntax.

. Auto Drill is not supported on Across fields in active reports.

.4 You must use dimension fields as a sorting field, either BY or ACROSS.
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-l If you are creating a chart that has multiple dimension sort fields in the request and some
of these belong to the same dimension hierarchy, you may encounter multiple links with the
same label in the drill menu.

.4 When working in Document mode, Auto Drill is unavailable.

.4 Auto Drill functionality is not available in reports distributed by ReportCaster, because Auto
Drill uses live data, in an interactive session, for data drilling. Data values and totals may
not be the same if the data has changed since the last distribution. Mixing past data with
current data could impact data analysis.

-1 When Auto Drill is enabled, Accessibility is disabled. When Accessibility is enabled, Auto
Drill is disabled. In Chart mode, Accessibility is disabled, by default.

.4 Auto Drill is not supported with Save Parameters reports.

Procedure: How to Use Auto Dirill to Navigate the Hierarchy of Your Data Source
1. Select a data source that has a dimension hierarchy. For example, wf_retail_lite.mas.

2. Create a report or chart with one or more hierarchical fields (for example,
Product,Category), as shown in the following image.

[ Chart_Enabled[0] -1 X
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Accessories
Camcorder
Computers

Media Player
Stereo Systems
Televi

Video Product

Product Category

3. On the Format tab, in the Run with group, click Auto Dirill.
4., Click Run.
The report or chart displays.
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5. For reports, click a hyperlinked field within your report. For charts, hover over a chart

aspect (for example, a bar).

A menu appears, as shown in the following image.
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6. Select a hierarchical value to which to drill down to.

Once you have drilled down on a field, you can subsequently drill up.
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7. To return to the default state of the report or chart, click a hyperlink or hover over a chart
aspect, and then click Restore Original, as shown in the following image.

Home — Medis Player

280M

2400

200M
Product Subcategory: Blu Ray

MSRP: 243,779,705.05
Restore Original

160M Drill up to Product Category
Dill down to Model

[ Cost of Goods
MSRP
120M

&0OM

400

0 I — I
Blu Ray DVD Players DVD Players - Portable Streaming
Product Subcategory

Using the Auto Linking Feature to Link Content

Auto Linking makes it easy to connect reports and charts in your development environment,
expanding the reporting capabilities of your organization. Using Auto Linking, you can
dynamically link HTML reports, active reports, and HTML5 charts with a single report or chart of
any format, based on their common sort (BY) fields and parameters referenced in any filters. It
is this commonality that dynamically links content in your Db2 Web Query repository, allowing
you to discover new possibilities in your data, and explore new relationships within your
reporting enterprise. In addition, Auto Linking saves development time and effort, because
drilldowns do not need to be manually created and maintained.

To use Auto Linking, you must use the Enable Auto Linking option in InfoAssist+ to set the
reports or charts that can be auto-linked. In addition, you must also set reports or charts to be
Auto Link targets. The options to enable and disable Auto Linking and Auto Link Target
functionality are available on the Format tab, in the Auto Linking group, in InfoAssist+.

Note:

.4 The Auto Link Enabled option is activated only when the HTML, HTML5, and active report
output format is selected.
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-l You can open an existing report or chart and enable Auto Linking or set the item as an Auto
Link target.

When Auto Link functionality is activated, your reports or charts display a link for each sort (BY)
field with qualifying target reports or charts at run time. In Auto Link enabled reports, you must
add sort (BY) fields in the BY field container. In Auto Link enabled charts, you can add sort (BY)
fields to the Horizontal Axis, Vertical Axis, or Color field containers.

To qualify a report or chart as an Auto Link target, you must include filters that contain the
parameters that you selected as the sort field or fields in the enabled report or chart. The
parameter names defined in these filters must be the same as the sort (BY) field names in the
Auto Link enabled report. When you select a report or chart as the Auto Link Target, it specifies
that the parameter information should be catalogued, and will be evaluated when an Auto Link
enabled report or chart is run.

For an Auto Link enabled report at run time, the qualifying target reports and charts are those
that have filters with parameters for the selected sort field and the sort fields that precede it,
which appear to the left. For an Auto Link enabled chart at run time, the target reports and
charts are those that have filters with parameters for all sort fields. For run time for both
reports and charts, the linked sort field values in the Auto Link enabled report or chart are
passed to the Auto Link target report so that it can be filtered by the sort (BY) field values.

For example, you may have an Auto Link enabled report that contains sort (BY) fields Product
Category and Model, with a measure (Sum) field, Revenue. To qualify as an Auto Link target,
other reports or charts in your repository can contain a single filter with a parameter for
Product Category, or two filters with parameters for both Product Category and Model. When
you run the Auto Link enabled report, the Product Category field will link to target reports or
charts that have a filter with a parameter for Product Category and the Model field will link to
target reports or charts that have filters for both Product Category and Model.

If you use the same example for an Auto Link enabled chart instead of a report, you can
access the target reports or charts from a tooltip option that displays when you point your
mouse over an area of the chart, such as a bar that represents Revenue by Product Category
and by Model.
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Using Optional Parameters with Auto Linking to Enhance Drilldown Results

In addition to the basic Auto Linking functionality that is available in InfoAssist+, you can also
add optional parameters to your Auto Link reports and charts, extending the capability of this
feature. An Auto Link Enabled report can link to any target content that you are authorized to
access that satisfies the sort (BY) field to the Auto Link Target report filter parameter
requirement. Auto Link Target reports that satisfy this requirement and also have optional filter
parameters for other fields are included in the Auto Link target report evaluation, so that all
possible combinations of run-time parameters are evaluated and available as links as you run
the request. This may produce additional reports or charts in your list of available Auto Link
targets, offering you access to an expanded network of related content.

Setting a parameter to optional is not required because the Auto Link Enabled report will pass
the value for the fields being filtered to the Auto Link Target report. When a sort (BY) field value
in an Auto Link Enabled report is selected, that value and the value of its parent sort fields are
passed to the Auto Link Target. When a measure value in a chart is selected, all sort (BY) field
values for that measure are passed to the Auto Link Target. If you select the Optional option,
the Auto Link Target report can run on its own (from the Resources Tree or within InfoAssist+)
without being prompted by Autoprompt for a value for the parameter. This is because optional
parameters are assigned a default value.

With Auto Linking, you can link as many reports and charts as you want, and Auto Link Enabled
reports can also be an Auto Link Target which contributes to the development of a cascading
linkage of reports. For more information, see Using Filters to Customize the Display of Data.

Note:

. The linked reports displayed are limited to those that you are authorized to run or run
deferred.

.4 The Auto Link Enabled and Auto Link Target options can be set individually, or both can be
set on the same report or chart if that item meets the Auto Linking requirements.

.4 Consideration should be given to how many reports or charts are indicated as Auto Link
targets, as the run-time Multi-drill menu for the qualifying target reports may become long in
length. In these cases, some browsers may display a script processing warning message.

.4 Auto Linking utilizes the Multi-drill feature with cascading menus, except when running an
HTML report with On-demand Paging enabled or a chart request that is a legacy graph
format (PFJ-based formats, such as PNG and non-bucket HTML5), which will display a single
level list in the order the drill-downs are specified in the request.
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-1 The Multi-drill cascading menu displays:

- Horizontal lines to separate user-specified drilldowns and Auto Link navigation options.

- Auto Link Target reports in a single-level list that is sorted alphabetically, first by folder,
and then the Auto Link Target reports within the folder. This may differ from the sort
order of the resource tree that also applies the Properties Sort order option when
sorting folders and items within folders.

- When drilling down through a list of Auto Link target reports, a previously selected Auto Link

target report will be excluded so that the available Auto Link targets are reports that you
have not yet viewed.

How to Set an Existing Report or Chart as Auto Link Enabled

1.

On the BI Portal, select a file from within a folder, right-click, and select Edit.
InfoAssist+ opens in the relevant mode.
Verify that there is a sort (BY) field in the report or chart.

- For reports, sort fields are added to the BY field container.

- For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.
On the Format tab, in the Auto Linking group, click Enable Auto Linking.
Save the report or chart.

Your existing report or chart is now Auto Link enabled.

How to Set an Existing Report or Chart as an Auto Link Target

1.

On the Bl Portal, select a file from within a folder, right-click, and select Edit.
InfoAssist+ opens in the relevant mode.
On the Format tab, in the Auto Linking group, click Auto Link Target.

Note: Selecting Auto Link Target specifies that the parameter information for this report or
chart will be stored, adding it to the repository of reports and charts that will be evaluated
when an Auto Link enabled report is run.

Verify if the report or chart has an existing filter, as qualifying target reports are those that
have filters with parameters for the sort (BY) fields in Auto Link enabled reports or charts.
If a filter does not exist, add a filter with a simple parameter to the target report or chart.

a. From the Data pane, drag a sort (BY) field into the Filter pane.
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b. Using the Create a filtering condition dialog box, select Parameter as the Type and
use the default Name value, as shown in the following image. You may also select the
Optional check box.

,':r Create a filtering condition O x
,&? Mew Filter 4}? MNew Expression J Insart Before R Insert After a Group <@ Ungroup
K F

= ¥ WHERE
Product,Category Equal to <

Type: | Parameter -
Mame: PRODUCT_CATEGORY Description: Product Category:
* Simple Static Dyynamic
Optional
" 0K (§) Cancel
" OK & Cancel

Note: When creating a parameter for a field, the parameter name defaults to the
fieldname that you select. In the previous image, the creation of a filter with
parameter Product Category is shown. To ensure that the name of the parameter is
the same as the sort (BY) field in the Auto Link enabled report or chart, do not change
the name of the parameter that is generated by your field selection.

c. Click OK, and then click OK again to exit the Create a filtering dialog box.
Save the report or chart.

Your existing report or chart is now set as an Auto Link target.

Procedure: How to Create a New Auto Link Enabled Report or Chart

1.

2
3.
4

Open InfoAssist+ in Report or Chart mode.

From the Open dialog box, select a data source.

On the Format tab, in the Auto Linking group, click Enable Auto Linking.
Add fields to the report or chart, ensuring that one is a sort (BY) field.

.4 For reports, sort fields are added to the BY field container.
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-1 For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.

=] Query i Live Preview (500 Records)
4 |E] report (wi_retail_lite)
4 F sum
B Discount Froduct
a E By Category Discount
B Product,Category Accessories $6,014,845.52
= Across Camcorder $7,108,408.27
Computers 54.808,910.10
Media Flayer 511,519,142 41
Stereo Systems $13,630,873.57
Televizions 53,635,683.38

Video Production £2,695,890.76

5. Save the report or chart.

Your report or chart is now set as Auto Link Enabled.

Procedure: How to Create a New Auto Link Target Report or Chart
1. Open InfoAssist+ in Report or Chart mode.
2. From the Open dialog box, select a data source.
3. On the Format tab, in the Auto Linking group, click Auto Link Target.

Note: Selecting Auto Link Target specifies that the parameter information for this report or
chart will be stored, adding it to the repository of reports that will be evaluated when an
Auto Link enabled report is run.

4, Add fields to the report or chart.
Add a filter with a simple parameter to the target report or chart.

a. From the Data pane, drag a sort (BY) field into the Filter pane.
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b. Using the Create a filtering condition dialog box, select Parameter as the Type and
use the default Name value, as shown in the following image. You may also select the
Optional check box.

J Create a filtering condition ox
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W 0K (8 Cancel

" OK &) Cancel

Note: When creating a parameter for a field, the parameter name defaults to the
fieldname that you select. In the previous image, the creation of a filter with
parameter Product Category is shown. To ensure that the name of the parameter is
the same as the sort (BY) field in the Auto Link enabled report or chart, do not change
the name of the parameter that is generated by your field selection.

c. Click OK, and then click OK again to exit the Create a filtering dialog box.
6. Save the report or chart.

Your report or chart is stored as an Auto Link target.

Procedure: How to Run an Auto Link Enabled Report or Chart
You can run an Auto Link enabled report or chart from within InfoAssist+ or from the Bl Portal.

1. Open and run an Auto Link enabled report or chart in one of the following ways:

. In InfoAssist+, open or create an Auto Link enabled report and on the Quick Access
toolbar, click Run.

.4 From the Bl Portal, right-click a report or chart that is Auto Link enabled and click Run.
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Id Reports. Displays with hyperlinks on the sort (BY) fields that have qualifying target

reports. Click a hyperlink to display the menu with the Auto Links option, which
cascades to list the qualified Auto Link target reports and charts, as shown in the

following image.

2. Use the hyperlinks to link to other reports and charts, based on the following information:

Product Quantity

Category Revenue Sold Cost of Goods Gross Profit
Accessories w Sales 2015 511,667 $89,753,890.00 $359,854,44053
Camcorder Sales 2014 455244 $104,666,857.00 $49595,84524
Computers $103.31_6:4B2.12 31,777 569.807,664.00 $33,508,518.12
Media Player $246,073,055 36 771,934 5$190,240,4581.00 $55,83257836
Stereoc Systems  $291,294,933.52 1,114,332 §$205,113,863.00 $586,181,070.52
Televisions $78,381,132.81 105,188  561,551,109.00 $16,830,023.81
Video Production  $58,053,276.62 199,749  540,1065657.00 $17,947.619.62
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-1 Charts. Displays with aspects over which you can hover (for example, a bar) in the
chart. A tooltip displays with the Auto Link target reports and charts, as shown in the
following image.
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Using Multi Drill

The Multi Drill functionality enables you to create multiple drill down links on a data field in a
report or chart. This is useful when you want to define custom links to other visualizations,
charts, reports, InfoMini procedures, or external URLs.

Using the Multi Drill functionality, you can define conditions for drilling down or through the
data element that you select. Once drill down information is saved and you run the report or
chart, the drill down options display when you click or hover over the defined area of a report or
chart, respectively.
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You can create drill down links by selecting a field in the Query pane. On the Field tab, in the
Links group, click Drill Down to open the Drill Down dialog box. You can also right-click a field in
the Query pane, and click Drill Down. The Drill Down dialog box is shown in the following image.

#Y Drill Down - Quantity, Sold x

B X

® Report Rafresh BI Portal Web Page
Report*®
Browse
Description
Drill Down 1

Target

New Window -

Parameters

Name Value

= Required Field

0K

When you access the Drill Down dialog box, the name of the field that you selected displays in
the title bar. This enables you to identify the current field and is useful when working with Drill
Down parameters.

In the Drill Down dialog box, you can configure a hyperlink or drill-down procedure. When you
run the report, you can click the link that is created, which would take you to the specified URL
or execute the specified procedure.

You can also create multiple drilldowns for a selected field. The drill down links that you define
display as separate entries in the drill down list, also known as the drill menu, at run-time. The
display of these entries is based on the naming conventions that you applied when creating
the multi-drill scenario.
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Once your drilldown options are defined, you must run your report in order to access the drill
down links that you have created. For reports, the links display when you click on a hyperlink
for the data field that you selected. For charts, they display when you hover over an area of the
chart for which the drill down has been defined (that is, the field that you selected when you
defined the drill down).

These links enable you to drill directly through to an external procedure or URL.

For example, you can create one drill down link for an existing procedure, and another for a
webpage. Both drill downs are stored for the underlying field that you selected. Once you
define the first drill down, additional options display on the toolbar, as shown in the following

image.
‘% Drill Down - Product,Category x
*¥ BB X &
Margin by Product Category # Report Refresh BI Portal Auto Link Target Web Page
Report™

1BFS:/WFC/Repository/Retail_Samples/Reports/Margin_by_Proc

Description

Margin by Product Category

Target
Same Window =
Parameters &l
Name Value
* Required Field
W OK (S Cancel

Note: You can rename a drill down using the Description field in the right pane of the Drill
Down dialog box.
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The following icons are available on the Drill Down dialog box toolbar:

-1 Create a new drill down. This option is enabled when all required information is provided
for the first drill down. When you click Create a new drill down, a new drill down item is
created. This switches the drill down functionality from a regular drill down to multi-drill. By
default, the name of the drilldown is Drill Down n, where n is a consecutive integer, such as
Drill Down 1, Drill Down 2, etc. This option is initially disabled, but is enabled after you
have created at least one drill down link.

-1 Duplicate the selected drill down. When an existing drill down item is selected, clicking
this option duplicates the item. A (Copy n) is appended to the name of the drill down, where
n is the consecutive number assigned to the duplicated drill down. Once assigned, the
name can subsequently be changed in the Description field. Consecutive copies can also
be rearranged by dragging the drill down items into the desired order.

Note: The Duplicate button is only active when sufficient information is available for the
selected drill down item.

-1 Rename the selected drill down. This option enables you to rename an existing drilldown
and is active, by default. When this option is selected, the Description field is selected,
allowing you to provide a new name for the drill down link. You can enter a description up to
100 characters long. If you remove the description, the drilldown is renamed to the default
name.

-l Remove the selected drill down. If you have a drill down item selected, the Remove the
selected drill down option is active. When you select this option, the current drilldown is
deleted. If a drill down item is removed, the next drill down item is automatically selected. If
you remove the last drill down item, the Drill Down dialog box resets to its initial state,
restoring Drill Down 1 as the default value.

-l Options. The Options functionality enables you to change the order of your drill down items.
This allows you to control the order in which the items are presented in the drill menu when
you run your report and click on a hyperlink. You can change the order by selecting a
defined drill down in the list that is presented under Edit Order and then clicking the Move
Up or Move Down button. You can also remove one or more drill down items from the list by
selecting the desired items and then clicking the Remove from List button. If you multi-
select your drill down items using the CTRL key, the Move Up and Move Down buttons are
disabled.

Note: Move Up, Move Down, and Delete are also available as context menu options when
you right-click a drill down item in the Edit Order list.

The Drill Down dialog box contains the following options for specifying drill down information for
the selected field:

326 IBM



7. Navigating Reports and Charts I

Note: When specifying parameters for your drill down, click Add Parameter to add them to your
parameters list.

- Report. Select this option to choose a report for the current drill down. This option is
selected by default.

4 Report. Enables you to browse to a stored report.

.4 Description. Provides a field in which to describe the report. If you selected a report by
browsing, this field is automatically populated with the title of the procedure or the
name where procedure titles are not accessible. This field is also used to rename a
specified drill down.

.4 Target. Allows you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value for report is New Window.

d Parameters. Displays the parameters that you have indicated for the current drill down.

Note: When you drill down to an InfoMini report with dynamic parameters, the child report is
generated with the filter condition set by the parent report applied. You can access the
AutoPrompt dialog box by clicking the Show filter panel button to modify the data selection
with InfoMini.

4 Refresh Bl Portal. Select this option to refresh the components of the Bl Portal and pass
parameters to them.

.d Refresh. Provides options by which to refresh the page. Options include Current Page
and All Pages.

.4 Description. Provides a field in which to describe the refresh process. This field is also
used to rename a specified drill down.

- Target. Reflects the target for the drill down. The only applicable value for Refresh Bl
Portal is Same Window.

4 Parameters. Displays the parameters that you have indicated for the current drill down.

4 Auto Link Target. Select this option to create an explicit list of Auto Link targets. Upon
selection, these will be available in the drill down menu at run time.

Note: When working with reports, the Auto Link Target drill down option is only available for
a selected dimension (BY) field. For more information, see Using the Auto Linking Feature to
Link Content on page 315.

4 Auto Link Target. Enables you to browse to a stored target report.
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-

Description. Provides a field in which to describe the target report. If you originally
selected a report by browsing, this field is automatically populated with the report title
or the name where titles are not accessible. This field is also used to rename a
specified drill down.

Target. Enables you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value for Auto Link Target is New
Window.

Parameters. Displays the parameters that meet the column-to-parameter requirement
for the selected target report.

For more information, see Using the Auto Linking Feature to Link Content on page 315.

d Web Page. Select this option to indicate that you want to drill through to a webpage. Enter
a value in the URL field.

.

URL. Enables you to specify the URL for the webpage to which to drill down. This option
is available only when Web Page is selected.

Description. Enables you to enter additional comments related to the drill down. This
field is also used to rename a specified drill down.

Target. Enables you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value is New Window.

Parameters. Displays the parameters that you have indicated for the current drill down.
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Procedure:

If you are working with a report that has parameters, the parameter names are automatically
retrieved and made available from the Name control in the Parameters section of the Drill
Down dialog box, as shown in the following image.

% Drill Down - Product,Category X
* B3 X &
Rl ® Report Refresh BI Portal Auto Link Target Web Page
Report™
IBFS:/WFC/Repository/Retail_Samples/Reports/Auto_Link/YTD_ Browse
Drescription

¥TD Stats for Product Category

Target
Same Window i
Parameters )
Hame ' Name:
PRODUCT_CATEGORY l}
Type:
Field -
Value:
* Reguired Field Product, Category -

o OK
(S) Cancel

By default, the field is labeled with a value of Name. If there are multiple parameters to choose
from, you can use the drop down list to make a selection. You can also manually enter a name
to create a new parameter. The parameters that display are populated from the underlying
report procedure (.fex) that you selected for your drill down.

The Type field enables you to specify a field or constant value. The options in the Value list are
based on the fields that you selected for your report. The item that you select determines the
value for the parameter (for example, Discount or Revenue).

Note: If you switch the Type field from Field to Constant or from Constant to Field, the Value
field is reset, enabling you to specify a unique value.

How to Create a Single Drill Down Link
You can create a single drill down link on a measure field.

1. Create a report or chart with at least one measure field.

Db2 Web Query InfoAssist+ Part 1 329



Using Multi Drill

Procedure:

330

In the Query pane, do one of the following:

- Right-click the measure field and click Drill Down.

- Click the measure field and on the Field tab, in the Links group, click Drill Down.
The Drill Down Dialog box displays.

Select one of the following Drill Down options:

-1 Report

- Refresh BI Portal

- Auto Link Target

- Web Page
Populate the fields based on the drill down option you selected.
Note: Descriptions for these fields are provided earlier in this topic.

Optionally, rename the Drill Down using the Description field. This dictates how the Drill
Down will appear in the left pane of the Drill Down dialog box.

Click OK.

The drill down link displays when you hover over the defined area of a report or chart, at
run time.

How to Create Multi Drill Links

You can create a multiple drill down links on a single dimension field.

1.
2.

Create a report or chart with at least one dimension field.

In the Query pane, do one of the following:
d Right-click the dimension field and click Drill Down.
- Click the dimension field and on the Field tab, in the Links group, click Drill Down.

The Drill Down Dialog box displays.

Select one of the following Drill Down options:
- Report
- Refresh Bl Portal

- Auto Link Target
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-1 Web Page
4. Populate the fields based on the drill down option you selected.
Note: Descriptions for these fields are provided earlier in this topic.

5. Optionally, rename the Drill Down using the Description field. This dictates how the Drill
Down will appear in the left pane of the Drill Down dialog box.

6. Repeat steps 3-5 until you have added all of the drill down links required.

Note: The following image defines three unique drill down links for the selected dimension

field.
‘% Drill Down - Product,Category X
#*¥ MR X &

Margin by Product Catego
£ e # Report Refresh BI Portal Auto Link Target Web Page

YTD Stats for Product Category Report*
Quantity Sold By Stores 1BF5:/WFC/Repository/Retail_Samples/Reports/Margin_by_Proc Browse

Description

Margin by Product Category

Target
Same Window =
Parameters @
Hame Value
* Required Field
" OK 5% Delete all and exit

7. Click OK.
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The links display when you hover over the defined area of a report or chart, at run time, as

shown in the following image.

Product Category: Stereo Systems
Discount: $13,530,873.57

Y¥TD Stats for Product Category
Margin by Product Category
Quantity Sold By Stores @

Auto Links >

Stereo Systems Televisions
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Chapter

Styling Reports, Charts, and
Visualizations

You can style and customize reports, charts, and visualizations using the ribbon.

In this chapter:

.4 Customizing Reports

Using the Report Style Dialog Box

Using the Color Dialog Box

Accessing Reporting Options in the Report Group
Enabling Report Features

Enabling Chart Features

Labeling Charts

Using Interactive Options

Customizing Page Setup

Customizing Reports

You can customize reports using the various options on the Layout tab and Field tab.

.4 Cell Padding. Opens the Cell Padding dialog box, where you can set specific values to
control the amount of space inserted between rows and columns in a report. For more
information, see How to Use Cell Padding in a Report on page 89.

.4 AutoFit. Limits the width of columns in a report to be no wider than the largest value in
each column. When additional fields are added, the report automatically grows at design
time. AutoFit Column is selected, by default.

d Page Break. Starts a new page when the primary sort field changes. Clicking the drop-down
icon enables you to select Reset Page Numbers, which allows you to reset page numbers
on a page break to start at 1.

- Line Break. Inserts a line in the report output when the primary sort field changes.

Db2 Web Query InfoAssist+ Part 1 333



Customizing Reports

334

-1 Sub Header. Opens a dialog box where you can type text to add a subheading just below
the column titles in the report output when the primary sort field changes.

. Sub Footer. Opens a dialog box where you can type text to add a subfooting at the end of
the data on each page of the report output when the primary sort field changes.

. Subtotal. Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields
when the primary sort field changes.

The drop-down menu on the Field tab, in the Format group provides three field-type options for
the selected column, which are Alphanumeric, Integer, and Decimal. Selecting the fourth
option, More options, opens the Field Format Options dialog box, which provides further
formatting options for the selected field. For more information, see Changing a Field Format on
page 90.

Using the Currency Symbol drop-down list, you can apply options such as floating and non-
floating currency. You also apply percent sighs and commas using the check boxes on the
Field Format Options dialog box.

To turn on the non-floating currency option, open the drop-down menu and select Non floating
Currency. To turn off the non-floating currency option, click the Currency Symbol drop-down list
again and make a different selection, or choose None.

The following options on the Field tab, in the Display group:

.4 Hide Field. Allows you to hide a selected field.

. Hide Missing. Allows you to hide fields that have no value.

d Aggregation. Opens a drop-down menu of the following options:
4 None (default)

Sum

Average

Count

Count Distinct

Percent of Count

Distinct Values

L U U U U U U

First Value

IBM



8. Styling Reports, Charts, and Visualizations I

Last Value

Maximum

Minimum

Total

Percent

Row Percent

Median

L U o U v uJ o U

Average Square

Sum is the default aggregation type value for all numeric fields added to the Measure Query
field container in the Query pane. Changing the Measure Query field container from Sum to
Print, Count, or List overrides all assigned aggregation type values. For more information
related to reports, see How to Display Numeric Measure Data Using Aggregation Options in a
Report on page 99. For more information related to charts, see How to Display Aggregations
on Measure Data on page 154.

. Traffic Lights. Opens the Traffic Light Condition dialog box. From this dialog box, you can
do the following:

.4 add new conditional styling by applying traffic light (and other) colors to a selected field
in the output when the field meets specified criteria

.4 modify existing conditional styling

4 enable conditional drill-down

For more information related to reports, see Styling Reports on page 80. For more
information related to charts, see Traffic Light Condition Dialog Box on page 143.

. Data Bars. (Reports only.) Adds a data visualization column to the right of a selected
numeric field. The column displays values in each row using horizontal bars that extend
from left to right in varying lengths, depending on the corresponding data values. For more
information, see How to Add Data Visualization Bars to a Report on page 99.

. Within. Allows you to use specific aggregation tasks at different report levels. You can use
the Within phrase to manipulate display field values as they are aggregated within a sort
group rather than a report column. For more information, see How to Access the Within
Functionality on page 99.
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Column(s). Allows you to indicate the number of columns in which you wish to display
multiple graphs. The value can be between 1 and 512. The default is 1. This option is also
available from the Query pane shortcut menu for a Multi-graph component.

Using the Report Style Dialog Box

336

The Report Style dialog box provides options to style your report, as described below. You can
access this dialog box by clicking Style on the Home tab, in the Report group.

@ Report Style x
ARTAL - g -
B ru E== @Bt $ 2
Preview
ARIAL 9

L U oo o U

W« OK (%) Cancel 2 apply

Font. Use the drop-down menu to change the font.

Font size. Use the drop-down menu to change the numeric value for the font size.

Font style. Click the appropriate button (bold, italic, underline) to style the selected text.
Text alignment. Click the appropriate button (left, center, right) to align the selected text.

Font Color. Click the button to open the Color dialog box, where you can select the font
color. For more information, see Using the Color Dialog Box on page 337.

Background Color. Click the button to open the Color dialog box, where you can select the
background color for the report.

Currency Symbol. Click the button to access the following currency symbols US Dollar,
British Pound, Japanese Yen, Euro, New Israeli Shekel.

Note: The New Israeli Shekel currency symbol can be displayed with the following settings
only:

4 Server codepage = 1255, 65001, 424, or 65002.
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-1 Client codepage = 1255 or 65001.
.4 Application server encoding = Cp1255 or UTF8.
.4 Font name = Lucida Sans Unicode or Arial Unicode MS.

Reset to Quick Styles from Template. Click the button to reset all settings to the default
settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must use
the Undo command on the Quick Access Toolbar.

Using the Color Dialog Box

The Color dialog box provides options for working with color in your report.

The Color dialog box options are:

_I

_I

L U o U

Standard Color Swatches. Provides a set of 48 predefined colors from which to choose on
the left side of the dialog box. Your selection appears in the Selected Color field.

Custom Color Palette. Provides a palette on the right side of the dialog box to define a
custom color. Your selection appears in the Selected Color field.

Luminosity bar. Drag the slider to change the luminosity (relative lightness or darkness) of
a color. The corresponding numerical value appears in Lum.

Hue. Indicates the hue value of your selected color. You can enter a value, or increase or
decrease the hue value by using the up and down arrows, respectively.

Sat. Indicates the saturation value of your selected color. You can enter a value, or
increase or decrease the saturation value by using the up and down arrows, respectively.

Lum. Indicates the luminosity (lightness or darkness) of your selected color. You can enter
a value, or increase or decrease the luminosity value by using the up and down arrows,
respectively.

Red. Represents the numeric value of red (0 to 255).
Green. Represents the numeric value of green (O to 255).
Blue. Represents the numeric value of blue (0 to 255).

Selected Color. Displays the color that you selected.
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- Transparent. Makes the color transparent. This is only available for background colors.

Accessing Reporting Options in the Report Group

338

The Report group contains commands to enhance a report.

4 Theme. Opens a dialog box where you can select a theme to style your report. You can use
the default style sheet by clicking the Use Default Stylesheet button.

You can also select a document styling theme or an application theme to style all reports
created. Use the Environment and Styling section of the Options window, which is
accessible by clicking Options in the Application main menu.

.4 Style. Opens the Report Style dialog box for applying global styling to the entire report. For
more information about the Report Style dialog box, see Using the Report Style Dialog Box
on page 336. For more information about styling reports, see Styling Reports on page 80.

.4 Banded. Opens a Color dialog box for choosing a color that provides an alternating color
scheme for the report. The report output displays alternating rows of data, using a white
background for one row and a background of the selected color for the next row. This
pattern continues throughout the report. For more information about the Color dialog box,
see Using the Color Dialog Box on page 337. For more information about banded styling,
see How to Style Rows of Data With Alternating Colors in a Report on page 85.

d Header & Footer. Opens the Header & Footer dialog box, from which you can add and style
headings and footings.

4 For a report, you can add and style report headings, page headings, page footings, and
report footings. In the dialog box, the tab for Report Header is active, by default.

. For a chart, you can add and style page headings and page footings. Page Header is
active, by default.

d You can drag fields from the Data pane into the Header & Footer dialog box.

Another way to access the Header & Footer dialog box is to click the down arrow next to the
Header & Footer button. It opens a drop-down menu from which you can select the heading
or footing that you want to work with (Report Header, Page Header, Page Footer, Report
Footer). After you make your selection, the Header & Footer dialog box opens, and the
heading or footing that you selected is active.
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From the Header & Footer dialog box, you can add and style the active heading or footing,
or choose a different heading and footing to work with by selecting the applicable tab. You
can switch among tabs, but InfoAssist+ does not save changes made on the tabs until you
click Apply or OK. If you click Apply, the Header & Footer dialog box remains open. If you
click OK, the dialog box closes.

You can style a selected heading or footing using the options on the styling toolbar. From
left to right, you can customize the font type, font size, and font style (bold, italic, or
underline). You can justify text (left, center, or right), select the font color and background
color, and restore styling settings to their default value from the template.

You can also add page footings to your reports or charts. From the Header & Footer dialog
box, select Page Footer. When working with reports, you may use the Additional alignment

options icon Ei T to specify whether you want to align the footer relative to the data
(default) or relative to the page. The Align Relative to Data option places the footer directly
below the data, and the Align Relative to Page option positions the footer at the bottom of
the page. When working with charts, only the default page footer alignment option is
supported.

Note: The Align Relative to Page option works with reports that use positioned formats (for
example, PDF, PS, DHTML, PPT, and PPTX).

You can also insert quick text into a heading or footing. Quick text is supplied for you. It
includes information that is typically useful in identifying a report or chart. From the
preformatted text drop-down menu, you can select:

Draft
Page X of Y
Confidential

1

1

1

4 Date (multiple formats)
- Time (multiple formats)
1

Created by (followed by a name)

For charts, an icon Iﬂ T on the far right of the styling ribbon is enabled. This icon provides
two options for controlling the way in which the page heading and page footing are
rendered. The default option, Create Header and Footer as text, renders the heading and
footing as text elements that are separate from the chart image. The option, Embed Header
and Footer in the chart, renders the heading and footing text as part of the chart image.
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Once you have added a heading or footing to a report or chart, you can double-click it on
the canvas in design mode to reopen the Header & Footer dialog box. You can also right-
click an existing heading or footing in design mode and click Edit from the menu to open
the dialog box.

For more information on adding and styling headings and footings, see How to Add
Headings and Footings to a Report on page 82 and Formatting Page Headings and Page
Footings on page 212.

-1 Column Totals. (Reports only) Adds a grand total row to the bottom of the report to sum
numeric data in each column. For more information, see How to Add Column Totals to a
Report on page 98.

d Row Totals. (Reports only) Adds a grand total column to the right side of the report to sum
numeric data in each row. For more information, see How to Add Row Totals to a Report on
page 98.

Enabling Report Features

The options on the Format tab, in the Features group, while in Report mode, allow you to add
pop-up titles to columns, stack measures, and more.

. Title Popup. Displays pop-up titles when the mouse pointer hovers over a column title in
the report output. For more information, see How to Add Pop-Up Titles to a Report on page
98.

4 Accordion. Creates expandable views of data for each vertical sort field. This option
displays data values only for the first vertical sort field when you first view the output. You
can manually expand your view to expose the data values of lower-level sort fields. For
more information, see Create Accordion Reports.

Note: You cannot use the Table of Contents with the Accordion feature.

d Repeat Sort Value. Displays all repeated sort values instead of blanks in the output after
the first instance of a new sort value, which is the default behavior.

-1 Stack Measures. Displays all numeric measure field names in a column of the report
output with the corresponding numeric data values. For more information, see Implement
Stack Measures.

.1 active report options. Opens the active report options dialog box where you can configure
your active report options such as menu items, graph engine, and colors. For more
information, see Creating Active Technologies Components With InfoAssist+.
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- Accessibility. Allows a title to be added to a report, chart, or document that is Section 508-
compliant.

The following table lists the output for which each feature is available. Yes means the output is
available for the feature. No means that the output is not available for the feature.

HTML HTMLS active PDF active Excel PowerPoint
report PDF

Title Popup yes no no no no no no
Accordion yes no yes no no no no

Repeat Sort Values yes yes yes yes yes yes yes

Stack Measures yes no no no no no no

active report options no no yes no yes no no
Accessibility (reports, yes no no yes no no no

charts)

Accessibility (documents) | no no no yes no no no

Enabling Chart Features

The options on the Format tab, in the Features group, when in Chart mode, allow you to add
effects and different functionality to your charts.

Note: When working with maps, all options in the Features group are disabled with the
exception of Frame & Background and Accessibility.

4 3D Effect. Sets the three-dimensional view to on or off. The 3D Effect feature is disabled
for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.
This is the default.

-l Rotate. Toggles between a vertical display or horizontal display of a chart. For more
information, see How to Rotate a Chart on page 215. The Rotate feature is disabled for pie,
scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart
types.
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Reference. Opens a drop-down menu that provides the Add Reference Line to Y-Axis and
Add Reference Line to X-Axis options. Selecting one of these options opens the appropriate
Reference Line dialog box, where you can set the specific X-axis or Y-axis value, type the
text that you want, and position the reference line on a chart. For more information, see
How to Display a Static Reference Line on page 216. The Reference feature is disabled for
pie, 3D, stock, gauge, gauge thermometer, spectral map, and funnel chart types.

Annotate. Opens a drop-down menu that provides the Add an annotation option. Selecting
this option opens the Annotation dialog box, where you can type the text that you want and
position the annotation on a chart. For more information, see How to Display Annotations on
page 219.

Note: The annotation option is not available in HTML5.

Grid. Opens a drop-down menu allowing you to expand options for Horizontal or Vertical
Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking
More Options opens the Format Grid Lines dialog box. For more information, see Formatting
Gridlines on page 173.

Frame & Background. Opens the Frame & Background dialog box where you can edit the
background style and frames for charts. The dialog contains different options depending on
the chart type selected. For more information, see Formatting a Frame and a Background
on page 193.

Gauges. Opens the Gauge dialog box where you can edit your gauge chart. This button is
only available when a gauge chart type is selected. For more information, see How to Style
a Gauge Needle on page 211.

active report Options. Opens the active report options dialog box where you can configure
your active report options, such as menu items, graph engine, and colors. This button is
available when the output type is set to active report or active PDF.

Accessibility. Allows a title to be added to a report, chart, or document that is Section 508
compliant. This option is only available for reports and charts when the output type is HTML
or PDF. For documents, the output type must be set to PDF.

Note: The chart features are unavailable when designing a chart that will be output in active
report or active PDF formats.

Labeling Charts

You can add labels to charts using the Labels group on the Format tab.
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Note: When working with maps, the Axes option is disabled.

.4 Axes. Opens a drop-down menu, where you can enable, stagger, and rotate horizontal and
vertical axis labels. You can also edit the axis labels by clicking More Horizontal Axis
Options or More Vertical Axis Options. For more information, see Formatting Axis Labels on
page 183.

4 Legend. Opens a drop-down menu, where you can select the Show Legend option to display
the legend on the chart, or clear your selection to hide the legend, change the default
legend position, and change the default legend orientation. For more information, see
Format Legend Dialog Box on page 168.

Using Interactive Options

To add interactive options to a chart, on the Format tab, in the Interactive Options group, click
Interactive Options.

Note: The Interactive group is enabled only when the HTML5 output format is selected for your
chart.

When you click Interactive Options, the Interactive Options dialog box displays. The Interactive
Options dialog box enables you to specify animation, mouse over, and scrolling effects in your
chart.

@ Interactive Options x

EziEw General

Animation

Animate Once

Duration 1400 = ms

-

Mouse Over

#| Enable Hover Over Effect

Scrolling

#| Auto Enable X-Axis Scrolling

" OK () Cancel 2 Apply
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Options on the Interactive Options dialog box include:

Animation section

-l Show Animation. Enables you to specify options for animation in your chart. Clear this
check box to disable animation. This option is selected by default.

Note: If the Show Animation check box is cleared, the option to Animate Once is not
available.

- Animate Once. Enables you to specify the frequency of chart animation. Select this check
box to indicate that the chart should be drawn the first time a procedure is executed, but
not on subsequent executions of that procedure. If this check box is not selected, the chart
will animate every time the chart is redrawn.

- Duration. Defines the duration of the animation in milliseconds. You can manually enter a
millisecond value (ms) or use the arrows to adjust the default value, which is 1400. This
value may vary depending on the theme that you select.

Note: When specifying a duration for an animation, larger numbers produce slower
animation.

Mouse Over section

- Enable Hover Over Effect. Controls the display of the mouse over indicator, which shows
chart component information when you hover your mouse over an object. This option is
selected by default. However, settings in your theme may override this setting.

Scrolling section

1 Auto Enable X-Axis Scrolling. Enabled by default in Visualization mode, this option controls
the display of scroll bars for bar, line, area, scatter, bubble, and all matrix charts. In all
other modes, you must enable the functionality in the Interactive Options dialog box on the
Format tab. If you are working with a large dataset, this functionality enables you to use
scroll bars to review your data from left to right. If your dataset is smaller, the scroll bar
functionality automatically determines if a scroll bar is needed. You can disable and re-
enable this option, depending on your display or data viewing requirements.

344 IBM



8. Styling Reports, Charts, and Visualizations I

Customizing Page Setup

You can customize how your pages display when working with reports, charts, documents.
These options can be found on the Layout tab, in the Page Setup group.

. Margins. Enables you to set margin values by choosing Normal (1 inch all around), Narrow
(.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom.
Choosing Custom opens the Margins dialog box, where you can set specific margins as
needed.

.4 Orientation. Enables you to set the orientation of your report to portrait or landscape.

. Size. Enables you to select the size of the paper for printing output. You can choose A3,
A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size (34 x 44 Inches).

.d Units. Enables you to select the unit of measurement used for customizing the dimension
fields of your report or chart. You can choose Inches, Centimeters, or Points.

.d Page Numbers. (Reports only). Enables you to select page numbering options. You can
choose one of the following:

.4 No Lead (no space for headers)
.4 On (page numbers only in headers)

4 Off (space for headers, but no page numbering)

The Page Numbers value is overridden by header and footer text options.
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Chapter

Creating Maps to lllustrate Trends

Using InfoAssist+, you can create maps to identify patterns or trends in your data. By
converting data into values that can be displayed on a map, you are able to visualize
scenarios, illustrate hot spots, and identify potential problem areas. For example, a law
enforcement agency may use mapping functionality to identify areas of higher crime
within the locations they cover. You can also use maps to determine how places are
related, understand where things are located, and identify the best actions to take. By
illustrating trends on a map, a decision maker can identify patterns easily, and reach
conclusions sooner.

In this chapter:

.d A Brief History of Mapping

.  InfoAssist+ and Esri Integration
.4 Adding a Custom Geographic Role
d

Enabling Additional Territories in a Leaflet Map
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An early example of how maps can be used to illustrate trends is the case of Dr. John Snow,
an epidemiologist who was one of the first to use data to map occurrences of cholera to find
the cause of infection. By plotting the cholera data on a map of a town, Dr. Show was able to
visualize a trend that showed higher incidences of cholera closest to water pumps. This
example is shown in the following image.

Maps also allow you to measure size, shape, and distribution to detect and quantify patterns,
and even perform predictive analytics. An example of how maps can help detect and quantify
patterns is the scenario in which a state agency used a Db2 Web Query mapping application to
solve a problem with their food stamp system. Using this application, odd food stamp
redemptions, such as rounded numbers transactions, were discovered. By plotting those
transactions on a map, the agency discovered that the redemptions appeared in the same
geographic location. Upon further investigation, the agency identified that individuals were
selling their food stamps at reduced prices, $50 worth of food stamps for $40 in cash, to
others instead using them as intended. This map example is shown in the following image.

itizen l: 1

Jane Smith 01/03/2015 35.26

Jane Smith 01/05/2015 44.12
Jane Smith 01/10/2015 12.42
John Wilson 01/02/2015 100.00
John Wilson 01/08/2015 50.00
John Wilson 01/11/2015 75.00
Mary Johnson 01/03/2015 23.24
Mary Johnson 01/06/2015 14.32
Mary Johnson 01/11/2015 34.88
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When working with maps, the concepts of location intelligence and business intelligence are
important to understand. A Geographic Information System (GIS) captures, stores, analyzes,
manages, and presents data linked to a location, while Business Intelligence (BI) relies on the
conversion of raw data into meaningful information. Location intelligence is the process of
analyzing data to make better business decisions. It combines GIS and Bl/Analytics to allow
the recognition of patterns in your data, including the visualization and discovery of geospatial
outliers, which would not be easily discovered if you use the technology independently and
separately.

More specifically, maps use non-intrusive GIS workflows with existing data. You can view
symbol layers for data bound to a geo-location, such as state, country, and ZIP code, in an
integrated map viewer. Using metrics from your data, you can also visualize geographic roles or
dimensions. Geographic roles, or dimensions, can be built directly into your Metadata or
assigned to a data field when you create a map.

InfoAssist+ and Esri

Integration

Using Db2 Web Query InfoAssist+ with the Esri integration, you can create maps that help you
illustrate or identify trends so you can take action quickly. Db2 Web Query architecture
provides the framework in which this system operates. Using a JavaScript map viewer, you can
navigate the interface easily, as shown in the following image.

- E=

+
-8 Navigation Tools Tahle of Contents

Legend I

Tooltip
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In addition, this integration utilizes the capabilities of Esri by leveraging the ArcGIS JavaScript
API and content. Specifically, you can integrate data into maps with published content in
ArcGIS Online platform. For more information, see http://www.esri.com/software/arcgis/
arcgisonline. Additionally, by using this integration, you can include information about
demographics, spending habits, crime, and lifestyle to maps that contain your data. These
maps include layers with extensive demographic or reference detail and topography and allow
you to view information about people, businesses, climate, and much more.

You can create the following maps in InfoAssist+:

.4 Choropleth. A common thematic map that uses geographical measures (for example,
states and countries), representing the values aerially while employing a varying intensity of
colors. It is useful for visualizing location-based data, trends, and distributions across a
geographic area. The color hues for Choropleth maps are dictated by the legend, based on
the selected measure, enabling you to determine data concentration across your map.

4 Proportional Symbol (Bubble). A map that represents coordinates, such as an address or
intersection, using symbols of different sizes to represent any measure. These maps focus
on specific areas, for which data concentrations may vary. When the data concentration is
larger, the bubble will be bigger.

Both maps can be created in Chart or Visualization mode. Built-in zooming capabilities allow
you to drill down to a specific geographic area of focus easily. This allows you to get a closer
look at regional or local data, draw inferences, and make recommendations, without changing
the initial view of your data.

In Chart mode, you can also use the Auto Drill and Auto Linking features that are available
when you create charts or reports in InfoAssist+. In Visualization mode, you can also drill up
and down within different levels in a data hierarchy in a map. Auto Drill allows you to navigate
through the geographical hierarchy of your map data at run time. You can use this information
to visualize the same measure at different geographical hierarchies, such as Countries to
States and States to Cities. Auto Linking allows you to connect to related charts or reports in
your environment that share similar data parameters.

Using the Esri integration in InfoAssist+, you can also add the following layers to your map:

-1 Backgrounds. Display a layer that positions data as it is located, in context to other
geographical features, such as streets, terrain, and imagery. Some standard Background
options may combine road, aerial, and topographic data using a variety of symbols. Hosted
on ArcGIS, you can change your background at any time, to review your data in a different
context.
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When you apply a Background to your map, its appearance changes. You can then adjust
the view of your data, showing different terrain or geographical views. Backgrounds provide
at least 17 levels of zoom. For more information, see https://developers.arcgis.com/
javascript/jsapi/esri.basemaps-amd.htmi.

|1 Reference Layers. Display a layer of boundaries and locations that range from a
continental scale to country, state, and even local neighborhood. For example, if you are
viewing World data on electricity usage, you may want to add a Reference Layer that
displays the borders and concentration of your data within each country.

IJ Demographic Layers. Display a layer of information about people and businesses in a
specific demographic area. This includes the United States and 120 other countries.
Demographic Layers are thematic maps that provide additional information about the
location, such as spending habits, population, and lifestyles. You can add Demographic
Layers to a map about sales data, to identify new locations for stores, based on the
spending habits for a specific area.

Both mapextent and the Layers menu functionality are applied to your map when you select a
Background, Reference Layer, or Demographic Layer. Mapextent is an automatic view of the
map. Layers is a menu that appears on the map and provides access to options that allow you
to adjust the information that is being displayed.

The map example in the following image shows the use of layers.

2015 Tapestry Segmentation in the
United States

This web map shows the dominant LifeMode Summary

Group in the United States in 2015 by state, county, ZIP

Code, tract, and block group based on Esri's Tapestry
1 Segmentation system. ArcGIS Online subscription

i
raquired.

Web Map by e=ri_demographics

More Info

Note: Backgrounds, Demographic Layers, and Reference Layers can be accessed from the
Format tab for maps in both chart and Visualization mode. These layers are static, standard
options that Esri provides for use with InfoAssist+, and do not change based on the data
source that you select.
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Configuring an
Esri On Premise Environment

Procedure:

352

The Esri On Premise functionality enables you to download and access mapping files through
the use of a local Application Programming Interface (API). Once you download and configure
the API, you do not need an internet connection to utilize the robust mapping features that Esri
provides. For information on downloading and configuring the API that controls this feature, see
How to Download and Configure the ArcGIS JavaScript APl on page 352.

The Esri On Premise functionality provides you with local access to Esri mapping files. This is

particularly useful if you are away from your office or without an internet connection. You may

also be using a mobile device, such as an iPad or smartphone with a large screen, without an
internet connection. The following mapping components are supported when using the Esri On
Premise functionality:

1 Offline Basemaps. Basemaps are an offering from ArcGIS. Standard basemaps are
provided for your use offline. For example, there is an Oceans basemap and a Terrain with
Labels basemap. In InfoAssist+, these basemaps are also known as backgrounds. In an
online setting, there are 10 basemaps available. In order to use offline basemaps you need
to use a tiled mapservice published in the ArcGIS Server.

4 Offline Geographic Roles. Geographic Roles are used to visualize measures with commonly
known dimensions (for example, Country, State, Cities, and so on). These provide the
location information often in the form of (x/y) needed to plot on a map. Geographic roles
are pre-defined for online users through ArcGIS Online. In InfoAssist+, a geographic role
defines the geographic component that you can select when creating a map (for example,
State or Continent). For an offline user, the options that display can be customized in the
geoservices.xml file.

Note: Demographic Layers are not supported in an Esri On Premise environment.

How to Download and Configure the ArcGIS JavaScript API

You can use this procedure to download and configure the API that controls the Esri On
Premise environment.

1. Sign in to Esri ArcGIS.

2. In your browser, navigate to the following URL to download the API: https://
developers.arcgis.com/downloads#javascript
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3. Navigate to Version 3.28 of the ArcGIS API for JavaScript, as shown in the following image.

v3.28 - March 28 2019 - Release notes

Type Size MD5 checksum

APT o7 [ -

Type Size MD5 checksum

& arcgis_js_v328_sdk.zip

4. Click arcgis_js_v328_api.zip to download the API.

In /qibm/userdata/qwebqry/base80/config/web_resource, create a folder named
arcgis_api.

6. Open the arcgis_js_v328_api.zip file downloaded in step 4 and navigate to
arcgis_js_v328_api\arcgis_js_api\library\3.28\3.28.

7. Extract the files in that folder to the /qibm/userdata/qwebqry/base80/config/
web_resource/arcgis_api folder.

8. Next, verify the path to the API in the Db2 Web Query Administration Console, as shown in
the following image.

Note: This is the path to which you extracted the API files. For example, /web_resource/

arcgis_api

(V| —

Configuration  Securty  RepartCaster _ Diagnostics Licenses  Clear Cache  Close @)
Configuration ESRI

» [ Reporting Servers

~ &2 Application settings "~ @  EsriOn premise Jweb_resource/arcgis_apl x

save Caneel

§| Deferred Reporting
£l Encryption

£ Esrl

il Fiters

3 magnify

) Multiple Reports

This field identifies the path to the internal ArcGIS Javascript APl Source that develops
ESRI-based maps. This setting is blank, by default, indicating that the use of the internal
API source to develop ESRI maps is not activated. The API that is referenced is https://
Jjs.arcgis.com/3.28/, by default. To direct Db2 Web Query to use the internal ArcGIS
Javascript API to develop ESRI maps, enter the path to the local API files that you
extracted into this setting.

Note: This path should be a relative path that is accessible within the local Db2 Web
Query install.

Db2 Web Query InfoAssist+ Part 1 353


https://js.arcgis.com/3.28/
https://js.arcgis.com/3.28/

InfoAssist+ and Esri Integration

9. Click Save.

10. Next, open the following two local API files in a text editor:
- /aibm/userdata/qwebqry/base80/config/web_resource/arcgis_api\init.js
4 /qgibm/userdata/qwebqry/base80/config/web_resource/arcgis_api\dojo\dojo.js

In both files, search for HOSTNAME_AND_PATH_TO_JSAPI to locate the baseUrl property.
Replace the string [HOSTNAME_AND_PATH_TO_JSAPI] in baseUrl:"https://
[HOSTNAME_AND_PATH_TO_JSAPI]dojo" with the path to your on-premise ArcGIS server.
For example:

baseUrl:"https://local host/arcgis/jsapi/jsapi/dojo"

11. In the Db2 Web Query Administration Console, click Clear Cache to clear the browser
cache. Your configuration is complete.

Creating and
Customizing Maps in
InfoAssist+

The following procedures provide step-by-step instructions on how to create and customize
maps.

As you create your maps, you can use the following built-in map viewer features:

.4 You can use the plus (+) and minus (-) symbols, , within the map to zoom in and out of
different areas of the map. You can also click your left mouse button to zoom in to a
specific location.

. Like all HTML5 visualizations, the highlighted markers and regions on a map support drill,
multi-drill, auto-linking, and informational tooltip features.

.4 When working with maps in Chart mode, you can use the Pan / Selection button to
alternate between the Pan and Selection controls. This option is in the upper-right corner of
the map.

.4 When working with maps in Visualization mode, you can toggle the Pan or Selection button
to make a selection. The Pan control allows you to click, hold, and move the map with your
mouse. The Selection control allows you to lasso a specific area of the map and select
data in the map.
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- Creating a map chart using the US Zipcode 5 Georole with more than 2000 polygons will
fail to draw.

Procedure: How to Create an Esri Choropleth Map
Note: The default option of creating a map utilizes the ArcGIS JavaScript API that Esri provides.

1. Launch InfoAssist+ in Chart or Visualization mode.
.4 In Chart mode, on the Format tab, in the Chart Types group, click Choropleth.

. In Visualization mode, on the Home tab, in the Visual group, click Change and click

Choropleth.
A blank map displays and the Layer field container is enabled, as shown in the following
image.
[al] Query W Live Preview (500 Records)

a [al) chart (wf_retail_litz)
- ‘-'H'- Location

ary —
w3y Layer +
a Lifi Metric
% Color

#2 Tooltip
E Multi-graph

F Filter

6000km

Esti, HERE, Garmin, NGA, USGS... | (3301

2. Add a Geolocation field to the Layer field container.
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4.

This field, which already has a geographic role assigned, is denoted with a Layer icon, %,
in the Data panel, as shown in the following image. You can also hover over a data field to
view the geographic role assignment.

4 pttributes
ﬁ]i Stare,Continent,Code
",I'lr; Store,Continent,Latitude
",I'lr; Store,Continent,Longitude
{ﬂrﬁ Store,Continent
ﬁ'ﬂ Store,Continent, #enulation

485 store,Country,Caj Segment: WF_RETAIL_GEOGRAPHY_STORE
‘-‘.','; Store, Country, Cal MName: Store,Continent

q Alias: CONTINENT_NAME
ﬁ]i Store,Country,Ca| i
J]i S —— Title: Store, Continent

ore,Country,

= ' & Description: Continent Full Name
‘:; Store,Country,Lat . ALY
& Store,Country, Lot Geggraphic Rele: CONTINENT
V_”]i Store, Country, Population, Hange W e

For more information, see Geographic Roles on page 369.
The canvas refreshes, and your map displays.
Before saving your map, to add insight, you can also do following:

.4 Click Run, to preview your map.

. Add a measure or dimension to the Color field container, to color your chart by that
underlying data value. When you add a measure or dimension field to the Color field
container, a legend displays for that data value. If you specify a dimension in the Color
field container, the label changes to Color BY.

4 Add a dimension or measure to the Tooltip field container, which will display tooltip
information when you place your mouse over an area of the map.

-1 Add a Background, Demographic Layer, or Reference Layer.

Click Save to save your map.

Procedure: How to Create an Esri Proportional Symbol (Bubble) Map

356

1.

Launch InfoAssist+ in Chart or Visualization mode.
d In Chart mode, on the Format tab, in the Chart Types group, click Proportional Symbol.

. In Visualization mode, on the Home tab, in the Visual group, click Change and select
Proportional Symbol.

A blank map displays and the Layer field container is enabled.
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2. Place a data field with a defined geographic role in the Layer field container.

This field, which already has a geographic role assigned, is denoted with a Layer icon, i:":'l",
in the Data panel, as shown in the following image. You can also hover over a data field to
view the geographic role assignment.

4 ptributes
v_’ﬂ Store,Continent,Code
&5 Store, Continent, Latitude
q'il'; Store,Continent,Longitude
<85 Store, Continent
v_‘ii Sture,(ontinent‘.&nulalinn
8 Store,Country,Ca] Segment:
485 Store, Country, Cal N‘.ame:
iﬁstore,C0unw,Ca| ﬁ;ja:
v_:riistore,anuntry,IS( S
q'ilr; Store, Country, Lat E
9y Store,Country, Lot
v_‘ii Store,Country, Population, Hange

WF_RETAIL_GEQGRAPHY_STORE
Store, Continent
CONTINENT_NAME
Store,Continent

Continent Full Name

ALSY

Geographic Role: CONTINENT

W il

For more information, see Geographic Roles on page 369.

A basic bubble map displays, as shown in the following image.

[ul]) Query
4 [il] Chart (wf_retail_lite)
4 é’,“ Location
- iil'j‘ Layer
B Store,Country
- E\lﬂ Marker
B size
% Ccalor
=2 Tooltip
E Multi-graph

‘¥ Filter
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Procedure: How to Assign a Geographic Role to a Data Field
1.

358

3. Before saving your map, to add insight, you can also do following:

4. Click Save to save your map.

d
-

_I

_I

Launch InfoAssist+ in Chart or Visualization mode.

.4 In Chart mode, on the Format tab, in the Chart Types group, click Choropleth or

d In Visualization mode, on the Home tab, in the Visual group, click Change and click

In the Data pane, select a data field without a geolocation assignment.

Click Run, to preview your map.

Add a measure or dimension to the Color field container, to color your chart by that

underlying data value.

Add a measure to the Size field container, to control the size of the bubbles on your

map.

Add a measure to the Tooltip field container, to display tooltip information when you

place your mouse over an area of the map at run time.

Add a Background, Demographic Layer, or Reference Layer.

Proportional Symbol.

Choropleth or Proportional Symbol.

Perform one of the following tasks to open the Map dialog box and assign a geographic
role:

. Right-click the desired data field, click Map As and select a geographic role, as shown
in the following image.

4 Store

Store,Business, Region

2 sto re,Business,5ub Region

- "!ri Store,Country

4 pttributes z
&y store,Cor 55
1’,5," Store,Cot =5
1’,5," Store,Cor
1’,5," Store, Cor
& store,Cor
& store,Cor_wF

-i,g," Store, Country, Capital Longitude

Sum
Create Group...
Add To Query

Y Filter

Slicers

5 Map As

ﬁ"’ﬂ Store, Country, Capital
4§ Store, Country,150-3166,Code
&) Store, Country, Latitude

=5 - ) Live Preview

Done

3

3

3

\an paLITI-Arann
3 Digit Zipcode

5 Digit Zipcode

City (United States)...
City...

Continent L\\)

Country (1502)

Country (1503)

Country (Name)

County (United States)...
County...

Latitude...

Longitude...

Postal code
State/Province...

US State (Abbreviation)
U5 State (FIPS)

US State (Name)
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- Drag the desired data field into the Layer field container.

The Map dialog box displays, as shown in the following image.

%-:; Map Store,State,Province,|50-3166-2,Code X

Geographic Role

4. In the Map dialog box, select a geographic role. For example, State.

Note: When specifying a geographic role, you can use Name or an ISO-2 value for
countries. The ISO-2 codes are recognized worldwide, as published in http://
WWW.iso.org/iso/country_codes.

The Map dialog box refreshes and shows the Depends on section, as shown in the
following image.

%lr,". Map Store,State,Province,150-3166-2,Code x
Geographic Role Stored As
State - Name -
Depends on
Geographic Role Stored As ® Field () User Defined
Country > | Name ~ | Store,Country -
" OK ) Cancel

Note: If you used the Map As option, the Depends on section automatically displays, since
a geographic role was selected at that time.

5. In the Depends on section, choose from the following options:
. Field. Identifies a specific field on which the geographic role depends. For example,
you can select Country or Continent.

4 User Defined. Enables the definition of a specific value from the data source.
Selections can be as simple as a specific country. For example, you can select US.

The Geographic Role field automatically populates based on the hierarchy of your data
source. For example, if your primary geographic role was State, and in your metadata
hierarchy, State depends on Country, this option displays.
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6. Click OK.
If you used the Map As option, you must place the data field with the defined geographic
role in the Layer field container. If you placed a data field in the Layer field container and
defined a geographic role, the field is automatically added to the Layer field container.

A basic map displays, as shown in the following image.

¢ Layers

|

Stockhalm

M oscon

&

Wl Ew
London 1A
£F
Iilan
Ialiricl Istanlsul
; ; e
Eaghdad
Cairo :
Mew Delhi
Y T .
Culsai :
2000km
1 Unknown | |—'_I=_r :i o -

Esri, DelLorme, NGA, USGS | Esri, HERE,...

7. Before saving your map, to add insight, you can also do following:
.4 Click Run, to preview your map.

. Add a measure or dimension to the Color field container, to color your chart by that
underlying data value.

d Add a measure to the Size field container, to control the size of the bubbles on your
map.

d Add a measure to the Tooltip field container, to display tooltip information when you
place your mouse over an area of the map at run time.
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-1 Add a Background, Demographic Layer, or Reference Layer.

8. Click Save to save your map.

Procedure: How to Change the Geographic Role of a Geolocation Field

You can change the geographic role assignment of any geolocation field using the following
steps.

1. Launch InfoAssist+ in Chart or Visualization mode.
. In Chart mode, on the Format tab, in the Chart Types group, click Choropleth.

. In Visualization mode, on the Home tab, in the Visual group, click Change and click
Choropleth.

From the Data pane, right-click a geolocation field and click Map As.
3. Select a geographic role.
The Map dialog box displays using the selected Geographic Role.

4. In the Map dialog box, optionally select a geographic role from the drop-down list. For
example, Country.

Note: This changes the selection that you made on the Map As list.

5. Accept the default value for Stored As, or choose a new value from the drop-down list, for
example, ISO code. Stored As indicates how the data values are represented in the table.

6. Click OK.

The geographic role changes for the selected Geolocation field in the Data pane, and the
map refreshes using the new geolocation that you specified.

Procedure: How to Change the Default Background of a Map

1. Create a new map or open an existing map in InfoAssist+.
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2. On the Format tab, expand the Map group and click Background, as shown in the following
image.

s @ L%

Background Demographic Reference Run with Auto
Layers Layers Linking

Sopel o
arianeil
e BEEAN

3. Select one of the following options:
4 World Street Map

Terrain with Labels

Oceans Basemap

OpenStreetMap

World Imagery

Imagery with Labels

Light Gray Canvas

National Geographic World Map

Dark Gray Canvas

L U o U v v uJ o d

None

Note: The Imagery with Labels Background provides the terrain for your map, ranging from
land contours to city streets.

Once you make a selection, the background of the map refreshes. You can continue to
change your background until it displays the desired information.
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Procedure: How to Add Demographic Layers to a Map
1. Create a new map or open an existing map in InfoAssist+.
2. On the Format tab, expand the Map group and click Demographic Layers.

3. Select from various population and lifestyle groups, as shown in the following image.

ﬁ Demographic Layers x
USA Lifestyle

|:| USA Tapestry Segmentation 2012
|:| USA Tapestry Segmentation 2017

USA Population

[]| usA Average Household Size 2012 3
|:I USA Labor Force Participation Rate 2010

]| usA Median Age 2017

[J| uSA Median Home Value 2012

|:| USA Median Household Income 2012

|:| USA Median Met Worth 2012

]| usA Owner Occupied Housing 2012

]| USA Population By Sex 2012

[_]| USA Population Change 1990-2000
[]| USA Population Change 2000-2010 Y

" OK & Cancel

Note: These are pre-defined demographic profiles, provided by ArcGIS. You can select
multiple options in either category to gain additional insight into your data. Specifically,
each Demographic Layer has its own profile and provides a layering option, when
comparing values across different layers or profiles.

4. Click OK.
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The Demographic Layers that you select are applied to your map. The map engine displays
the different groups with unique hues and coloring. You can use the Table of Contents or
Layers option, to toggle between the different layers that you have specified. The Layers

option is shown in the following image.
» Layers

USA Tapesiry Segmentation 2017

|:| Opacity
USA Tapestry Segmentation 2017

Country
B L1: Affluent Estates
. L2 Upscale Avenues
L3: Uptown Individuals
L4: Family Landscapes
L5: GenXurban
L6: Cozy Country Living
L7: Ethnic Enclaves
L3: Middle Ground
LS: Senior Styles -

Note: You can select and clear the check boxes to enable the display of one or more
Demographic Layers to compare and contrast the different demographic scenarios.

Procedure: How to Add Reference Layers to a Map
1. Create a new map or open an existing map in InfoAssist+.

2. On the Format tab, expand the Map group and click Reference Layers.
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The Reference Layers dialog box displays, as shown in the following image.

&4 Reference Layers x

USA Counties Generalized
Usa Major Cities
USA States Generalized
UsA ZIP
ZIP 3
ZIP 5
World Admin Divisions
World Cities
World Continents

«| World Countries

(S Cancel

3. Select one or more Reference Layers, such as World Countries, to add to your map, and
then click OK.
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Your map refreshes, and the definitions and borders of the References Layers display on
the canvas. You can use the Table of Contents or Layers option, to toggle different
Reference Layers in your map. These options are shown in the following image.

0
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| 1Unknown | 2000n

Esri, HERE, Garmin, NGA, USGS | Esri

Procedure: How to Create a Leaflet Map

366

You can use the following procedure to create Leaflet maps, which are part of the Lightweight
Mapping functionality.

Note:
[d For charts, you must use the HTML5 output format to access this functionality.

|1 Data labels display for choropleth Leaflet maps, providing you with information about your
underlying data directly on the map.

1. Launch InfoAssist+ in Chart mode or Visualization mode.

2. Create a Leaflet map using one of the following options:
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To create a Leaflet map as a chart:
1. On the Format tab, in the Chart Types group, click Other.
2. In the left pane, select Map.

All map options display, including Leaflet maps. Click either Leaflet Choropleth or
Leaflet Bubblemap.

To create a Leaflet map in a visualization:
1. On the Home tab, in the Visual group, click Change.
2. On the Select a visual menu, click Map.
The Select a map dialog box opens.
3. From the Type group, select a map.

3. From the Location group, using the Territory drop-down list, select a territory (for example,
United States of America).

This section allows you to pick geographic locations for which maps are available. You can
select a territory option from the drop-down list. Options include: United States of America,
World, Europe, Africa, Asia, Australia, Austria, Denmark, Germany, Japan, North America,
South America, and Sweden. For more information on adding or enabling additional
territories, see Enabling Additional Territories in a Leaflet Map on page 380.

4. Click OK.

From the Data pane, add a data source containing geolocation data to the Layer field
container in the Query pane.

Note: For bubble maps, Layer, Latitude, and Longitude field containers display. You can
specify latitudinal and longitudinal data using these fields. The Size field container also
displays for bubble maps.

The Location Type dialog box displays, as shown in the following image.
":*\"1 Location Type

Geographic Role
state_abbr (AK, AL, AR) -

" OK {S) Cancel
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The Location Type is needed for geocoding, which is a process through which fields are
assigned to a specific geographic dimension (for example, Zip Code, State, or Country) so
that it can be matched correctly to the geographic coordinates. The geocoding process will
occur once you add a geographic field to the Location data container.

Select a geographic role from the drop-down list and click OK.

The map displays.

Note: You can change the geographic role by right-clicking the location dimension in the
Query pane, and clicking Geographic Role. The Location Type dialog box opens.

Optionally, add a field to the Color field container, or add a field to the Size field container
if you are creating a bubble map.

The map displays based on your data and selections for geolocation and optionally, color
and size. The legend identifies the data in the map by color, based on the data field

specified in the Color field container.

Reference: Query Field Containers by Map Type

This section presents the Query field containers that display for both charts and visualizations,

by map type.
Query field container Chart mode Visualization mode
Layer. One data field, specifically a field e v v
containing location data (for example,
State).
Latitude. One data field, containing % ® v
latitude data.
Longitude. One data field, containing x x e
longitude data.
Color. One data field. e e e
Tooltip. Up to one data field (not required). e v e
Multi-graph. Up to one data field (not e x %
required).
Size. One data field. % % e

368

IBM



9. Creating Maps to lllustrate Trends I

Reference: Geographic Roles

Note: Geographic roles are only available with Esri maps.

Geographic Role

Description

Maps Supported

CONTINENT World Continents Choropleth, Proportional
Symbol

COUNTRY World Countries Choropleth, Proportional
Symbol

STATE World Admin Divisions Choropleth, Proportional
Symbol

CITY World Cities Proportional Symbol

COUNTY World Counties Choropleth, Proportional
Symbol

POSTAL-CODE Postal Code Choropleth, Proportional

Symbol

The following table summarizes additional geographic role information.

Note: All of the following roles are geographic roles, with the exception of Latitude and
Longitude, which are coordinates.

Role Name Role Format Geographic Role

Address Full ADDRESS_FULL
Line ADDRESS_LINE

City Name CITY

Continent ISO-3166 code CONTINENT_ISO2

Name

CONTINENT
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Role Name

Role Format

Geographic Role

Country

FIPS code

COUNTRY_FIPS

ISO-3166-2 code

COUNTRY_ISO2

ISO-3166-3 code

COUNTRY_ISO3

Name COUNTRY
Country (NUTS level O) NUTS code NUTSO_CC

Name NUTSO
District (NUTS level 3) NUTS code NUTS3_CC

Name NUTS3
Geometry area GEOMETRY_AREA
Geometry line GEOMETRY_LINE
Geometry point GEOMETRY_POINT
Latitude LATITUDE
Longitude LONGITUDE
Postal code POSTAL-CODE
Province (NUTS level 2) NUTS code NUTS2_CC

Name NUTS2
Region (NUTS level 1) NUTS code NUTS1_CC

Name NUTS1
State FIPS code STATE_FIPS

Name STATE
US County FIPS FIPS code USCOUNTY_FIPS
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Role Name Role Format Geographic Role
US city FIPS code USCITY_FIPS
Name USCITY
US county Name USCOUNTY
US Postal code 3 digits ZIP3
5 digits ZIP5

US state

Abbreviation

USSTATE_ABBR

FIPS code

USSTATE_FIPS

Name

USSTATE

US ISO subdivision code

STATE_ISO_SUB

The following table illustrates the geographic roles and their dependencies. Level 1 indicates
the highest level of hierarchy and level 5 is the lowest level of hierarchy.

Region

Hierarchy Level

Geographic Role

United States

1 COUNTRY, COUNTRY_ISO_CC

2 USSTATE, USSTATE_ABBR,
USSTATE_FIPS

3 USCOUNTY, USCOUNTY_FIPS

4 USCITY, USCITY_FIPS

5 ZIP3, ZIP5

Db2 Web Query InfoAssist+ Part 1
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Region Hierarchy Level Geographic Role
World 1 CONTINENT, CONTINENT_ISO_CC
2 COUNTRY, COUNTRY_FIPS,

COUNTRY_ISO_CC,
COUNTRY_ISO2, COUNTRY_ISO3

3 STATE, STATE_ISO_SUB
4 CITY
5 POSTAL CODE

Adding a Custom Geographic Role
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Customers with Enterprise Data often have map layers that represent their territories, events,
or logistical information. These are published as Map Services to either a subscription based
in the Esri Cloud (ArcGIS.com) or on an internal portal. This portal is available with ArcGIS
Server 10.3 installations. More information can be found at http://server.arcgis.com/en/
portal/.

The Reporting Server comes with a configuration file (geo_services.xml) that contains elements
that describe all of the geographic roles, geographic hierarchies, URLs to the map services,
and base maps available to the Esri map viewer. This file is located in the catalog directory
under the server home directory:

/qibm/proddata/QWEBQRY/ibi/srv77/home/catalog
where nn is the release of your Reporting Server. For example, 77 for 7.7.

The geographic role selections that you can make while using the InfoAssist+ Map As option
are built dynamically using this configuration file. Each role definition in the configuration file,
when selected in InfoAssist+, generates Metadata and a request that is sent to Esri in order to
download the appropriate map and place the markers or polygons on the map.

A geographic role can be part of a hierarchy. For example, the World geographic role is at the
top of a hierarchy that contains continents, countries, states, and cities. These hierarchies are
also described in the geo_services.xml file. The default location is:

/qibm/proddata/QWEBQRY/ibi/srv77/home/catalog/geo_services.xml

where nn is the release of your Reporting Server. For example, 77 for 7.7.
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To add a custom geographic role, you must add the necessary parameters for the geography to
this file.

Following standard XML syntax rules, each element is enclosed in element start and end tags
(<elementname>, </elementname>), and attribute values are enclosed in double quotation
marks (").

Reference: Geographic Role Definitions

A geographic role is stored as geo_role element in the geo_roles object of the
geo_services.xml file. A geographic role must be defined with:

.4 An ID that will identify the role in the configuration file.
- A format and length for the data to be returned.

d A role name.
d

A display title for the role name (to appear as a selection when using the InfoAssist+ Map
As option).

.4 An optional role format (if the role can have multiple formats, such as a name and an
abbreviation).

4 A display title for the format.
.4 A role type (GEOGRAPHY for polygons or GEOMETRY for points).

4 An optional vocabulary rule element containing vocabulary elements for associating the role
with a field in the metadata.

The following attributes define a geographic role.

id
Is an alphanumeric uppercase value, up to 50 characters, used to identify the geographic
role.

type
Is the data type for the ID. Can be one of the following.

4 "alpha". For alphanumeric data, formats An or In.

4 "integer". For integer numeric data, format In.

. "numeric". For fractional numeric data, formats Pn.m, Dn.m, or Fn.m.
d

"text". For text data, format TXn.
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value_size

Is the optional number of characters in USAGE format length (any, if not set).
role_name

Is the name of the geographic role.
role_name_title

Is the title of the geographic role, which displays when you hover over a data field with a
geographic role assigned. You can also assign a geographic role, by title, using the Map As
option.

role_format

Is an optional format for the geographic role. This is useful when the role can be
referenced using multiple formats, such as a name, an ISO code, and an abbreviation.

role_format_title

Is an optional title for the format of the geographic role. It will be shown in parentheses
along with the role title when you use the Map As option. For example, US State
(abbreviation).

geo_type

Is one of the following predefined role types.
- "geography". For geographic objects, such as country or city.

- "geometry". For geometry objects, such as latitude, longitude, or geometry point and
area.

vocabulary_rules

Is an element that consists of a group of vocabulary elements that explicitly describe
column names for the geographic role. These rules will be used to select the best
geographic data for the role.

Elements in a rule are connected by the Boolean logic operation OR (only one needs to be
satisfied). Each vocabulary element contains words enclosed with special characters.
Words in the rule element are connected by the Boolean logic operation AND (all need to
be satisfied).
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Example:

A word may be prefixed and/or suffixed with the percent character (%), which is a place
holder for any sequence of characters. If an element contains more than one word, each
word has to be prefixed by the character plus (+) or minus (- ). Plus indicates that the word
must be found in the column name. Minus indicates that the word must not be found in
the column name.

Sample Geographic Role Definitions

The following defines the State Abbreviation geographic role. The role ID is USSTATE_ABBR.
The role name is USSTATE with a role format of ABBR. The titles that show when using the
Map As option are US State (Abbreviation). The format is A2, and the vocabulary rules specify
that the characters state must be present, but the characters iso, capital, and population must
not be present. The geo type is geography, indicating that the returned data will be a
geographic area.

<geo_role

i d=" USSTATE_ABBR"

val ue_si ze="2"

type="al pha"

rol e_nane=" USSTATE"

role nane_title="US state"

rol e_format =" ABBR'

role format _title="Abbreviation"
geo_t ype="geography">

<vocabul ary_rul es>

<vocabul ary>+%st at e% % so% %api t al % %popul ati on%</ vocabul ary>
</vocabul ary_rul es>

</ geo_rol e>

The following is a role definition for latitude values. The role ID is LATITUDE. The role name is
also LATITUDE. Its format is numeric. The title that displays when you hover over a field with a
geographic role assigned (or when using the Map As option) is Latitude. The geo type is
geometry, indicating that the returned data will be points or areas described using points. The
vocabulary rules specify that the characters latitude must be present.

<geo_role
i d="LATI TUDE"
type="nuneric"
rol e_nane="LATI TUDE"
role_nane_title="Latitude"
geo_t ype="coordi nate">
<vocabul ary_rul es>
<vocabul ary>% at i t ude%</ vocabul ary>
</vocabul ary_rul es>
</ geo_rol e>
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Reference:
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The following is the definition for the city role. The ID is CITY. The role name is also CITY. Its
format is NAME. The title that displays when you hover over a field with a geographic role
assigned (or when using the Map As option) is City (Name). The definition has a set of
vocabulary elements. Only one of the elements in the list must be true. Therefore, the
characters city, or town, or country plus capital, or state plus capital must be present.
<geo_role
id="Cl TY"
type="al pha"
rol e_nane="Cl TY"
role nane_title="City"
rol e_f or mat =" NAME"
role format _title="Nanme"
geo_t ype="geography" >
<vocabul ary_rul es>
<vocabul ary>+%i t y% %popul ati on%</ vocabul ary>
<vocabul ar y>+% own% %popul ati on%</ vocabul ary>
<vocabul ary>+%ount r y%s-%api t al % %popul at i on%</ vocabul ary>
<vocabul ary>+%st at e%+-%capi t al % Y%popul ati on%</ vocabul ary>

</vocabul ary_rul es>
</ geo_rol e>

Geographic Hierarchy Definitions

Some geographic roles exist as part of a hierarchy, and the data for the hierarchical roles are
stored at the same map services endpoint (URL). Hierarchical role relationships are stored as
hier elements in the geo_services.xml file.

Hierarchy definitions provide Db2 Web Query with the information needed to use Auto Drill from
a geographic role at a higher level of the geographic hierarchy to a geographic role at a lower
level of the geographic hierarchy.

Each hierarchy has the name of hierarchy (attribute ID) and a group of LEV elements with the
attributes level, geo_role, and, optionally, value. Not all defined roles can be used in
hierarchies. The same role can be included in more than one hierarchy and may be on different
hierarchical levels in each. However, the same role cannot be used more than once in the
same hierarchy. Multiple geographic roles can be assigned to the same hierarchical level in a
hierarchy.

Geographic hierarchies are defined with the following attributes:
id

Is a name of up to 50 alphanumeric characters used to identify the hierarchy.
level

Is a natural number (integer starting with 1 for the top level) that specifies the level of the
role within the hierarchy.
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Example:

Reference:

geo_role
Is the ID attribute of a geographic role (geo_role element).

value
Is an alphanumeric value, up to 50 characters, predefined for this geo role in this
hierarchy.

Sample Geographic Hierarchy Definition

The following element defines the world hierarchy. The top level is CONTINENT, both the Name
role and the ISO code role. Level 2 has four COUNTRY geographic roles, corresponding to four
different country formats. Level 3 contains three state formats, level 4 contains the city name,
and level 5 contains two address formats and the postal code.

<hier i d:"W)rI d">
<l ev | evel ="1" geo_rol e=" CONTI NENT"/ >

<l ev | evel ="1" geo_rol e=" CONTI NENT_I SC2"/ >
<lev |evel ="2" geo_rol e=" COUNTRY"/ >

<l ev |l evel ="2" geo_rol e=" COUNTRY_FI PS"/ >
<l ev |l evel ="2" geo_rol e=" COUNTRY_I SQ2"/ >
<l ev |l evel ="2" geo_rol e=" COUNTRY_I SG3"/ >
<l ev |l evel ="3" geo_rol e="STATE"/ >

<l ev |l evel ="3" geo_rol e="STATE | SO SUB"/ >
<l ev |l evel ="3" geo_rol e="STATE_FI PS"/ >

<lev |l evel ="4" geo_role="Cl TY"/>

<l ev | evel ="5" geo_rol e=" ADDRESS FULL"/>

<l ev |l evel ="5" geo_rol e=" ADDRESS LI NE"/>

<l ev |l evel ="5" geo_rol e="POSTAL_CCDE"/ >
</ hier>

Adding the Federal Reserve Districts Geographic Role

These steps describe how to add the Federal Reserve Districts geographic role to the
geo_services.xml file.

1. Open the geo_services.xml file. The default location is:
/qibm/proddata/QWEBQRY/ibi/srv77/home/catalog/geo_services.xml
where nn is the release of your Reporting Server. For example, 77 for 7.7.

2. Add the role to the end of the GEO_ROLES object:

<geo_rol e id="FED- Dl ST" val ue_si ze="50" type="al pha" rol e_nane="FEDDI ST"
role nane title="FED District" role format="FR Distric"
role format _title="FED District Nane" geo_type="geography">
<vocabul ary_rul es>
<vocabul ary>+%-R _Di stri c%</ vocabul ary>
</vocabul ary_rul es>
</geo_role

Db2 Web Query InfoAssist+ Part 1 377



Adding a Custom Geographic Role

378

3. The ID is FED-DIST. The role name is also FED-DIST. Its format is FR_Distric. The title that

displays when you hover over a field with a geographic role assigned (or when using the
Map As option) is FED District. The definition has a vocabulary rule. The characters
FR_Distric must be present.

4. Add this role to the US Hierarchy:

<hier id="US">
<lev level ="1" value="United States" geo_rol e="COUNTRY"/ >
<lev | evel ="1" val ue="US" geo_rol e=" COUNTRY_I SO2"/ >
<lev level ="1" val ue="USA" geo_rol e=" COUNTRY_I| SC3"/ >
<lev level ="2" geo_rol e="USSTATE"/ >

<lev | evel ="2" geo_rol e="USSTATE _ABBR'/ >
<lev | evel ="2" geo_rol e="USSTATE FI PS"/ >
<lev | evel ="3" geo_rol e="USCOUNTY"/ >

<lev | evel ="3" geo_rol e="USCOUNTY_FI PS"/ >

<lev | evel ="4" geo_rol e="USC TY"/ >
<lev |l evel ="4" geo_rol e="USCI TY_FI PS"/ >
<lev | evel ="5" geo_rol e=" ADDRESS FULL"/>
<lev | evel ="5" geo_rol e=" ADDRESS LI NE"/>
<lev |l evel ="5" geo_rol e="ZI P3"/>
<lev | evel ="5" geo_role="ZIP5"/>
<lev level="6" geo_role="FED-DIST"/>

</ hier>

5. Add the URI to the map server layer for this role at the end of the URIS object:

<uri description="FedReserve Districts">

<returned_geonet r y>GEOVETRY_AREA </ returned_geonetry>

<r et urned_geor ol e>FED- DI ST</r et ur ned_geor ol e>

<url type="esri" authorization="none" synonyne"">
http://services7.arcgis.conl L95Ww9(Q RQItj As/ arcgi s/ rest/ services/
FRDI STRI CTS/ Feat ur eSer ver/ 0</url >

<par anet er s>

<parm order="1" parm nane="FR_Di stric" parm georol e="FED- DI ST"/ >
</ par anet er s>
<furi>
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You will now be able to select this role when using the Map As option the next time you

start InfoAssist+, as shown in the following image.
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InfoAssist+ provides a number of territories, out of the box, for Leaflet maps, which are
provided through Leaflet Open Source API. These pre-packaged territories are listed in Default
Territories on page 382 and are contained in JavaScript Object Notations (.json) files.

Note: This functionality is only available for maps built with the Leaflet API.

In addition to the out of the box territories that are available, you can also enable other
territories for use in creating custom maps. These additional territories are contained in .json
or .csv files.

Note: Files in .csv format can be used for latitude and longitude data values. This could be for
an exact point or for the centroid of a location. When using .csv files, there is a csvfields field
class that is used to specify latitude and longitude values. For example,
csvfields='country,lat,Ing'. The .csv must have at least latitude and longitude specified. In
addition, all fields require the use of quotes and a comma-delimited format.

You can also use GeoJSON files if you have access to location files in GeoJSON format. For
more information, see the following webpages:

- http://geojson.org
. http:;//converter.mygeodata.eu/vector (Convert Shape Files to GeoJSON)

In order to enable a new territory, you must copy the .json, .csv, or .geojson file to the
appropriate directory and then modify the CustomUIMaps.xml file to reference it, as described
in the following procedure.

How to Enable Additional Territories in a Leaflet Map

Note: This functionality is only available for maps built with the Leaflet API.

1. To enable one of the location files installed with Db2 Web Query, identify the pre-
packaged .json file that you want to enable in the following directory:

/qibm/ProdData/QWEBQRY/base80/webapps/webfocus/tdg/jschart/distribution/map
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2. Copy the selected .json file to the following directory:
/qibm/ProdData/QWEBQRY/base80/config/web_resource/map
Note:

. If you want to use a .geojson or .csv file, copy it to this directory.

. If you are using a .json file, a layer must be defined, as .json files can contain multiple
layers. The specification of layers is not required for .geojson files.

. In this example, the primary layer = regions must be set in the .json file. You can verify
this by opening the .json file in a standard text editor, such as Notepad or Textpad.

3. Inthe /qgibm/ProdData/QWEBQRY/base80/config/web_resource/map directory, open the
CustomUIMaps.xml file using a standard text editor.

4. Remove the commenting characters from the line that you wish to create. Specifically,
remove <!- from the beginning of the line of code and remove —> from the end. This
activates the .json file that you are including.

5. Specify the following criteria within the <Json> tag for each territory that you want to
enable:

4 Map file: This is the .json or .csv file name. For example, uszip3.json.

d Name: The label, or identifying name, that displays in the Territory drop-down list when
using the Lightweight Mapping functionality. For example, Zip 3.

4 Layer: Files may have multiple layers in them, such as landmarks and the actual item
you want to symbolize. If they do, you must specify which layer to use. In the following
example, regions is used.

<?xml version="1.0" encoding="UTF=-8"2> ~

013 Information Builders, Ing. All rights reserved. -->

<!--%Re 12 1.7 §:——>
J<Maps>
<Json>

</Map>—->

e Regions">

</Map> ——>

<Map file="sample wfretail regions.geejsen"” name="WFRetail Sample Regions"> </Map>
<Map file="uszip3.jsen" layer='regions' name="Zip 3"></Map>
</Json>

(= X -

6. Save the CustomUIMaps.xml file.

7. Restart your application server.
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The name of the territory that you enabled displays in the Territory drop-down list when you

create a map chart.

Default Territories

382

InfoAssist+ comes pre-packaged with a number of default territories. These include:

-

L v U U v U U U U o uw U oL

Note: A full list of maps is available in your local installation directory:
/qibm/ProdData/QWEBQRY/base80/webapps/webfocus/tdg/jschart/distribution/map

United States of America

World

Europe

Africa

Asia

Australia
Austria
Denmark
Germany
Japan

North America
South America

Sweden

IBM



Legal and Third-Party Notices

SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR
PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE
EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY
OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS
OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE
AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER
LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE
SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH
SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE
LICENSE(S) LOCATED IN THE "LICENSE" FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT
IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE
ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this
document may be reproduced in any form without the written authorization of TIBCO Software
Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, FOCUS, iWay, Omni-Gen, Omni-HealthData, and
WebFOCUS are either registered trademarks or trademarks of TIBCO Software Inc. in the
United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of
Oracle Corporation and/or its affiliates.

All other product and company names and marks mentioned in this document are the property
of their respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating
system platforms for a specific software version are released at the same time. See the
readme file for the availability of this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS.
CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL
BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE
IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S)
DESCRIBED IN THIS DOCUMENT AT ANY TIME.

383



384

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING
BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.

This and other products of TIBCO Software Inc. may be covered by registered patents. Please
refer to TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 2022. TIBCO Software Inc. All Rights Reserved.

IBM



	Contents
	1. Introducing InfoAssist+
	InfoAssist+ Highlights
	Additional InfoAssist+ Types
	InfoMini


	2. Navigating the InfoAssist+ Interface
	InfoAssist+ Application Window
	Application Main Menu
	Reference: Open Dialog Box
	Accessing InfoAssist+ Options
	Getting Started
	Help
	Selecting a Data Source
	Reference: Opening a New Procedure


	Changing InfoAssist+ User Preferences
	Startup Options
	View
	Layout
	Format
	Environment and Styling
	Changing Global Preferences


	Quick Access Toolbar
	Ribbon
	Working With the Ribbon

	Home Tab
	Insert Tab
	Format Tab
	Data Tab
	Slicers Tab
	Layout Tab
	View Tab
	Field Tab
	Series Tab
	Understanding the Resources Panel
	Reference: Field Image List
	Reference: Filter Pane
	Using the Data Pane
	Using the Data Pane to Add Fields to a Report
	Enforcing Paths to Disable Unavailable Fields

	Using the Query Pane and Filter Pane
	Using Field Containers
	Field Containers for Reports
	Field Containers for Charts and Visualizations

	Adding Parameters for Data Selection at Run Time
	Procedure: How to Add a Parameter

	Using Shortcut Menu Options in the Query Pane
	Reference: Right-Click Field Options in the Query and Filter Panes
	Dynamic Grouping
	Procedure: How to Create a Dynamic Group



	Understanding the Canvas
	Using the Query Pane and Filter Pane on the Canvas
	Understanding Output Options
	Reference: Output Target Options
	Reference: Output View Options
	Reference: Output Format Options


	Using the Navigation Taskbar
	Using the Status Bar

	3. Creating and Customizing Reports
	Creating Reports
	Procedure: How to Create a Report
	Procedure: How to Create a Report From the Application Main Menu
	Procedure: How to Create a Report From the Quick Access Toolbar
	Procedure: How to Create a Report From an Existing Chart
	Choosing a Report Output
	Using Procedure Settings
	Procedure: How to Create a Procedure Using the Missing Value Option
	Procedure: How to Create a Procedure Using the Empty Report Option


	Styling Reports
	Procedure: How to Apply Styling to an Entire Report
	Procedure: How to Perform Field-Level Styling in a Report
	Procedure: How to Add Headings and Footings to a Report
	Procedure: How to Style Headings and Footings in a Report
	Procedure: How to Style Rows of Data With Alternating Colors in a Report
	Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Constant)
	Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Field)
	Procedure: How to Use Cell Padding in a Report

	Changing a Field Format
	Procedure: How to Assign an Alphanumeric Format
	Procedure: How to Assign a Numeric Format
	Procedure: How to Assign a Date Format
	Procedure: How to Assign a Date-Time Format
	Procedure: How to Add a Percent Sign to a Numeric Field

	Using Custom Reporting Features
	Procedure: How to Rank Fields in a Report
	Procedure: How to Limit the Values of a Column in a Report
	Procedure: How to Add Page and Line Breaks to a Report
	Procedure: How to Add Subtotals to a Report
	Procedure: How to Add Column Totals to a Report
	Procedure: How to Add Row Totals to a Report
	Procedure: How to Add Subheadings and Subfootings to a Report
	Procedure: How to Add Pop-Up Titles to a Report
	Procedure: How to Add Data Visualization Bars to a Report
	Procedure: How to Display Numeric Measure Data Using Aggregation Options in a Report
	Procedure: How to Access the Within Functionality
	Procedure: How to Display Repeated Sort Values in a Report
	Procedure: How to Recalculate the Result of a Compute Command

	Creating Customized Report Outputs
	Procedure: How to Create Table of Contents Reports
	Procedure: How to Freeze Column Titles in Reports
	Procedure: How to Create Pages On Demand Reports
	Procedure: How to Create OLAP Reports
	Procedure: How to Create Accordion Reports
	Procedure: How to Implement Stack Measures


	4. Creating and Customizing Charts
	Visualizing Your Data With Charts
	Selecting a Chart Type
	Bar Charts
	Bar Chart Types

	Pie Charts
	Pie Chart Types

	Line Charts
	Line Chart Types

	Area Charts
	Area Chart Types

	Scatter Charts
	Multi-Axis Charts
	XY Plot Charts
	XY Plot Chart Types

	3D Charts
	3D Chart Types

	Stock Charts
	Stock Chart Types

	Special Charts
	HTML5 Charts
	Combination Charts
	Maps

	Creating Charts
	Procedure: How to Create a Basic Chart
	Procedure: How to Create an Advanced Chart
	Procedure: How to Create a Combination Chart
	Procedure: How to Create a Dual-Axis Chart
	Procedure: How to Create a Multi-Axis Chart
	Chart Outputs

	Binning
	Procedure: How to Use Binning in a Vertical Bar Chart
	Procedure: How to Edit an Existing Bin
	Procedure: How to Create Bins for Reporting
	Binning Values in a Histogram
	Procedure: How to Create a Histogram with Automatic Binning in Chart Mode
	Procedure: How to Create a Histogram with Automatic Binning in Visualization Mode


	Accessing Chart Formatting Tools
	Using Live Preview

	Formatting a Series
	Associated Dialog Boxes
	Format Series Dialog Box
	Edit Title Dialog Box
	Traffic Light Condition Dialog Box

	Series Elements Shortcut Menu
	Using Series Properties
	Procedure: How to Select a Series
	Procedure: How to Format the Fill and Border of a Series
	Enhancing Series Using the Series Tab
	Procedure: How to Change the Type of a Series
	Procedure: How to Add a Trendline

	Formatting Charts Using the Series Tab
	Procedure: How to Apply Smooth Line Effect to a Line Chart
	Procedure: How to Hide a Series Line Between Markers
	Procedure: How to Change the Appearance of a Marker
	Procedure: How to Expand Pie Slices
	Procedure: How to Hide a Pie Slice
	Procedure: How to Filter Values in a Series
	Procedure: How to Sort the Fields in a Series
	Procedure: How to Hide a Field in a Series
	Procedure: How to Display Aggregations on Measure Data
	Procedure: How to Display Aggregations on Dimension (Non-Numeric) Data
	Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)
	Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)
	Procedure: How to Change the Title of a Series
	Procedure: How to Control the Color Mode
	Procedure: How to Delete a Series



	Formatting Data Labels
	Associated Dialog Boxes
	Format Labels Dialog Box
	Style Dialog Box
	Line Style Dialog Box

	Data Labels Elements Shortcut Menu
	Using Data Labels Properties
	Procedure: How to Show and Hide Data Labels
	Procedure: How to Change the Position of Data Labels


	Formatting a Legend
	Format Legend Dialog Box
	Legend Elements Shortcut Menu
	Using Legend Properties
	Procedure: How to Hide a Legend
	Procedure: How to Position a Legend
	Procedure: How to Specify the Color of a Legend Border


	Formatting Gridlines
	Format Grid Lines Dialog Box
	Gridline Elements Shortcut Menu
	Using Gridline Properties
	Procedure: How to Display Horizontal Major Gridlines
	Procedure: How to Display Horizontal Minor Gridlines
	Procedure: How to Display Vertical Major Gridlines
	Procedure: How to Display Vertical Minor Gridlines
	Procedure: How to Set the Color, Weight, and Style of a Gridline
	Procedure: How to Set Ticks
	Procedure: How to Set Color Bands
	Procedure: How to Delete a Gridline
	Procedure: How to Add Frames to Regions on a Chart


	Formatting Axis Labels
	Format Axis Dialog Box
	Reference: Format Vertical Axis Dialog Box
	Reference: Format Horizontal Axis Dialog Box
	Secondary Axes Options
	Axis Elements Shortcut Menu
	Using Axis Properties
	Procedure: How to Delete Axis Labels
	Procedure: How to Stagger Axis Labels
	Procedure: How to Rotate Axis Labels
	Procedure: How to Format Axis Labels
	Procedure: How to Manually Set the Scale of an Axis
	Procedure: How to Add an Axis Title
	Procedure: How to Set Advanced Axis Properties


	Formatting a Frame and a Background
	Frame & Background Dialog Box
	Frame and Background Shortcut Menu
	Using Frame and Background Properties
	Procedure: How to Change the Color of the Frame
	Procedure: How to Change the Color of the Background


	Formatting a Gauge Chart
	Format Gauge Dialog Box
	Gauge Elements Shortcut Menu
	Using Gauge Properties
	Procedure: How to Set the Number of Gauges Per Row
	Procedure: How to Set the Minimum and Maximum Axis Scale Values
	Procedure: How to Style Axis Labels
	Procedure: How to Format Axis Labels
	Procedure: How to Rotate Axis Labels
	Procedure: How to Set Gauge Tick Marks
	Procedure: How to Set Gauge Color Bands
	Procedure: How to Match Needle Center Color to Band Color (Gauge Center by Quality)
	Procedure: How to Style a Gauge Needle
	Procedure: How to Set Gauge Needle Colors in a Multi Series Gauge Chart


	Formatting Page Headings and Page Footings
	Procedure: How to Add a Page Heading and Page Footing to a Chart
	Procedure: How to Control the Rendering of a Page Heading and Page Footing

	Using Additional Formatting Features
	Procedure: How to Set 3D Depth on a Bar Chart
	Procedure: How to Rotate a Chart
	Procedure: How to Sort a Chart by Total Value
	Procedure: How to Display a Static Reference Line
	Procedure: How to Display a Dynamic Reference Line
	Procedure: How to Display Annotations


	5. Creating and Customizing Documents
	Accessing Document Mode
	Procedure: How to Access Document Mode to Build a New Document
	Procedure: How to Access Document Mode by Opening an Item From the Splash Screen
	Procedure: How to Access Document Mode by Opening a Report From the Quick Access Toolbar
	Procedure: How to Access Document Mode From the Document Button on the Home and View Tabs

	Building a Document
	Inserting Reports From Multiple Data Sources
	Procedure: How to Insert Two Reports From Two Different Data Sources

	Inserting a New Report
	Procedure: How to Insert a Report

	Inserting a New Chart
	Procedure: How to Insert a Chart

	Inserting an Existing Report
	Procedure: How to Insert an Existing Report With the Insert Tab

	Creating a Document From a Single Report
	Inserting Text and Images
	Procedure: How to Insert Text
	Procedure: How to Insert an Image

	Editing Components in a Document
	Procedure: How to Resize a Component
	Procedure: How to Move a Component
	Procedure: How to Align Components
	Procedure: How to Style and Customize a Report
	Procedure: How to Style and Customize a Chart
	Procedure: How to Edit Text
	Procedure: How to Delete a Component



	6. Creating and Customizing Visualizations
	Creating a Visual
	Procedure: How to Create a Visualization from Within Db2 Web Query
	Procedure: How to Create a Visualization From InfoAssist+
	Changing the Visual Type
	Procedure: How to Change the Visual Type


	Selecting a Visual
	Grids
	Procedure: How to Create a Grid

	Bar Charts
	Procedure: How to Insert a New Bar Chart
	Procedure: How to Create a Stacked Bar Chart
	Procedure: How to Create a Matrix Bar Chart

	Line Charts
	Procedure: How to Create a Line Chart
	Procedure: How to Create a Matrix Line Chart

	Area Charts
	Procedure: How to Create an Area Chart
	Procedure: How to Create a Stacked Area Chart
	Procedure: How to Create a Matrix Area Chart

	Pie Charts
	Procedure: How to Create a Pie Chart
	Procedure: How to Create a Matrix Pie Chart

	Ring Pie Charts
	Procedure: How to Create a Ring Pie Chart
	Procedure: How to Create a Matrix Ring Pie Chart

	Scatter Charts
	Procedure: How to Create a Scatter Chart

	Bubble Charts
	Procedure: How to Create a Bubble Chart

	Matrix Marker
	Procedure: How to Create a Matrix Marker Chart

	Treemaps
	Procedure: How to Create a Treemap

	Gauges
	Procedure: How to Create a Circular Gauge
	Procedure: How to Create a Matrix Circular Gauge

	Heatmaps
	Procedure: How to Create a Heatmap

	Matrix Charts
	Procedure: How to Create a Matrix Chart


	Interacting With Visualizations
	Procedure: How to Insert a New Visual
	Procedure: How to Add Text to Your Visualization
	Procedure: How to Create a Visualization
	Minimizing or Maximizing a Visual
	Procedure: How to Minimize or Maximize a Visual

	Procedure: How to Delete a Visual
	Renaming a Visual
	Procedure: How to Rename a Visual

	Using Paper-Clipping to Group Values in a Visual
	Procedure: How to Paper-Clip Two or More Values Together
	Procedure: How to Merge an Additional Value into an Existing Group
	Procedure: How to Rename an Existing Group

	Viewing Data Behind Visuals
	Procedure: How to Show the Data Behind Your Visual
	Procedure: How to Show Data With Related Columns
	Procedure: How to Export the Data Behind Your Visual

	Using Multi Drill in Visualization Mode
	Creating Multi-Y Axis Comparative Visuals
	Procedure: How to Create a Multi-Y Axis Comparative Visual


	Customizing Visualizations
	Formatting Axis Labels
	Format Axis Dialog Box
	Reference: Format Vertical Axis Dialog Box
	Reference: Format Horizontal Axis Dialog Box

	Using Axis Properties
	Procedure: How to Hide Axis Labels
	Procedure: How to Stagger Axis Labels
	Procedure: How to Rotate Axis Labels
	Procedure: How to Format Axis Labels
	Procedure: How to Manually Set the Scale of an Axis
	Procedure: How to Add an Axis Title
	Procedure: How to Set Advanced Axis Properties

	Formatting Data Labels
	Procedure: How to Access the Format Legend Dialog Box

	Formatting the Legend
	Procedure: How to Access the Format Labels Dialog Box

	Formatting a Series
	Procedure: How to Change the Appearance of a Marker

	Formatting and Display Tools for Data in a Visual

	Using Handles to Organize Your Visualization
	Procedure: How to Place a Visual in a Visualization
	Procedure: How to Move a Visual in a Visualization


	Using Storyboards
	Procedure: How to Create a Storyboard

	Animating Visualizations
	Procedure: How to Add Animation to a Visual

	Using Visualizations at Run-Time
	Working With Filters at Run Time
	Procedure: How to Filter Data With Tooltips at Run Time
	Viewing Data at Run Time
	Procedure: How to View Data at Run Time
	Using the Run-Time Toolbar Options




	7. Navigating Reports and Charts
	Using Auto Drill
	Procedure: How to Use Auto Drill to Navigate the Hierarchy of Your Data Source

	Using the Auto Linking Feature to Link Content
	Using Optional Parameters with Auto Linking to Enhance Drilldown Results
	Procedure: How to Set an Existing Report or Chart as Auto Link Enabled
	Procedure: How to Set an Existing Report or Chart as an Auto Link Target
	Procedure: How to Create a New Auto Link Enabled Report or Chart
	Procedure: How to Create a New Auto Link Target Report or Chart
	Procedure: How to Run an Auto Link Enabled Report or Chart

	Using Multi Drill
	Procedure: How to Create a Single Drill Down Link
	Procedure: How to Create Multi Drill Links


	8. Styling Reports, Charts, and Visualizations
	Customizing Reports
	Using the Report Style Dialog Box
	Using the Color Dialog Box
	Accessing Reporting Options in the Report Group
	Enabling Report Features
	Enabling Chart Features
	Labeling Charts
	Using Interactive Options
	Customizing Page Setup

	9. Creating Maps to Illustrate Trends
	A Brief History of Mapping
	InfoAssist+ and Esri 	 Integration
	Configuring an 		Esri On Premise Environment
	Procedure: How to Download and 		Configure the ArcGIS JavaScript API
	Creating and 		Customizing Maps in  		InfoAssist+
	Procedure: How to Create an Esri 		Choropleth Map
	Procedure: How to Create an Esri 		Proportional Symbol (Bubble) Map
	Procedure: How to Assign a 		Geographic Role to a Data Field
	Procedure: How to Change the 		Geographic Role of a Geolocation Field
	Procedure: How to Change the 		Default Background of a Map
	Procedure: How to Add 		Demographic Layers to a Map
	Procedure: How to Add Reference 		Layers to a Map
	Procedure: How to Create a 		Leaflet Map
	Reference: Query Field 		Containers by Map Type
	Reference: Geographic 		Roles

	Adding a Custom Geographic Role
	Reference: Geographic Role Definitions
	Example: Sample Geographic Role Definitions

	Reference: Geographic Hierarchy Definitions
	Example: Sample Geographic Hierarchy Definition

	Reference: Adding the Federal Reserve Districts Geographic Role

	Enabling Additional Territories in a Leaflet Map
	Procedure: How to Enable Additional Territories in a Leaflet Map
	Default Territories


	Legal and Third-Party Notices



